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About SolarWinds 
SolarWinds, Inc develops and markets an array of network management, monitoring, and 
discovery tools to meet the diverse requirements of today’s network management and consulting 
professionals. SolarWinds products continue to set benchmarks for quality and performance and 
have positioned the company as the leader in network management and discovery technology. 
The SolarWinds customer base includes over 45 percent of the Fortune 500 and customers from 
over 90 countries. Our global business partner distributor network exceeds 100 distributors and 
resellers. 

Contacting SolarWinds 
You can contact SolarWinds in a number of ways, including the following: 

Team Contact Information 
Sales 1.866.530.8100 

www.solarwinds.com  
Technical Support www.solarwinds.com/support  
User Forums www.thwack.com 

A customer account is required to access the Customer 
Support area of the website. 

 

Conventions 
The documentation uses consistent conventions to help you identify items throughout the printed 
and online library. 

Convention Specifying 
Bold Window items, including buttons and fields. 
Italics Book and CD titles, variable names, new terms 
Fixed font File and directory names, commands and code examples, 

text typed by you 
Straight brackets, as in 
[value] 

Optional command parameters 

Curly braces, as in 
{value} 

Required command parameters 

Logical OR, as in 
value1|value2 

Exclusive command parameters where only one of the 
options can be specified 
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SolarWinds LANsurveyor Express Documentation Library 
The following documents are included in the SolarWinds LANsurveyor Express documentation 
library: 

Document Purpose 
Administrator Guide Provides detailed setup, configuration, and 

conceptual information. 
Page Help Provides help for every window in the LANsurveyor 

Express user interface 
Release Notes Provides late-breaking information, known issues, 

and updates. The latest Release Notes can be 
found at www.solarwinds.com.  
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Chapter 1 

Introduction 

Thank you for purchasing SolarWinds LANsurveyor Express. LANsurveyor 
Express is network documentation software any network manager, 
administrator, engineer, or designer can use with Microsoft Visio 2007 to 
automatically map networks of any size. 

Why Install LANsurveyor Express 
Right out of the box, an installation of LANsurveyor Express (LANsurveyor 
Express) gives you the ability to draw maps showing the logical connectivity 
of your network devices and create status and inventory reports about 
mapped network devices. Once installed, LANsurveyor Express is integrated 
within Microsoft Visio, allowing you to immediately leverage the functionality 
of Microsoft Visio 2007 for your network documentation requirements. Used 
independently, the easy-to-use LANsurveyor Express interface and the 
improved LANsurveyor Network Discovery engine will quickly have you 
mapping your network and creating status reports. 

How LANsurveyor Express Works 
The improved LANsurveyor Express Network Discovery engine searches 
your network over a designated IP address range for devices of selected 
types. During network discovery LANsurveyor Express uses a very small 
amount of network bandwidth. For each type of device it attempts to 
discover, LANsurveyor Express sends one small (<300 bytes) UDP packet 
per IP address. In addition, LANsurveyor Express breaks up large IP address 
ranges into blocks of 30 addresses and waits several seconds for responses 
from those 30 addresses. By searching the network in this way, LANsurveyor 
Express minimizes its affect on your network devices or bandwidth. After 
discovering devices, LANsurveyor Express employs Microsoft Visio 2007 to 
generate a map of discovered devices matching your selected criteria. 

You can configure LANsurveyor Express to discover any of the following 
types of devices: 

ICMP (Ping) 

LANsurveyor Express can be configured to use ICMP (ping) operations 
to discover and map network devices that are neither SNMP-enabled nor 
supported by responders or other third party client software. 
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NetBIOS 

For network nodes that employ Microsoft Networking, LANsurveyor 
Express can use NetBIOS operations for device discovery and mapping. 

SNMP-enabled Devices 

SNMP-enabled devices, including servers, routers, printers, 
network-attached storage (NAS), UPS systems, and other managed 
network devices, may be shown on LANsurveyor Express maps. 

Note: Maps drawn by users without required community string privileges 
to SNMP-enabled routers cannot show connectivity between network 
segments.  

SIP Clients 

SIP-based Voice-over-IP (VoIP) devices can be discovered and 
displayed on LANsurveyor Express maps. Reports can include SIP 
devices and SIP-specific information. 

Note: If your site uses a non-default SIP UDP socket, click Advanced in 
the LANsurveyor Express configuration window to set the UDP socket 
number for your SIP-enabled network devices. 

Responders 

LANsurveyor Express can discover and map devices running the 
LANsurveyor Responder client software. LANsurveyor Responders are 
used by LANsurveyor applications to remotely control networked 
systems and create software and hardware asset management reports. 
For more information about LANsurveyor Responders, see the 
SolarWInds LANsurveyor Responder website at 
http://www.solarwinds.com/products/LANsurveyor/responders.aspx. 

Retrospect and Timbuktu Clients 

Retrospect and Timbuktu clients may also be included in LANsurveyor 
Express maps and reports. For more information about using Retrospect 
and Timbuktu clients on your network, see http://www.retrospect.com 
and http://www.netopia.com, respectively. 

After configuring LANsurveyor Express for your network, click Start Network 
Discovery. LANsurveyor Express then builds your network map as follows: 

Note: The map building and layout process may take a few minutes on larger 
networks. If all search options are enabled, allow at least four seconds per 30 
IP addresses to complete discovery and mapping.  
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1. LANsurveyor Express sends network queries to discover nodes. 

2. Items that respond to more than one type of query (for example, both 
SNMP and ICMP) are merged. 

Note: The network name of a given device is determined by the first 
query type returned to LANsurveyor Express. 

3. IP addresses and icons are assigned to each network object. 

4. Managed switch and hub ports are mapped. 

5. SNMP interfaces are mapped. 

6. Discovered networks and nodes are arranged. 

7. The network layout is completed in Microsoft Visio 2007 

Note: Using Microsoft Visio 2007, you can also generate informative 
network status and inventory reports with the information discovered by 
LANsurveyor Express. For more information about creating reports with 
LANsurveyor Express and Microsoft Visio 2007, see “Creating Reports” 
on page 16. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Administrator Guide  SolarWinds LANsurveyor Express 
 

 
4  Introduction  

 

 

 

 



SolarWinds LANsurveyor Express  Administrator Guide 
 

 
Installing LANsurveyor Express  5 

Chapter 2 

Installing LANsurveyor Express 

Installing LANsurveyor Express is a straightforward process, and the system 
requirements are not extensive. The following sections provide required system 
specifications and the installation procedure. 

Requirements 
Hardware and software requirements for LANsurveyor Express are nominal. The 
following table presents minimum hardware and software requirements to ensure 
satisfactory performance: 

LANsurveyor Express Requirements 
CPU Pentium-class 
RAM 256MB 
Hard Drive Space  35MB 
Operating System Windows Vista, XP, 2003 (professional, workstation, or server 

editions) 
Microsoft Visio 2007 version 
Network IP-based 

 

Additionally, some LANsurveyor Express features are only functional with 
SNMP-enabled nodes (SNMP agents). If you want to map and create reports for 
these devices, you must provide valid community strings, or passwords. The 
following SNMP agents are used by LANsurveyor Express: 

• MIB-II SNMP agents available on most IP routers and many IP devices. 

• Various Cisco-specific MIBs for determining user-defined interface 
names and switch ports. 

• Bridge MIB SNMP agents for determining switch port connectivity. 

• Repeater MIB SNMP agents for determining hub port connectivity. 

Required Ports 
If you are installing LANsurveyor Express on a computer that is operating behind 
a firewall or within any other type of network security framework, ensure that the 
following User Datagram Protocol (UDP) and Transmission Control Protocol 
(TCP) ports are open: 

• SNMP: UDP port 161 

• LANsurveyor Responders: TCP and UDP port 4347 
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• NetBIOS Clients: UDP port 137 

• SIP (VoIP) Nodes: UDP port 5060 

• Retrospect Clients: UDP port 497 

• Timbuktu Clients: UDP port 407 

Required SNMP MIBs 
LANsurveyor Express uses the following standard Management Information 
Bases (MIBs) during network discovery: 

• MIB-II that exists on nearly all IP routers and many IP devices 

• Printer MIB that exists on some IP printers 

• Bridge MIB to determine switch port connectivity (RFC 1493) 

• Repeater MIB to determine hub port connectivity (RFC 2108) 

• Various Cisco-specific MIBs for determining user-defined interface 
names and switch ports 

Installing LANsurveyor Express 
Complete the following procedure to install LANsurveyor Express. 

To install LANsurveyor Express: 

1. Navigate to your download location, and then launch the executable.  

2. Click Next on the Welcome window. 

3. If you want to create shortcuts for LANsurveyor Express, check the 
locations where you would like to provide them, and then click Next. 

4. Select I accept the terms in the License Agreement, and then click Next. 

5. Click Browse to find the folder in which you want to install LANsurveyor 
Express or type the folder path in the Folder field, and then click Next. 

6. Click Install on the Ready to Install window to begin installation. 

7. If you do not want to launch LANsurveyor Express right now, clear 
Launch LANsurveyor Express. 

8. Click Finish to exit the Setup Wizard. 
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9. If you chose to launch LANsurveyor Express, personalize your installation 
by providing your Name, Organization, and LANsurveyor Express Serial 
Number, and then click OK. 

Note: The serial number is case sensitive, and it must be typed exactly as 
you received it. 

10. Provide the requested information to register your installation of LANsurveyor 
Express, and then click Register Now. 

Note: The information you provide here may also be used as labels on 
generated maps and reports. For more information about personalized 
information, see “Configuring a Custom Logo” on page 9. 

The LANsurveyor Express user interface displays, showing default settings for 
your network. For more information about configuring LANsurveyor Express and 
creating maps, see “Creating Maps” on page 10. 
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Chapter 3 

Using LANsurveyor Express 

LANsurveyor Express features an easy-to-use interface enabling you to quickly 
start mapping your network and generating status and inventory reports. The 
following sections present procedures for starting LANsurveyor Express, for 
creating network maps, and for generating reports. 

Starting LANsurveyor Express 
The following procedure provides required steps to start LANsurveyor Express. 

Note: You must complete the installation procedure for LANsurveyor Express. 
For more information about installation, see “Installing LANsurveyor Express” on 
page 6.  

To start LANsurveyor Express: 

1. Launch Microsoft Visio 2007. 

Note: Generally, you should be able to open Microsoft Visio 2007 by clicking 
Start > All Programs > Microsoft Office > Microsoft Office Visio 2007. 

2. Click Tools > Add-Ons > LANsurveyor Express. 

3. If this is the first time you are starting LANsurveyor Express, 
personalize your installation by providing your Name, Organization, and 
LANsurveyor Express Serial Number, and then click OK. 

Note: The serial number is case sensitive, and it must be typed exactly as 
you received it. 

4. If you have not registered your installation of LANsurveyor Express, 
provide the requested information, and then click Register Now. 

Note: The information you provide here may also be used as labels on 
generated maps and reports. For more information about personalized 
information, see “Configuring a Custom Logo” on page 9. 

The LANsurveyor Express user interface displays, showing default settings for 
your network. For more information about configuring LANsurveyor Express and 
creating maps, see “Creating Maps” on page 10. 

Configuring a Custom Logo 
When LANsurveyor Express creates your network map, the personalized 
information provided at startup is placed in the upper left-hand corner of the map. 
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In addition, LANsurveyor Express can put your logo in the upper left-hand corner 
of your network diagrams. LANsurveyor Express uses the logo identified as 
YourLogo.bmp in your installation directory, which is typically 
C:\Program Files\SolarWinds\LANsurveyor Express. 

Launching LANsurveyor Express from Microsoft Visio 
Because LANsurveyor Express installs as an integrated Microsoft Visio 2007 
add-on, if you have already installed LANsurveyor Express, you can open it 
directly from within Microsoft Visio 2007, as shown in the following steps.  

To launch LANsurveyor Express from within Microsoft Visio 2007: 

1. Launch Microsoft Visio 2007. 

Note: Generally, you should be able to open Microsoft Visio 2007 by clicking 
Start > All Programs > Microsoft Office > Microsoft Office Visio 2007. 

2. Click Tools > Add-Ons > LANsurveyor Express. 

Creating Maps 
Once you personalize your software, the LANsurveyor Express window displays 
with your default network properties. At a minimum, SolarWinds recommends 
that you provide SNMP community strings to include SNMP-enabled devices in 
your network discovery. If you choose not to provide a valid SNMP community 
string, your LANsurveyor Express map will show neither connectivity outside your 
current subnet nor connectivity among managed switches and hubs. 

Note: The only feature LANsurveyor Express cannot access without local 
administrative privileges is the discovery of nodes via ICMP ping. With the ICMP 
ping feature, LANsurveyor Express attempts to "ping" itself upon startup to 
ensure ICMP access. If your user account does not have sufficient ICMP 
privileges, LANsurveyor Express will give an error when launched. To test your 
access to ICMP ping, open a Windows command prompt and enter ping 
127.0.0.1. This command attempts to ping the local machine. If this command 
fails, you do not have sufficient privileges to send ICMP packets. 

Creating a New Map 
Upon launch, the main LANsurveyor Express window displays a number of 
options that must be configured before you can discover and map your network. 
After you have configured your network mapping options, LANsurveyor Express 
is able to search your network for objects such as routers, subnets, and end 
nodes. Once the selected types of network objects are discovered, LANsurveyor 
Express automatically builds your network map. The following procedure gives 
the steps required to configure and start network discovery and mapping. 
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To create a network map with LANsurveyor Express: 

1. In the Network Parameters area, provide the start and end IP addresses of 
the range in which the devices you want to map are located. 

Note: LANsurveyor Express determines a default IP address range from the 
network settings of the computer running LANsurveyor Express. 

2. If you want LANsurveyor Express to also search external networks and 
subnets, provide a number of allowed router hops to increase the extent of 
LANsurveyor Express network discovery. 

Note: SNMP router access is required if you want to extend network 
discovery into subnets and external networks. Provide appropriate SNMP 
community strings in the Routers, Switches and Other SNMP Device 
Discovery area, as described in the next step. 

3. If you want to include SNMP-enabled devices in your map, in the 
Routers, Switches and Other SNMP Device Discovery area check the types 
of SNMP devices (SNMPv1, SNMPv2, or SNMPv3) to include, and then 
provide required SNMP Community Strings. 

Notes: 

• LANsurveyor Express allows you to provide up to ten community strings. 
Strings should be separated by commas or single spaces, as shown 
below: 
public, private, cstring1, cstring2  

• If you check SNMP devices without providing a valid community string, 
LANsurveyor Express uses the strings public and private by default. 

4. If you check SNMPv3 Devices, click SNMPv3 Options and then complete 
the following procedure to configure SNMPv3 options: 

a. Provide a Configuration Name. 

b. Provide an appropriate User Name and Context for this configuration. 

c. Select one of the following Authentication Levels: 

• NoAuthNoPriv designates an SNMPv3 configuration requiring 
neither an authentication password nor a privacy password. 

• AuthNoPriv designates an SNMPv3 configuration requiring an 
authentication password is required, but no privacy password. 

• AuthPriv designates an SNMPv3 configuration requiring both an 
authentication password and a privacy password. 
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d. If you specify AuthNoPriv as the Authentication Level, select the 
Authentication Type, provide the Authentication Password, and then, 
if you also want the designated password to serve as the SNMPv3 
authentication key, check Treat Password as Key. 

e. If you specify AuthPriv as the Authentication Level, select the 
Authentication Type and the Privacy Type, provide the 
Authentication Password and the Privacy Password, and then, if you 
also want either of the designated passwords to serve as the SNMPv3 
authentication or privacy keys, respectively, check Treat Password as 
Key as appropriate. 

f. Click Save to save your SNMPv3 configuration, and then click OK. 

5. If you want to discover and map other types of network devices, check 
the appropriate device types in the Other IP Service Discovery area. For 
more information about the network devices that LANsurveyor Express can 
discover and map, see “How LANsurveyor Express Works” on page 1. 

6. Set the discovery speed for LANsurveyor Express with the slider in the 
Mapping Speed area. 

Note: The Mapping Speed slider applies to the current map. The timeout 
settings in the Advanced Options, described in the next step, affect mapping 
speed globally for all generated maps. As mapping speed increases, it 
becomes more likely that LANsurveyor Express may fail to discover older or 
slower network devices. 

7. Click Advanced to set advanced options, as shown in the following steps: 

a. Click the Network tab, and, in the appropriate fields, set search and 
SNMP query timeouts, and provide the SIP UDP socket number for your 
network. 

Notes: 

• Search and SNMP query timeouts are linked to the mapping speed 
slider in the Mapping Speed area of the LANsurveyor Express 
configuration window. Longer timeouts result in a slower mapping 
speed, but they may ensure that LANsurveyor Express discovers 
older or slower devices on your network. 

• The SIP UDP Socket number should match your VoIP environment. 

b. Click Logging and check the types of information that you want to include 
in available LANsurveyor Express performance logs, and then click OK. 

Note: In the event of a performance-related issue with your installation, a 
SolarWinds support representative may request these logs. To view 
these logs, click Start > All Programs > LANsurveyor Express > 
LANsurveyor Express Log. 
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8. Once you have configured all discovery and mapping options, click Start 
Network Discovery to begin searching and mapping your network. 

LANsurveyor Express searches your network for the selected devices over the 
specified IP address range. When Network Discovery is complete, LANsurveyor 
Express opens Microsoft Visio 2007 and displays the generated map as a Visio 
drawing. You can now edit and modify the generated map using available 
Microsoft Visio 2007 tools. 

Viewing and Editing Device Properties 
LANsurveyor Express automatically provides available device information to 
Microsoft Visio 2007. For most network devices, the information provided 
includes the fully qualified domain name, the IP Address, and the device Network 
Description, which is the node name as reported by SNMP, NetBIOS, or a 
LANsurveyor Responder during Network Discovery. The following procedure 
provides the steps required to view and edit device properties. 

To view and edit device properties: 

1. Click the device icon on your generated Visio drawing. 

2. Click View > Shape Data Window to open the Shape Data window. 

3. Scroll to view and edit properties as necessary. Entered values are saved 
automatically when you close the Shape Data window. 

4. If you want to edit the automatically generated device label that 
displays on the map beneath the device icon, double-click the device icon 
label and edit as necessary. 

Reading Maps 
When LANsurveyor Express finishes discovering the designated portion of your 
network, a map is drawn in Microsoft Visio 2007. Maps generated by 
LANsurveyor Express contain the following types of network objects: 

Networks 

LANsurveyor Express represents both wired and wireless networks as lines. 
IP address ranges display below and to the left of these network lines. 

Routers 

LANsurveyor Express represents SNMP-enabled routers with custom icons. 
Network lines are drawn from router icons to directly connected networks. If a 
router type cannot be determined or if no icon is available, a generic router 
icon is used. Microsoft Visio 2007 tools allow you to change any icon, as 
needed.  
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Managed Switches and Hubs 

Most end nodes connect to the network through hubs and switches. If the 
hubs or switches on your network are SNMP-enabled, LANsurveyor Express 
maps end nodes as they are connected to the appropriate SNMP-enabled 
hub or switch.  

If you have entered the community string for these devices, the map will also 
display port connectivity information next to each device. If a hub or switch 
type cannot be determined or if no icon is available, a generic icon is used. 
Standard Microsoft Visio 2007 tools allow you to change icons as needed. 

End Nodes 

An end node is any device that does not behave like a router or a managed 
hub or switch. Examples of end node objects include servers, computers, 
printers, SIP phones, and unmanaged hubs and switches. LANsurveyor 
Express includes hundreds of icons to provide the most accurate 
representation of your network. Standard Microsoft Visio 2007 tools allow 
you to change icons as needed. 

For any SNMP device with more than one interface (for example, routers and 
servers with more than one network connection), LANsurveyor Express also 
displays interface information. 

Troubleshooting Maps 
LANsurveyor Express provides specific icons to represent each of the different 
types of nodes and SNMP-enabled devices on your network. If the icon for a 
device on your generated network map is the generic "IP device" icon, one or 
more of the following may be true: 

• The device does not support SNMP. 

• SNMP is not enabled on the device. 

• The SNMP community string provided in the initial LANsurveyor Express 
configuration is not correct for the device. 

• The access control list of the device is not properly configured to accept 
SNMP requests from the LANsurveyor Express computer. 

• A firewall blocking SNMP, ICMP, SIP, or other requests is preventing 
access to the device. 

The following procedure may reveal a configuration issue regarding LANsurveyor 
Express and network discovery of the problematic “IP device”. For more 
information about LANsurveyor Express configuration options, see “Creating 
Maps” on page 10. 
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To troubleshoot a network map: 

1. Confirm that the network discovery options in the LANsurveyor Express 
configuration window are configured appropriately for your network. 

2. Consider including additional options when defining network discovery. For 
example, provide more SNMP community strings or select additional IP 
services. 

3. Confirm that the correct SIP UDP socket number is provided in the SIP 
(VoIP) area of the Advanced Options window. 

4. Rebuild the network map using a slower, more accurate mapping speed. 

For more information about troubleshooting SNMP access issues, see 
“Troubleshooting SNMP” on page 21. 

Viewing and Editing Network Device Data 
Microsoft Visio 2007 records data about network devices mapped with 
LANsurveyor Express. This data is useful for creating reports, and it is collected 
from your network devices if your network administrator has made it available. 
The following procedure provides the steps required to view and edit map object 
data in Microsoft Visio 2007. 

Note: Microsoft Visio 2007 refers to all objects on a generated map, regardless 
of function, as shapes. This convention is used in the following procedure. 

To view and edit shape data: 

1. Click a shape on your network map. 

2. Click Data > Shape Data. The Shape Data window displays, listing 
properties that may be defined for the selected shape. 

3. If you want to provide shape data in existing fields, type appropriate 
values in the selected data fields, and then click OK. 

4. If a field does not already exist for the data you want to save for the 
selected shape, click Define, and then define a new data field in the Define 
Shape Data window, as shown in the following steps: 

a. Provide a label for the data in the Label field, select the Type and 
Language of your data value, select a Format for your data value, and 
then type an appropriate value for your new data field in the Value field. 

b. If you want to provide an explanatory note describing the data value 
you are defining, type this information in the Prompt field. This 
information displays in the Prompt area of the Shape Data window when 
you click the corresponding data field. 
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5. If you have completed configuration of your new data field, click OK. 

6. If you have provided all required data for the selected shape, click OK. 

Creating Reports 
When it generates a map, LANsurveyor Express stores network device 
information in the Shape Data window of Microsoft Visio 2007. Using the 
standard Microsoft Visio reporting engine, you can easily create reports of device 
data for your network. Your installation of LANsurveyor Express provides a 
number of predefined reports, but you can also define custom reports using the 
Visio Report Definition Wizard to best meet your network monitoring needs. 
These reports are available as Excel, HTML, or XML documents or as Visio 
objects. 

Predefined Reports 
LANsurveyor Express provides the following reports in Microsoft Visio 2007: 

Inventory 

This report provides a simple list of the devices and infrastructural 
components of your network. For each device or component, which are 
referred to as “shapes” within Microsoft Visio 2007, this report provides the 
number of corresponding shapes on your network map. 

Network Device 

This report provides a list of the devices on your network, including devices 
identified merely as IP devices. For each device, the Network Name, IP 
Address, and Network Description, if available, are presented. An additional 
column, titled Displayed Text, shows the full label accompanying each 
respective device icon on the generated map. By default, the Displayed Text 
label is a collection of the Network Name, IP Address, and Network 
Description for each device. Subnet Mask and MAC Address fields are also 
available for each device.  

Network Equipment 

The Network Equipment report displays the same default information 
presented in the Network Device report, except that the Network Equipment 
report only lists defined devices. Undefined “IP Devices” are not included. 
Additional fields are available for each device to record physical information, 
including Building, Room, Manufacturer, Product Description, Product 
Number, Part Number, Serial Number, and Asset Number. 



SolarWinds LANsurveyor Express  Administrator Guide 
 

 
Using LANsurveyor Express  17 

PC Report 

This report provides information related specifically to the PCs on your 
network. For each PC node, this report displays Network Name, Network 
Description, Operating System, Memory, CPU, Hard Drive Capacity, and the 
Displayed Text label accompanying each respective device icon on the map. 

Report Formats and Options 
LANsurveyor Express can generate custom and predefined reports in the 
following formats: 

Excel 

LANsurveyor Express allows you to create reports in Excel format. Reports 
generated in Excel format open directly as Excel worksheets Select Excel in 
the Run Report window, and then click Browse to navigate to a save location 
or type your desired path and filename. 

Note: To create reports in Excel format, you must have Excel installed on 
your LANsurveyor Express computer. 

Visio Shape 

As a Microsoft Visio 2007 add-in, LANsurveyor Express can create reports 
that behave as Visio shapes. Reports saved as Visio shapes appear as 
Excel spreadsheets embedded within the same network map. Select Visio 
shape in the Run Report window, and then select either of the following 
options: 

• Select Copy of report definition to save the report definition with the 
generated Visio shape. With this option, changes to the original report 
definition are not reflected in the generated Visio shape. Save your 
report as a copy if you want to share it with other users. 

• Select Link to report definition if you want the generated Visio shape to 
reflect future changes that may be made to the report definition.  

Note: To save reports as Visio shapes, you must have Microsoft Excel 
installed on your LANsurveyor Express computer. 

HTML 

Reports may be saved as HTML documents for use in web applications. 
Select HTML in the Run Report window, and then click Browse to navigate 
to a save location or type your desired path and filename. 

XML 

Reports may be saved as XML documents. Select XML in the Run Report 
window, and then click Browse to navigate to a save location or type your 
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desired path and filename. Reports saved as XML files open directly in a 
browser. 

Creating Predefined Reports 
The following procedure presents the steps required to generate predefined 
network device reports in Microsoft Visio 2007. 

Note: It is possible to create custom reports if available predefined reports do not 
meet your needs. For more information on creating custom reports, see “Creating 
Custom Reports” on page 18. 

To create a predefined report in Microsoft Visio 2007: 

1. Use LANsurveyor Express to generate a Visio drawing of your network. For 
more information about creating maps with LANsurveyor Express, see 
“Creating Maps” on page 10. 

2. Click Data > Reports to open the Reports wizard. 

3. If you want to see all available predefined Microsoft Visio 2007 reports, 
clear Show only drawing-specific reports on the Reports window. 

Note: By default, Microsoft Visio 2007 provides a list of reports related to the 
object types on your network map. For more information about these 
provided reports, see “Predefined Reports” on page 16. 

4. Select the title of the report you want to create, and then click Run. 

5. Select the format of your report, specify available options, and then click OK. 
For more information about available report formats and options, see “Report 
Formats and Options” on page 17. 

Creating Custom Reports 
Microsoft Visio 2007 allows you to define your own reports using the Report 
Definition Wizard. The following procedure provides the steps required to 
generate your own custom reports. 

Note: Ensure that the data you want to report is available for all network devices. 
This data is either made available by your network administrator or it may be 
entered for each device. For more information about providing network device 
data, see “Viewing and Editing Device Properties” on page 13. 

To create a custom report in Microsoft Visio 2007: 

1. Use LANsurveyor Express to generate a Visio drawing of your network. For 
more information about creating maps with LANsurveyor Express, see 
“Creating Maps” on page 10. 

2. Click Data > Reports to open the Reports wizard. 
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3. Click New. 

4. Select the option for the shapes you want to include in your custom report. 

5. If you want to define criteria to limit the size of your report, click 
Advanced, and then specify conditions as appropriate. For more information 
about report limitations, see “Using Limitations in Microsoft Visio Reports” on 
page 20. 

6. Click Next. 

7. Check shape properties to display as columns in your report. If the property 
you need is not listed, check Show all properties and review the list. 

8. Click Next. 

9. Type a title for your report in the Report Title field. 

10. If you want to group results, provide subtotals, or calculate basic 
statistics on numerical data, click Subtotals, and then complete the 
following steps: 

a. Select a shape property for grouping your results in the Group by field. 

b. If you want to configure the way Microsoft Visio 2007 displays 
reported data, click Options, and then select the values you want to 
display. 

c. If you want to exclude duplicate rows or show grand totals, check 
the appropriate options, and then click OK.  

d. If you want to provide basic statistics on your report, check the 
operations you want to perform for each property, and then click OK. 

11. If you want to sort your report results, click Sort and complete the 
following procedure: 

a. Configure the Column Order by selecting properties and clicking Move 
Up or Move Down as appropriate.  

b. Configure the Row Order by selecting properties by which to sort 
sequentially, and then select either Ascending or Descending as the 
order of listed values within each column. 

c. Click OK. 

12. If you want to set the precision of reported numerical values, click 
Format, set the number of decimal digits to show in your report, designate 
whether or not you want to Show units, and then click OK. 

13. Click Next. 

14. Provide a Name and the Description of your custom report. 
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15. Select either of the following options: 

• Save in this drawing embeds your report as an object within your 
generated map file. 

• Save in a file saves your report externally as a Visio report in the 
location you specify in the associated field. 

16. Click Finish, and then click Run in the Reports window. 

17. Select the format of your report, specify available options, and then click OK. 
For more information about available report formats and options, see “Report 
Formats and Options” on page 17. 

Using Limitations in Microsoft Visio Reports 
If there are a large number of devices on your network map, the size of reports 
that you generate may easily become difficult to manage. To address this 
potential situation, Microsoft Visio 2007 provides a wizard in which you can 
define logical conditions to tailor your reports to your specific needs. The 
following procedure provides the steps required to define and apply logical 
conditions to your custom reports. 

To use report limitations: 

1. Select the Property on which your limitation depends. 

2. Select a relational operation in the Condition field. 

3. Provide a Value that is appropriate for the property and condition that you 
have entered. 

4. Click Add. 

5. If your condition is case sensitive, check Case sensitive. 

6. If you need to define additional conditions, repeat the preceding 
procedure for each additional condition. 

7. If you have provided all required conditions, click OK. 

For example, if you want to create a report listing devices located in Austin and 
location information has been provided by your network administrator, select 
Location in the Property field and equals in the Condition field, and then type 
Austin in the Value field. 
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Appendix A 

Troubleshooting SNMP Issues 

LANsurveyor Express queries SNMP-enabled network equipment to gather 
important connectivity information for network maps. SNMP data allows 
LANsurveyor Express to identify routers, switches, and connectivity between 
networking hardware and other systems. LANsurveyor Express requires 
read-only access to SNMP for map drawing. Read-write access is not required. 

LANsurveyor Express identifies switches using the SNMP Bridge MIB (RFC 
1493), and it uses the SNMP Repeater MIB (RFC 2108) to identify hubs. Port 
connectivity can be mapped if LANsurveyor Express has access to these MIBs. If 
your routers and switches are not displayed on your map, use the following 
checklist to troubleshoot your SNMP access. 

Does your device support SNMP?  

SNMP-capable network devices may also be called smart or managed 
devices. Refer to the device manufacturer to ensure that the device is 
SNMP-capable. 

Is SNMP enabled?  

Some devices require specific configuration procedures to enable SNMP. 
Confirm that your device is configured for SNMP as directed by the device 
manufacturer. Instructions for enabling SNMP on Windows devices may be 
found by searching “configure SNMP” at www.microsoft.com. Instructions for 
enabling SNMP on Cisco devices may be found by searching “configuring 
SNMP user” at www.cisco.com. 

Are you using the correct SNMP community string?  

Community strings, like passwords, are case sensitive. Ensure that the 
correct community string is provided on the Network tab of the Advanced 
Options window. For more information, see “Creating Maps” on page 10. 

Is the computer running LANsurveyor Express on the access control list 
for your device?  

Many devices limit SNMP access to a specific IP address or address range. 
This access control list is generally configured using the switch management 
interface in a browser. Consult the device documentation or the device 
manufacturer for more information.  
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Is the device too busy to respond to SNMP queries?   

If a device is operating at or near 100% utilization, it may not have the 
resources available to properly respond to SNMP queries. 

Is there a firewall between you and the target device?  

Some sites have established firewalls around their routers to prevent 
unauthorized access. If a port must be opened in a firewall, LANsurveyor 
Express uses UDP port 161 for SNMP queries. 

Is the SNMP query timeout sufficiently long?  

If the SNMP query timeout is not sufficiently long, the device may not have 
the opportunity to properly respond to SNMP queries from LANsurveyor 
Express. If queries are sent across particularly slow or busy links, increase 
the SNMP Query timeout on the Network tab of the Advanced Options 
window. For more information, see “Creating Maps” on page 10. 
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Appendix B 

Troubleshooting LANsurveyor Express Issues 

Though LANsurveyor Express functions as a fully integrated add-on to Microsoft 
Visio 2007, some issues with using Microsoft Visio 2007 may arise. The following 
FAQ addresses some of the more common issues. 

Why is LANsurveyor Express having trouble exporting maps to Microsoft 
Visio? 
LANsurveyor Express requires Microsoft Visio 2007 or later. If Microsoft Visio 
2007 is not installed or if a version older than Microsoft Visio 2007 is installed, 
LANsurveyor Express can not render maps after network discovery completes. 

Does LANsurveyor Express require administrator privileges? 
The only feature that LANsurveyor Express can not enable without administrator 
privileges is the discovery of nodes via ICMP ping. Regardless of whether or not 
you think you are logged-in as an administrator, LANsurveyor Express attempts 
to "ping" itself when starting. If an error displays, the problem is usually 
insufficient user privileges. 

You can confirm this diagnosis by opening a Windows command prompt and 
typing ping 127.0.0.1. This command attempts to ping the local machine. If 
this request fails, then Windows is indicating that you do not have sufficient 
privileges to send ICMP packets. 

How does LANsurveyor Express assign shapes to nodes? 
LANsurveyor Express assigns shapes to nodes based solely on the responses it 
receives when performing network discovery. The following is a list of response 
types and the corresponding icons that are assigned. 

• ICMP: Generic IP icon 

• NetBIOS: Generic PC icon 

• LANsurveyor Responder: LANsurveyor Responder icon based on OS 

• SNMP: Icon assignment is based on the SNMP ID of the discovered 
device. Each manufacturer is assigned a unique SNMP ID. 

Note: LANsurveyor Express does not have the ability to differentiate between PC 
manufacturers. A DELL PC sends the same response as an HP PC. In addition, 
LANsurveyor Express can not tell which computers are running servers and 
which computers are not.  
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Can LANsurveyor Express discover and map nodes connected via wireless 
access points? 
If the wireless access point is configured as a bridge, then LANsurveyor Express 
can map the nodes connected to it. If the wireless access point (or any other 
router) is configured to use network address translation (NAT), then no network 
analysis tool will be able to go beyond the device to examine the nodes 
connected to it because NAT is designed to hide multiple workstations behind a 
single IP address. 

Can LANsurveyor Express use third party stencils and shapes? 
The easiest way to use third party stencils and shapes on your network maps is 
to buy the full version of LANsurveyor. With the full version you can replace the 
icons of any of the devices with icons of your choice. When you export the 
LANsurveyor map to Microsoft Visio 2007 these icons will be converted into Visio 
shapes.  

It is possible to replace shapes, but in order to do so you must configure your 
third party shapes and stencils so that LANsurveyor Express can recognize and 
use them. The following procedure provides the steps required to complete this 
configuration.  

To use third party stencils and shapes with LANsurveyor Express: 

1. Launch Microsoft Visio 2007. 

Note: Generally, you should be able to open Microsoft Visio 2007 by clicking 
Start > All Programs > Microsoft Office > Microsoft Office Visio 2007. 

2. Click Tools > Options, and then click the Advanced tab. 

3. Clear the Open each ShapeSheet in the same window option. 

4. Open the LANsurveyor Express stencil containing the shape you want to 
replace, and then open the stencil that contains the shape you want to use. 

5. Right-click on the LANsurveyor Express stencil, and then click Edit Stencil. 

6. Copy the shape you want to use into the LANsurveyor stencil. 

7. Right-click on your shape, and then click Edit Master > Master Shape. 
Repeat for the LANsurveyor Express shape.  

8. In the shape window, select your shape, and then click Window > Show 
ShapeSheet. Repeat for the LANsurveyor Express shape. 

9. Edit the shapesheet of the new shape so that it matches the shapesheet of 
the old shape. 

Note: Do not change the Shape Transform section or the User.ShapeType 
and User.SubShapeType rows of the User-defined Cells section. 
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10. Save the new shape. 

11. Rename the old shape to ShapeName-Old where ShapeName is the current 
name of the shape. Rename the new shape to ShapeName where ShapeName 
was the name of the LANsurveyor Express shape. 

12. Save the LANsurveyor Express Stencil. 

13. Build a new map using LANsurveyor Express. Your new shape should 
replace the old shape. 
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