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Introduction

Welcome

LANsurveyor is network management software any network manager, administrator,
engineer, or designer can use to automatically diagram networks of any size. The
LANsurveyor map provides a graphical interface so you can manage your network from
anywhere on the network.

With LANsurveyor, you can:

e draw a map showing the logical connectivity of your entire network

* make queries of network objects for such information as Simple Network
Management Protocol (SNMP) data and Responder client data

® add icons to your map to represent network objects

¢ be alerted when a new device is added to your network

¢ launch other applications using the map as an interface

e create reports aboutanyitems on the map

e scan your network for intruders using one or more maps as the baseline and
automatically disable network access for rogue nodes

With LANsurveyor's Responder client add-on, you can:

* manage remote Windows, Linux, and Mac OS nodes from the LANsurveyor map,
including starting and stopping applications, distributing files and folders,

restarting and shutting down, and synchronizing clocks

¢ help plan your backup and disaster recovery strategy

Licensing

If you are using the evaluation version of LANsurveyor, please purchase a LANsurveyor
license. Licensed users receive information on free updates and upgrade availability,
and onlylicensed users can receive technical support.
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Compatibility

To use LANsurveyor, you must have the following:

¢ APentium-class computer with 256MB memory

* Windows 2003, Vista (professional, workstation, or server editions), 7, 2008, or
2008 R2

e Aconnection to an IP-based network

Additionally, some LANsurveyor features require the following:

¢ Responder client software add-on jnstalled on nodes for reports and client
management.

¢ Nodes that understand SNMP (called "SNMP Agents") and the community string
(or password) for SNMP devices you wish to report on. Some of the SNMP Agents
used by LANsurveyor are:

* MIB-Il SNMP agents that exist on nearly all IP routers and many IP devices.
¢ Printer MIB SNMP agents that exist on some IP printers.

e Bridge MIB SNMP agents to determine switch port connectivity.

e Repeater MIB SNMP agents to determine hub port connectivity.

e Microsoft SQL Server 2005 or Microsoft SQL Server 2005 Express to store SNMP
configuration and Responder clientinformation in LANsurveyor's Repository.

Upgrade LANsurveyor

Upgrading from LANsurveyor 10.2 or 10.3

If you are running LANsurveyor 10.2 or 10.3 on Windows 2003, Vista, 7, or 2008,
you can upgrade to LANsurveyor 10.4 by following the Install LANsurveyor procedures.
Settings and configuration information are transferred to the new installation
automatically.

If you are running LANsurveyor 10.2 on Windows 2000, upgrading to LANsurveyor
10.4 is not supported. You will need to first upgrade to a supported version of
Windows (2003, Vista, 7, or 2008). Then you will need to uninstall the LANsurveyor 10.2
software (using Start > Control Panel > Add or Remove Programs), and do a clean
install of 10.4 by following the Install LANsurveyor procedures.
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Releases of LANsurveyor Prior to 10.2

If you are running a release of LANsurveyor prior to 10.2, upgrading is not
supported. You will first need to ensure that your system has a supported version of
Windows (2003, Vista, 7, or 2008) and upgrade if it does not. Then you will need to
uninstall the previous LANsurveyor software (using Start > Control Panel > Add or
Remove Programs), and do a clean install of 10.4 by following the Install LANsurveyor
procedures.

Install LANsurveyor

Note: If you have been running the evaluation version of the LANsurveyor software, you
must uninstall the evaluation software before installing the licensed version.

To uninstall the LANsurveyor evaluation version:

1.
2.

Click Start > Control Panel, and then double-click Add or Remove Programs.
Click SolarWinds LANsurveyor in the Currently installed programs list, and
then click Remove.

To download and install your LANsurveyor software:

1.

aghrwDd

o

Log in to the SolarWinds portal at http://www.solarwinds.com/customerportal
using the login information you received from SolarWinds.

Click View All in the DOWNLOADS section of the ALERTS & NEWS tab.
Locate the LANsurveyor section, and then click DOWNLOAD NOW.

Click Save Hle, and then click OK.

After the download finishes, double-click the LANsurveyor-v<XX.X>.zip file to
open it.

Double-click the LANsurveyor<version>.exe installer file, where version is
the version number of your LANsurveyor software, for example
LANsurveyorl04.exe is the installer for LANsurveyor version 10.4.

Click Run when you are prompted “Do you want to run this file?”.

Follow the instructions in the SolarWinds LANsurveyor Setup Wizard.

To license and register your LANsurveyor software:

1.
2.

3.

4,

Run LANsurveyor.

In the Solarwinds LANsurveyor dialog, enter your Name, Organization, and
the Serial Number you received in the SolarWinds e-mail, and then click OK.
If you are warned that some of LANsurveyor’s features may be unavailable,
make note of the likely causes of this problem, and then click OK.

In the Online Registration dialog, enter the requested information, and then
click Register Now.

Your software is now licensed and registered, and you are ready to begin using
LANsurveyor.
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Configure LANsurveyor for Windows Vista/7/2008

The Windows Vista/7/2008 firewall blocks ICMP ping replies by default, preventing
LANsurveyor from performing network discovery using ping. To correct the situation,
either adminstratively turn off the Vista firewall or add a rule permitting ping replies
through the firewall, as shown in the following procedure.

To add a rule enabling ICMP ping for LANsurveyor on Windows Vista/7/2008:

1. Login to Windows as an Administrator.

2. Click Start>Control Panel>Administrative Tools>Windows Frewall with Advanced
Security.

Note: This option is not available if you are not an Administrator.

. Click Inbound Rules in the left pane.

. Click New Rule in the right pane.

. Select Custom, and then click Next.

. Select All programs, and then click Next.

. Select ICMPv4 as the Protocol type, and then click Next.

. Confirm that Any IP address is selected for both Which local IP addresses does
this rule match? and Which remote IP addresses does this rule match?, and then
click Next.

9. Select Allow the connection on the Action page, and then click Next.

10.Confirm that all options are checked on the Profile page, and then click Next.

11.Provide an appropriate Name for your new rule, and then click Finish.

12.Repeat the preceding steps, clicking Outbound Rules instead of Inbound Rules.

13.Test the new rules by opening LANsurveyor and then creating a new map with only

ICMP (Ping) checked in the Other IP Service Discovery area of the Create a New
Network Map window.

0O ~NO O W

The Mapping Progress window will show ICMP receipts, and the resulting map should
show one or more workstations with generic IP icons.

Install Responder Clients

Your LANsurveyor Installation includes the Responder client add-on installers for
Windows, Linux, and Mac OS computers unless you are running the evaluation version.

Note for Evaluation Version: If you are running the evaluation version of LANsurveyor,
the Responder clientinstallers are notincluded, however you can download them if
desired from the following location: http://www.solarwinds.com/
embedded_in_products/productlink.aspx?id=L ANsurveyor_Responders. The
evaluation version includes licenses for up to 5 Responder clients, so you can install
and evaluate up to 5 Responder clients without using the License Manager to enter
Responder Client licenses.

Some of LANsurveyor's most advanced reporting and management features require
the Responder client add-on to be installed on network computers, and systems with a

4 :: Introduction


http://www.solarwinds.com/embedded_in_products/productLink.aspx?id=LANsurveyor_Responders
http://www.solarwinds.com/embedded_in_products/productLink.aspx?id=LANsurveyor_Responders

Administrator Guide : : SolarWinds LANsurveyor

Responder client can have their hardware and software asset data automatically
stored in LANsurveyor's Repository. See Repository for information on installing the
Repository.

LANsurveyor Responder client licenses must be purchased separately from your
LANsurveyor license. Contact sales @solarwinds.com to obtain the LANsurveyor
Responder clientlicenses.

Install Responder Client License

Use LANsurveyor's License Manager to install the Responder client add-on licenses.
Note that the LANsurveyor Responder clients require a separate license thatis
different from your LANsurveyor license.

To install the Responder client add-on licenses:

1. Select License Manager from the Window menu, then enter your Responder client
license code.
2. After entering the license code, click Add License, and then click OK.

Deploy via Directory Services

You can deploy Responder clients to 2000, XP, 2003 and Vista-based Windows
computers through Remote Procedure Call and Remote Registry services using a
directory service such as Active Directory. To deploy using Active Directory, log into the
LANsurveyor computer using an account in an Active Directory administrative group
(Domain Admins or Enterprise Admins).

Note for Evaluation Version: If you are running the evaluation version of LANsurveyor,
the option to Deploy via Directory Services is not supported. You must deploy the
Responder clients manually, as described in the "Deploy Manually" section that
follows.

When you create your map, LANsurveyor will prompt you to deploy your Responder
clients.

To deploy your Responder clients if you have already created a map (or declined to
deploy when first prompted):

1. Select XP/2003/2K/Vista LANsurveyor Responders... from the Tools>Deploy menu.

2. The Deploy Responder client wizard is displayed, allowing you to select the
appropriate computers and the schedule for deployment.
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Tip: If you're having difficulty deploying via Directory Services, configure your Windows
workstations as follows:

¢ Ensure thatthe Remote Registry service is running
e Ensure thatthe RPC service is running

e Turn on file and print sharing service and configure your workstation firewall to
allow connections to UDP 137, UDP 138, UDP 445, and TCP 139, and TCP 445
ports

Deploy Manually

You can copythe client installation software to any system (or to a central server) for
local installation. All supported Responder clientinstallers are included in folders in
the LANsurveyor installation directory (e.g., "Linux LANsurveyor Responders™).

Note for Evaluation Version: If you are running the evaluation version of LANsurveyor,
the Responder clientinstallers are notincluded in folders in the LANsurveyor
installation directory. You can download them from the following location: http://www.
solarwinds.com/embedded in products/productLink.aspx?

id=LANsurveyor_Responders.

There are two Linuxinstallers: rpm for RedHat based systems and deb for Debian
based systems. Refer to the "nrlinux-readme.doc" file in the folder for up-to-date
information on installing Responder clients on Linuxsystems as well as supported
systems.

After copying the Responder client installers to each of the client systems, install the
Responder client on each client system by running the installer.

If you deploy the Responder client manually, as described in this section, you will need
to password protect your Responder client using the Manage wizard.

Upgrade Responder Clients

Other than manually using the installation software on each computer, LANsurveyor
provides two methods for automatically upgrading Responder client software on your
workstations and servers.

Upgrade Responder Clients Wizard
The easiest method is to use the Upgrade Wizard. Select Upgrade LANsurveyor

Responders... from the Tools menu, and the wizard will upgrade all Responder clients
on anyopen LANsurveyor map to the latest revision.
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There are five steps in the wizard:

¢ Selectthe name and location for a Microsoft Excel-format file that will contain the
current status of each node during the upgrade process (optional)

¢ Determine whether systems that require restart should be automatically restarted
to complete the upgrade

e Compose an instant message that will be sent if a restartis necessaryso users
can be prepared for the restart

e Specifyretry frequency and number of days to try to upgrade nodes that are offline
and cannot be upgraded when the upgrade is executed

¢ Schedule the upgrade eitherimmediately or at a specified time in the future

The upgrade process will automatically select the proper Responder client version to
send to each workstation, only upgrade nodes that are running an older version of the
Responder client, and save the status of the upgrade in a file (if you chose one in the

wizard).

Send Fle Wizard

If you would rather upgrade only selected Responder clients, use LANsurveyor's Send
File feature.

Select Send Fle from the Manage menu to start the three step wizard:

e Select the computers you want to upgrade from each map

¢ Use the browse button to select the Responder client upgrade file and select
Responder client from the Destination pull-down

e Schedule the upgrade either immediately or at a specified time in the future

The Responder client upgrade files are located in the "LANsurveyor Responder
Updaters" folder in the SolarWinds LANsurveyor application folder. There are different
files for the different OSes supported.

Once the wizard completes, you need to either restart the Responder client service
(Windows NT/2K/XP/Vista), restart the computer (Windows 95/98/ME and Mac OS), or
log off the currentuser and log back in (Mac OS X) to load the upgraded software.
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Remove Responder Clients

You can uninstall Responder clients from 2000, XP, 2003, and Vista-based Windows
computers through a directory service such as Active Directory.

To uninstall Responder clients from 2000, XP, 2003, and Vista-based Windows
computers through a directory service:

1. Log into the LANsurveyor computer using an accountin an administrative group
(Domain Admins or Enterprise Admins for Active Directory).

2. Open a map with the computers that have the Responder clients installed.

3. Select XP/2003/2K/Vista LANsurveyor Responders... from the Tools>Uninstall
menu.

4. The Uninstall Responder client wizard is displayed, allowing you to select the
appropriate computers and the schedule for the removal.

Manually Remove Responder client
Windows Systems

You can also remove Responder clients manually on Windows systems with your
choice of methods:

(Method 1) To remove Responder clients manually on a Windows system using
Control Panel:

1. Click Add or Remove Programs in Control Panel to remove Responder clients on a
system.
2. The Responder client software will be uninstalled.

(Method 2) To remove Responder clients manually on a Windows system using
Control Panel:

Since the Responder clientruns as a service on Windows Vista/XP/2003/2000
systems, you can use Computer Management to remove the Responder clients.

1.In Control Panel, click Administrative Tools.

2. Then double-click Computer Management.

3. Expand theServices and Applications category and click Services.

4. The Responder client service should be displayed among the other running services
in the right window

5. Right-click the Responder client service and select Properties.

6. Click Stop to stop the service and change Startup type to Disabled.

7. Note where the executable is located on your disk in the Path to executable field.

8 :: Introduction
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Linux

Use either rpm or deb to uninstall the Linux Responder client. The uninstall process
will also stop the Responder client if itis currently running.

For rpm based installations, use: rpm - e neonr esponder

For deb based installations, use: deb - P neonr esponder

Mac OS X

Run the Responder clientinstaller software and choose the Uninstall option.
Mac OS 9 and earlier

Drag the Responder client extension to the trash can and restart the system.

Repository

LANsurveyor's Repository collects asset data from SNMP-enabled network equipment
in addition to workstations and servers running the Responder client software and
stores the data on a regular basis in a database. LANsurveyor uses either Microsoft
SQL Server Express or Microsoft SQL Server (either locally or across the network).

This section covers pre-installation considerations as well as Repository setup.
Responder clients

Asset data stored in the Repository is gathered from systems running the optional
Responder client software. In order to store data in the Repository, Responder clients

must be version 5.4 or later. Refer to the Install Responder clients or Upgrade
Responder client sections of this manual for more information.

Responder clients are assigned their primary database key based on the millisecond
the LANsurveyor system installs the key.

SNMP-enabled Network Equipment

SNMP asset data can also be stored in the Repository including basic configuration
information, printer statistics, and APC-specific UPS data.

Introduction :: 9
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Architecture Considerations

If you plan to use just one copy of LANsurveyor at your site, you can skip this section.
You can also skip this section if you plan to implement multiple copies of LANsurveyor
with independent Repository databases.

If your organization plans to implement more than one copy of LANsurveyor with a
shared database, you need to consider which copy of LANsurveyor will be responsible
for gathering data from which clients. The responsibility for gathering client data lies
with the LANsurveyor applications and is based on the maps either opened or
specified at each copy of LANsurveyor under AutoOpen options.

Computers included on maps opened by multiple copies of LANsurveyor will be
subject to multiple Repository requests within the same data collection period. There
will not be multiple primary records for the computers; rather, there will be duplicate
entries for individual pieces of information, such as memory, CPU speed, etc. For
example, if there are two copies of LANsurveyor, a central SQL Server Repository, and
the Repositoryis setto gather information once a week from each system, each
system included on the active or specified LANsurveyor diagrams of both LANsurveyor
systems will have information gathered twice per week rather than once per week.

Sites with multiple copies of LANsurveyor may share maps between systems so each
copy has access to a superset of network data. In order to prevent inadvertent
duplication of Repository resources, each copy of LANsurveyor can specify which maps
should be used for Repository tasks using the AutoOpen option.
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Repository Installation
To install, configure, and run the Repository:

1. Select Tools>Options and click the Repository tab.

2. Click Install Repository to begin the installation process.

3. If you want to connect to an existing SQL Server, select Use Existing SQL Server.

a) Enter the full name of the existing SQL Server in the Server Name field.

b) Enter the User Name and Password for a user with administrative rights. Provide an
administrator's login name and password (or a login with enough permissions to
create a database and run the sp_addlogin stored procedure).

4.1f you want to install a new SQL Server Express database, select Install New
Database.

The most current installation instructions and links to supported SQL Server Express
software are available on the SolarWinds website at http://www.solarwinds.com/
lansurveyor/Repositoryinstructions .htm.

5. Click Next.

6. If you chose to install a new SQL Server Express database in step 4, enter your
UserName and Password for the Repository. Then Confirm Password by re-
entering it.

Note the information displayed about saving the login info for creating reports with
third party tools and the need to use strong passwords for SQL Server.

7. Click Finish.

Once the Repositoryis successfullyinstalled, the other options become available.

Note: If you have maps created with prior versions of LANsurveyor or older
Responder client software installed, you will need to upgrade your Responder client
software and draw a new map to begin data capture.

After the Repositoryis created and a new LANsurveyor map is generated, Responder
clients and SNMP systems are automatically tracked in the Repository.

Repository Options

To display the Repository tab at any time: select Tools>Options and click the
Repository tab.

Uninstall Repository
Click Uninstall Repository to uninstall the repositiory.
Change Repository Password
To change the repository password:
1. Click Change Repository Password. The Change Repository Login Information

dialog is displayed.
2. Enter the User Name.
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3. Enter the Current Password.

4. Enter the New Password.

5. Confirm New Password by re-entering it.

6. Click OK to change the repository password.
Alert on any Repository error, use alert

Use the menu to specify an alert to use if LANsurveyor encounters a Repository
error.

Create Repository backup every
Specify the backup frequency (in days).

Run Repository maintenance every
Specify the frequency (in days) for running the internal maintenance routines.
LANsurveyor includes these built-in database maintenance utilities to optimize
and protect your Repository.

Asset Data Collection Options

The Asset Data Collection section of the Repository tab allows you to specify
Repository settings for this specific copy of LANsurveyor.

Collect asset data every
Specify how frequently (in days) LANsurveyor should attemptto collect asset data.
Retry unresponsive nodes every

Specify how frequently (in hours) LANsurveyor should attempt to contact
unresponsive nodes.

Discard asset data older than

Specify how long data should be retained (in months). This option helps you to
minimize the database resources used to maintain asset information.

Alert on unresponsive nodes, use alert
Use the menu to specify an alert to use if LANsurveyor encounters an
unresponsive node. If LANsurveyor fails to gather asset data within the given

number of days, selecting this option causes an alertto be sent for each missing
node.
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Change LANsurveyor Responder Node Collection Status

Displays a dialog that allows you select the Responder nodes for which
LANsurveyor collects asset data.

Change SNMP Node Collection Status

Displays a dialog that allows you select the SNMP nodes for which LANsurveyor
collects asset data.

Always use Repository data when generating reports

If selected, LANsurveyor uses Repository for all custom reports with Responder
client data fields as well as the Software Inventory, Missing Software, and
Hardware Inventory standard reports. LANsurveyor will never use the Repository
for Backup Profiler, Software Meter, or Get Info reports as these are real-time in

nature.

Collect Basic Configuration Data

If selected, uses SNMP to collect basic configuration data for nodes.
Collect Printer Stats

If selected, uses SNMP to collect printer stats.
Collect APC UPS Stats

If selected, uses SNMP to collect APC UPS stats.
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Repository Monitor

The Repository Monitor shows the current status of the Repository database, including
the last maintenance operations and any current actions. Select Repository Monitor
from the Window menu to view the Repository Monitor.

If LANsurveyor is unable to collect data from every node within the time specified in the
Asset Data Collection section of the Repository options tab, the nodes are listed in the
Repository Asset Data List. Click the Queue button to view the list. If the Queue button
is unavailable, every node is up to date.
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Draw a Map

Start LANsurveyor

LANsurveyor launches exactly like any other application. Double-click the LANsurveyor
icon or the icon of any LANsurveyor document.

The firsttime you use LANsurveyor, personalize your copy of the program. Enter your
name and serial number in the appropriate text boxes. The serial numberis case
sensitive and must be typed exactly as you received it.

Once you personalize your copy of LANsurveyor, LANsurveyor prompts you to set your
default authentication preferences. Ata minimum, we recommend you set your SNMP
community string(s). Otherwise, your LANsurveyor map will show neither connectivity
outside LANsurveyor's subnet nor managed switch and hub connectivity.

Note: Make sure ICMP Ping requests and responses are allowed in your firewall and
the network policy configuration for the user logged into the system running
LANsurveyor.

Getting Started with LANsurveyor Dialog

The Getting Started with LANsurveyor Dialog is displayed each time you run
LANsurveyor.

This dialog contains useful options you can explore for learning about LANsurveyor:

e >>View example map — view a sample map using Visio (requires a
supported version of Visio).

e Watch a video intro — watch a video introduction to using LANsurveyor.

e Learn more >> —read about creating maps for Orion with LANsurveyor.

e >>thwack LANsurveyor forum — browse questions and answers from
LANsurweyor users.

e >> Online Manual — display a page where you can click the link to view the
LANsurveyor Online Manual.

e >> Evaluation Guide — display a page where you can click the link to view
the LANsurveyor Evaluation Guide.

e >> Support —view the SolarWinds Customer Support portal, where you can
find support resources.

Click Close to dismiss the dialog when you are finished using it.
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To prevent this dialog from being displayed each time you run LANsurveyor, check the
option Don't shown again at the bottom of the dialog and then click Close.

Create a New Map

Once you personalize your copy of LANsurveyor, the Create ANew Network Map dialog
is displayed. LANsurveyor automatically builds a map of your network by searching for
network objects, such as routers, networks, and end nodes.

LANsurveyor incorporates a number of different discovery and query methods in order
to provide you with the most complete and accurate map possible (including node
name). These discovery and query methods include ICMP (ping), SNMP, NetBIOS, SIP,
CDP (Cisco Discovery Protocol), LLDP (Link Layer Discovery Protocol), and installed
client software, including our own Responder client software.

Note: Make sure you license and install the Responder client add-on if you want to use
LANsurveyor's remote management features or the Windows, Macintosh, and Linux
assetmanagement. If you are in an Active Directory environment, you may deploy
Windows Responder clients automatically after the map is created.

Select which items you would like to include on your map:

e |P Address Range

e Hops

e SNMP Devices

e Responder clients

e |CMP (Ping)

e NetBIOS

e S|P Clients

e Active Directory Domain Controllers

and specifythe desired mapping speed.

After you have chosen your options, click Start Network Discovery to automatically
build your network map.

You may build maps in parallel, and you can open any number of maps, even while a
new map is being created.
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LANsurveyor automatically builds the map:

* network requests are sentto discover nodes

¢ jtems that respond to more than one type of query (e.g., SNMP and ICMP) are
merged

IP addresses are assigned to each network object

icons are assigned to each network object

managed switch and hub ports are mapped

SNMP interfaces are mapped

e networks and nodes are arranged

The map building and layout process maytake a long time on large networks. Allow at
least four seconds per ten IP addresses with all search options enabled.

LANsurveyor supports different map levels. Level 1 maps show routers, Level 2 maps
show routers and switches. Configure your display preferences using LANsurveyor

Level Options.

Add another IP address range to an existing map with Add to Map from the Tools
menu, and keep your map up-to-date (and your network secure) with Continuous Scan.

IP Address Range

Enter the IP address range(s) of your network. This defines the scope of the search for
the map. The default IP address range comes from the network settings of the
computer running LANsurveyor.

Mapping Multiple VLANs

LANsurveyor is capable of discovering and mapping multiple VLANs on Layer 2. For
example, to map a switch connecting multiple, non-consecutive VLANSs (e.g.,
10.110.1.0,10.111.1.0,10.112, 1.0), simply enter your VLAN ranges as the IP address
ranges to search.

Hops

LANsurveyor can also show connectivity between different networks (i.e., network
segments separated by routers or "hops"). Enter the number of hops LANsurveyor
should scan. You must have an SNMP-capable router and the SNMP community string
to automatically discover connectivity between networks. LANsurveyor can also display
each interface and the connected network segment.
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SNMP Devices

You may include routers, printers, network attached storage (NAS), UPS systems, and
other managed network devices on your map. Simply select SNMP and enter one or
more SNMP community strings (or passwords) for the devices, separated by spaces or
commas. Use the lock icon to hide the strings. If you do not know the community string,
try "public”, a common default access string.

Maps drawn without access to SNMP-based routers will not show connectivity between
network segments.

Responder Clients

LANsurveyor's most advanced client reporting and management features are available
using the Responder client add-on. Select the Responder client check boxand enter
your password to map and manage Windows, Linux, and Macintosh computers with

the Responder client installed.

To change the Responder client password on remote nodes (or to add a password),
select Update LANsurveyor Responder Passwords from the Tools menu and follow
the wizard.

The default Responder client password is stored with LANsurveyor's Network Options.
Each map can also have its own Responder client password so you can have different
passwords for different sites. Set the map-specific password in the Map Properties

dialog box or when first creating the map in the Create a New Network Map dialog box.

There are several methods you can use to upgrade your Responder client software, as
detailed in the Upgrade Responder clients section.

ICMP (Ping)

Some devices are not supported by Responder clients, do not support SNMP, and do
not have supported third party client software. To increase your chances of including
those nodes on your map, click the ICMP check box.

NetBIOS

Use NetBIOS to find network nodes running Microsoft Networking and include NetBIOS
node names on your network diagram.
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SIP Clients

LANsurveyor discovers and diagrams SIP-based Voice-over-IP (VoIP) devices,
including telephones, video conferencing systems, and other SIP devices. Reports can
include SIP devices and SIP-specific information, and the switch port report identifies
exactly where SIP devices are connected to switches.

If your site uses a non-default SIP UDP socket, set your UDP socket number in the
Network Options dialog box by selecting Options from the Tools menu and then
selecting the Network tab.

Active Directory Domain Controllers

LANsurveyor can map your Active Directory infrastructure onto the physical
infrastructure of your network. If you want to view just your Domain Controllers and your
infrastructure, use Filters.

Click the Active Directory DCs option to discover the domain controllers on your
network. By default, LANsurveyor uses the credentials of the person running
LANsurveyor. If you want to use different credentials, click Authentication, Use these
domain credentials, and then Add to enter the credentials you would like to use.

Note: Active Directory only allows one user to be logged into a domain ata time from
any given system. Therefore, if you are alreadylogged into a domain as the
LANsurveyor user and you would like to discover that domain, make sure that user has
administrator access.

Mapping Speed

The mapping speed slider modifies the Network Timeouts, setin the Network Tab of
the program options dialog box.

Slower devices and devices separated by several hops require more time to discover
than faster, closer devices. Setting the slider to "slower" gives greater accuracy.

Mapping switch and hub ports also takes time. You can significantly speed mapping

on large networks if you uncheck the Map switch/hub ports option on the
Miscellaneous tab of LANsurveyor's application preferences.
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Troubleshooting Your Map

LANsurveyor maps include icons to represent your end-nodes and SNMP-enabled
devices. If the map icons are generic "IP" computer icons, one or more of the following
could be true:

e your devices do not support SNMP
e SNMP is not enabled on your devices

¢ you do not have the correct SNMP community string (password) for your SNMP
devices

¢ your SNMP devices' access control lists haven't been configured to accept
requests from the LANsurveyor computer

¢ afirewall is preventing access to your devices (SNMP, ICMP, SIP, etc. requests
are blocked)

Refer to Appendix C, SNMP Checklist, for troubleshooting details. Also, consider
including more autodiscovery options in the Create a New Network Map dialog box,
adding Responder clients, and checking to make sure you have the correct SIP UDP
port specified in the Network Options dialog box.

Finally, try building your map using a slower, more accurate mapping speed.

Read a Map

When LANsurveyor finishes searching the network, a Map Window displays your new
map. Maps contain four types of network objects: networks, routers, managed
switches/hubs, and end nodes. If you have managed hubs or switches and you have
entered the community string for those devices, the LANsurveyor map will also display
port connectivity for those devices. LANsurveyor will also display interface information
for any SNMP device with more than one interface (e.g., routers and servers with more
than one network connection).

If you have a large network, your map may show just Level 1 objects (routers) or Level 2
objects (routers and switches), depending on the settings in the Levels section in
LANsurveyor Options dialog box. Select Options from the Tools menu and then select
the Levels tab to view the settings.
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Networks

LANsurveyor represents both wired and wireless networks as lines and displays IP
address ranges below and to the left of network lines.

Routers

Routers allow the transfer of data between networks. To properly display a network's
connectivity, the router must support SNMP. LANsurveyor represents a router by
displaying a custom icon with lines drawn to the networks to which the router is directly
connected.

If a router's type cannot be determined or no icon is available, a generic router icon is

used. You can manuallyassign a more meaningful icon and name to the router by
using the Node Properties item in the Edit menu.

Managed Switches/Hubs

Most end nodes connect to the network through hubs and switches. If you have SNMP-
enabled (or "managed"”) hubs or switches, LANsurveyor draws those nodes on the
map connected to the appropriate hub or switch and displays the portinformation on
the map.

If a hub or switch type cannot be determined or no icon is available, a genericicon is

used. You can manuallyassign a more meaningful icon and name by using the Node
Properties item in the Edit menu.

End Nodes

An end node is any device that does not behave like a router or a managed hub or
switch. Examples of end node objects are computers, printers, SIP phones, and
unmanaged hubs and switches.

LANsurveyor uses icons to represent end nodes. LANsurveyor includes hundreds of
icons to provide the most accurate representation of your network possible.

Computers with Responder clients installed use an icon with the LANsurveyor
compass in the center of the screen:

k|||;, Green: Windows NT, 2000, XP, 2003, and Vista

k|||;, Blue: Windows 95, 98, and ME
R
I |[F= orange: Linux
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5=
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L purple: Mac 0S X
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k||_|—/ Grey: Classic Mac OS

View Map Levels
Map levels make your maps easier to view. LANsurveyor maps can have thousands of
nodes, so LANsurveyor automatically groups map objects into three levels:
e Level 1includes network segments and routers (SNMP supportis required to
identify routers)

e Level 2 includes network segments, routers and switches (SNMP supportis
required to identify switches)

e Level 3includes network segments, routers, switches, and all other end
nodes

Your default map view is determined bythe Levels settings in the Options dialog.

Change Map Levels

To change your map level, click one of the map level icons. Click the Level 1 icon < to
view just your routers and network segments. Click the Level 2 icon 25 (0 view Level 1

plus your switches. The Level 3 icon - displays all map nodes. To limitthe nodes
displayed in Level 3 to certain classes of objects (e.g., just nodes thatresponded to
SNMP queries), use Level 3 object filtering in the Options dialog.

When you change your map view level, the map is redrawn and any changes you've
made to your map will be lost unless you undo the map level change. Therefore, if you
have arranged your map objects manually, make sure you save a copy of your initial
map to preserve your changes.

Show/Hide Nodes

You can display nodes connected to a specific device using the Show Sub-Level /Hide
Sub-Level icons. For example, if you want to see nodes connected to a switch in a

Level 2 view, click the switch icon on the map then click the Show Sub-Level icon '1') If
you want to hide nodes connected to a router, click the router icon on the map then click

the Hide Sub-Level icon :)

You can combine map levels and show/hide nodes to display a specific area of
interest on your network.
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Focus in New Window

Click the Focus in New Window icon to create a new map with the selected object
and all connected sub-level objects. If you select a router and use Focus in New
Window, the router, attached switches, and connected end nodes will be displayed in a
new map. If you select a switch, just the nodes connected to the switch will be
displayed.

Customized Visio Output

At any point, you can click the Save To Visio icon |£| or select Save as Visio from the
FHle menu to generate a copy of what you see on your screen in Visio format. Refer to
the Save as Visio section for more information.

Filter Map Objects

Click the Map View Filters icon T in the toolbar to display the Map View Filters dialog.
This dialog allows you to automatically obtain a more focused version of your network.
For example, you can display your map with only those nodes with SNMP enabled
(select SNMP Nodes) or just your Active Directory infrastructure (select Active Directory
DCs).

Combined with the Groups capability, you can filter your map so only those nodes
which belong to a specific group or 'system' are included.

Add To Map

You can include non-contiguous or disconnected network segments on the same map
by specifying the ranges on the Create ANew Network Map dialog or by selecting Add
To Map from the Tools menu. You can add as many different segments as you would
like on the same map.

You can add a single node to your map or connect two different network segments
using the Create Node option from the Edit menu.

Use Continuous Scan if you want LANsurveyor to keep your map up-to-date.
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Node Properties

You can change the appearance and underlying properties of any selected map item.
Select Node Properties from the Edit menu to display the Node Properties dialog box.

The Node Properties dialog box allows you to change the name, IP address, and
whether the node is locked. If the Locked option is checked, the name will not be
changed during rescan or Continuous Scan. Manually changing the node name
causes the Locked option to be checked.

You can also change the icon for the node as well as the underlying technologies
supported: Responder client, SNMP, and the SNMP access information. If the device
supports CDP or LLDP, information is automatically stored in the Autodiscovery
Properties.

If you are using Continuous Scan and wish to automatically disable network access for
rogue nodes, you may need to store a read/write SNMP access string for each of your
managed switches.

Move Map Objects

Objects on the map can be moved using standard click and drag techniques. To move
an object to a new location, simply click and hold the mouse button over the objectto
highlightitand use the mouse to reposition the object in a new location. Al
relationships between objects on the map will be maintained when an objectis
moved. Similarly, you can highlight several objects atthe same time and move them to
a new location. Multiple objects can be selected using a variety of methods including:

® Click several objects while holding down the shift key.

e Click a blank section of the Map Window and hold down while dragging the
mouse.

e Use the Select option from the Edit menu to select the appropriate type of
node.

* Selecta single map object, then use the Select>Same Icon menu item from
the Edit menu to highlight all network objects with the same icon as the
selected object.

Once multiple objects are selected, they can be moved by clicking again on any of the
highlighted objects in the group and moving them with the mouse to a new location.
Use Edit>Undo Move and Edit>Redo Move to undo or redo node positions.

LANsurveyor also has features to align map objects in relation to one another. Select
two or more map objects, then select Align Left or Align Top from the Tools menu.
Selecting Align Left will cause LANsurveyor to move all selected map objects
horizontally so that their left edges line up with the left edge of the leftmost object.
Selecting Align Top will cause LANsurveyor to move all selected map objects vertically
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so that their top edges line up with the top edge of the topmost object.

If you would like to reset the location of all the nodes on the map back to their original
location, use the Map Properties dialog box, pick a different map type, and LANsurveyor
will reset the icon locations or simply click between map levels.

Create Map Objects

After you create your map, you may add new map objects to reflect changes on your
network, add nodes not discovered during map creation, or connect network
segments.

Add new map objects to your map with the Edit>Create Node menu item. Click one or
more map objects (any node or network segment). The new node you create will be
connected to all selected map objects. Then select Create Node from the Edit menu.
The New Node Properties dialog is displayed.

Enter the Node Name, IP Address, and Node Properties, then click Select Icon to pick
a custom icon. Refer to Appendix B, LANsurveyor Icons, for information on creating your
own custom icons.

Connect different network segments by selecting two or more segments or nodes on
the map and then selecting Create Node from the Edit menu. LANsurveyor
automatically adds a node and connects the networks.

Groups

Groups provide an easyway to generate reports and network diagrams for only those
systems which belong to a specific region, function, or system.

Group information is stored both with the maps used to create the groups and with the
application in the Repository. Therefore, the Repository must be active for group
information to persist, and any groups you create must be saved in the map before the
group information is updated in the database. If you close a map after creating a group
and without saving changes, the group changes will be discarded similar to changes
made in anydocument or spreadsheet are discarded if the file is closed without saving
changes.

Creating Groups

To create a group, right-click the Groups heading in the left-hand navigation tree and
select New Group.

Name the group and provide additional details, if desired.
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Subgroups

Right-click any group in the left-hand navigation tree and select New Subgroup to add
a subgroup.

Add Nodes to Groups

Add nodes to a group by selecting the node(s) on the map or in the left-hand
navigation. Then right-click and select Add To Groups. The Add Nodes to Group wizard
is displayed.

Map Properties

Customize your map using Map Properties from the Tools menu. Store updated SNMP
community string and Responder client Password information as well as the drawing
properties for the map.

Some drawing options cause the map to be redrawn, so use these options
immediately after you build a new map and prior to customizations you wish to
preserve. When drawing options are altered, the positions of map objects may change.

Adjusting the values contained in the Map Spacing section affects the map layout style,
the amount of "padding"” space placed between network objects, and the amount of
space between levels of the map. LANsurveyor remembers the drawing settings with
each saved map and between sessions.

Customize your map using these options:

e Map Layout

e Map Spacing

e Map Background Image
e Map Labels

If you don't like the result of your changes, use Edit>Undo to revert (or Edit>Redo to
revert back).
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Map Layout

By default, LANsurveyor automatically draws network maps and displays network
objects in a map layout style known as Hierarchical. Hierarchical layout draws nodes
and network segments along a linear axis and is the most common layout style for

representing network hierarchies.
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The Layout Style pull-down menu in the Map Properties tab allows the selection of
two other layout styles: Symmetrical and Circular.
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Symmetrical maps draw nodes and network segments using geometric patterns that
match top to bottom and left to right.
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Circular maps draw nodes and network segments using circular patterns, grouping
nodes around their connected network segments.

The layout style you use depends on personal preference and also on how nodes are
distributed on your particular network. Most users will prefer either Hierarchical or
Symmetrical layout styles.

Switching between layout styles for an existing network map will cause LANsurveyor to
reorganize the map contents radically so any changes in node positions you have
made will be lost.

Map Spacing

You can adjust the amount of space or "padding" around map objects and between
networks ("l