SAM software requirements

The following table lists software requirements and recommendations for a SAM installation.

  • SolarWinds does not support installing SolarWinds Orion on domain controllers.
  • SolarWinds neither recommends nor supports the installation of any Orion product on the same server or using the same database server as a Research in Motion (RIM) Blackberry server.

Important End of Support
Microsoft Windows Server: Support for Windows Server 2008 R2 is deprecated as of this release. Future releases will no longer support installing on Windows Server 2008 R2, though you can continue to monitor computers running Windows Server 2008 R2. SolarWinds recommends that you upgrade to Windows Server 2012, 2012 R2, or 2016 at your earliest convenience.

Software Requirements

Operating system

Production Evaluation Only
  • Windows Server 2008 R2 SP1
  • Windows Server 2012, and 2012 R2. IIS must be installed.
  • Windows Server 2016
  • Windows 7 SP1
  • Windows 8 (except for Standard Edition)
  • Windows 8.1 (except for Standard Edition)
  • Windows 10

Installing SAM on Windows Server 2012 R2 Essentials is not supported.

Operating system languages

  • English
  • German
  • Japanese
  • Simplified Chinese

IP address version

IPv4

IPv6 implemented as a dual stack. For more information, see RFC 4213 - Basic Transition Mechanisms for IPv6 Hosts and Routers.

CIDR notation is not supported for IPv6 addresses.

Web server

Microsoft Internet Information Services (IIS), version 7.5 or later

  • DNS specifications require that host names be composed of alphanumeric characters (A-Z, 0-9), the minus sign (-), and periods (.). Underscore characters (_) are not allowed. For more information, see RFC 952 - DOD Internet Host Table Specification.
  • IIS is installed by the SolarWinds installer. You can install this software manually to reduce your installation time or network bandwidth.
  • SolarWinds products are not compatible with IIS version 6.0 installations that use web gardens.

.NET Framework

.NET 4.5

Compatible with 4.6.1

SolarWinds recommends using .NET 4.5.2.

Be sure that you are running the same version of .NET on your primary server and any additional polling engines or web servers in the environment.

Web console browser

  • Microsoft Internet Explorer version 11 or later with Active scripting
  • Microsoft Edge
  • Firefox 45.0 or later (Toolset Integration is not supported on Firefox)
  • Chrome 49.0 or later
  • Safari for iPhone
Other

MSMQ, RabbitMQ

Services

The following services must be running after installation is complete to collect syslog messages and traps:

  • SolarWinds Syslog Service
  • SolarWinds Trap Service
User privileges

SolarWinds recommends that administrators have local administrator privileges to ensure full functionality of local SolarWinds tools. Accounts limited to the Orion Web Console do not require administrator privileges.

PowerShell

SAM PowerShell Script Monitor works with PowerShell 1.0 and higher for local execution.

PowerShell 2.0 or higher is required for remote execution.