References > Aliases > PowerShell 2.0 Remoting Requirements

PowerShell 2.0 Remoting Requirements

To enable PowerShell remoting, all computers participating in remote management should have the following software:

  • Windows PowerShell 2.0
  • NET framework 2.0 SP1 or later
  • Windows Remote Management (WinRM) 2.0

All of the above are installed by default on Windows 7 and Windows Server 2008 R2. However, earlier versions of Windows will require you to download the updates from Microsoft website and install them yourself.

PowerShell 2.0 and WinRM 2.0 are included as a part of Windows Management Framework download and are available for Windows XP, Windows Server 2003, Windows Vista and Windows Server 2008.

To be able run scripts and commands on remote computers, the user performing remote script execution must be:

  • A member of the administrators group on the remote machine or
  • Should be able to provide administrator credentials at the time of remote execution or
  • Should have access the PS session configuration on the remote system

Also, on client OS versions of Windows such as Windows Vista and Windows 7, network location must be set either to Home or Work. WS-Management may not function properly if the network location for any of the network adapters is set to public.