References > Troubleshooting > Troubleshooting AppInsight for IIS > Error Code 16090 PowerShell 2.0 or higher required

Error code 16090 PowerShell 2.0 or higher required

Error: PowerShell 2.0 or higher is required. PowerShell is used for scripting in SAM.

Cause: PowerShell 2.0 or higher is not installed on the target server.

Resolution: Ensure that PowerShell 2.0 or higher is installed on the target server. When complete, rerun the AppInsight for IIS Automatic Configuration Wizard.

For Windows Server 2008, download the installation file for PowerShell 2.0 at http://support.microsoft.com/kb/968929/en-us and install it on the target server.

PowerShell 2.0 is automatically installed on Windows Server 2008 R2 and therefore no additional installation is required.