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About SolarWinds 

SolarWinds, Inc develops and markets an array of network management, monitoring, and 
discovery tools to meet the diverse requirements of todayôs network management and consulting 
professionals. SolarWinds products continue to set benchmarks for quality and performance and 
have positioned the company as the leader in network management and discovery technology. 
The SolarWinds customer base includes over 45 percent of the Fortune 500 and customers from 
over 90 countries. Our global business partner distributor network exceeds 100 distributors and 
resellers. 

Contacting SolarWinds 

You can contact SolarWinds in a number of ways, including the following: 

Team Contact Information 

Sales 

sales@solarwinds.com 
www.solarwinds.com 
1.866.530.8100 
+353.21.5002900 

Technical Support www.solarwinds.com/support  

User Forums www.thwack.com 
 

http://www.solarwinds.net/
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SolarWinds Orion Network Performance Monitor 
Documentation Library 

The following documents are included in the SolarWinds Orion Network Performance Monitor 
documentation library: 

Document Purpose 

Administrator Guide 
Provides detailed setup, configuration, and conceptual 
information. 

Orion Common 
Components 
Administrator Guide 

Provides detailed setup, configuration, and conceptual 
information relevant to all products in the Orion family. 
Material from the SolarWinds Orion Common Components 
Administrator Guide that is relevant to Orion NPM has been 
included in this SolarWinds Orion NPM Administrator Guide. 

Evaluation Guide 
Provides an introduction to Orion Network Performance 
Monitor features and instructions for installation and initial 
configuration. 

Page Help 
Provides help for every window in the Orion Network 
Performance Monitor user interface 

Quick Start Guide 
Provides installation, setup, and common scenarios for 
which Orion Network Performance Monitor provides a 
simple, yet powerful, solution. 

Release Notes 
Provides late-breaking information, known issues, and 
updates. The latest Release Notes can be found at 
www.solarwinds.com.  

 

Conventions 

The documentation uses consistent conventions to help you identify items throughout the printed 
and online library. 

Convention Specifying 

Bold Window items, including buttons and fields. 

Italics Book and CD titles, variable names, new terms 

Fixed font  
File and directory names, commands and code 
examples, text typed by you 

Straight brackets, as in 
[value] 

Optional command parameters 

Curly braces, as in 
{value} 

Required command parameters 

Logical OR, as in 
value1|value2 

Exclusive command parameters where only one of the 
options can be specified 

 

 

 

 

 

 

 

http://www.solarwinds.net/
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Chapter 1 

Introduction 

SolarWinds Network Performance Monitor (NPM) delivers comprehensive fault 
and network performance management that scales with rapid network growth 
and expands with your network monitoring needs, allowing you to collect and 
view availability and realtime and historical statistics directly from your web 
browser. While monitoring, collecting, and analyzing data from routers, switches, 
firewalls, servers, and any other SNMP-, ICMP-, or WMI-enabled devices, 
SolarWinds NPM successfully offers you a simple-to-use, scalable network 
monitoring solution for IT professionals juggling any size network. Users find that 
it does not take a team of consultants and months of unpleasant surprises to get 
SolarWinds NPM up and running because the NPM experience is far more 
intuitive than conventional, complex enterprise network management systems. 
Because it can take less than an hour to deploy and no consultants are needed, 
NPM provides quick and cost-effective visibility into the health of network 
devices, servers, and applications on your network, ensuring that you have the 
realtime information you need to keep your systems running at peak 
performance. 

Why Install SolarWinds Orion NPM 

Out of the box, SolarWinds NPM monitors the following critical performance 
metrics for physical and virtual devices on your network: 

¶ Network availability 

¶ Bandwidth capacity utilization 

¶ Buffer usage and errors 

¶ CPU and memory utilization 

¶ Interface errors and discards 

¶ Network latency 

¶ Node, interface, and volume status 

¶ Volume usage 

These monitoring capabilities, along with a fully customizable web-based 
interface, alerting, reporting engines, and flexible expansion capabilities, make 
SolarWinds Orion Network Performance Monitor the easiest choice you will make 
involving your network performance monitoring needs. 
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Benefits of Orion Network Performance Monitor 

Consider the following benefits of Orion Network Performance Monitor. 

Out-of-the-box Productivity 

Automatic discovery and wizard-driven configuration offer an immediate 
return on your investment. Within minutes of installing SolarWinds NPM, you 
can be monitoring your critical network devices. 

Easy to Understand and Use 

SolarWinds NPM is designed for daily use by staff that also have other 
responsibilities. The SolarWinds interface provides what you need where you 
expect to find it and offers advanced capabilities with minimal configuration 
overhead. 

Affordable Value 

While SolarWinds NPM provides functionality that is comparable, if not 
superior, to most other solutions, the cost and maintenance of your 
SolarWinds installation is less than the initial cost of most other solutions. 

Scalability 

By adding individual polling engines, you can scale your SolarWinds NPM 
installation to any environment size. By sharing the same database, you can 
also share a unified user interface, making the addition of polling engines 
transparent to your staff. 

thwack.com Online Community 

thwack.com is a community site that SolarWinds developed to provide 
SolarWinds users and the broader networking community with useful 
information, tools and valuable resources related to SolarWinds network 
management solutions. Resources that allow you both to see recent posts 
and to search all posts are available from the Orion Web Console, providing 
direct access to the thwack.com community. 

Key Features of Orion Network Performance Monitor 

Considering the previously listed benefits of SolarWinds NPM and the following 
features, NPM is a simple choice to make. 

Customizable and Flexible Orion Web Console 

Detailed graphs, tables, and lists are displayed in a fully customizable 
web-based interface allowing you to remotely view network fault, availability, 
and performance information. Using the award-winning, intuitive SolarWinds 
web interface, you can conduct administrative tasks, such as adding new 
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devices, both individually and in groups, create custom resources and views, 
establish unique user accounts and views for departments, geographic 
areas, or any other user-defined criteria, and customize web console 
displays from anywhere on your network. These features allow you to save 
time by administering NPM tasks remotely without having to RDP directly into 
your SolarWinds server. 

Automatic and Scheduled Device Discovery 

Wizard-driven device discovery further simplifies the addition of devices and 
interfaces to SolarWinds NPM. Answer a few general questions about your 
devices, and the discovery application takes over, populating the SolarWinds 
database and immediately beginning network analysis. You can also create 
network discovery schedules to independently and automatically run Network 
Sonar Discovery jobs whenever you need them. 

Intuitive SolarWinds NPM Administration 

Using the award-winning, intuitive web interface, you can now conduct 
administrative tasks, such as adding new devices, both individually and in 
groups, establish unique user accounts, and customize web console displays 
from anywhere on your network. These administration features allow you to 
save time by administering NPM tasks remotely without having to RDP 
directly into your SolarWinds server. 

Open Integration 

Enterprise-tested standards, including a Microsoft® SQL Server database 
and industry-standard MIBs and protocols, are the backbone of the 
SolarWinds NPM network monitoring solution. 

Integrated Wireless Poller 

An integrated wireless device poller enables you to leverage proven Orion 
NPM alerts, reports, and web console resources as you monitor and manage 
wireless thin and autonomous access points in the same views in which you 
are already monitoring your wired network devices.  

Cisco EnergyWise Monitoring 

Cisco EnergyWise technology allows you to responsibly manage energy 
usage across the enterprise. With Orion NPM, you can view EnergyWise 
device management data to measure, report, and reduce the energy 
consumption of any devices connected to EnergyWise-enabled switches. 

Network Atlas with ConnectNow 

Network Atlas, the Orion network mapping application, gives you the ability to 
create multi-layered, fully customizable, web-based maps of your network to 
visually track the performance of any device in any location across your 
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network in real time. The ConnectNow feature automatically draws links 
between directly-connected physical nodes discovered on your network. 

Unpluggable Port Mode 

Orion NPM enables you to designate selected ports as unpluggable, so you 
donôt receive unnecessary alerts when users undock or shutdown connected 
devices. This feature is particularly useful for distinguishing low priority ports 
connected to laptops and PCs from more critically important infrastructure 
ports. 

 Universal Device Pollers 

The Universal Device Poller allows you to easily add any SNMP-enabled 
device into the local monitoring database and collect any statistics or 
information that are referenced in device MIB tables. Using poller transforms 
available in the Universal Device Poller Wizard, you can also manipulate 
data collected from multiple Universal Device Pollers to create your own 
custom statistics and then choose your own customized data display. 

VMware Infrastructure Monitoring 

SolarWinds NPM enables you to monitor your VMware servers, datacenters, 
and clusters, including VMware ESX and ESXi, Virtual Center, and any 
virtual machines (VMs) hosted by ESX servers on your network. Available 
resources include lists of VMs on selected ESXi and ESX servers, 
performance details for ESXi and ESX servers and hosted VMs, and relevant 
charts and reports. 

Data Center Monitoring 

Orion NPM offers predefined reports and web console views and resources 
specifically tailored to provide performance data about Cisco Unified 
Computing Systems (UCS) and Fibre Channel devices manufactured by 
Cisco MDS, Brocade, and McData. 

Incident Alerting 

You can configure custom alerts to respond to hundreds of possible network 
scenarios, including multiple condition checks. SolarWinds NPM alerts help 
you recognize issues before your network users experience productivity hits. 
Alert delivery methods and responses include email, paging, SNMP traps, 
text-to-speech, Syslog messaging, and external application execution. 

Integrated Trap and Syslog Servers 

SolarWinds NPM allows you to save time when investigating network issues 
by giving you the ability to use traps and Syslog messages to access network 
information from a single interface instead of requiring that you poll multiple 
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machines. You can use SolarWinds NPM to easily set up alerts and then 
receive, process, forward, and send syslog and trap messages. 

Detailed Historical Reports 

Easily configure reports of data from the Orion database over custom time 
periods. Data is presented in an easily reviewed format in the web console or 
in the Orion Report Writer application. With over 40 built-in reports available, 
you can project future trends and capacity needs, and immediately access 
availability, performance, and utilization statistics. You can also download 
new reports for import into Report Writer from www.thwack.com. 

Groups and Dependencies 

The ability to define device groups and dependencies allows you to more 
effectively manage your network. Groups give you the ability to logically 
organize monitored objects, regardless of device type or location, and 
dependencies allow you to more faithfully represent what can actually be 
known about your network, eliminating ñfalse positiveò alert triggers and 
providing more accurate insight into the status of monitored network objects. 

Coordinated Network, Application, and Configuration Management 

SolarWinds provides a complete network management and monitoring 
solution when SolarWinds NPM is installed with SolarWinds Application 
Performance Monitor (APM), SolarWinds IP Address Manager (IPAM), and 
the SolarWinds Network Configuration Manager (NCM) integration to monitor 
network applications, manage IP address and subnet allocations, and 
manage network device configuration, respectively. 

Extensible SolarWinds NPM Modules 

With additional SolarWinds modules NetFlow Traffic Analyzer (NTA) and IP 
SLA Manager (formerly Orion VoIP Monitor) SolarWinds NPM can analyze 
network traffic and monitor VoIP and WAN traffic using Cisco IP SLA, 
respectively. NPM modules save time by leveraging the existing SolarWinds 
NPM deployment to add feature functionality without requiring additional 
standalone software. 

Product Update Notifications 

Receive regular, automatic notification of updates to your installed Orion 
monitoring and management applications in the Orion Web Console as soon 
as they are available from SolarWinds. Product updates can include upgrade 
opportunities, service packs, and hotfixes. 

Orion Product Team Blog 

Stay in touch with the people who bring you the products in the Orion family 
by following the Orion Product Team Blog on thwack, the SolarWinds online 

http://www.thwack.com/
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user community. Read posts from Orion product managers and developers 
to learn how to extend and optimize your Orion installation to best meet the 
needs of your network. 

Networking Concepts and Terminology 

The following sections define the networking concepts and terminology that are 
used within Orion NPM. 

¶ Internet Control Message Protocol (ICMP) 

¶ Simple Network Management Protocol (SNMP) 

¶ SNMP Credentials 

¶ Management Information Base (MIB) 

¶ Windows Management Instrumentation (WMI) 

Internet Control Message Protocol (ICMP) 

Orion NPM uses the Internet Control Message Protocol (ICMP) to poll for status 
using ping  and echo  requests of managed devices. When Orion NPM polls a 

managed device using ICMP, if the device is operationally up, it returns a 
response time and record of any dropped packets. This information is used by 
Orion NPM to monitor status and measure average response time and packet 
loss percentage for managed devices. 

Note: Orion NPM only uses ICMP to poll devices for status, average response 
time, and packet loss percentage. Other information displayed in the Orion Web 
Console is obtained using SNMP requests. 

Simple Network Management Protocol (SNMP) 

For most network monitoring and management tasks, Orion NPM uses the 
Simple Network Management Protocol (SNMP). SNMP-enabled network devices, 
including routers, switches, and PCs, host SNMP agents that maintain a virtual 
database of system status and performance information that is tied to specific 
Object Identifiers (OIDs). This virtual database is referred to as a Management 
Information Base (MIB), and Orion NPM uses MIB OIDs as references to retrieve 
specific data about a selected, SNMP-enabled, managed device. Access to MIB 
data may be secured either with SNMP Community Strings, as provided with 
SNMPv1 and SNMPv2c, or with optional SNMP credentials, as provided with 
SNMPv3. 

Notes: 

¶ To properly monitor devices on your network, you must enable SNMP on all 
devices that are capable of SNMP communications. The steps to enable 
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SNMP differ by device, so you may need to consult the documentation 
provided by your device vendor. 

¶ If SNMPv2c is enabled on a device you want Orion NPM to monitor, by 
default, Orion NPM will attempt to use SNMPv2c to poll the device for 
performance information. If you only want Orion NPM to poll using SNMPv1, 
you must disable SNMPv2c on the device to be polled. 

For more information about MIBs, see ñManagement Information Base (MIB)ò on 
page 7. For more information about SNMP credentials, see ñSNMP Credentialsò 
on page 7. 

SNMP Credentials 

SNMP credentials secure access to SNMP-enabled managed devices. SNMPv1 
and SNMPv2c credentials serve as a type of password that is authenticated by 
confirming a match between a cleartext SNMP Community String provided by an 
SNMP request and the SNMP Community String stored as a MIB object on an 
SNMP-enabled, managed device. SNMPv3 provides a more secure interaction 
by employing the following fields: 

¶ The User Name is a required cleartext string that indentifies the agent or poll 
request that is attempting to access an SNMP-enabled device. User Name 
functions similarly to the SNMP Community String of SNMP v1 and v2c. 

¶ The Context is an optional identifying field that can provide an additional 
layer of organization and security to the information available in the MIB of an 
SNMP-enabled device. Typically, the context is an empty string unless it is 
specifically configured on an SNMP-enabled device. 

¶ SNMPv3 provides two optional Authentication Methods: Message Digest 5 
(MD5) and Secure Hash Algorithm 1 (SHA1). Both methods, MD5 and SHA1, 
include the Authentication Key with the SNMPv3 packet and then generate 
a digest of an entire SNMPv3 packet that is then sent. MD5 digests are 20 
bytes long, and SHA1 digests are 16 bytes long. When the packet is 
received, the User Name is used to recreate a packet digest using the 
appropriate method. Both digests are then compared to authenticate.  

¶ SNMPv3 also provides two optional Privacy/Encryption Methods: Data 
Encryption Standard (DES56) and Advanced Encryption Standard (AES128) 
using a 128 bit key. DES56 uses a 56 bit key with a 56 bit salt, and AES128 
uses a 128 bit key with a 128 bit salt to encrypt the full SNMP v3 packet. 

Management Information Base (MIB) 

A Management Information Base (MIB) is the formal description of a set of 
objects that can be managed using SNMP. MIB-I refers to the initial MIB 
definition, and MIB-II refers to the current definition. Each MIB object stores a 
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value such as sysUpTime , bandwidth utilization , or sysContact . During 

polling, SolarWinds NPM sends a SNMP GET request to each device to poll the 

specified MIB objects. Received responses are then recorded in the SolarWinds 
database for use in NPM, including within Orion Web Console resources. 

Most network devices can support several different types of MIBs. While most 
devices support the standard MIB-II MIBs, they may also support any of a 
number of additional MIBs that you may want to monitor. Using a fully 
customizable Orion Universal Device Poller, you can gather information from 
virtually any MIB on any network device to which you have access. 

Windows Management Instrumentation (WMI) 

Windows Management Instrumentation (WMI) is a proprietary technology used to 
poll performance and management information from Windows-based network 
devices, applications, and components. When used as an alternative to SNMP, 
WMI can provide much of the same monitoring and management data currently 
available with SNMP-based polling with the addition of Windows-specific 
communications and security features. 

Note: Due to specific characteristics of WMI polling requests, polling a single 
WMI-enabled object uses approximately five times the resources required to poll 
the same or similar object with SNMP on the same polling frequency.  

For more information about WMI, see the Microsoft article, ñAbout WMIò. 

How Orion Network Performance Monitor Works 

Through ICMP, SNMP, WMI, and Syslog communication and data collection, 
NPM continuously monitors the health and performance of your network, and it 
does this without interfering with the critical functions of your network devices. 
Unlike many other network monitoring products, Orion NPM helps you maintain 
the overall performance of your network in the following ways: 

¶ Orion NPM does not install outside agents on your mission-critical servers 

¶ Orion NPM does not employ services that take vital resources from critical 
applications 

¶ Orion NPM does not install any code on monitored network devices. 
Unmanaged or outdated  code can open security holes in your network. 

After installing Orion NPM, you can automate the initial discovery of your 
network, and then simply add new devices as you add them to your network. 
NPM stores gathered information in a SQL database (the SolarWinds database) 
and provides a user-friendly, highly customizable web console in which to view 
current and historical network status. 

http://msdn.microsoft.com/en-us/library/windows/desktop/aa384642(v=vs.85).aspx
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The following procedure and diagram provide an outline of how SolarWinds NPM 
monitors your network. 

 

1. After Network Sonar Discovery has populated the SolarWinds Database with 
the network objects you want to monitor, node and volume information is 
passed to the Business Layer. 

2. The Business Layer passes node and volume information to the Collector 
Polling Controller and provides licensing information to the SolarWinds 
Information Service (SWIS). 

3. The Collector Polling Controller creates the required polling jobs and then 
passes them on to the Job Engine v2. 

4. The Job Engine v2 performs requested polling jobs, using SNMP, ICMP and 
WMI, as configured in Network Sonar Discovery. 

Note: All other SolarWinds modules perform polling in this way, as well. 

5. The Job Engine v2 then passes the results of all requested polling jobs to the 
Collector Polling Controller. 

6. The Collector Polling Controller places all polling results into the Microsoft 
Message Queue (MSMQ). 

7. The Collector Data Processor pulls polling results from the MSMQ, and then 
performs the following operations: 

a. The Collector Data Processor performs any required calculations, and 
then inserts these ñcookedò results into the SolarWinds database.  
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b. The Collector Data Processor checks with the SolarWinds Information 
Service (SWIS) for any existing dependencies that are defined for the 
polled nodes. 

c. The Collector Data Processor checks polling results against existing 
basic alert definitions to determine if any basic alerts and corresponding 
actions should be triggered.  
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Chapter 2 

Installing SolarWinds Orion Network 
Performance Monitor 

Orion Network Performance Monitor (Orion NPM) provides a simple, wizard-
driven installation process. For an enterprise-class product, system hardware 
and software requirements are nominal. 

Licensing Orion Network Performance Monitor 

Orion NPM can collect data and detailed information from any of your version 3 
or earlier SNMP-enabled devices, including routers, switches, firewalls, and 
servers. Orion NPM is licensed in accordance with the largest number of the 
following three types of monitored network elements: 

Nodes 

Nodes include entire devices, for example, routers, switches, virtual and 
physical servers, access points, and modems. 

Interfaces 

Interfaces include switch ports, physical interfaces, virtual interfaces, sub-
interfaces, VLANs, and any other single point of network traffic. 

Volumes 

Volumes are equivalent to the logical disks you are monitoring. 

NPM Licensing Levels 

The following list provides the different types of Orion Network Performance 
Monitor licenses that are available: 

¶ An SL100 license allows you to monitor up to 100 nodes, 100 interfaces, and 
100 volumes (300 elements in total). 

¶ An SL250 license allows you to monitor up to 250 nodes, 250 interfaces, and 
250 volumes (750 elements in total). 

¶ An SL500 license allows you to monitor up to 500 nodes, 500 interfaces, and 
500 volumes (1500 elements in total). 

¶ An SL2000 license allows you to monitor up to 2000 nodes, 2000 interfaces, 
and 2000 volumes (6000 elements in total). 



Quick Start Guide Ö SolarWinds Orion Network Performance Monitor 
 

 
12 Ö Installing SolarWinds Orion Network Performance Monitor 

¶ An SLX license allows you to monitor a virtually unlimited number of 
elements. For more information about relevant server sizing considerations, 
see ñServer Sizingò on page 16. 

Database size increases with the addition of monitored elements. Depending on 
the number of elements and the amount of traffic on your network, monitoring 
more than 8,000 elements can require additional polling engines. For more 
information about polling engines, see ñUsing Additional Polling Enginesò in the 
SolarWinds Orion NPM Administrator Guide. 

Licensing NPM with Other SolarWinds Products 

Your NPM license interacts additively with your other SolarWinds licenses. For 
example, if you have an NPM SL500 (500 nodes and 500 volumes) installed with 
APM AL50, you can monitor a total of 550 nodes (500 NPM nodes + 50 APM 
nodes), 500 interfaces, 550 volumes (matching the node count), and 50 
applications. 

Orion NPM Requirements 

SolarWinds recommends installing Orion NPM on its own server, with the Orion 
database hosted separately, on its own SQL Server. Installations of multiple 
Orion servers, including Orion NPM, Orion Application Performance Monitor, and 
Orion Network Configuration Manager using the same database are not 
supported. For more information, see ñOrion Requirementsò on page 12. 

Note: Any and all installed Additional Polling Engines and Additional Web 
Servers must use the same version of Orion NPM that is installed on the primary 
Orion server. 

Orion Requirements 

SolarWinds recommends installing Orion and your SQL Server on separate 
servers. Installations of multiple Orion NPM servers using the same database are 
not supported. The following sections provide specific requirements: 

¶ Orion Server Software Requirements 

¶ Orion Server Hardware Requirements 

¶ Requirements for the Orion Database Server (SQL Server) 

¶ Requirements for Virtual Machines and Servers 

¶ Additional Required Components 

http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionAGConfiguringAdditionalPoller.htm
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
../../Users/andrew.pacetti/AppData/Roaming/Microsoft/Orion/OrionCoreAdministratorGuide.doc#Requirements
../../Users/andrew.pacetti/AppData/Roaming/Microsoft/Orion/OrionCoreAdministratorGuide.doc#Requirements
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Orion Server Software Requirements 

The following table lists minimum software requirements and recommendations. 

Software Requirements 

Operating 
System 

Windows Server 2003 SP2 including R2, 32- or 64-bit, with IIS in 32-bit mode  
Windows Server 2008 SP2 including R2 SP1 
IIS and MSMQ must be installed. SolarWinds recommends that Orion 
administrators have local administrator privileges to ensure full functionality of 
local Orion tools. Accounts limited to use of the Orion Web Console do not 
require administrator privileges. 
Notes: 

¶ SolarWinds does not support production installations of Orion products on 
Windows XP, Windows Vista, or Windows 7 systems. 

¶ Orion NPM is not compatible with installations of Internet Information 
Services version 6.0 (IIS6) that make use of web gardens. 

Operating 
System 
Languages 

English (UK or US) 
German 
Japanese 
Simplified Chinese 

IP Address 
Version 

IPv4 or IPv6 implemented as a dual stack. For more information, see ñRFC 
4213 - Basic Transition Mechanisms for IPv6 Hosts and Routersò. 
Note: CIDR notation is not currently supported for IPv6 addresses. 

Application 
Ports 

161, 162, 443 (SNMP). VMware ESX/ESXi Servers are polled on 443. 
514 (UDP) for Syslog messaging. 162 (SNMP) for SNMP traps. 
17777 (TCP) open for Orion module traffic 
17778 (HTTPS) open to access the SolarWinds Information Service API 
17779 (HTTP and HTTPS) for the SolarWinds Toolset Integration  

Web Server 

Microsoft IIS, version 6.0 or higher, in 32-bit mode. 
DNS specifications require that hostnames be composed of alphanumeric 

characters (A- Z, 0- 9), the minus sign (- ), and periods (. ). Underscore 

characters (_) are not allowed. For more information, see ñRFC 952 - DOD 

Internet Host Table Specificationò 
Warning: The following Windows accounts, as configured by IIS 6.0 on 
Windows Server 2003 with their default security settings, are required: 

¶ IUSR_<hostname>, as a member of the Guests group ONLY. 

¶ IWAM_<hostname>, as a member of the IIS_WPG group ONLY. 
Disabling these accounts or changing any default settings of these accounts 
may negatively affect the operation of your Orion installation. SolarWinds 
strongly recommends against altering these accounts or their settings. 
Notes: 

¶ SolarWinds does not support or allow installations of SolarWinds 

Orion NPM on domain controllers. 

¶ SolarWinds neither recommends nor supports the installation of any Orion 
product on the same server or using the same database server as a 
Research in Motion (RIM) Blackberry server. 

.NET 
Framework 

Version 3.5. .NET Framework 3.5 SP1 is recommended. 

Web 
Console 
Browser 

Microsoft Internet Explorer version 7 or higher with Active scripting 
Mozilla Firefox 3.5 or higher (Toolset Integration is not supported on Firefox) 
Google Chrome 8 or higher 
Note: JavaScript must be enabled on all browsers to ensure full web console 
functionality. 

http://tools.ietf.org/html/rfc4213
http://tools.ietf.org/html/rfc4213
http://tools.ietf.org/html/rfc952
http://tools.ietf.org/html/rfc952
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Orion Server Hardware Requirements 

The following table lists minimum hardware requirements and recommendations 
for your Orion server. 

Note: Hardware requirements are listed by Orion NPM license level. 

Hardware SL100, SL250, or SL500 SL2000 SLX 

CPU Speed 

2.0 GHz 2.4 GHz 3.0 GHz 

Note: A dual-core processor is required, but a quad-core processor is 
recommended. Physical Address Extension (PAE) should not be enabled. 

Hard Drive 
Space 

2.5 GB 5 GB 20 GB 

Note: A RAID 1 drive for server operating system, Orion installation,  and 
tempdb files is recommended. Orion requires at least 1.5GB for job engine, 
information service, collector service, MIB database and other required files. 
The Orion installer needs 1GB on the drive where temporary Windows system 
or user variables are stored. Per Windows standards, some common files may 
need to be installed on the same drive as your server operating system. For 
more information, see ñWorking with Temporary Directoriesò in the SolarWinds 
Orion Network Performance Monitor Administrator Guide. 

Memory 3 GB 4 GB 8 GB 

Requirements for the Orion Database Server (SQL Server) 

The following table lists software and hardware requirements for your Orion 
database server. Orion NPM license levels are provided as a reference. 

Requirements SL100, SL250, or SL500 SL2000 SLX 

SQL Server 

SQL Server 2005 Express, Standard, or Enterprise 
SQL Server 2008 Express, Standard, or Enterprise 
SQL Server 2008 R2 Express, Standard, or Enterprise 
Notes: 

¶ SolarWinds strongly recommends maintaining SolarWinds servers as 
physically separate from your SQL server.  

¶ SQL Server Compact 3.5 SP2 is only supported for Orion evaluations. 

¶ Due to latency effects, SolarWinds does not recommend installing your 
SQL Server and your Orion server or additional polling engine in 
different locations across a WAN. For more information, see 
SolarWinds Knowledge Base article, ñCan I install my Orion server or 
Additional Polling Engine and my Orion database (SQL Server) in 
different locations across a WAN?ò 

¶ Either mixed-mode or SQL authentication must be supported. 

¶ If you are managing your Orion database, SolarWinds recommends 
you install the SQL Server Management Studio component. 

¶ If your Orion NPM product installs SQL Server System CLR Types, a 
manual restart of the SQL Server service for your Orion database is 
required. 

¶ Use the following database select statement to check your SQL Server 
version, service pack or release level, and edition: 

select SERVERPROPERTY ('productversion'), 

SERVERPROPERTY ('productlevel'), SERVERPROPERTY 

('edition' )  

http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionAGTroubleshootingSystemTempDirectories.htm
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://knowledgebase.solarwinds.com/kb/questions/1809/Can+I+install+my+Orion+server+or+Additional+Polling+Engine+and+my+Orion+database+%28SQL+Server%29+in+different+locations+across+a+WAN%3F
http://knowledgebase.solarwinds.com/kb/questions/1809/Can+I+install+my+Orion+server+or+Additional+Polling+Engine+and+my+Orion+database+%28SQL+Server%29+in+different+locations+across+a+WAN%3F
http://knowledgebase.solarwinds.com/kb/questions/1809/Can+I+install+my+Orion+server+or+Additional+Polling+Engine+and+my+Orion+database+%28SQL+Server%29+in+different+locations+across+a+WAN%3F
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SQL Server 
Collation 

English with collation setting SQL_Latin1_General_CP1_CI_AS 
English with collation setting SQL_Latin1_General_CP1_CS_AS 
German with collation setting German_PhoneBook_CI_AS 
Japanese with collation setting Japanese_CI_AS 
Simplified Chinese with collation setting Chinese_PRC_CI_AS 

CPU Speed 2.0 GHz 2.4 GHz 3.0 GHz 

Hard Drive 
Space 

2 GB 5 GB 20 GB 

Note: Due to intense I/O requirements, a RAID 1+0 drive is strongly 
recommended the SQL Server database and Orion data and log files. 
RAID 5 is not recommended for the SQL Server hard drive. The Orion 
installer needs at least 1GB on the drive where temporary Windows 
system or user variables are stored. Per Windows standards, some 
common files may need to be installed on drive as your server operating 
system. For more information, see ñWorking with Temporary Directoriesò 
in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

Memory 

2 GB 3 GB 4 GB 

Note: SolarWinds recommends additional RAM, up to 8 GB, for Orion 
APM installations including more than 1000 monitors. 

.NET 
Framework 

Version 3.5. .NET Framework 3.5 SP1 is recommended. 

Requirements for Virtual Machines and Servers 

Orion installations on VMware Virtual Machines and Microsoft Virtual Servers are 
fully supported if the following minimum requirements are met for each VM. 

Notes: 

¶ SolarWinds strongly recommends that you maintain your SQL Server 
database on a separate physical server. 

¶ SolarWinds does not support or allow installations of SolarWinds Orion NPM 
on domain controllers. 

VM Configuration 
Orion Requirements by License Level 

SL100, SL250, or SL500 SL2000 SLX 

CPU Speed 2.0 GHz 2.4 GHz 3.0 GHz 

Allocated 
Hard Drive Space 

2.5 GB 5 GB 20 GB 

Note: Due to intense I/O requirements, SQL Server should be 
hosted on a separate physical server configured as RAID 1+0. RAID 
5 is not recommended for the SQL Server hard drive. 

Memory 3 GB 4 GB 8 GB 

Network Interface 

Each virtual machine on which Orion is installed should have its 
own, dedicated network interface card.  
Note: Since Orion uses SNMP to monitor your network, if you are 
unable to dedicate a network interface card to your Orion server, 
you may experience gaps in monitoring data due to the low priority 
generally assigned to SNMP traffic. 

http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionAGTroubleshootingSystemTempDirectories.htm
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
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Additional Required Components 

The Orion Installation Wizard installs the following required x86 components if 
they are not found on your Orion database server: 

¶ SQL Server System Common Language Runtime (CLR) Types. Orion 
products use secure SQL CLR stored procedures for selected, non-business 
data operations to improve overall performance. 

¶ Microsoft SQL Server Native Client 

¶ Microsoft SQL Server Management Objects 

Server Sizing 

Orion NPM is capable of monitoring networks of any size, ranging from small 
corporate LANs to large enterprise and service provider networks. Most Orion 
NPM systems perform well on 3.0 GHz systems with 3 GB of RAM, using default 
polling engine settings. However, when monitoring larger networks, you should 
give additional consideration to the hardware used and the system configuration. 

There are three primary variables that affect scalability. The most important 
consideration is the number of monitored elements, where an element is defined 
as a single, identifiable node, interface, or volume. Systems monitoring more 
than 1,000 elements may require tuning for optimal performance. The second 
variable to consider is polling frequency. For instance, if you are collecting 
statistics every five minutes instead of the default nine, the system will have to 
work harder and system requirements will increase. Finally, the number of 
simultaneous users accessing Orion NPM directly impacts system performance. 

When planning an Orion NPM installation, there are four main factors to keep in 
mind with respect to polling capacity: CPU, memory, number of polling engines, 
and polling engine settings. For minimum hardware recommendations, see 
ñOrion Server Hardware Requirementsò on page 14. For more information about 
polling engines, see ñUsing Additional Polling Enginesò in the SolarWinds Orion 
NPM Administrator Guide. 

In most situations, installing Orion NPM and SQL Server on different servers is 
highly recommended, particularly if you are planning to monitor 2000 elements or 
more. If you experience performance problems or you plan to monitor a very 
large network, you should certainly consider this option. This scenario offers 
several performance advantages, as the Orion NPM server does not perform any 
database processing, and it does not have to share resources with SQL Server. 

If you plan to monitor 10000 or more elements, SolarWinds recommends that 
you install additional polling engines on separate servers to help distribute the 
work load. For more information about sizing Orion NPM to your network, contact 
the SolarWinds sales team or visit www.solarwinds.com. For more information 

http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionAGConfiguringAdditionalPoller.htm
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
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about polling engines, see ñUsing Additional Polling Enginesò in the SolarWinds 
Orion NPM Administrator Guide. 

SNMP Requirements for Monitored Devices 

SolarWinds NPM can monitor the performance of any SNMPv1-, SNMPv2c-, or 
SNMPv3-enabled device on your network. If a device is SNMPv2c-enabled, by 
default, Orion NPM will attempt to use SNMPv2c to poll the device for 
performance information. If you only want Orion NPM to poll using SNMPv1, you 
must disable SNMPv2c on the device to be polled. Consult your device 
documentation or a technical representative of your device manufacturer to 
acquire specific instructions for configuring SNMP on your device. 

Notes: 

¶ Unix-based devices should use the configuration of Net-SNMP version 5.5 or 
higher that is specific to the type of Unix-based operating system in use. 

¶ Orion NPM is capable of monitoring VMware ESX and ESXi Servers versions 
3.5 and higher with VMware Tools installed. For more information about 
enabling SNMP and VMware Tools on your VMware device, consult your 
VMware documentation or technical representative. 

Enabling Microsoft Internet Information Services (IIS) 

To host the Orion Web Console, Microsoft Internet Information Services (IIS) 
must be installed and enabled on your Orion server. Windows Server 2003 
requires IIS version 6, and Windows Server 2008 requires IIS version 7, as 
detailed in the following sections: 

¶ Enabling IIS on Windows Server 2003 

¶ Enabling IIS on Windows Server 2008 

Enabling IIS on Windows Server 2003 

The following procedure enables IIS on Windows Server 2003. 

To enable IIS on Windows Server 2003: 

1. Click Start > Control Panel > Add or Remove Programs. 

2. Click Add/Remove Windows Components. 

3. Click Application Server, confirm it is checked, and then click Details. 

4. Click Internet Information Services (IIS), confirm it is checked, and then 
click Details. 

5. Click World Wide Web Service, confirm it is checked, and click Details. 

http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionAGConfiguringAdditionalPoller.htm
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
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6. Select World Wide Web Service, confirm it is checked, and then click OK. 

7. Click OK on the Internet Information Services (IIS) window, and then click 
OK on the Application Server window. 

8. Click Management and Monitoring Tools, confirm it is checked, and then 
click Details. 

9. Confirm that both Simple Network Management Protocol and WMI SNMP 
Provider are checked, and then click OK. 

10. Click Next on the Windows Components window, and then click Finish after 
completing the Windows Components Wizard. 

Note: You may be prompted to install additional components, to provide your 
Windows Operating System media, or to restart your computer. Restart your 
server if prompted, but Orion does not require the Phone Book Service. 

11. If you are currently enabling IIS as part of an Orion installation, restart 
the Orion installer. For more information, see the installation instructions in 
the Administrator Guide for your specific Orion product. 

Enabling IIS on Windows Server 2008 

The following procedure enables IIS on Windows Server 2008. 

To enable IIS on Windows Server 2008: 

1. Click Start > All Programs > Administrative Tools > Server Manager. 

2. Click Roles in the left pane, and then click Add Roles in the main pane. 

3. Click Next to start the Add Roles Wizard. 

4. Check Web Server (IIS). 

5. If you are prompted to add features required for Web Server (IIS), click 
Add Required Features. 

6. Click Next on the Select Server Roles window, and then click Next on the 
Web Server (IIS) window. 

7. Confirm that Common HTTP Features > Static Content is installed. 

8. Check Application Development > ASP.NET, and then click Add Required 
Role Services. 

9. Check both Security > Windows Authentication and Security > Basic 
Authentication. 

10. Check Management Tools > IIS 6 Management Compatibility, and then 
click Next on the Select Role Services window. 
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11. Click Install on the Confirm Installation Selections window, and then click 
Close on the Installation Results window. 

12. If you are currently enabling IIS as part of an Orion installation, restart 
the Orion installer. For more information, see the installation instructions in 
the Administrator Guide for your specific Orion product. 

Installing Orion Network Performance Monitor 

Any installation or upgrade of Orion NPM requires completion of both the installer 
and the Configuration Wizard, as detailed in the following sections: 

Note: Downgrades of Orion products are not supported. If you are upgrading or 
installing multiple Orion products, confirm that you are installing them in the order 
given in the Upgrade Instructions located in your SolarWinds Customer Portal. 

¶ Completing an Orion NPM Installation 

¶ Completing the Orion Configuration Wizard 

Completing an Orion NPM Installation 

Before completing an Orion NPM installation, ensure that the server on which 
you are installing Orion NPM currently meets or exceeds stated requirements. 
For more information, see ñOrion Requirementsò on page 12. 

Notes: 

¶ SolarWinds generally recommends that you back up your database before 
performing any upgrade. For more information, see ñCreating Database 
Backupsò in the SolarWinds Orion Network Performance Monitor 
Adminstrator Guide. 

¶ If you are upgrading from a previous version of Orion Network Performance 
Monitor, see ñUpgrading Orion Network Performance Monitorò on page 25. 

¶ If you are using Internet Explorer, SolarWinds recommends that you add the 
URL of your Orion website (http:// FullOrionServerName / ), the URL of 

SolarWinds support (http://support.solarwinds.com ), and about:blank  

to the list of trusted sites. For more information about adding sites to your 
trusted sites list, see the Microsoft article, ñWorking with Internet Explorer 6 
Security Settingsò.  

¶ For evaluation purposes only, Orion NPM may be installed on Windows 7, 
Windows XP, or Windows Vista. SolarWinds does not, however, support or 
recommend installing Orion NPM on these operating systems in production 
environments. 

http://www.solarwinds.com/customerportal/
http://fullorionservername/
http://www.microsoft.com/windows/ie/ie6/using/howto/security/settings.mspx
http://www.microsoft.com/windows/ie/ie6/using/howto/security/settings.mspx
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¶ When installing Orion NPM on Windows XP, you must confirm that Shared 
Memory, Named Pipes, and TCP/IP are enabled on remote databases. 

¶ SolarWinds does not support or allow installations of SolarWinds Orion NPM 
on domain controllers. 

The following procedure installs Orion NPM. 

To install Orion Network Performance Monitor: 

1. As an administrator, log on to your Orion NPM server. 

2. If you downloaded the product from the SolarWinds website, navigate to 
your download location, and then launch the executable file.  

3. If you received physical media, browse to the executable and launch it. 

4. If you are prompted to install requirements, click Install, and then 
complete the installation, including a reboot, if required. 

Notes: 

¶ Downloading and installing Microsoft .NET Framework 3.5 SP1 may take 
more than 20 minutes, depending on your existing system configuration. 

¶ If a reboot is required, after restart, click Install to resume installation, 
and then click Next on the Welcome window. 

5. If you want to use the Orion Improvement Program to send anonymous 
data about your Orion usage to SolarWinds, click Yes, send data.   

6. Review the Welcome text, and then click Next. 

7. If the Orion Network Performance Monitor Setup Wizard detects that 
Microsoft Internet Information Services (IIS) is not installed, select 
Suspend installation to manually install IIS, click Finish, quit setup, and 
then install IIS. 

Notes: 

¶ The Orion Web Console requires that Microsoft IIS is installed on the 
Orion NPM Server. If you do not install IIS at this point, you must install 
IIS later, and then configure a website for the Orion Web Console to use. 

¶ A browser window may open automatically to display the SolarWinds 
Knowledge Base article, ñEnabling IIS: What IIS components does Orion 
NPM require?ò This article provides instructions for enabling IIS on 
Windows Server 2003 and 2008, Windows XP, Windows Vista, and 
Windows 7. 

http://knowledgebase.solarwinds.com/kb/questions/1309/
http://knowledgebase.solarwinds.com/kb/questions/1309/
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8. If an IIS installation was required, launch the installer again, and then click 
Next on the Welcome window. 

Note: A server reboot may be required after installing IIS.  

9. Accept the terms of the license agreement, and then click Next. 

10. If you want to install Orion NPM in a destination folder other than the 
default given, click Browse, select an installation folder, and then click OK. 

11. Click Next on the Choose Destination Location window. 

12. Confirm the current installation settings, and then click Next on the Start 
Copying Files window. 

13. Click Finish when the Orion Network Performance Monitor Setup Wizard 
completes. 

14. If you are evaluating Orion NPM, click Continue Evaluation. 

15. If you are installing a production version of Orion NPM, click Enter 
Licensing Information, and then complete the following procedure to 
license your Orion NPM installation: 

a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation keyé, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check I 
access the internet through a proxy server, and then provide the 
Proxy address and Port. 

b. If you do not have access to the internet from your designated 
Orion NPM server, select This server does not have internet 
accessé, click Next, and then complete the steps provided. 

The Orion Configuration Wizard should load automatically. For more information 
about completing the Orion Configuration Wizard, see ñCompleting the Orion 
Configuration Wizardò on page 21. 

Completing the Orion Configuration Wizard 

The following procedure using the Orion Configuration Wizard completes and 
configures your Orion NPM installation. 

Notes: 

¶ Confirm that you have designated a SQL Server database instance for Orion 
NPM. For more information, see ñOrion Requirementsò on page 12. 

¶ Confirm that the Internet Information Services (IIS) Manager is not open 
while the Configuration Wizard is running. 
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¶ SolarWinds recommends that you close any and all browsing sessions that 
may be open to the web console before starting the Configuration Wizard. 

¶ During configuration, the Orion polling engine will shutdown temporarily with 
the result that, if you are actively polling, you may lose some polling data. 
SolarWinds recommends that you perform upgrades during off-peak hours of 
network usage to minimize the impact of this temporary polling stoppage. 

To configure Orion Network Performance Monitor: 

1. If the Configuration Wizard has not loaded automatically, click Start > 
All Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Configuration Wizard. 

2. Click Next on the Welcome dialog of the Configuration Wizard. 

3. If you are prompted to stop services, click Yes.  

Note: To ensure that all updates and changes are installed correctly, it is 
imperative that you stop all services. 

4. Specify the SQL Server instance you want to use to store network data. 

Notes: 

¶ If you are using SQL Express, specify your instance as (local)  and 

use a strong password. For more information about authentication with 
strong passwords, see http://msdn.microsoft.com/ms143705.aspx. Due 
to its inherent limitations, SolarWinds recommends against the use of 
SQL Express in production environments. 

¶ The selected instance must support mixed-mode or SQL authentication 
with strong passwords. A strong password must meet at least three of 
the following four criteria: 

o Contains at least one uppercase letter. 

o Contains at least one lowercase letter. 

o Contains at least one number. 

¶ Contains at least one non-alphanumeric character, e.g., #, %, or ^. 

For more information about authentication with strong passwords, see 
http://msdn.microsoft.com/ms143705.aspx. 

5. Provide credentials, if required, to log into the selected instance.  

Notes: 

¶ In general, SolarWinds recommends using SQL Server Authentication 
to ensure that the Orion NPM server can always access the SQL Server, 
even when it is hosted remotely on a separate server. 

http://msdn.microsoft.com/ms143705.aspx
http://msdn.microsoft.com/ms143705.aspx
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¶ If you are using an existing database, the user account needs only to 

be in the db_owner  database role for the existing database. 

¶ If you are using an existing SQL account, the user account needs 
only to be in the db_owner  database role for the Orion NPM database. 

¶ If you are creating a new database, the user account must be a 
member of the dbcreator  server role.  The sysadmin  role and the sa  

user account are always members of dbcreator . 

¶ If you are creating a new SQL account for use with Orion NPM, the 
user account must be a member of the securityadmin  server role. 

Note: The sysadmin  role and the sa  user account are always members 

of securityadmin . 

6. Click Next. 

7. If you are creating a new database, select Create a new database, 
provide a name for the New Database, and then click Next. 

Note: SolarWinds recommends against using non-alphanumeric characters 
in database names. 

8. If you are using an existing database, select Use an existing database, 
type the database name or select it from the list, and then click Next. 

9. If you want to create a new SQL account for the Orion NPM polling 
engine and web console to use for accessing the database, select 
Create a new account, provide an account name and password, confirm the 
account password, and then click Next. 

10. If you want to use an existing SQL account to provide database access 
to the Orion NPM polling engine and web console, select the existing 
account, provide the appropriate password, and then click Next. 

11. If you need to specify a particular IP Address for the Orion NPM Web 
Console, provide the IP address of the host web server. 

Note: SolarWinds recommends the default (All Unassigned) unless your 
environment requires a specific IP address for your Orion Web Console. 

12. Specify both the Port through which you want to access the web console and 
the Website Root Directory into which you want to install web console files.  

Note: If you specify any port other than 80, you must include that port in the 

URL used to access the web console. For example, if you specify an IP 

address of 192.168.0.3  and port 8080 , the URL used to access the web 

console is http://192.168.0.3:8080 . 
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13. If you want to enable automatic login using Windows Authentication, 
select Yes ï Enable automatic login using Windows Authentication. 

Note: Manual login using Windows Authentication is always available, 
regardless of whether or not automatic login is enabled. 

14. Click Next. 

15. If you are prompted to create a new directory, click Yes. 

16. If you are prompted to create a new website, click Yes. 

Note: Choosing to overwrite the existing website will not result in the deletion 
of any custom Orion NPM website settings you may have previously applied. 

17. Confirm that all services you want to install are checked. 

Note: Typically, all listed services should be selected for installation. 

18. Click Next. 

19. If you are prompted to disable the SNMP Trap Service and enable the 
SolarWinds Trap Service, click Yes to disable the (Windows) SNMP Trap 
Service and enable the SolarWinds Trap Service. 

20. Review the final configuration items, and then click Next. 

21. Click Next on the Completing the Orion Configuration Wizard dialog. 

22. Click Finish when the Orion Configuration Wizard completes. 

23. Log in to the Orion Web Console as an administrator. 

Notes: 

¶ By default, until you change your account, you can log in with User name 
Admin  and no password. 

¶ If you are prompted to install the Toolset integration (SWToolset.exe ), 
click More Options, select a response, and then click Install or Donôt 
Install, as appropriate. 

24. If you need to discover and add network devices to the Orion database, 
the Network Discovery Wizard starts. For more information, see ñNetwork 
Discovery Using the Network Sonar Wizardò on page 30. 
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Upgrading Orion Network Performance Monitor 

Complete the following procedure when you are upgrading Orion NPM from a 
previous version or upgrading the licensed number of elements you can monitor.  

Notes: 
¶ SolarWinds recommends that you backup your database before any 

upgrade. For more information about creating database backups, see 
ñCreating Database Backupsò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

¶ While it is being upgraded, your Orion polling engine will shutdown 
temporarily with the result that you may lose some polling data. SolarWinds 
recommends that you perform upgrades during off-peak hours of network 
usage to minimize the impact of this temporary polling stoppage.  

¶ Discovery profiles from older Orion NPM versions are not retained through 
upgrades. If you want to retain a discovery profile, prior to starting your 
upgrade, externally record the configuration of the profiles you want to retain. 

¶ If your currently installed version of Orion NPM is older than version 
7.8.5, you must upgrade to Orion NPM 7.8.5. 

¶ If you currently have Orion NPM version 7.8.5 through 8.5 installed, you 
must upgrade to Orion NPM 8.5.1. 

¶ If you currently have Orion NPM version 8.5.1, upgrade to version 9.1. 

¶ If you currently have Orion NPM version 9.0 through 9.5.1, you must 
upgrade to version 10.0 before upgrading to the current version. 

Specific instructions for completing an upgrade are available in the SolarWinds 
Customer Portal. For more information about upgrading Orion NPM, particularly if 
you are upgrading an Orion NPM installation that includes Orion modules, log in 
to your SolarWinds Customer Portal at www.solarwinds.com/customerportal/, 
click License Management, and then click Upgrade Instructions under the 
license listing of any Orion product. The following procedure completes an Orion 
NPM upgrade. 

To upgrade Orion Network Performance Monitor: 

1. If you are using more than one polling engine to collect network 
information, shut down all polling engines before continuing. 

2. Using the local administrator account, log on to the computer on which you 
want to upgrade Orion Network Performance Monitor. 

3. If you downloaded the product from the SolarWinds website, navigate to 
your download location and then launch the executable.  

4. Review the Welcome text, and then click Next. 

http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionCoreAGDatabaseManagerCreatingBackups_2.htm
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/customerportal/
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5. Orion Network Performance Monitor automatically detects the previous 
installation. When prompted to upgrade the current installation, click Next. 

Note: All customizations, including web console settings, are preserved. 

6. Accept the terms of the license agreement, and then click Next. 

7. Confirm the current installation settings, and then click Next on the Start 
Copying Files window. 

8. Provide required information on the Install Software License Key window. 

Note: You need your customer ID and password to successfully install the 
key. 

9. Click Continue, and then click Continue again when the license is installed. 

10. Review the Upgrade Reminder, and then click Next. 

11. Click Finish on the InstallShield Wizard Complete window. 

12. Complete the Configuration Wizard. For more information, see ñCompleting 
the Orion Configuration Wizardò on page 21. 

Upgrading an Evaluation License 

The standard Orion NPM evaluation period is 30 days. At the end of thIs period 
you will be prompted to either buy a license to Orion NPM or enter information 
corresponding to an Orion NPM license you have already purchased. At any 
point in your evaluation period, if you have purchased an Orion NPM license, you 
may upgrade your evaluation license as indicated in the following procedure. 

To upgrade an Orion NPM evaluation license: 

1. Click Start > All Programs > SolarWinds Orion > Network Performance 
Monitor > Network Performance Monitor Licensing. 

2. Click Enter Licensing Information. 

3. If the computer on which you installed Orion NPM is connected to the 
Internet, complete the following procedure: 

a. Select I have internet access... 

b. Browse to http://www.solarwinds.com/customerportal/, and then log in 
using your SolarWinds CustomerID and password. 

Note: If you do not know your SolarWinds CustomerID and password 
and you are not on active maintenance, contact the SolarWinds 
Maintenance Renewal team at maintenance@solarwinds.com. If you do 
not know your SolarWinds CustomerID and password and you are on 
active maintenance, submit a customer service ticket at 
www.solarwinds.com/support/ticket/. 

http://www.solarwinds.com/customerportal/
mailto:maintenance@solarwinds.com
http://www.solarwinds.com/support/ticket/
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c. Click License Management. 

d. Browse to Orion Network Performance Monitor, and then locate the 
Unregistered Licenses list. 

e. Copy your unregistered Orion NPM activation key to the clipboard, and 
then paste it into the Activation Key field on the Activate NPM window. 

f. If you are using a proxy server to access the Internet, check I 
access the internet through a proxy server, and then type the proxy 
address and port number. 

g. Click Next. 

4. If the computer on which you are installing Orion NPM is not connected 
to the Internet, complete the following procedure:  

a. Select This server does not have internet access, and then click Next.  

b. On the Activate Product window, click Copy Unique Machine ID. 

c. Paste the copied data into a new document in a text editor, and then 
save the text document. 

d. Transfer the document to a computer with internet access. 

e. On the computer with internet access, browse to 
http://www.solarwinds.com/customerportal/. 

f. Log in using your SolarWinds CustomerID and password. 

Note: If you do not know your SolarWinds CustomerID and password 
and you are not on active maintenance, contact the SolarWinds 
Maintenance Renewal team at maintenance@solarwinds.com. If you do 
not know your SolarWinds CustomerID and password and you are on 
active maintenance, submit a customer service ticket at 
www.solarwinds.com/support/ticket/. 

g. Click License Management. 

h. Browse to Orion Network Performance Monitor, and then click Manually 
Register License. 

i. Provide the Unique Machine ID you transferred in Step 3, above, and 
then download your license key. 

j. Transfer the license key to a shared location, and then, on the server 
that does not have internet access, browse to the shared License Key 
File location from the Activate Product window.  

Maintaining Licenses with License Manager 

SolarWinds License Manager is a free utility allows you to easily migrate Orion 
licenses from one computer to another without contacting SolarWinds Customer 

http://www.solarwinds.com/customerportal/
mailto:maintenance@solarwinds.com
http://www.solarwinds.com/support/ticket/
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Service. The following sections provide procedures for installing and using 
License Manager: 

¶ Installing License Manager 

¶ Using License Manager 

Installing License Manager 

Install License Manager on the computer from which you are migrating currently 
licensed products. 

Note: You must install License Manager on a computer with the correct time. If 
the time on the computer is even slightly off, in either direction, from Greenwich 
Mean Time (GMT), you cannot reset licenses without contacting SolarWinds 
Customer Service. Time zone settings neither affect nor cause this issue. 

To install License Manager: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager 
Setup. 

2. Click I Accept to accept the SolarWinds EULA. 

3. If you are prompted to install the SolarWinds License Manager 
application, click Install. 

Using License Manager 

You must run License Manager on the computer where the currently licensed 
SolarWinds product is installed before you can migrate licenses to a new 
installation. The following procedure deactivates currently installed licenses that 
can then be transferred to a new installation. 

To deactivate currently installed licenses: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager. 

2. Check the products you want to deactivate on this computer, and then click 
Deactivate. 

3. Specify your SolarWinds Customer ID and password when prompted, and 
then click Deactivate. 

Note: Deactivated licenses are now available to activate on a new computer. 

When you have successfully deactivated your products, log on to the computer 
on which you want to install your products, and then begin installation. When 
asked to specify your licenses, provide the appropriate information. The license 
you deactivated earlier is then assigned to the new installation. 
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Chapter 3 

Getting Started with Orion NPM 

Orion products use either Network Sonar discovery and import or Node 
Management in the Orion Web Console to discover objects for monitoring. The 
method recommended largely depends on the number of devices to be added. 

¶ To discover and add a larger number of devices across your enterprise, the 
Network Sonar and Network Sonar Results Wizards are available. For more 
information, see ñNetwork Discovery Using the Network Sonar Wizardò on 
page 37. 

¶ The web console provides an easy-to-use Web Node Management to add 
individual objects for monitoring. For more information, see ñAdding Devices 
for Monitoring in the Web Consoleò on page 52. 

Discovery Central 

Discovery Central provides a centralized overview of the types and number of 
network objects you are monitoring with your currently installed SolarWinds 
products. The Discovery Central view is subdivided into sections corresponding 
to the SolarWinds products you have installed. The Network Discovery section 
displays for all node-based products. For more information about the Network 
Discovery section, see ñNetwork Discoveryò on page 29. For more information 
about specific sections, see the Administrator Guide for the corresponding Orion 
product. 

Clicking Go to Orion Home opens the Summary Home view for your entire 
monitored network. 

Network Discovery 

The Network Discovery resource provides the number of nodes and volumes that 
are currently monitored. This information is both available and applicable to all 
installed SolarWinds products. 

Click Network Sonar Discovery to start a Network Sonar Discovery. For more 
information, see ñNetwork Discovery Using the Network Sonar Wizardò on 
page 30. 

Click Add a Single Device to open the Add Node ï Define Node view of the 
Orion Node Management utility. For more information, see ñAdding Devices for 
Monitoring in the Web Consoleò on page 52. 
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Interface Discovery 

The Interface Discovery section provides the number of interfaces on which you 
can monitor network trafficTo discover interfaces on your network, simply 
discover or add the parent node and SolarWinds will automatically discover any 
and all interfaces on the designated parent node. This information is available 
and applicable to SolarWinds Network Performance Monitor (NPM) and all 
installed SolarWinds NPM modules. 

Click Network Sonar Discovery to start a Network Sonar Discovery. For more 
information, see ñNetwork Discovery Using the Network Sonar Wizardò on 
page 37. 

Network Discovery Using the Network Sonar Wizard 

Orion products employ the easy-to-use Network Sonar Wizard to direct you in the 
discovery of devices on your network. Before using the Network Sonar Wizard, 
consider the following points about network discovery in Orion NPM: 

¶ The Network Sonar Wizard recognizes network devices that are already in 
your SolarWinds database and prevents you from importing duplicate 
devices.  

¶ CPU and Memory Utilization charts are automatically enabled for your 
Windows, Cisco Systems, VMware, and Foundry Networks devices. 

¶ The community strings you provide in the Network Sonar Wizard are only 

used for SNMP GET requests, so read-only strings are sufficient. 

¶ The Interfaces page of the Network Sonar Results Wizard allows you to 
select interfaces for monitoring. 

The following procedure steps you through the discovery of devices on your 
network using the Network Sonar Wizard. 

To discover devices on your network: 

1. If the Network Sonar Wizard is not already open, click Start > All 
Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Network Discovery. 

2. If you want to create a new discovery, click Add New Discovery.  

3. If you have already defined a network discovery, a number of options are 
available on the Network Sonar Discovery tab. Select one of the following: 

¶ If you want to edit an existing discovery before using it, select the 
discovery you want to edit, and then click Edit. 
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¶ If you want to use an existing discovery to rediscover your network, 
select the discovery to use, click Discover Now, and then complete the 
Network Sonar Results Wizard after dicovery completes. For more 
information, see ñUsing the Network Sonar Results Wizardò on page 41. 

¶ If you want to import some or all devices found in a defined 
discovery that you may not have already imported for monitoring, 
select a defined discovery, and then click Import All Results. For more 
information, see ñUsing the Network Sonar Results Wizardò on page 41. 

¶ If you want to import any newly enabled devices matching a defined 
discovery profile, select a currently defined discovery, and then click 
Import New Results. For more information about network discovery 
results, see ñUsing the Network Sonar Results Wizardò on page 41. 

¶ If you want to delete an existing discovery profile, select a currently 
defined discovery and then click Delete. 

4. If the devices on your network do not require community strings other 

than the default strings public  and private  provided by Orion NPM, 

click Next on the SNMP Credentials view. 

5. If any of your network devices require community strings other than 

public  and private  or if you want to use an SNMPv3 credential, 

complete the following steps to add the required SNMP credential. 

Notes: 

¶ If you intend to use SNMPv3 for monitoring VLAN interfaces on Cisco 
devices, confirm that all relevant VLAN contexts are added to all VLAN 
groups defined for your monitored Cisco devices. 

¶ Repeat the following procedure for each new community string. To 
speed up discovery, highlight the most commonly used community 
strings on your network, and then use the arrows to move them to the 
top of the list. 

a. Click Add New Credential, and then select the SNMP Version of your 
new credential. 

b. If you are adding an SNMPv1 or SNMPv2c credential, provide the 
new SNMP Community String. 

c. If you are adding an SNMPv3 credential, complete the following fields: 

¶ User Name, Context, and Authentication Method 

¶ Authentication Password/Key, Privacy/Encryption Method and 
Password/Key, if required. 

d. Click Add. 
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6. Click Next on the SNMP Credentials view. 

7. If you want to discover any VMware VCenter or ESX Servers on your 
network, confirm that Poll for VMware is checked. 

Note: If you know there are VMware devices on your network that you want 
to monitor, confirm that you check Poll for VMware. Nodes cannot be 
identified as VMware devices unless Poll for VMware is enabled.  

8. If you want to discover VMware devices on your network, repeat the 
following procedure for each VMware credential you add or edit. To speed up 
discovery, use the arrows to move the most commonly used credentials on 
your network to the top of the list. 

a. Click Add vCenter or ESX Credential. 

b. If you are using an existing VMware credential, select the appropriate 
credential from the Choose Credential dropdown menu. 

c. If you are adding a new VMware credential, select <New Credential> 
in the Choose Credential dropdown menu, and then provide a new 
credential name in the Credential Name field. 

Note: SolarWinds recommends against using non-alphanumeric 
characters in credential names. 

d. Add or edit the credential User Name and Password, as necessary. 

e. Confirm the password, and then click Add. 

9. Click Next on the Local vCenter or ESX Credentials for VMware view. 

10. If you want to discover any WMI- or RPC-enabled Windows devices on 
your network, complete the following steps to add or edit credentials. 

Notes: 

¶ SolarWinds does not poll interfaces on WMI- or RPC-enabled nodes. 

¶ Repeat the following procedure for each new credential. To speed up 
discovery, use the arrows to move the most commonly used credentials 
on your network to the top of the list. 

a. Click Add New Credential. 

b. If you are using an existing Windows credential, select the 
appropriate credential from the Choose Credential dropdown menu. 

c. If you are adding a new Windows credential, select <New 
Credential> in the Choose Credential dropdown menu, and then 
provide a new credential name in the Credential Name field. 

Note: SolarWinds recommends against using non-alphanumeric 
characters in credential names. 
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d. Add or edit the credential User Name and Password, as necessary. 

e. Confirm the password, and then click Add. 

11. Click Next on the Windows Credentials view. 

12. If you want to discover devices located on your network within a 
specific range of IP addresses, complete the following procedure. 

Note: Only one selection method may be used per defined discovery.  

a. Click IP Ranges in the Selection Method menu, and then, for each IP 
range, provide both a Start address and an End address. 

Note: Scheduled discovery profiles should not use IP address ranges 
that include nodes with dynamically assigned IP addresses (DHCP). 

b. If you want to add another range, click Add More, and then repeat the 
previous step. 

Note: If you have multiple ranges, click X to delete an incorrect range. 

c. If you have added all the IP ranges you want to poll, click Next. 

13. If you want to discover devices connected to a specific router or on a 
specific subnet of your network, complete the following procedure: 

Note: Only one selection method may be used per defined discovery.  

a. Click Subnets in the Selection Method menu. 

b. If you want to discover on a specific subnet, click Add a New 
Subnet, provide both a Subnet Address and a Subnet Mask for the 
desired subnet, and then click Add. 

Note: Repeat this step for each additional subnet you want to poll. 

c. If you want to discover devices using a seed router, click Add a 
Seed Router, for each seed router, provide the IP address of the 
Router, and then click Add. 

Notes: 

¶ Network Sonar reads the routing table of the designated router and 
offers to discover nodes on the Class A network (255.0.0.0 mask) 
containing the seed router and, if you are discovering devices for an 
Orion NPM installation, the Class C networks (255.255.255.0 mask) 
containing all interfaces on the seed router, using the SNMP version 
chosen previously on the SNMP Credentials page. 

¶ Networks connected through the seed router are NOT automatically 
selected for discovery. 

d. Confirm that all networks on which you want to conduct your network 
discovery are checked, and then click Next. 
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14. If you already know the IP addresses or hostnames of the devices you 
want to discover and include in the Orion database, complete the 
following procedure: 

Note: Use this method to add devices with both IPv4 and IPv6 addresses. 

a. Click Specific Nodes in the Selection Method menu. 

b. Type the IP addresses or hostnames of the devices you want to discover 
for monitoring into the provided field. 

Note: Type only one IP address or hostname per line. 

c. Click Validate to confirm that the provided IP addresses and hostnames 
are assigned to SNMP-enabled devices. 

d. If you have provided all the IP addresses and hostnames you want 
to discover, click Next. 

15. Configure the options on the Discovery Settings view, as detailed in the 
following steps. 

a. Provide a Name and Description to distinguish the current discovery 
profile from other profiles you may use to discover other network areas. 

Note: This Description displays next to the Name in the list of available 
network discovery configurations on the Network Sonar view. 

b. Position the slider or type a value, in ms, to set the SNMP Timeout. 

Note: If you are encountering numerous SNMP timeouts during Network 
Discovery, increase the value for this setting. The SNMP Timeout should 
be at least a little more than double the time it takes a packet to travel 
the longest route between devices on your network. 

c. Position the slider or type a value, in ms, to set the Search Timeout. 

Note: The Search Timeout is the amount of time Network Sonar 
Discovery waits to determine if a given IP address has a network device 
assigned to it. 

d. Position the slider or type a value to set the number of SNMP Retries. 

Note: This value is the number of times Network Sonar Discovery will 
retry a failed SNMP request, defined as any SNMP request that does not 
receive a response within the SNMP Timeout defined above. 

e. Position the slider or type a value to set the Hop Count. 

Note: If the Hop Count is greater than zero, Network Sonar Discovery 
searches for devices connected to any discovered device. Each 
connection to a discovered device counts as a hop. 
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f. Position the slider or type a value to set the Discovery Timeout. 

Note: The Discovery Timeout is the amount of time Network Sonar 
Discovery is allowed to complete a network discovery. If a discovery 
takes longer than the Discovery Timeout, the discovery is terminated. 

16. If you only want to discover devices that respond to SNMP or WMI, 
check Ignore nodes that only respond to ICMP (ping). 

Note: By default, Network Sonar uses ICMP ping  requests to locate devices. 

Most information about monitored network objects is obtained using SNMP 
queries, but WMI is supported for Windows devices. 

17. If multiple Orion polling engines are available in your environment, 
select the Polling Engine you want to use for this discovery. 

18. Click Next. 

19. If you want the discovery you are currently defining to run on a regular 
schedule, select either Custom or Daily as the discovery Frequency, as 
shown in the following steps: 

Notes: 

¶ Scheduled discovery profiles should not use IP address ranges that 
include nodes with dynamically assigned IP addresses (DHCP). 

¶ Default Discovery Scheduling settings execute a single discovery of your 
network that starts immediately, once you click Discover. 

¶ Results of scheduled discoveries are maintained on the Scheduled 
Discovery Results tab of Network Discovery. For more information about 
managing scheduled discovery results, see ñManaging Scheduled 
Discovery Resultsò on page 45. 

a. If you want to define a custom discovery schedule to perform the 
currently defined discovery repeatedly in the future, select Custom 
and then provide the period of time, in hours, between discoveries. 

b. If you want your scheduled discovery to run once daily, select Daily, 
and then provide the time at which you want your discovery to run every 

day, using the format HH:MM AM/PM. 

20. If you do not want to run your network discovery at this time, select No, 
donôt run now, and then click Save or Schedule, depending on whether you 
have configured the discovery to run once or on a schedule, respectively. 

21. If you want your Network Sonar discovery to run now, click Discover to 
start your network discovery. 

Note: Because some devices may serve as both routers and switches, the 
total number of Nodes Discovered may be less than the sum of reported 
Routers Discovered plus reported Switches Discovered. 
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Using the Network Sonar Results Wizard 

The Network Sonar Results Wizard directs you through the selection of network 
devices for monitoring, and it opens whenever discovery results are requested, 
either when the Network Sonar Wizard completes or when either Import All 
Results or Import New Results is clicked for a selected discovery. For more 
information, see ñNetwork Discovery Using the Network Sonar Wizardò on 
page 37. 

The following steps detail the selection of discovered objects for monitoring in 
Orion NPM. 

To select the results of a network discovery for monitoring in Orion NPM: 

1. On the Device Types to Import page, check the device types you want Orion 
NPM to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific device type, check 
the device type in question. If, later, you do not want to monitor a selected 
device, simply delete the device using Web Node Management. For more 
information, see ñManaging Devices in the Orion Web Consoleò on page 51. 

2. If you are discovering devices for an Orion NPM installation, check the 
interface types you want Orion NPM to monitor on the Interface Types to 
Import page, and then click Next. 

Note: If you are not sure you want to monitor a specific interface type, check 
the interface type in question. If, later, you do not want to monitor a selected 
interface, delete it using Web Node Management. For more information, see 
ñManaging Devices in the Orion Web Consoleò on page 51. 

3. On the Volume Types to Import page, check the volume types you want 
Orion NPM to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific volume type, check 
the volume type in question. If, later, you do not want to monitor any volume 
of the selected type, delete the volume using Web Node Management. For 
more information, see ñManaging Devices in the Orion Web Consoleò on 
page 51. 

4. If you want to import nodes, even when they are already known to be 
polled by another polling engine, check the option in the Allow Duplicate 
Nodes section. For more information about working with multiple polling 
engines, see ñUsing Additional Polling Enginesò in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

OrionNPMCoreAdministratorGuide.doc#ConfiguringAdditionalPoller
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5. If you are discovering devices for an Orion NPM installation, check valid 
states for imported interfaces on the NPM Import Settings page, and then 
click Next. 

Note: By default, Orion NPM NPM imports interfaces that are discovered in 
an Operationally Up state. However, because interfaces may cycle off and 
on intermittently, the Import Settings page allows you to select interfaces 
found in Operationally Down or Shutdown states for import, as well. 

6. If there are any devices on the Import Preview that you do not ever want 
to import, check the device to ignore, and then click Ignore. Selected nodes 
are added to the Discovery Ignore List. For more information, see ñUsing the 
Discovery Ignore Listò on page 46. 

7. Confirm that the network objects you want to monitor are checked on the 
Import Preview page, and then click Import. 

8. If you are discovering devices for an Orion NPM installation, after the 
import completes, click Finish. 

Note: Imported devices display in the All Nodes resource. 

Network Discovery Using the Network Sonar Wizard 

Orion NPM provides the easy-to-use Network Sonar Wizard to direct you in the 
discovery of devices on your network. Before using the Network Sonar Wizard, 
consider the following points about network discovery in Orion NPM: 

¶ The Network Sonar Wizard recognizes network devices that are already in 
your Orion database and prevents you from importing duplicate devices.  

¶ CPU and Memory Utilization charts are automatically enabled for your 
Windows, Cisco Systems, VMware, and Foundry Networks devices. 

¶ The community strings you provide in the Network Sonar Wizard are only 
used for SNMP GET requests, so read-only strings are sufficient. 

The following procedure steps you through the discovery of devices on your 
network using the Network Sonar Wizard. 

To discover devices on your network:  

1. If the Network Sonar Wizard is not already open, click Start > All 
Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Network Discovery. 

2. If you have already defined a network discovery, select one of the 
following options:  

¶ If you want to create a new discovery, click Add New Discovery. 
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¶ If you want to use an existing discovery to rediscover your network, 
select the discovery you want to use, click Discover Now, and then 
complete the Network Sonar Results Wizard. For more information, see 
ñUsing the Network Sonar Results Wizardò on page 42. 

¶ If you want to edit an existing discovery before using it, select the 
discovery you want to edit, and then click Edit. 

¶ If you want to import some or all devices found in a defined 
discovery that you may not have already imported for monitoring, 
select a currently defined discovery, and then click Import All Results. 
For more information about network discovery results, see ñManaging 
Scheduled Discovery Resultsò on page 45. 

¶ If you want to import any newly enabled devices matching a defined 
discovery profile, select a currently defined discovery, and then click 
Import New Results. For more information about network discovery 
results, see ñManaging Scheduled Discovery Resultsò on page 45. 

¶ If you want to delete an existing discovery profile, select a currently 
defined discovery and then click Delete. 

3. If the devices on your network do not require community strings other 

than the default strings public  and private  provided by Orion NPM, 

click Next on the SNMP Credentials view. 

4. If any of your network devices require community strings other than 

public  and private  or if you want to use an SNMPv3 credential, 

complete the following steps to add the required SNMP credential. 

Note: Repeat the following procedure for each new community string. To 
speed up discovery, highlight the most commonly used community strings on 
your network, and then use the arrows to move them to the top of the list.  

a. Click Add New Credential. 

b. Select the SNMP Version of your new credential. 

c. If you are adding an SNMPv1 or SNMPv2c credential, provide the 
new SNMP Community String. 

d. If you are adding an SNMPv3 credential, provide the following 
information for the new credential: 

¶ User Name, Context, and Authentication Method 

¶ Authentication Password/Key, if required. 

¶ Privacy/Encryption Method, if required. 

¶ Password/Key, if required. 

e. Click Add. 
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5. Click Next on the SNMP Credentials view. 

6. If you want to discover any VMware VCenter or ESX Servers on your 
network, confirm that Poll for VMware is checked, and then complete the 
following steps to add or edit required VMware credentials. 

Note: Repeat the following procedure for each new credential. To speed up 
discovery, use the arrows to move the most commonly used credentials on 
your network to the top of the list. 

a. Click Add vCenter or ESX Credential. 

b. If you are using an existing VMware credential, select the appropriate 
credential from the Choose Credential dropdown menu. 

c. If you are adding a new VMware credential, select <New Credential> 
in the Choose Credential dropdown menu, and then provide a new 
credential name in the Credential Name field. 

Note: SolarWinds recommends against using non-alphanumeric 
characters in VMware credential names. 

d. Add or edit the credential User Name and Password, as necessary. 

e. Confirm the password, and then click Add. 

7. Click Next on the Local vCenter or ESX Credentials for VMware view. 

8. If you want to discover devices located on your network within a 
specific range of IP addresses, complete the following procedure. 

Note: Only one selection method may be used per defined discovery.  

a. Click IP Ranges in the Selection Method menu, and then, for each IP 
range, provide both a Start address and an End address. 

Note: Scheduled discovery profiles should not use IP address ranges 
that include nodes with dynamically assigned IP addresses (DHCP). 

b. If you want to add another range, click Add More, and then repeat the 
previous step. 

Note: If you have multiple ranges, click X to delete an incorrect range. 

c. If you have added all the IP ranges you want to poll, click Next. 
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9. If you want to discover devices connected to a specific router or on a 
specific subnet of your network, complete the following procedure: 

Note: Only one selection method may be used per defined discovery.  

a. Click Subnets in the Selection Method menu. 

b. If you want to discover on a specific subnet, click Add a New 
Subnet, provide both a Subnet Address and a Subnet Mask for the 
desired subnet, and then click Add. 

Note: Repeat this step for each additional subnet you want to poll. 

c. If you want to discover devices using a seed router, click Add a 
Seed Router, provide the IP address of the Router, and then click Add. 

Notes: 

¶ Repeat this step for each additional seed router you want to use. 

¶ Orion NPM reads the routing table of the designated router and 
offers to discover devices on the Class A network (255.0.0.0 mask) 
containing the seed router and the Class C networks (255.255.255.0 
mask) containing all interfaces on the seed router, using the SNMP 
version chosen previously on the SNMP Credentials page. 

¶ Networks connected through the seed router are NOT automatically 
selected for discovery. 

d. Confirm that all networks on which you want to conduct your network 
discovery are checked, and then click Next. 

10. If you already know the IP addresses or hostnames of the devices you 
want to discover and include in the Orion database, complete the 
following procedure: 

a. Click Specific Nodes in the Selection Method menu. 

b. Type the IPv4 addresses or hostnames of the devices you want Orion 
NPM to discover for monitoring into the provided field. 

Note: Type only one IPv4 address or hostname per line. 

c. Click Validate to confirm that the provided IPv4 addresses and 
hostnames are assigned to SNMP-enabled devices. 

d. If you have provided all the IPv4 addresses and hostnames you 
want to discover, click Next. 
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11. Configure the options on the Discovery Settings view, as detailed in the 
following steps. 

a. Provide a Name and Description to distinguish the current discovery 
profile from other profiles you may use to discover other network areas. 

Note: This Description displays next to the Name in the list of available 
network discovery configurations on the Network Sonar view. 

b. Position the slider or type a value, in ms, to set the SNMP Timeout. 

Note: If you are encountering numerous SNMP timeouts during Network 
Discovery, increase the value for this setting. The SNMP Timeout should 
be at least a little more than double the time it takes a packet to travel 
the longest route between devices on your network. 

c. Position the slider or type a value, in ms, to set the Search Timeout. 

Note: The Search Timeout is the amount of time Orion NPM waits to 
determine if a given IP address has a network device assigned to it. 

d. Position the slider or type a value to set the number of SNMP Retries. 

Note: This value is the number of times Orion NPM will retry a failed 
SNMP request, defined as any SNMP request that does not receive a 
response within the SNMP Timeout defined above. 

e. Position the slider or type a value to set the Hop Count. 

Note: If the Hop Count is greater than zero, Orion NPM searches for 
devices connected to any discovered device. Each connection to a 
discovered device counts as a hop. 

f. Position the slider or type a value to set the Discovery Timeout. 

Note: The Discovery Timeout is the amount of time, in minutes, Orion 
NPM is allowed to complete a network discovery. If a discovery takes 
longer than the Discovery Timeout, the discovery is terminated. 

12. If you only want to use SNMP to discover devices on your network, 
check Use SNMP only. 

Note: By default, Network Sonar uses ICMP ping  requests to locate devices. 

13. If multiple Orion polling engines are available in your environment, 
select the Polling Engine you want to use for this discovery. 

14. Click Next. 
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15. If you want the discovery you are currently defining to run on a regular 
schedule, select either Custom or Daily as the discovery Frequency, as 
shown in the following steps: 

Notes: 

¶ Scheduled discovery profiles should not use IP address ranges that 
include nodes with dynamically assigned IP addresses (DHCP). 

¶ Default Discovery Scheduling settings execute a single discovery of your 
network that starts immediately, once you click Discover. 

¶ Results of scheduled discoveries are maintained on the Scheduled 
Discovery Results tab of Network Discovery. For more information, see 
ñManaging Scheduled Discovery Resultsò on page 45. 

a. If you want to define a Custom discovery schedule to perform the 
currently defined discovery repeatedly in the future, select Custom 
and then provide the period of time, in hours, between discoveries. 

b. If you want your scheduled discovery to run once daily, select Daily, 
and then provide the time at which you want your discovery to run every 

day, using the format HH:MM AM/PM. 

16. If you do not want to run your network discovery at this time, select No, 
donôt run now, and then click Save or Schedule, as appropriate. 

17. Click Discover to start your network discovery. 

Note: Because some devices may serve as both routers and switches, the 
total number of Nodes Discovered may be less than the sum of reported 
Routers Discovered plus reported Switches Discovered. 

Using the Network Sonar Results Wizard 

The Network Sonar Results Wizard directs you through the selection of devices 
for monitoring, and it opens whenever discovery results are requested, either 
when the Network Sonar Wizard completes or when either Import All Results or 
Import New Results is clicked for a selected discovery. For more information, 
see ñNetwork Discovery Using the Network Sonar Wizardò on page 37. 

The following steps detail the process of selecting discovered devices, interfaces, 
and volumes for monitoring in Orion NPM. 

To select the results of a network discovery for monitoring in Orion NPM: 

1. On the Device Types to Import page, check the device types you want Orion 
NPM to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific device type, check 
the device type in question. If, later, you do not want to monitor a selected 
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device, simply delete the device using Web Node Management. For more 
information, see ñManaging Devices in the Orion Web Consoleò on page 51. 

2. Check the interface types you want Orion NPM to monitor on the Interface 
Types to Import page, and then click Next. 

Note: If you are not sure you want to monitor a specific interface type, check 
the interface type in question. If, later, you do not want to monitor a selected 
interface, delete it using Web Node Management. For more information, see 
ñManaging Devices in the Orion Web Consoleò on page 51. 

3. On the Volume Types to Import page, check the volume types you want 
Orion NPM to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific volume type, check 
the volume type in question. If, later, you do not want to monitor any volume 
of the selected type, delete the volume using Web Node Management. For 
more information, see ñManaging Devices in the Orion Web Consoleò on 
page 51. 

4. If you want to import nodes, even when they are already known to be 
polled by another polling engine, check the option in the Allow Duplicate 
Nodes section. For more information about working with multiple polling 
engines, see ñManaging Orion Polling Enginesò in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

5. Check valid states for imported interfaces on the Import Settings page, and 
then click Next. 

Note: By default, Orion NPM imports interfaces that are discovered in an 
Operationally Up state. However, because interfaces may cycle off and on 
intermittently, the Import Settings page allows you to select interfaces found 
in Operationally Down or Shutdown states for import, as well. 

6. If there are any devices on the Import Preview that you do not ever want 
to import, check the device to ignore, and then click Ignore. Selected nodes 
are added to the Discovery Ignore List. For more information, see ñUsing the 
Discovery Ignore Listò on page 46. 

7. Confirm that the network objects you want to monitor are checked on the 
Import Preview page, and then click Import. 

8. After the import completes, click Finish. 

Note: Imported devices display in the All Nodes resource. 

OrionNPMCoreAdministratorGuide.doc#ManagingOrionNPMPollingEngines
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Importing a List of Nodes Using a Seed File 

In versions of Orion NPM products following the release of Orion NPM version 
10.0, the Specific Nodes option in the Network Discovery Wizard may be used to 
import devices from a seed file. The following procedure details how the Specific 
Nodes option is used with a seed file to import devices into the Orion database. 

Note: A Seed File discovery option is available in Orion NPM prior to version 10. 

To import devices from a seed file: 

1. Open your seed file. 

2. If the Network Sonar Wizard is not already open, click Start > All 
Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Network Discovery. 

3. If you want to create a new discovery, click Add New Discovery, click 
Add New Discovery. 

4. If you have already defined a network discovery, a number of options are 
available on the Network Sonar Discovery tab. Select one of the following: 

¶ If you want to edit an existing discovery before using it, select the 
discovery you want to edit, and then click Edit. 

¶ If you want to use an existing discovery to rediscover your network, 
select the discovery to use, click Discover Now, and then complete the 
Network Sonar Results Wizard after discovery completes.  

¶ If you want to import some or all devices found in a defined 
discovery that you may not have already imported for monitoring, 
select a defined discovery, and then click Import All Results. For more 
information, see ñUsing the Network Sonar Results Wizardò on page 41. 

¶ If you want to import any newly enabled devices matching a defined 
discovery profile, select a currently defined discovery, and then click 
Import New Results. For more information about network discovery 
results, see ñUsing the Network Sonar Results Wizardò on page 41. 

¶ If you want to delete an existing discovery profile, select a currently 
defined discovery and then click Delete. 

5. If the devices on your network do not require community strings other 

than the default strings public  and private  provided by Orion NPM, 

click Next on the SNMP Credentials view. 

6. If you need to supply new SNMP credentials to discover the devices in 
your seed file, click Add New Credential, provide the required information, 
and then click Add. For more information, see ñNetwork Discovery Using the 
Network Sonar Wizardò on page 37. 
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7. Click Next on the SNMP Credentials view. 

8. If you intend to import known VMware vCenter or ESX servers and you 
need to supply new VMware credentials to discover these servers in 
your seed file, complete the following steps on the Local vCenter or ESX 
Credentials for VMware view: 

a. Check Poll for VMware, and then click Add vCenter or ESX 
Credential. 

b. Provide the required information, and then click Add. 

Note: For more information, see ñNetwork Discovery Using the Network 
Sonar Wizardò on page 37. 

9. Click Next, and then click Specific Nodes in the Selection Method menu. 

10. Copy and then paste the IP addresses or hostnames of the devices you want 
to discover from your seed file into the provided field. 

Note: Confirm that no line has more than one IPv4 address or hostname. 

11. Click Validate to confirm that the provided IP addresses and hostnames are 
assigned to SNMP-enabled devices. 

12. If you have provided all the IP addresses and hostnames you want to 
discover, click Next. 

13. Complete the Network Discovery and Network Discovery Results Wizards. 
For more information, see ñNetwork Discovery Using the Network Sonar 
Wizardò on page 37. 

Managing Scheduled Discovery Results 

The Scheduled Discovery Results tab of Network Discovery provides a list of all 
recently discovered, changed, or imported devices on your monitored network. 
Results are compared between discoveries, and results are listed on this tab. 
The following procedure provides guidelines for managing discovery results. 

To manage scheduled discovery results: 

1. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Network Discovery. 

2. Click Scheduled Discovery Results. 

3. Select the type of devices you want to view from the Status menu in the left 
pane. The following options are available: 

¶ Select Found to view all devices discovered by a scheduled discovery. 
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¶ Select Changed to view all devices that have changed between recent 
scheduled discoveries. Changes include the addition of interfaces and 
device configuration changes. 

¶ Select Imported to view all devices you have recently imported into 
Orion NPM. For more information about importing devices, see ñUsing 
the Network Sonar Results Wizardò on page 42. 

¶ Select Ignored to view all devices you have added to your Discovery 
Ignore List. For more information about the Discovery Ignore List, see 
ñUsing the Discovery Ignore Listò on page 46. 

¶ Select Found and Changed to view a combined list of all devices found 
or changed as described above. 

¶ Select All except Ignored to view all discovered, changed or imported 
devices you have not already designated as Ignored, as detailed above. 

4. If you want to apply a grouping criterion to organize your listed results, 
select an appropriate criterion from the Group by menu in the left pane. 

5. If there are changed or discovered nodes in the results list that you 
want to update your Orion database to include, check all nodes to update 
or add, and then click Import Nodes. 

6. If there are devices you want Orion NPM to ignore in future discoveries, 
regardless of discovered updates or changes, check all nodes to ignore, 
and then click Add to Ignore List. For more information about the Discovery 
Ignore List, see ñUsing the Discovery Ignore Listò on page 46. 

Using the Discovery Ignore List 

Often, devices are found during a network discovery that you never intend to 
monitor with Orion NPM. The Discovery Ignore List is a record these devices. By 
placing a device on the Discovery Ignore List you can minimize the SNMP 
processing load associated with discovering devices you never intend to monitor. 

To manage devices on the Discovery Ignore List: 

1. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Network Discovery. 

2. If you want to view the current Discovery Ignore List, click Discovery 
Ignore List. 

3. If you want to add devices to the Discovery Ignore List, complete the 
following procedure: 

a. Click Scheduled Discovery Results. 

b. Check devices you want to ignore, and then click Add to Ignore List. 
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4. If you want to remove devices from the Discovery Ignore List, complete 
the following procedure: 

a. Click Scheduled Discovery Results, and then  

b. Check the devices you want to remove from the list, and then click 
Remove from Ignore List. 

c. Confirm that you want to stop ignoring selected items by clicking OK. 

Using the Web Console Notification Bar 

Below the web console menu bar, the Orion notification bar provides 
informational messages related to the following Orion NPM features: 

¶ The Orion Product Team Blog offers regular posts from members of the 
Orion product team to help you take full advantage of features provided by 
Orion NPM and its modules. 

¶ If you have configured the Orion Web Console to store blog posts, new and 
unread posts to the Orion Product Team Blog are announced in the 
notification bar. 

¶ If you have currently configured a scheduled discovery, results display in the 
notification bar when the discovery completes. For more information about 
Scheduled Discovery, see ñNetwork Discovery Using the Network Sonar 
Wizardò on page 37. 

¶ If you are currently using Orion NPM to monitor any VMware ESX or ESXi 
Servers, the notification bar can display messages communicating the 
number of ESX nodes found during any discovery, and, if any discovered 
ESX nodes require credentials, the notification bar tells you. For more 
information about monitoring VMware ESX Servers, see ñVirtualizationò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

For more information about any displayed notification bar message, click More 
Details and a web console view relevant to the displayed message opens. 

To delete a posted message, either click Dismiss Message next to the displayed 
message, or properly address the situation mentioned in the posted notification. 

To remove the notification bar from your web console, click Close (X) at the right 
end of the notification bar. 

Navigating the Orion Web Console 

The Orion Web Console offers two primary methods of navigation: top-level web 
console tabs and view-level breadcrumbs. The following sections describe how 
these navigation methods are used: 

OrionNPMCoreAdministratorGuide.doc#MonitoringVMwareESXServers
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Using Web Console Tabs 

In the case of a basic Orion NPM installation, the Orion Web Console displays 
the following tabs: 

Home 

The Home tab provides a menu bar of links to views aiding you in general 
network management and monitoring. Information, like events and Top 10 
lists, and technologies, like alerts, used to generate the views linked from the 
Home menu are generally available to all Orion modules. By default, the 
Orion Summary Home view displays when you click Home from any view in 
the web console. 

Applications (Orion APM) 

If you are viewing the Orion Web Console on a server on which Orion APM is 
also installed, the Applications tab opens a menu of default views for some 
of the many different types of applications Orion APM can monitor. If Orion 
APM is installed without Orion NPM, the APM Summary Home view 
displays by default when you click Home from any web console view.  

Network (Orion NPM) 

The Network tab opens a menu bar of links to views and technologies, like 
EnergyWise, wireless network and interface monitoring, that are specific to 
the features provided by Orion NPM NPM. If Orion NPM is installed, the NPM 
Summary Home view displays by default when you click Home from any 
web console view. 

Configs (Orion NPM and NCM) 

If the Orion NCM Integration for Orion NPM is installed, the Configs tab 
provides links to default device configuration management views. If Orion 
NPM is installed, clicking Home from any web console view displays the 
NPM Summary Home view by default.  

Virtualization 

The Virtualization tab provides access to specific views and resources that 
are tailored for monitoring virtual devices. For more information about 
virtualization monitoring in Orion, see ñVirtualizationò in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

The web console provides an additional module-specific tab for each installed 
Orion module. These tabs offer access to views and tools specific to the Orion 
module added. For more information about additional Orion modules, see 
www.solarwinds.com. For more information about customizing menu bars, see 
ñManaging the Orion Web Consoleò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide.  

http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionAPMVirtualization.htm
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/documentation/Orion/docs/OrionNPMAdministratorGuide.pdf
http://www.solarwinds.com/
http://www.solarwinds.com/NetPerfMon/SolarWinds/default.htm#context=SolarWinds&file=OrionCoreAGCustomizingWebConsoleMenuBars_2.htm
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Using and Disabling Web Console Breadcrumbs 

As you navigate web console views, your location is recorded as a series of links, 
or breadcrumbs, to the views you have opened. Each breadcrumb offers the 
following navigation options: 

¶ Clicking a breadcrumb opens the corresponding view directly. 

¶ Clicking > next to a breadcrumb opens a clickable list of all other views at the 
same navigation level in the web console. For example, if you are on a Node 
Details view, clicking > displays a list of other monitored nodes. 

Note: Only the first 50 monitored nodes, listed in alphanumeric order by IP 
address, are displayed. 

Customizing Web Console Breadcrumbs 

Dropdown breadcrumb lists are customizable, as shown in the following steps. 

To customize the items in a breadcrumb dropdown: 

1. Click > at an appropriate level in a breadcrumb to open the dropdown. 

2. Click Customize this list. 

3. Select a criterion from the menu, and then click Submit. 

Note: All items in the customized list will be identical for the selcted criterion. 

Disabling Web Console Breadcrumbs 

To ensure access is appropriately restricted for account-limited users, you may 
want to disable breadcrumbs, as indicated in the following procedure. 

To disable web console breadcrumb navigation: 

1. Log on to your Orion server using an account with administrative access. 

2. Open web.config  (default location C: \ I netpub \ SolarW inds \ ) for editing. 

3. In the <appsettings>  section, locate the following setting: 

<add key=òDisableBreadCrumbsò value=òfalseò/> 

4. Change ñfalseò to ñtrueò, as follows: 

<add key =òDisableBreadCrumbsò value=òtru eò/> 

5. Save web.config . 

Note: If you run the Configuration Wizard after editing this setting, your 
changes may be overwritten. 
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Configuring the Orion Web Console 

The primary user interface for Orion NPM is the Orion Web Console, where 
performance data for your network devices is most easily viewed. The following 
sections describe the primary administrative functions performed by an Orion 
Web Console administrator. For more information about administrative functions 
in the Orion Web Console, including extensive configuration examples, see 
ñManaging the Orion Web Consoleò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Logging in for the First Time as an Adminstrator 

The first time you start the Orion Web Console, you will be presented with a login 
page requiring both a User Name and a Password. Log in to the Orion Web 
Console as shown in the following steps. 

To log in to the Orion Web Console: 

1. Launch the Orion Web Console using either of the following methods: 

¶ Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

¶ Or launch a browser on your Orion NPM server and enter 
http: // ip _address  or http:// hostname , where ip _address  is the IP 

address of your Orion NPM host server, or where hostname  is the 

domain name of the server hosting your Orion NPM installation. 

2. Enter Admin  as your User Name, and then click Login. 

Notes: 

¶ The latest version of the Orion Web Console supports authentication of 
defined Active Directory users and groups. 

¶ Until you set a password, you can log in as Admin with no Password. 
After your first login, you may want to change the Admin password. For 
more information, see ñChanging an Account Passwordò on page 50. 

Windows Authentication with Active Directory 

As of Orion Core version 2010.2, the Orion Web Console can authenticate Active 
Directory users and users who are members of Active Directory security groups. 

To enable Active Directory Windows authentication to the web console: 

1. Install and configure Active Directory on your local network. 

Notes: 

¶ For more information about Active Directory on Windows Server 2008, 
see the Microsoft TechNet article, ñActive Directory Servicesò. 

OrionNPMCoreAdministratorGuide.doc#ManagingOrionWebConsole
http://technet.microsoft.com/en-us/library/dd578336%28WS.10%29.aspx
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¶ For more information about installing Active Directory on Windows 
Server 2003, see the Microsoft Support article, ñHow To Create an Active 
Directory Server in Windows Server 2003ò. 

2. If you want to enable automatic login for web console accounts using 
Windows Authentication, configure the Orion Web Console as shown in the 
following steps: 

a. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Configuration Wizard. 

b. Check Website, and then click Next. 

c. After providing the appropriate IP Address, Port, and Website Root 
Directory, select Yes ï Enable automatic login using Windows 
Authentication. 

d. Click Next, and then complete the Configuration Wizard. 

3. Log in to the web console using the appropriate domain and user, providing 

Domain \User name or Username@Domain as the web console User name. 

Changing an Account Password 

Orion NPM administrators may change user account passwords at any time, as 
shown in the following procedure. 

To change an account password: 

1. Log in to the web console as an administrator. 

2. Click Settings in the top right corner of the web console. 

3. Click Account Manager in the Accounts grouping of the Orion Website 
Administration page. 

4. Select the user account with the password you want to change, and then 
click Change Password. 

5. Complete the New Password and Confirm Password fields, and then click 
Change Password. 

6. Click Continue when the password is successfully changed. 

Managing Devices in the Orion Web Console 

Managing all the monitored devices on your network is greatly simplified with the 
Node Management feature of the Orion Web Console. Using this tool, you can 
easily add and remove nodes, interfaces, and virtual servers and quickly view 
and edit device properties. Any user that has been granted node management 
rights can directly access the Node Management tool either from any All Nodes 

http://support.microsoft.com/kb/324753
http://support.microsoft.com/kb/324753
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resource or through the Orion Website Administration page. For more information 
about granting node management rights, see ñEditing User Accountsò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

The following sections describe the various functions that allow you to view and 
manage all your network devices from the Orion Web Console. 

Note: The Node Management feature is accessible by clicking Manage Nodes 
either in the header of any All Nodes resource or in the Node & Group 
Management group of the Orion Website Administration page. The All Nodes 
resource is included on the Orion Summary Home view by default, but you can 
include it on any other web console view as well. Confirm that the All Nodes 
resource is available on an appropriate Web Console view before continuing. For 
more information about adding resources to Orion NPM views, see ñEditing 
Viewsò in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

Adding Devices for Monitoring in the Web Console 

The following procedure details the steps required to add a device and its 
interfaces and volumes for monitoring in the Orion Web Console. 

To add a device for monitoring in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator, and then click Settings 
in the top right of the web console. 

2. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

3. Click Add Node on the Node Management toolbar. 

4. Provide the hostname or IP Address of the node you want to add in the 
Hostname or IP Address field. 

5. If you only want to use ICMP to monitor node status, response time, or 
packet loss for the added node, check ICMP (Ping only). 

6. If you are adding a VMware ESX Server, check Poll for ESX to ensure that 
Orion NPM acquires any data the ESX Server provides to SNMP polling 
requests, and then complete the following steps to provide required ESX 
Server credentials. For more information about monitoring VMware ESX 
Servers, see ñVirtualizationò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

a. Provide an appropriate VMware credential name. 

Notes: 

¶ If you are editing an existing credential, select the credential you are 
editing from the Choose Credential field. 
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¶ SolarWinds recommends against using non-alphanumeric characters 
in VMware credential names. 

b. Provide an appropriate User name and a Password. 

c. Provide the password again in the Confirm password field. 

d. Click Validate VMware to confirm the ESX credentials you provided. 

7. If you want to add an External node to monitor a hosted application 
with Orion Application Performance Monitor, check External. 

Note: Orion NPM does not collect or monitor any network performance data 
from nodes designated as External. The External status is reserved for 
nodes hosting application that you want to monitor with Orion Application 
Performance Monitor. 

8. If you want to use SNMP to monitor the added node, confirm that ICMP 
(Ping only) is cleared, and then complete the following steps: 

a. Select the SNMP Version for the added node. 

Notes: 

¶ Orion NPM uses SNMPv2c by default. If the device you are adding 
supports or requires the enhanced security features of SNMPv3, 
select SNMPv3. 

¶ If SNMPv2c is enabled on a device you want Orion NPM to monitor, 
by default, Orion NPM will attempt to use SNMPv2c to poll for 
performance information. If you only want Orion NPM to poll using 
SNMPv1, you must disable SNMPv2c on the device to be polled. 

b. If you have installed multiple polling engines, select the Polling 
Engine you want to use to collect statistics from the added node. 

Note: This option may not be available if you are only using one polling 
engine to collect information from your network. 

c. If the SNMP port on the added node is not the Orion NPM default of 
161, provide the actual port number in the SNMP Port field. 

d. If the added node supports 64 bit counters and you want to use 
them, check Allow 64 bit counters. 

Note: Orion NPM fully supports the use of 64-bit counters; however, 
these high capacity counters can exhibit erratic behavior depending on 
manufacturer implementation. If you notice peculiar results when using 
these counters, use the Node Details view to disable the use of 64-bit 
counters for the device and contact the hardware manufacturer. 
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9. If you want Orion NPM to use SNMPv2c to monitor the added node, 
provide valid community strings for the added node. 

Note: The Read/Write Community String is optional, but Orion NPM does 

require the public  Community String, at minimum, for node monitoring. 

10. If you want Orion NPM to use SNMPv3 to monitor the added node, 
provide the following SNMP Credentials, Authentication, and 
Privacy/Encryption settings: 

¶ SNMPv3 Username and Context 

¶ SNMPv3 Authentication Method and Password/Key 

¶ SNMPv3 Privacy/Encryption Method and Password/Key 

11. If you are using SNMP to communicate with your added node, click 
Validate SNMP after entering all required credentials to confirm your SNMP 
settings. 

12. Click Next. 

13. Check the interfaces, volumes, and interface charts for the added node that 
you want Orion NPM to monitor. The following options are available: 

¶ Clicking All selects all listed devices and charts for monitoring. 

¶ Clicking None clears any checked interfaces, volumes, or interface 
charts that have been selected for monitoring. 

¶ Clicking All Active Interfaces selects only currently active interfaces 
and the associated interface charts for monitoring. 

¶ Clicking All Volumes selects all listed volumes for monitoring. 

¶ Clicking All Interfaces selects all listed interfaces for monitoring. 

14. After you have selected interfaces, volumes, or interface charts for 
monitoring, click Next. 

15. If you want to apply pollers to the added node, click + to expand poller 
groups, as necessary, check the appropriate pollers, and then click Next. 

Note: For more information about using predefined pollers or about defining 
your own universal device pollers, see ñMonitoring MIBs with Universal 
Device Pollersò in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

16. If you want to edit the SNMP settings you provided earlier, change the 
appropriate values in the SNMP area of the Change Properties page, and 
then click Validate SNMP to confirm your new settings. 
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17. If you want to edit the default polling settings for your added node, 
change the Node Status Polling or Collect Statistics Every values in the 
Polling area of the Change Properties page, as appropriate. 

Note: The Node Status Polling value refers to the number of seconds, 
between the node status checks Orion NPM performs on the added node. 
The Collect Statistics Every value refers to the period of time between the 
updates Orion NPM makes to displayed statistics for the added node. 

18. If you have defined any custom properties for monitored nodes, provide 
appropriate values for the added node in the Custom Properties area of the 
Change Properties page. 

Note: The Custom Properties area is empty if you have not defined any 
custom properties for monitored nodes in Orion NPM. 

19. Click OK, Add Node when you have completed properties configuration for 
your added node. 

20. If you have successfully added the node, click OK on the dialog. 

Deleting Devices from Monitoring 

The following procedure deletes devices from monitoring in the web console. 

Warning: Deleting nodes from monitoring in the web console automatically 
terminates monitoring of all interfaces and volumes on deleted nodes. 

Note: You can select multiple devices to delete at the same time. Additionally, 
using the search tool above the node list, you can select multiple interfaces on 
different nodes for simultaneous deletion.  

To delete devices from monitoring in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator, and then  

2. Click Settings in the top right of the web console. 

3. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. If you want to delete a node with all its monitored interfaces, complete 
the following steps. 

a. Locate the node to delete using either of the following methods: 

¶ Use the search tool above the node list to search your Orion 
database for the node you want to delete. 

¶ Select an appropriate Group by: criterion, and then click the 
appropriate group including the node to delete. 
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b. Check the node to delete in the list, and then click Delete on the toolbar. 

5. If you want to delete an interface or a volume, use the following steps. 

a. Locate the element to delete using either of the following methods: 

¶ Use the search tool above the node list to search your Orion 
database either for the interface or for the parent node of the 
interface or volume to delete. 

¶ Select a Group by: criteria, and then click the appropriate group 
including the parent node of the interface or volume to delete. 

b. If you have a list of node results, click + to expand the parent node of 
the interface or volume you want to delete. 

c. Check the interface or volume to delete, and then click Delete on the 
Node Management toolbar. 

6. Click OK to confirm deletion. 

Editing Device Properties 

The following procedure provides the steps required to edit node, interface, or 
volume properties using the Node Management utility of the Orion Web Console. 

Note: Editing multiple devices in multiple browser tabs in the same session may 
result in lost data or database errors. Limit device management activities to a 
single browser tab to prevent database errors and data losses. 

To edit device properties in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Nodes in the Node & Group Management grouping. 

3. Locate the device to edit using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database 
for either the node or interface you want to edit or the parent node of the 
volume you want to edit. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including either the node to edit or the parent node of the interface 
or volume to edit. 

4. If you want to edit the properties of a monitored node, check the node 
you want to edit, and then click Edit Properties. 
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5. If you want to edit the properties of a monitored interface, click + next to 
the parent node of the interface you want to edit, check the interface you 
want to edit, and then click Edit Properties. 

6. If you are editing the SNMP properties of a node, click Validate SNMP 
after providing new settings to confirm they are valid for the edited node. 

7. If the selected node is a VMware ESX Server and you want to poll it for 
data using the VMware API, Confirm that Poll for ESX is checked. 

8. If you want to poll for ESX data using an existing ESX credential, select 
the appropriate credential from the VMware credentials dropdown menu. 

9. If you want to poll for ESX data using a new ESX credential, complete 
the following steps: 

a. Select <New Credential> in the Choose Credential dropdown menu, 
and then provide a new credential name in the Credential Name field. 

Note: SolarWinds recommends against using non-alphanumeric 
characters in VMware credential names. 

b. Add the credential User name and Password, as necessary. 

c. Confirm the password, and then click Validate VMware to confirm the 
credentials you have provided are valid for the edited node. 

10. Edit additional device properties as needed, and then click Submit. 

Viewing Node Resources 

The List Resources feature of the Orion Web Console Node Management utility 
allows you to immediately see all monitored interfaces, volumes, and interface 
charts on a selected node, as shown in the following procedure. 

To view a list of all resources present on a node: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Nodes in the Node & Group Management grouping. 

3. Locate the node to view using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database 
for the node you want to view. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including the node to view. 

4. Check the node you want to view from the list. 

5. Click List Resources on the Node Management toolbar. 
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Setting Device Management States 

Monitored devices are regularly polled for operational status. Collected statistics 
are displayed in the Orion Web Console. Using the Node Management feature of 
the Orion Web Console, the management status of monitored nodes, is easily set 
or changed, allowing you to either temporarily suspend data collection or resume 
polling and statistics collection, as necessary. The following procedure sets or 
changes management states for monitored nodes in the Orion Web Console. 

Note: Setting a node to an unmanaged state automatically suspends the 
management of all interfaces and volumes on the selected node. 

To set or change the management state of a node: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Nodes in the Node & Group Management grouping. 

3. Locate the node to manage using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database 
for the device you want to manage. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including the node to manage. 

4. Check the node to change, and then click Unmanage or Remanage, as 
appropriate, for the selected node. 

5. If you have selected Unmanage, provide start and end times and dates for 
your management suspension, and then click OK. 

Assigning Pollers to Monitored Devices 

Orion NPM provides both a selection of predefined pollers and the Universal 
Device Poller utility for defining your own pollers to monitor specific aspects of 
your network devices. In the Orion Web Console, the assignment of pollers to 
monitored devices is a straightforward process, as shown in the following steps. 

Note: If you do not see a poller that meets your specific monitoring needs, use 
the Universal Device Poller to create your own poller. For more information, see 
ñMonitoring MIBs with Universal Device Pollersò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

To assign a poller to a monitored device: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 
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3. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. Locate the node to poll, the interface to poll, or the parent node of the 
interface or volume to poll using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including either the node to poll or the parent node of the interface 
or volume to poll. 

5. If you want to assign a poller to a node, complete the following steps: 

a. Check the monitored node to which you want to assign the poller. 

b. Click Assign Pollers in the Node Management toolbar. 

c. Check the pollers you want to assign to the selected node, and then click 
Submit. 

d. Click OK to confirm the assignment. 

6. If you want to assign a poller to an interface or volume, complete the 
following steps: 

a. Click + next to the parent node of the interface or volume to which you 
want to assign the poller. 

b. Check the interface or volume to which you want to assign the poller. 

c. Click Assign Pollers in the Node Management toolbar. 

d. Check the pollers you want to assign to the selected interface or volume, 
and then click Submit. 

e. Click OK to confirm the assignment. 
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Viewing Node and Interface Data in Tooltips 

Node and interface tooltips in Orion NPM provide immediate status overviews of 
monitored nodes and interfaces. To view a quick overview of any monitored node 
or interface in the web console, hover over the device name. Depending on the 
selected device, the information in the following tables is displayed immediately. 

Interface Data 

Interface Name 
The name of the interface as discovered from its parent 
node 

Operational Status Operational status of the interface 

Administrative Status 
Administrative status of the interface (enabled or 
disabled) 

Interface Type 
Numerical type of the interface, as determined by Orion 
NPM when the parent node is discovered. 

Transmitted Current Traffic 
The amount of traffic the interface was transmitting as of 
the last interface poll 

Transmitted Percent Utilization 
The percent of available bandwidth used for traffic 
transmitted from the interface as of the last interface poll 

Received Current Traffic 
The amount of traffic the interface was receiving as of the 
last interface poll 

Received Percent Utilization 
The percent of available bandwidth used for traffic 
received by the interface as of the last interface poll 

 

Node Data 

Node Status 
Current status of the node. (up, down, warning, 
unplugged, or unmanaged) 

IP Address The IP address currently assigned to the selected node 

Machine Type 
The vendor icon and vendor description of the selected 
node 

Average Response Time 
The measured average response time of the selected 
node as of the last node poll 

Packet Loss 
The percent of all transmitted packets that are lost by the 
selected node as of the last node poll 

CPU Load 
The percent of available processing capacity on the 
selected node that is currently used as of the last node 
poll 

Memory Used 
The percent of available memory on the selected node 
that is currently used as of the last node poll 
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Adding Views to the Admin Toolbar 

As an example of a useful customization in the Orion Web Console, the following 
procedure adds a Network Trends chart view to the Admin toolbar. 

To add the Network Trends chart view to the Admin toolbar: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Web Console as an administrator, and then click Settings in the 
top right of the web console. 

3. Click Customize Menu Bars in the Customize grouping of the Orion Website 
Administration page, and then click Edit under the Admin menu bar. 

4. Click and drag Network Trends from the Available items list on the left to the 
Selected items list on the. 

Note: The Edit Admin Menu Bar lists a wide array of views that can be added 
directly to the Orion Web Console Views toolbar. Hover over any view title to 
read a view description. Selected views may be further customized by 
clicking Edit next to the view title. 

Note: Selected items display from left to right in the edited menu bar as they 
are listed from top to bottom. 

5. Click Submit on the Edit Admin Menu Bar page. 

6. Click Network Trends on the Admin toolbar.  

Note: Due to the amount of data queried from the database, the Network 
Trends resources may take a significant time to load. You can also edit the 
number of resources included in the view to reduce the time to load. For 
more information about customizing views, see ñCustomizing Viewsò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 
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Chapter 4 

Using Orion Network Performance Monitor 

A wealth of information can be collected about your network using the powerful 
tools that comprise Orion Network Performance Monitor (Orion NPM). The first 
two sections in this chapter introduce the configuration of Orion NPM reports and 
alerts, and a third section details additional Orion NPM features: 

¶ Creating Custom Orion NPM Reports 

¶ Using Orion NPM Alerts 

¶ Additional Orion NPM Features 

Creating Custom Orion NPM Reports 

Using Orion Report Writer, you can create custom network monitoring reports. A 
variety of predefined reports are also included . Icons preceding report names 
distinguish available report types. The following procedure starts Report Writer. 

Note: Before Report Writer can create useful reports Orion NPM must have 
collected at least a few minutes worth of data in the Orion database populated 
with the network devices that you want to monitor. 

To start Report Writer: 

1. Click Start > All Programs > SolarWinds Orion > Report Writer. 

2. Click File > Settings. 

3. In the General tab of the Report Writer Settings window, select either of the 
following as a default viewing mode: 

¶ Preview displays the report as it will appear in printed form. For more 
information, see ñPreview Modeò on page 64. 

¶ Report Designer is the report creation and editing interface. For more 
information, see ñDesign Modeò on page 64. 

Note: You can toggle between Preview and Report Designer modes at any 
time by clicking Preview or Design, respectively, on the toolbar. 

4. If you want to separate the data for individual network objects with 
horizontal lines, click Report Style, and then check Display horizontal 
lines between each row. 

5. Click OK to exit Report Writer Settings.  
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Preview Mode 

Preview mode shows a report as it will print. When you open a report in Preview 
mode, or switch to Preview mode from Design mode, Orion NPM runs the query 
to generate the report and Report Writer displays the results. 

The Preview window toolbar provides the following actions and information: 

¶ Current page number and total number of pages in the report in the form 
current# / total# 

¶ Page navigation buttons: First Page, Page Up, Page Down, and Last Page 

¶ Zoom views 

Note: Double-click on a report preview to zoom in and double-right-click to 
zoom out. 

¶ Print report 

Design Mode 

Use Design mode to create new reports and modify or rename existing reports. 
The options available for both creating and modifying reports are the same. 
Design mode options are also dynamic, based upon the type of report, included 
report data, and report presentation. Available options differ according to the type 
of report that you are designing, but all reports require that you select the data to 
include and decide how that data will be sorted, ordered, filtered, and presented. 

Creating and Modifying Reports 

The following procedure guides you in the creation and modification of reports in 
Report Writer. 

Notes: 

¶ The SQL query used to generate a report may be viewed in an additional tab. 
Click Report > Show SQL to add a read-only SQL tab to the Design window. 

¶ A preview of your report is also available at any time. Click Preview to enter 
Preview Mode, and then click Design to return to Design Mode. 

To open a report with Report Writer: 

1. If you want to modify an existing report, select an existing report from the 
inventory in the left pane of the main Report Writer window. 

2. If you want to create a new report, click File > New Report, select the type 
of report that you would like to create, and then click OK. 
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The following sections provide procedures for formatting your reports in Design 
mode. Each of the following sections corresponds to an available tab containing 
report formatting options. 

Note: Each report, depending on its type, offers unique options on separate tabs 
of the Report Designer. Depending on the type of report, some of the following 
formatting tabs may not be available. 

General Options 

The General tab opens by default and shows titling and display options that may 
be configured as follows. 

To configure General options: 

1. Specify the Report Group, Report Title, Sub Title, and Description for 
your report. 

Note: If you use an existing report group name, the new report is added to 
that existing group in the left pane of the main window. 

2. Select the display Orientation of your report. 

3. If you do not want to make this report available on your Orion Web 
Console, clear Make this Report available from the Orion website. 

Note: By default, most reports are made available for display in the Orion 
Web Console. For more information, see ñCustomizing Viewsò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

Select Fields Options 

The Select Fields tab allows you to select the data fields either to include in a 
new report or to modify in an existing report as follows. 

To select and configure fields: 

1. Click Select Fields. In the Select Fields tab, fields are chosen, sort orders are 
established, and functions are specified. 

2. If you are creating a new report or adding fields to an existing report, 
click Browse (...), select Add a new field, and then dynamically define each 
new report field as follows: 

a. Click the asterisk after Field:, and then select the type of information you 
want to include in the current report field. 

b. If you want to sort the data in the current field, click the sort asterisk, 
and then select a sort order. 

c. If you want to perform an operation on the data in the current field, 
click the function asterisk and select an operation. 
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3. If you are modifying an existing report, click the Field, sort, or function 
that you want to change and select a new value as follows. 

a. Click the asterisk after Field: and select the type of information that you 
want to include in the current report field. 

b. If you want to sort the data in the current field, click the sort asterisk 
and select a sort order. 

c. If you want to perform an operation on the data in the current field, 
click the function asterisk and select an operation. 

4. If you want to test your selections as you assemble your report, click 
Execute SQL Query to view the current query results. 

5. If you want to preview your report, click Preview to run the query and 
display the results in Preview mode. Click Design in the toolbar to return to 
the Design Mode window. 

6. If you want to delete a field or rearrange the order of the fields that are 
listed in your report, select a field, click Browse (...), and then select the 
appropriate action. 

Note: Unchecked fields are not displayed in your report, but their sort and 
function configurations are retained. 

Filter Results Options 

The Filter Results tab allows you to generate filter conditions for field data by 
selecting appropriate descriptors from the linked context menus. Results filters 
are configured as follows. 

To configure results filters: 

1. Click Browse (...), and then select from the following options: 

¶ Select Add a new elementary condition to generate a condition that is 
based on a direct comparison of network object data fields. 

¶ Select Add a new advanced elementary condition to generate a 
condition based on a comparison of device data fields and values. 

¶ Select Add a new complex condition to define a condition that filters 
other defined conditions. 

¶ Select Delete current condition to remove a selected condition. 

¶ Select Move current condition forward or Move current condition 
backward to change the order of your conditions accordingly. 

Note: The lists of available linked descriptors are dynamically generated in 
consideration of all other variables within the same condition. For more 
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information, see ñUnderstanding Condition Groupsò in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

2. Check or clear individual filter conditions to enable or disable their 
application, respectively, to your report. 

Top XX Records Options 

The Top XX tab allows you to limit the number of records that are shown in your 

report to either a top number  or a top percentage  of all results. Top XX options 

are configured as follows. 

To configure Top XX records: 

1. If you want to show all records in your report, select Show All Records. 

2. If you want to specify a truncated list of eligible items for your report, 

either select Show only the Top number  Records or select Show the Top 

percentage  % of Records, and then provide number  or percentage  values. 

Time Frame Options 

The Time Frame tab allows you to limit the scope of your report to a specific 
period of time. Time Frame options are configured as follows. 

To configure Time Frame options: 

1. Select a Named, Relative, or Specific Time Frame for your report: 

2. Select or provide required values. 

Notes: 

¶ If you receive a SQL Timeout error message, you may edit the timeout 
setting in the SWNetPerfMon.db  file. By default, this file is located in the 

C: \ Program  Files \ SolarWinds \ Orion  directory 

¶ The Relative Time Frame is continuously variable. Reports run using it 
may show different results, even if they are run close together in time. 

Summarization Options 

The Summarization tab allows you to generate summaries of your results over 
specific periods of time. Summarization options are configured as follows. 

To configure results summarization: 

1. If you do not want to summarize your results, confirm that Do not 
Summarize the Results is selected. 

2. If you want to summarize your results over specific periods of time, 
select Summarize the Results by Hour, Date, Month, etc and then select 

OrionNPMCoreAdministratorGuide.doc#UnderstandingConditionGroups
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the summarization period, specifying the location of the summary field for 
your report, and select a location for the Summary Date/Time field. 

Report Grouping Options 

The Report Grouping tab allows you to group results by field descriptor within 
your report. Add, edit and delete report groups to organize the data in your 
report. Establish and edit report groups as follows. 

To add and edit report groups: 

1. If you want to add a new report group, select a field from the list to define 
your group, and then click Add Report Group to add your selected field to 
the Report Groups list.  

Note: Use up and down arrows to change the grouping order accordingly. 

2. If you want to edit an existing report group, select the field from the 
Report Groups list, and then click Edit Report Group.  

3. The following options may be changed as needed: 

¶ The Group Header is the text that designates groups on your report. 

¶ The Web URL is the dynamic location of your published report with 
respect to your Orion Web Console. 

¶ Font size, face, color, and background may all be modified by clicking 
associated ellipses. 

¶ Alignment may be left, center, or right. 

¶ Check Transparent Background for better results with web reports. 

¶ Use the up and down arrows to change the grouping order accordingly. 

Field Formatting Options 

The Field Formatting tab allows you to customize the format of report fields. 

To format results fields: 

1. Select the field that you want to format, and then edit labels and select 
options as appropriate. 

Note: Formatting options for each field may differ according to field data 
type. Check Hidden Field to hide any field in your report. 

2. If you want to view your changes at any time, click Preview. 
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Customizing the Header and Footer Image 

The image that is displayed at the top and bottom of each report can be 
changed. To add your company logo or any other image as the header and 
footer image in your reports, rename your logo or custom image file as 

ReportHeader.jpg , and then copy it to the SolarWinds \ Orion  folder. 

Note: The image must be in JPEG format with a height of 150 pixels or less. 

Example of Report Creation 

The following procedure generates an example report of network device 
availability information over the previous week. The final report is sorted so that 
the worst errors are viewed first. Down nodes that are still down are at the top 
with all devices listed in order of increasing availability. 

Note: At any point during the creation of a report (or perhaps at many points), 
you may save what you have done by clicking File > Save. The first time you 
save you must give your report a filename or accept the default, which will be the 
report title that you assign in the following procedure. 

To generate an example report of network device availability information: 

1. Click File > New Report. 

2. The example calls for a report on availability over the past week, so select 
Historical Availability Details, and then click OK. 

3. Type My Reports  in the Report Group field. 

4. Enter Last Weekôs Availability as the Report Title. 

5. Select Portrait for the paper orientation. 

6. Click Select Fields. 

7. Click Browse (...), and then select Add a new field. 

8. Click the Field asterisk, and then select Network Nodes > Node Details > 
Node Name. 

9. Click Browse (...), and then select Add a new field. 

10. Click the Field asterisk, and then select Network Nodes > Node Status > 
Status. 

11. Click Browse (...), and then select Add a new field. 

12. Click the Field asterisk, and then select Network Nodes > Node Status > 
Status Icon. 

Note: While this field makes a distinct visual difference for a report viewed in 
color, it will make little or no difference if printed in black and white. 
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13. Click Execute SQL Query to view the report data in the preview window. 

14. If you want to see the status icon before the status description, click 
Status Icon to move Browse (...) to the Status Icon line, and select Move 
Current Field Backward. 

15. Click Execute SQL Query. 

Note: The report should show information about both current and historical 
status. Current status entries must be relabeled to avoid confusion. 

16. Click Field Formatting. 

17. Select Status from the field list. 

18. Change the Column Header entry to Current Status . 

19. Select Status_Icon from the field list. 

20. Change the Column Header entry to Current S tatus . 

21. Click Execute SQL Query. 

Note: Column widths are adjustable. To change a column width, place your 
cursor on the column divider and drag it to a different position. 

22. Click Select Fields. 

23. Click the sort asterisk on the Status field line, and then select descending. 

24. Click Execute SQL Query to confirm your choice. 

25. Click Browse (...), and then select Add a new field. 

26. Click the Field asterisk, and then select Historical Response Time and 
Availability > Availability. 

27. Click the sort asterisk on the new line, and then select ascending. 

28. Click Execute SQL Query to view the report. 

29. Click Time Frame. 

30. Select Relative Time Frame, type 7 in the text field, and then select Days 

from the list. 

31. If you want to break down the report day-by-day, click Summarization and 
specify your choices. 

32. If you want to filter your report, click Filter Results and specify filter rules. 

33. Click File > Save to save your work. 
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Using Orion NPM Alerts 

An alert is a configurable response to the behavior of a monitored object. One of 
the many powerful features of Orion Network Performance Monitor is its ability to 
alert on almost every aspect of your network. You can trigger responses when an 
alert is generated and when it is resolved; you can create simple or complex 
conditions under which an alert is triggered or reset; you can suppress alerts 
when a set of simple or complex conditions exist; and you can create an 
escalation path that triggers when an alert remains unresolved. 

When monitoring your network, you can take advantage of Orion NPM alerts to 
draw attention to a number of issues, including the following: 

¶ Unexpected one-time or sustained high CPU load 

¶ Loss of available memory or insufficient hard drive space 

¶ Slow response time 

¶ Disproportionate interface utilization or excessive interface errors 

Both the triggering of an alert and the resetting of an alert can trigger a number of 
actions, including the actions listed in the following table. 

Note: Windows Server 2008 does not support Windows Net Messaging, so the 
Send a Windows Net message alert action is not available to Orion NPM 
installations on Windows Server 2008. 

Orion NPM Alert Actions 

Play a .wav sound Send an email or page Log alerts to the Windows Event Log 

Log alerts to a file Text-to-Speech output Log alerts to the Orion NPM Event Log 

Email a web page Send a Syslog message Send a Windows Net message 

Send SNMP traps Execute an external program Execute an external VB script 

Paging or SMS Get or Post a URL  

 

Configuring Orion NPM Alerts 

The following sections provide steps required to configure a few example alerts.  

High CPU Load Alert Example 

The following procedure creates a high CPU load alert. 

To configure a high CPU load alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts, and then click New on the Manage Alerts 
window. 
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3. Type CPU Load  High in the Name of Alert field on the General tab. 

4. Provide an alert description in the Enter a description for this Alert field. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab, and then select Node from the Type of 
Property to Monitor list. 

7. Click Add, and then select Simple Condition. 

8. Click is equal to, and then select greater or equal. 

9. Click the first *, and then click Network Nodes > Current CPU Memory > 
CPU Load. 

10. Click 0 after is greater than or equal to, and then type 80. 

11. Click the Reset Condition tab, and then select Reset this alert when the 
following conditions are met. 

Note: Configuring a reset condition ensures that stale alerts do not remain 
prominent in your alert log. 

12. Click Add, and then select Simple Condition. 

13. Click is equal to, and then select less or equal. 

14. Click the first *, and then click Network Nodes > Current CPU and 
Memory > CPU Load. 

15. Click 0 after is less than or equal to, and then type 70. 

16. Click the Trigger Actions tab, and then click Add New Action. 

17. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information, see ñAvailable Advanced Alert Actionsò in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

18. After completing the configuration of your selected alert action, click OK. 

19. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about alert actions, see ñAvailable Advanced 
Alert Actionsò in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

a. Click the Reset Actions tab. 

b. Click Add New Action. 

OrionNPMCoreAdministratorGuide.doc#AvailableAdvancedAlertActions


SolarWinds Orion Network Performance Monitor Ö Quick Start Guide 
 

 
Using Orion Network Performance Monitor Ö 73 

c. Select an action to execute when the alert is reset, and then click OK. 

d. Complete the displayed tabs as appropriate, and then click OK. 

20. Click OK when you are satisfied with the configuration of your alert. 

Sustained High CPU Load Alert Example 

The following procedure creates a sustained high CPU load alert. 

Note: This alert differs from the High CPU Load Alert created in the previous 
procedure in that the alert in this example procedure allows the triggering 
condition to persist for an hour before the trigger action fires. 

To configure a sustained high CPU load alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type CPU Load  Sustained  High in the Name of Alert field on the General 

tab. 

5. Provide an alert description in the Enter a description for this Alert field. 

6. Check Enable this Alert. 

7. Click the Trigger Condition tab, and then select Node from the Type of 
Property to Monitor list. 

8. Click Add, and then select Simple Condition. 

9. Click is equal to, and then select greater or equal. 

10. Click the first *, and then click Network Nodes > Current CPU and 
Memory > CPU Load. 

11. Click 0 after is greater than or equal to, and then type 80. 

12. At the bottom of the window, next to Do not trigger this action until 

condition exists for more than, type 1, and then select Hours. 

13. Click the Trigger Actions tab, and then click Add New Action. 

14. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see ñAvailable Advanced Alert 
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Actionsò in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

15. After completing the configuration of your selected alert action, click OK. 

16. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

Note: For more information, see ñAvailable Advanced Alert Actionsò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

17. Click OK when you are satisfied with the configuration of your alert. 

Sustained Loss of Available Memory Alert Example 

The following procedure creates a sustained loss of available memory alert. 

Note: This alert allows the low memory triggering condition to persist for 30 
minutes before the configured trigger action fires. 

To configure a loss of available memory alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts, and then click New on the Manage Alerts 
window. 

3. Type Memory Low  in the Name of Alert field on the General tab. 

4. Check Enable this Alert. 

5. Click the Trigger Condition tab, and then select Node from the Type of 
Property to Monitor list. 

6. Click Add, and then select Simple Condition. 

7. Click is equal to, and then select less or equal. 

8. Click the first *, and then click Network Nodes > Current CPU and 
Memory > Percent Memory Available. 

9. Click 0 after is less than or equal to, and then type 10. 

10. At the bottom of the window, next to Do not trigger this action until 

condition exists for more than, type 30, and then select Minutes. 

11. Click the Trigger Actions tab, and then click Add New Action. 
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12. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see ñAvailable Advanced Alert 
Actionsò in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

13. After completing the configuration of your selected alert action, click OK. 

14. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see ñAvailable 
Advanced Alert Actionsò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

15. Click OK when you are satisfied with the configuration of your alert. 

Insufficient Hard Drive Space Alert Example 

The following procedure creates a low hard drive space alert. 

To configure an insufficient hard drive space alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Disk Space Low  in the Name of Alert field on the General tab. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab, and then select Volume from the Type of 
Property to Monitor list. 

7. Click Add. 

8. Select Simple Condition. 

9. Click is equal to, and then select less or equal. 

10. Click the first *, and then click Volumes > Volume Status > Volume 
Percent Available. 
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11. Click 0 after is less than or equal to, and then type 5. 

12. Click the Trigger Actions tab, and then click Add New Action. 

13. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see ñAvailable Advanced Alert 
Actionsò in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

14. After completing the configuration of your selected alert action, click OK. 

15. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see ñAvailable 
Advanced Alert Actionsò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

a. Click the Reset Actions tab. 

b. Click Add New Action. 

c. Select an action to execute when the alert is reset, and then click OK. 

d. Complete the displayed tabs as appropriate. 

e. Click OK. 

16. Click OK when you are satisfied with the configuration of your alert. 

Sustained Slow Response Time Alert Example 

The following procedure creates a sustained slow response time alert. 

Note: This alert allows the slow response time triggering condition to persist for 
10 minutes before the configured trigger action fires. 

To configure a sustained slow response time alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Response Time Slow  in the Name of Alert field on the General tab. 

5. Check Enable this Alert. 
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6. Click the Trigger Condition tab. 

7. Select Node from the Type of Property to Monitor list. 

8. Click Add. 

9. Select Simple Condition. 

10. Click is equal to, and then select greater or equal. 

11. Click the first *, and then click Network Nodes > Current Response Time > 
Response Time. 

12. Click 0 after is greater than or equal to, and then type 150 . 

Note: Response time is measured in milliseconds. 

13. At the bottom of the window, next to Do not trigger this action until 

condition exists for more than, type 10, and then select Minutes. 

14. Click the Trigger Actions tab. 

15. Click Add New Action. 

16. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see ñAvailable Advanced Alert 
Actionsò in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

17. After completing the configuration of your selected alert action, click OK. 

18. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see ñAvailable 
Advanced Alert Actionsò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

19. Click OK when you are satisfied with the configuration of your alert. 
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Sustained Excessive Interface Utilization Alert Example 

The following procedure creates a sustained excessive interface utilization alert. 

Note: This alert allows the excessive interface utilization triggering condition to 
persist for 10 minutes before the configured trigger action fires. 

To configure an excessive interface utilization alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Interface Utilization (Excessi ve)  in the Name of Alert field on 

the General tab. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab. 

7. Select Interface from the Type of Property to Monitor list. 

8. Click Add, and then select Simple Condition. 

9. Click is equal to, and then select greater or equal. 

10. Click the first *, and then click Interfaces > Current Traffic > Average 
Xmit+Recv Percent Utilization. 

11. Click 0 after is greater than or equal to, and then type 80. 

12. At the bottom of the window, next to Do not trigger this action until 

condition exists for more than, type 10, and then select Minutes. 

13. Click the Trigger Actions tab. 

14. Click Add New Action. 

15. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information about available alert actions, see ñAvailable Advanced Alert 
Actionsò in the SolarWinds Orion Network Performance Monitor Administrator 
Guide. 

16. After completing the configuration of your selected alert action, click OK. 
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17. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see see ñAvailable 
Advanced Alert Actionsò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

18. Click OK when you are satisfied with the configuration of your alert. 

Interface Error Alert Example 

The following procedure creates an interface error alert. 

To configure an interface error alert: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Alert 
Manager. 

2. Click View > Configure Alerts. 

3. Click New on the Manage Alerts window. 

4. Type Interface Receive Errors (Excessive)  in the Name of Alert field 

on the General tab. 

5. Check Enable this Alert. 

6. Click the Trigger Condition tab, and then select Interface from the Type of 
Property to Monitor list. 

7. Click Add, and then select Simple Condition. 

8. Click is equal to, and then select greater or equal. 

9. Click the first *, and then click Interfaces > Errors and Discards > Recv 
Errors ï This Hour. 

10. Click 0 after is greater than or equal to, and then type 50. 

11. Click the Trigger Actions tab, and then click Add New Action. 

12. Select your preferred means of notification, click OK, and then complete the 
displayed tabs as appropriate. 

Note: As an example, select Send an Email/Page, and then specify the 
appropriate information on tabs of the Edit Email/Page Action window to 
receive an email whenever the High CPU Load alert is triggered. For more 
information, see ñAvailable Advanced Alert Actionsò in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 
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13. After completing the configuration of your selected alert action, click OK. 

14. If you want to specify an action to execute when this alert is reset, 
complete the following steps: 

Note: For more information about available alert actions, see ñAvailable 
Advanced Alert Actionsò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

a. Click the Reset Actions tab, and then click Add New Action. 

b. Select an action to execute when the alert is reset, and then click OK. 

c. Complete the displayed tabs as appropriate, and then click OK. 

15. Click OK when you are satisfied with the configuration of your alert. 

Viewing Alerts in the Orion Web Console 

Once you have configured alerts in Orion NPM, the Orion Web Console provides 
both an Alerts view and alerts resources that you can use to continuously monitor 
the status of your network and its devices. The following sections provide steps 
to use alerts for immediate notification of potential problems on your network. 

Using the Alerts View 

Orion provides the Alerts view on the Views toolbar, allowing you to quickly 
review all triggered alerts on your network. The following procedure configures 
the Alerts view to display the specific alerts you need to see at any time. 

To use the Alerts view to review network alerts: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the web console as an administrator, and then click Home > Alerts. 

3. Select Advanced from the Select an Alert Engine list. 

Note: The example alerts created in the ñUsing Orion NPM Alertsò section on 
page 71 are all advanced alerts. For more information about alerts in Orion 
NPM, see ñUsing Orion Advanced Alertsò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

4. If you want to limit the list of alerts to only those dealing with a single 
device, select the specific device from the Select a Network Device list. 

Note: This option is only available if alerts fire on multiple network devices. 

5. If you want to limit the list of alerts to only those dealing with a single 
type of device, select the type from the Select a Type of Device list. 

Note: This option is only available if Orion NPM is monitoring multiple types 
of network devices. 
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6. If you want to limit the list of alerts to only those of a single type, select 
the specific alert type from the Type of Alert list. 

Note: This option is only available if Orion NPM has fired multiple types of 
alerts. 

7. If you want to group the list of alerts by type or by device, select the 
appropriate grouping criterion (Type of Alert or Network Node) from the 
Group By list. 

8. Click Refresh to update the alerts list with your new settings. 

The Alerts view shows all alerts matching your provided criteria. For each alert, 
the Alerts view provides the time the alert was triggered, the network device and 
object that triggered the selected alert, the measure value that triggered the alert, 
and any message associated with the triggered alert. 

Adding the Active Alerts Resource to Orion Web Console Views 

Orion provides the Active Alerts resource for use in Orion Web Console views, 
allowing you to tailor your views of alerts to specific devices on your network. The 
following steps add the Active Alerts resource to Orion Web Console views. 

To add the Active Alerts resource to an Orion Web Console view: 

1. Log in to the Web Console as an administrator, and then click Settings in the 
top right of the web console. 

2. Click Manage Views in the Views grouping. 

3. Click the view to which you want to add the Active Alerts resource, and then 
click Edit. 

Note: The scope of an Active Alerts resource is limited by the scope of the 
view in which the Active Alerts resource displays. For example, if you add an 
Active Alerts resource to a Node Details view, the added Active Alerts 
resource only displays alerts relevant to the viewed node. In the same way, 
the Active Alerts resource in the Orion Summary Home view displays all 
active alerts on your entire network. 

4. Click + next to the view column in which you want to display the Active Alerts 
resource. 

5. Click + next to Alerts to expand the list of available alerts resources. 

6. Check All Triggered Alerts, and then click Submit. 
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Additional Orion NPM Features 

Orion NPM provides a number of additional tools and features that can enhance 
your ability to fully monitor the performance of your network. The following 
sections provide brief descriptions of these additional tools and features. 

Monitoring IPv4 and IPv6 Devices 

SolarWinds NPM can monitor devices configured with IPv4/IPv6 dual stacks. For 
more information about IPv4 and IPv6, see ñRFC 4213 - Basic Transition 
Mechanisms for IPv6 Hosts and Routersò. 

Note: CIDR notation is not currently supported for IPv6 addresses.  

Monitoring Fibre Channel Devices and VSANs 

Orion NPM specifically recognizes VSANs and Fibre Channel devices on your 
network when they are added to the Orion database as network objects for 
monitoring. For more information about the views and resources available in the 
Orion Web Console, see ñMonitoring Fibre Channel Devices and VSANsò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

Monitoring EnergyWise Devices 

SolarWinds has partnered with Cisco to present EnergyWise to optimize energy 
usage on your network. EnergyWise is a Cisco technology developed to help you 
cut enterprise energy costs, address environmental concerns, and adhere to 
government directives around green technologies. By deploying EnergyWise 
capable devices and by enabling their energy-saving features, you can run 
business-critical systems in a fully powered state while allowing less critical 
devices on Power over Ethernet (PoE) ports to power down or drop into standby 
during off-peak hours. Orion NPM provides the EnergyWise Summary view and 
related EnergyWise resources to help you monitor the energy expended on your 
network and the energy savings provided by EnergyWise-enabled devices. For 
more information about monitoring EnergyWise-enabled devices, see ñMonitoring 
EnergyWise Devicesò in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

Using Maps in Orion NPM 

Orion Network Atlas is a powerful tool for creating custom maps and network 
diagrams. The maps created in Orion Network Atlas enable users to view a 
graphical depiction of their network in the Orion Web Console. You can also use 
the maps to create network documentation, which can then be printed and 
exported as needed. Creating a map can be as simple as selecting a background 
image, dragging nodes to the image, and connecting them with a few lines. 
However, Network Atlas presents options enabling you to be as creative as you 
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like. For more information about creating network maps for use with Orion NPM, 
see the SolarWinds Orion Network Atlas Administrator Guide. 

Monitoring Wireless Networks 

Orion NPM can monitor any 802.11 IEEE-compliant autonomous access point 
(AP) or wireless controller. Details about your access points (AP), wireless 
clients, wireless controllers, thin APs, and rogue APs can all be monitored using 
Orion NPM. Wireless device monitoring is configured, customized, and managed 
using the Orion Web Console. For more information about monitoring wireless 
networks, see ñMonitoring Wireless Networksò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Monitoring VMware ESX Servers 

Orion NPM gives you the ability to monitor the performance of VMware ESX 
servers, including VMware ESXi servers, and the multiple virtual machines (VMs) 
hosted by ESX servers on your network. Available resources include lists of VMs 
on selected ESX servers, performance details for ESX servers and hosted VMs, 
and relevant alerts, charts and reports. For more information about monitoring 
VMware ESX Servers, see ñVirtualizationò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Using Custom Properties in Orion NPM 

Orion NPM provides the Custom Property Editor, allowing you to add custom 
properties to any interface, node, or volume. Custom properties are additional 
fields, such as country, asset tag, or serial number that you can define and store 
in your Orion Network Performance Monitor database. Once properties are 
added, they are available for display and filtering within the Orion Web Console 
and other Orion applications. For more information about custom properties, see 
ñCreating Custom Propertiesò in the SolarWinds Orion Network Performance 
Monitor Administrator Guide. 

Using Groups and Dependencies in Orion NPM 

Groups and dependencies enable you to more effectively manage your network. 
Groups give you the ability to logically organize monitored objects, regardless of 
device type or location, and dependencies allow you to more faithfully represent 
what can actually be known about your network, eliminating ñfalse positiveò alert 
triggers and providing more accurate insight into the status of your monitored 
network objects. For more information about groups and dependencies, see 
ñManaging Groups and Dependenciesò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 
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Using SNMP Traps in Orion NPM 

The Orion NPM Trap Viewer application is used in Orion NPM to configure alerts, 
view and search trap messages, and to apply rules to filter out certain types of 
messages. Because the SolarWinds Trap service has the ability to open multiple 
connections to the SQL server database, it can handle large quantities of 
incoming trap messages. For more information about using SNMP traps in Orion 
NPM, see ñMonitoring SNMP Trapsò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Using Syslog Messaging in Orion NPM 

The Orion Syslog Server allows the Network Performance Monitor to receive and 
process Syslog messages from any type of device. Syslog messages are 
realtime messages that network devices generate to notify about a specific event 
within the device. The Syslog Viewer is used to configure alerts, to view and 
search Syslog messages, and to apply rules to filter out certain types of 
messages. Because the Syslog service has the ability to open multiple 
connections to your SQL server, it can handle large numbers of simultaneously 
incoming Syslog messages. For more information about using Syslog messaging 
in Orion NPM, see ñMonitoring Syslog Messagesò in the SolarWinds Orion 
Network Performance Monitor Administrator Guide. 

Using Universal Device Pollers in Orion NPM 

Using Universal Device Pollers, Orion NPM has the ability to monitor more than 
just network status, availability, bandwidth, and errors. With Orion Universal 
Device Pollers, you can monitor virtually any statistic that your network devices 
can record. Orion Universal Device Pollers can both collect realtime statistics and 
record historical statistics. Additionally, with Universal Device Poller transforms, 
you can mathematically manipulate the results of multiple pollers to create your 
own network performance metrics. All network information collected from 
Universal Device Pollers is easily accessible within the Orion Web Console. For 
more information about using Universal Device Pollers in Orion NPM, see 
ñMonitoring MIBs with Universal Device Pollersò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

Viewing External Websites 

With the external website view feature, any Orion NPM administrator can make 
any website accessible as an Orion Web Console view. Designated external 
websites display as items in the Orion Web Console Views tool bar. For more 
information, see ñCreating and Editing External Website Viewsò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 
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Windows Management Instrumentation (WMI) 

Windows Management Instrumentation (WMI) is a proprietary technology used to 
poll performance and management information from Windows-based network 
devices, applications, and components. When used as an alternative to SNMP, 
WMI can provide much of the same monitoring and management data currently 
available with SNMP-based polling with the addition of Windows-specific 
communications and security features. 

Note: Due to specific characteristics of WMI polling requests, polling a single 
WMI-enabled object uses approximately five times the resources required to poll 
the same or similar object with SNMP on the same polling frequency.  

For more information about WMI, see the Microsoft article, ñAbout WMIò. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://msdn.microsoft.com/en-us/library/windows/desktop/aa384642(v=vs.85).aspx























