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About SolarWinds 

SolarWinds, Inc develops and markets an array of network management, monitoring, and 
discovery tools to meet the diverse requirements of todayôs network management and consulting 
professionals. SolarWinds products continue to set benchmarks for quality and performance and 
have positioned the company as the leader in network management and discovery technology. 
The SolarWinds customer base includes over 45 percent of the Fortune 500 and customers from 
over 90 countries. Our global business partner distributor network exceeds 100 distributors and 
resellers. 

Contacting SolarWinds 

You can contact SolarWinds in a number of ways, including the following: 

Team Contact Information 

Sales 

sales@solarwinds.com 
www.solarwinds.com 
1.866.530.8100 
+353.21.5002900 

Technical Support www.solarwinds.com/support/ 

User Forums www.thwack.com 

 

http://www.solarwinds.com/
http://www.solarwinds.com/support/
http://www.thwack.com/
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Conventions 

The documentation uses consistent conventions to help you identify items throughout the printed 
and online library. 

Convention Specifying 

Bold Window items, including buttons and fields. 

Italics Book and CD titles, variable names, new terms 

Fixed font  
File and directory names, commands and code 
examples, text typed by you 

Straight brackets, as in 
[value] 

Optional command parameters 

Curly braces, as in 
{value} 

Required command parameters 

Logical OR, as in 
value1|value2 

Exclusive command parameters where only one of the 
options can be specified 
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Chapter 1 

Introduction 

The SolarWinds Orion family of products delivers easy-to-use, scalable solutions 
to meet your network, systems, and storage monitoring and management needs. 
Built around the Orion Web Console, the Orion family of products can give you a 
comprehensive view of all aspects of your network from a single centralized 
location, while also offering the user flexibility and remote access abilities that are 
native to a web-based platform. SolarWinds users have also found that it does 
not take a team of consultants and months of unpleasant surprises to get a full 
Orion installation up and running because the overall Orion experience is far 
more intuitive than conventional, unnecessarily complex enterprise-level network, 
systems, and storage monitoring and management systems. 

What is SolarWinds Orion? 

The SolarWinds Orion family consists of the following network, systems, and 
storage monitoring and management products: 

Orion Network Performance Monitor 

Orion Network Performance Monitor (Orion NPM) makes it easy to quickly 
detect, diagnose, and resolve performance issues with your dynamic 
network. It delivers realtime views and dashboards enabling you to visually 
track network performance at a glance. Plus, with its new auto-updating 
network topology maps and automated network discovery features, you can 
keep up with your evolving network without breaking a sweat. And Orion 
NPM is the easiest product of its kind to use and maintain, meaning you will 
spend more time actually managing networks, and less time supporting your 
network manager. For more detailed information about Orion NPM, see the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

Orion Network Configuration Manager 

Monitoring a network is easy, but isolating problems is not. Fortunately, Orion 
Network Configuration Manager (Orion NCM) notifies you in realtime when 
device configurations change, helping you quickly determine which changes 
could potentially cause network issues. With Orion NCM, youôll never have to 
guess who changed what and when as you troubleshoot that infamous user 
complaint: `the Internet is down.ô You can also rest easy as you save time 
with features such as nightly config backups, bulk config changes, user 
tracking, and inventory and compliance reporting. For more information about 
Orion NCM, see the SolarWinds Orion Network Configuration Manager 
Administrator Guide. 
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Orion Application Performance Monitor 

Orion Application Performance Monitor (Orion APM) brings powerful 
monitoring, alerting, and reporting capabilities to applications and servers. 
Easily discover your applications and get the visibility you need into 
application performance and the underlying operating systems and servers 
they run on. For more detailed information about Orion APM, see the 
SolarWinds Orion Application Performance Monitor Administrator Guide. 

Orion NetFlow Traffic Analyzer 

Orion NetFlow Traffic Analyzer (Orion NTA) enables you to quantify exactly 
how your network is being used, by whom, and for what purpose. A new 
advanced application mapping feature correlates the traffic arriving from 
designated ports, source IPs, destination IPs, and even protocols, to 
application names you can easily recognize. Orion NTA makes it easy to get 
a comprehensive view of your network traffic, find the bottlenecks, and shut 
down the bandwidth hogs. For more information about Orion NTA, see the 
SolarWinds Orion NetFlow Traffic Analyzer Administrator Guide. 

Orion IP Address Manager 

Orion IP Address Manager (Orion IPAM) is a powerful, scalable IP address 
management module that enables you and your team to quickly create, 
schedule, and share IP space reports. With either Orion NPM or Orion APM, 
Orion IPAM provides affordable IP address management that is unified with 
performance monitoring data for a comprehensive view of network health. 
For more detailed information about Orion IPAM, see the SolarWinds Orion 
IP Address Manager Administrator Guide. 

Orion IP SLA Manager 

Orion IP SLA Manager delivers a powerful network monitoring solution for 
identifying site-specific and WAN-related performance issues from the 
perspective of each of your remote sites. With this Orion module, you can 
use Cisco IP SLA technology with automatic IP SLA setup to quickly begin 
monitoring your key WAN performance metrics, including Cisco VoIP jitter 
and MOS. For more information about Orion IP SLA Manager, see the 
SolarWinds Orion IP SLA Manager Administrator Guide. 

Orion Scalability Engines 

Orion Scalability Engines allow you to scale the monitoring and management 
capabilities of your primary Orion installation as your enterprise network 
expands and your network management needs change. Distribute polling 
across multiple servers with Additional Polling Engines, protect against 
monitoring outages with the Orion Failover Engine, and enable more users to 
access the Orion Web Console with Orion Additional Web Servers. For more 
information, see ñOrion Scalability Enginesò on page 251. 
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Orion Enterprise Operations Console 

With Orion Enterprise Operations Console (Orion EOC), remotely monitoring 
critical network infrstructure in multiple different physical locations is as easy 
and affordable as managing a router in the next room. Orion EOC provides a 
consolidated command center to monitor your entire enterprise network and 
gives you unified visibility into remote Orion servers running either Orion 
NPM or Orion APM and associated Orion modules. For more information 
about Orion EOC, see the SolarWinds Orion Enterprise Operations Console 
Administrator Guide. 

Benefits of Orion Products 

Consider the following benefits of SolarWinds Orion network, systems, and 
storage monitoring and management products: 

Out-of-the-box Productivity 

Automatic discovery and wizard-driven configuration offer an immediate 
return on your investment. Within minutes of installation, you can be 
monitoring your critical network elements and applications. 

Easy to Understand and Use 

Orion is designed for daily use by staff that also have other responsibilities. 
The Orion Web Console provides what you need where you expect to find it 
and offers advanced capabilities with minimal configuration overhead. 

Affordable Value 

While Orion provides functionality that is comparable, if not superior, to most 
other solutions, the cost and maintenance of your Orion installation is less 
than the initial cost of most other network and systems monitoring solutions. 

Scalability 

By adding individual polling engines, you can scale your Orion installation to 
any environment size. By sharing the same database, you can also share a 
unified user interface, making the addition of polling engines transparent to 
your staff. 

thwack.com Online Community 

thwack.com is a community site that SolarWinds developed to provide 
SolarWinds users and the broader networking community with useful 
information, tools and valuable resources related to SolarWinds network 
management solutions. Resources that allow you both to see recent posts 
and to search all posts are available from the Orion Web Console, providing 
direct access to the thwack.com community. 
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Key Features of Orion Monitoring Products 

Considering the previously listed benefits of Orion and the following features, 
Orion is a simple choice to make for monitoring your network. 

Customizable and Flexible Orion Web Console 

You can easily customize the web console to meet your individual needs. If 
you want to segregate use, you can custom design views of your data and 
assign them to individual users. You can also create web console accounts 
for departments, geographic areas, or any other user-defined criteria. 

Automatic and Scheduled Device Discovery 

Wizard-driven device discovery further simplifies the addition of devices to 
Orion for monitoring. Answer a few general questions about your devices, 
and the discovery application takes over, populating your Orion database 
and immediately beginning network analysis. You can also create network 
discovery schedules to independently and automatically run Network Sonar 
Discovery jobs whenever you need them. 

Open Integration 

Enterprise-tested standards, including a Microsoft® SQL Server database 
and industry-standard MIBs and protocols, are the backbone of the Orion 
monitoring solution. 

Network Atlas with ConnectNow 

Network Atlas, the Orion network mapping application, gives you the ability to 
create multi-layered, fully customizable, web-based maps of your network to 
visually track the performance of any device in any location across your 
network in real time. The ConnectNow feature automatically draws links 
between directly-connected physical nodes discovered on your network. 

Unpluggable Port Mode 

Orion enables you to designate selected ports as unpluggable, so 
unnecessary alerts are not triggered when users undock or shutdown 
connected devices. This feature is particularly useful for distinguishing low 
priority ports connected to laptops and PCs from more critically important 
infrastructure ports. 

Data Center Monitoring 

Orion offers predefined reports and web console views and resources 
specifically tailored to provide performance data about Cisco Unified 
Computing Systems (UCS) and Fiber Channel devices manufactured by 
Cisco MDS, Brocade, and McData. 
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 VMware Infrastructure Monitoring 

Orion NPM enables you to monitor your VMware servers, datacenters, and 
clusters, including VMware ESX and ESXi, Virtual Center, and any virtual 
machines (VMs) hosted by ESX servers on your network. Available 
resources include lists of VMs on selected ESXi and ESX servers, 
performance details for ESXi and ESX servers and hosted VMs, and relevant 
charts and reports. 

Groups and Dependencies 

Groups give you the ability to logically organize monitored objects, 
regardless of device type or location, and dependencies allow you to more 
faithfully represent what can actually be known about your network, 
eliminating ñfalse positiveò alert triggers and providing more accurate insight 
into the status of monitored network objects. 

Incident Alerting 

You can configure custom alerts to respond to hundreds of possible network 
scenarios, including multiple condition checks. Orion alerts help you 
recognize issues before your network users experience productivity hits. 
Alert delivery methods and responses include email, paging, SNMP traps, 
text-to-speech, Syslog messaging, and external application execution. 

Integrated Syslog Servers 

Save time when investigating network issues by using Syslog messages to 
access network information from a single Orion server instead of polling 
multiple machines independently. Use Orion to easily set up alerts and then 
receive, process, forward, and send Syslog messages. 

Detailed Historical Reports 

Easily configure reports of data from the Orion database over custom time 
periods. Data is presented in an easily reviewed format in the web console or 
in the Orion Report Writer application. With over 40 built-in reports available, 
you can project future trends and capacity needs, and immediately access 
availability, performance, and utilization statistics. You can also download 
new reports for import into Report Writer from www.thwack.com. 

Product Update Notifications 

Receive regular, automatic notification of updates to your installed Orion 
monitoring and management applications in the Orion Web Console as soon 
as they are available from SolarWinds. Product updates can include upgrade 
opportunities, service packs, and hotfixes. 
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Orion Product Team Blog 

Stay in touch with the people who bring you the products in the Orion family 
by following the Orion Product Team Blog on thwack, the SolarWinds online 
user community. Read posts from Orion product managers and developers 
to learn how to extend and optimize your Orion installation to best meet the 
needs of your network. 

Extensible Orion Modules 

The Orion product family provides solutions for all your network monitoring 
and management needs. With either Application Performance Monitor or 
Network Performance Monitor as a base, Orion products, including NetFlow 
Traffic Analyzer, IP SLA Manager (formerly VoIP Monitor), IP Address 
Manager, and the Network Configuration Manager integration, give you the 
ability to monitor network applications, analyze network traffic, monitor VoIP 
and WAN traffic using Cisco IP SLA, manage IP address and subnet 
allocations, and manage network device configurations, respectively, from a 
single location: your Orion Web Console.  

Networking Concepts and Terminology 

The following sections define the networking concepts and terminology that are 
used within Orion. 

¶ Internet Control Message Protocol (ICMP) 

¶ Simple Network Management Protocol (SNMP) 

¶ SNMP Credentials 

¶ Management Information Base (MIB) 

Internet Control Message Protocol (ICMP) 

Orion uses theICMP to poll for status using ping  and echo  requests of managed 

devices. When Orion polls a managed device using ICMP, if the device is 
operationally up, it returns a response time and record of any dropped packets. 
This information is used by Orion to monitor status and measure average 
response time and packet loss percentage for managed devices. 

Note: Orion only uses ICMP to poll devices for status, average response time, 
and packet loss percentage. Other information displayed in the Orion Web 
Console is obtained using SNMP requests. 

Simple Network Management Protocol (SNMP) 

For most network monitoring and management tasks, Orion products use SNMP. 
SNMP-enabled network devices, including routers, switches, and PCs, host 
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SNMP agents that maintain a virtual database of system status and performance 
information that is tied to specific Object Identifiers (OIDs). This virtual database 
is referred to as a Management Information Base (MIB), and Orion uses MIB 
OIDs as references to retrieve specific data about a selected, SNMP-enabled, 
managed device. Access to MIB data may be secured either with SNMP 
Community Strings, as provided with SNMPv1 and SNMPv2c, or with optional 
SNMP credentials, as provided with SNMPv3. For more information about MIBs, 
see ñManagement Information Base (MIB)ò on page 8. For more information 
about SNMP credentials, see ñSNMP Credentialsò on page 7. 

Notes: 

¶ To properly monitor devices on your network, you must enable SNMP on all 
devices that are capable of SNMP communications. The steps to enable 
SNMP differ by device, so you may need to consult the documentation 
provided by your device vendor. 

¶ If SNMPv2c is enabled on a device you want Orion to monitor, by default, 
Orion will attempt to use SNMPv2c to poll the device for performance 
information. If you only want Orion to poll using SNMPv1, you must disable 
SNMPv2c on the device to be polled. 

SNMP Credentials 

SNMP credentials secure access to SNMP-enabled managed devices. SNMPv1 
and SNMPv2c credentials serve as a type of password that is authenticated by 
confirming a match between a cleartext SNMP Community String provided by an 
SNMP request and the SNMP Community String stored as a MIB object on an 
SNMP-enabled, managed device. SNMPv3 provides a more secure interaction 
by employing the following fields: 

¶ The User Name is a required cleartext string that indentifies the agent or poll 
request that is attempting to access an SNMP-enabled device. User Name 
functions similarly to the SNMP Community String of SNMP v1 and v2c. 

¶ The Context is an optional identifying field that can provide an additional 
layer of organization and security to the information available in the MIB of an 
SNMP-enabled device. Typically, the context is an empty string unless it is 
specifically configured on an SNMP-enabled device. 

¶ SNMPv3 provides two optional Authentication Methods: Message Digest 5 
(MD5) and Secure Hash Algorithm 1 (SHA1). Both methods, MD5 and SHA1, 
include the Authentication Key with the SNMPv3 packet and then generate 
a digest of an entire SNMPv3 packet that is then sent. MD5 digests are 20 
bytes long, and SHA1 digests are 16 bytes long. When the packet is 
received, the User Name is used to recreate a packet digest using the 
appropriate method. Both digests are then compared to authenticate.  
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¶ SNMPv3 also provides two optional Privacy/Encryption Methods: Data 
Encryption Standard (DES56) and Advanced Encryption Standard (AES128) 
using a 128 bit key. DES56 uses a 56 bit key with a 56 bit salt, and AES128 
uses a 128 bit key with a 128 bit salt to encrypt the full SNMP v3 packet. 

Management Information Base (MIB) 

A Management Information Base (MIB) is the formal description of a set of 
objects that can be managed using SNMP. MIB-I refers to the initial MIB 
definition, and MIB-II refers to the current definition. Each MIB object stores a 
value such as sysUpTime , bandwidth utilization , or sysContact  that can be 

polled to provide current performance data for any selected device. For example, 
when polling your network for performance data, Orion Network Performance 

Monitor sends an SNMP GET request to each network device to poll the specified 

MIB objects. Received responses are then recorded in the Orion database for 
use in Orion products, including within Orion Web Console resources. 

Most network devices can support several different types of MIBs. While most 
devices support the standard MIB-II MIBs, they may also support any of a 
number of additional MIBs that you may want to monitor. Using a fully 
customizable Orion Universal Device Poller, you can gather information from 
virtually any MIB on any network device to which you have access. 

How Orion Works 

Using ICMP and SNMP polling, trap receiving, and Syslog communication and 
data collection, installed Orion products can continuously monitor the health and 
performance of all aspects your network. This monitoring is accomplished without 
interfering with the critical functions of your network devices. Unlike many other 
network monitoring products, Orion helps you maintain the overall performance 
of your network in the following ways: 

¶ Orion products do not install outside agents on your mission-critical servers 

¶ Orion products do not employ services that take vital resources from critical 
applications 

¶ Orion products do not install any code on monitored network devices as 
unmanaged or outdated  code can open security holes in your network. 

After installing Orion, you can automate the initial discovery of your network, and 
then simply add new devices for monitoring as you add them to your network. 
Orion stores all gathered information in a SQL database and provides the highly 
customizable web console in which to view current and historical network status. 
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Chapter 2 

Preparing a SolarWinds Orion Installation 

Orion products use a simple wizard to direct the installation process. For an 
enterprise-class product, installation requirements are nominal. 

Note: Downgrades of Orion products are not supported. If you are upgrading or 
installing multiple Orion products, confirm that you are installing them in the order 
given in the Upgrade Instructions located in your SolarWinds Customer Portal. 

Orion Requirements 

Your Orion product and your Orion database should use separate servers. 
Multiple Orion server installations using the same database are not supported. 
The following sections provide specific requirements: 

¶ Orion Server Hardware Requirements 

¶ Orion Server Software Requirements 

¶ Requirements for Virtual Machines and Servers 

¶ Requirements for the Orion Database Server (SQL Server) 

¶ Additional Required Components 

Orion Server Hardware Requirements 

The following table lists minimum hardware requirements and recommendations 
for your Orion server. 

Note: Hardware requirements are listed by Orion NPM license level. 

Hardware SL100, SL250, or SL500 SL2000 SLX 

CPU Speed 

2.0 GHz 2.4 GHz 3.0 GHz 

Note: Dual processor, dual core is recommended. Physical Address 
Extension (PAE) should not be enabled. 

Hard Drive 
Space 

2.5 GB 5 GB 20 GB 

Note: A RAID 1 drive for server operating system, Orion installation,  and 
tempdb files is recommended. Orion requires at least 1.5GB for job engine, 
information service, collector service, MIB database and other required files. 
The Orion installer needs 1GB on the drive where temporary Windows system 
or user variables are stored. Per Windows standards, some common files may 
need to be installed on the same drive as your server operating system. For 
more information, see ñWorking with Temporary Directoriesò on page 294. 

Memory 3 GB 4 GB 4 GB 

http://www.solarwinds.com/customerportal/
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Orion Server Software Requirements 

The following table lists minimum software requirements and recommendations. 

Software Requirements 

Operating 
System 

Windows Server 2003 SP2 or 2008, including R2, with IIS in 32-bit mode. 
IIS and MSMQ must be installed. SolarWinds recommends that Orion 
administrators have local administrator privileges to ensure full functionality 
of local Orion tools. Accounts limited to use of the Orion Web Console do not 
require administrator privileges. 
Notes: 

¶ SolarWinds does not support production installations of Orion products on 
Windows XP, Windows Vista, or Windows 7 systems. 

¶ Orion APM installations on Windows Server 2008 require R2. For more 
information, see ñAdditional APM Requirementsò in the SolarWinds Orion 
Application Performance Monitor Administrator Guide. 

Application 
Ports 

161, 162, 443 (SNMP). VMware ESX/ESXi Servers are polled on 443. 
17777 (TCP) open for Orion module traffic 
17778 (HTTPS) open to access the SolarWinds Information Service API 
17779 (HTTP and HTTPS) for the SolarWinds Toolset Integration  

Web Server 

Microsoft IIS, version 6.0 and higher, in 32-bit mode. 
DNS specifications require that hostnames be composed of alphanumeric 

characters (A- Z, 0- 9), the minus sign (- ), and periods (. ). Underscore 

characters (_) are not allowed. For more information, see RFC 952. 

Note: SolarWinds neither recommends nor supports the installation of any 
Orion product on the same server or using the same database server as a 
Research in Motion (RIM) Blackberry server. 

.NET 
Framework 

Version 3.5. .NET Framework 3.5 SP1 is recommended. 

SNMP Trap 
Services 

Windows operating system management and monitoring tools component 

Web Console 
Browser 

Microsoft Internet Explorer version 6 or higher with Active scripting 
Firefox 3.0 or higher (Toolset Integration is not supported on Firefox) 

Requirements for Virtual Machines and Servers 

Orion installations on VMware Virtual Machines and Microsoft Virtual Servers are 
fully supported if the following minimum configuration requirements are met for 
each virtual machine. 

Note: SolarWinds strongly recommends that you maintain your SQL Server 
database on a separate physical server. 

VM Configuration 
Orion Requirements by License Level 

SL100, SL250, or SL500 SL2000 SLX 

CPU Speed 2.0 GHz 2.4 GHz 3.0 GHz 

Allocated 
Hard Drive Space 

2GB 5GB 20GB 

Note: Due to intense I/O requirements, SQL Server should be 
hosted on a separate physical server configured as RAID 1+0. RAID 
5 is not recommended for the SQL Server hard drive. 
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VM Configuration Orion Requirements by License Level 

Memory 3 GB 4 GB 4 GB 

Network Interface 

Each virtual machine on which Orion is installed should have its 
own, dedicated network interface card.  
Note: Since Orion uses SNMP to monitor your network, if you are 
unable to dedicate a network interface card to your Orion server, 
you may experience gaps in monitoring data due to the low priority 
generally assigned to SNMP traffic. 

 

Requirements for the Orion Database Server (SQL Server) 

The following table lists software and hardware requirements for your Orion 
database server. Orion NPM license levels are provided as a reference. 

Requirements SL100, SL250, or SL500 SL2000 SLX 

SQL Server 

SQL Server 2005 SP1 Express, Standard, or Enterprise 
SQL Server 2008, including R2, Express, Standard, or Enterprise 
Notes: 

¶ SQL Server Compact 3.5 SP1 is only supported for Orion evaluations. 

¶ Due to latency effects, SolarWinds does not recommend installing your 
SQL Server and your Orion server or additional polling engine in 
different locations across a WAN. For more information, see 
SolarWinds Knowledge Base article, ñCan I install my Orion server or 
Additional Polling Engine and my Orion database (SQL Server) in 
different locations across a WAN?ò 

¶ Either mixed-mode or SQL authentication must be supported. 

¶ If you are managing your Orion database, SolarWinds recommends you 
install the SQL Server Management Studio component. 

¶ If your Orion product installs SQL Server System CLR Types, a manual 
restart of the SQL Server service for your Orion database is required. 

¶ Use the following database select statement to check your SQL Server 
version, service pack or release level, and edition: 

select SERVERPROPERTY ('productversion'), 

SERVERPROPERTY ('productlevel'), SERVERPROPERTY 

('edition' )  

CPU Speed 2.0 GHz 2.4 GHz 3.0 GHz 

Hard Drive 
Space 

2 GB 5 GB 20 GB 

Note: Due to intense I/O requirements, a RAID 1+0 drive is strongly 
recommended the SQL Server database and Orion data and log files. 
RAID 5 is not recommended for the SQL Server hard drive. The Orion 
installer needs at least 1GB on the drive where temporary Windows 
system or user variables are stored. Per Windows standards, some 
common files may need to be installed on drive as your server operating 
system. For more information, see ñWorking with Temporary Directoriesò 
on page 294. 

Memory 

2 GB 3 GB 4 GB 

Note: SolarWinds recommends additional RAM, up to 8 GB, for Orion 
APM installations including more than 1000 monitors. 

.NET 
Framework 

Version 3.5. .NET Framework 3.5 SP1 is recommended. 

http://knowledgebase.solarwinds.com/kb/questions/1809/Can+I+install+my+Orion+server+or+Additional+Polling+Engine+and+my+Orion+database+%28SQL+Server%29+in+different+locations+across+a+WAN%3F
http://knowledgebase.solarwinds.com/kb/questions/1809/Can+I+install+my+Orion+server+or+Additional+Polling+Engine+and+my+Orion+database+%28SQL+Server%29+in+different+locations+across+a+WAN%3F
http://knowledgebase.solarwinds.com/kb/questions/1809/Can+I+install+my+Orion+server+or+Additional+Polling+Engine+and+my+Orion+database+%28SQL+Server%29+in+different+locations+across+a+WAN%3F
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Additional Required Components 

The Orion Installation Wizard installs the following required x86 components if 
they are not found on your Orion database server: 

¶ SQL Server System Common Language Runtime (CLR) Types. Orion 
products use secure SQL CLR stored procedures for selected, non-business 
data operations to improve overall performance. 

¶ Microsoft SQL Server Native Client 

¶ Microsoft SQL Server Management Objects 

Orion Licensing 

Products in the Orion family are licensed additively, in terms of monitored 
network objects. So, for example, if you have purchased both Orion NPM with an 
SL100 license and Orion APM with an AL50 license you will be able to monitor 
performance of both interfaces and applications on a total of 150 unique nodes. 
For more information, see the Administrator Guide of your specific Orion product. 

Maintaining Licenses with License Manager 

SolarWinds License Manager is an easily installed, free utility that gives you the 
ability to migrate Orion licenses from one computer to another without contacting 
SolarWinds Customer Service. The following sections provide procedures for 
installing and using License Manager. 

Installing License Manager 

Install License Manager on the computer from which you are migrating currently 
licensed products. 

Note: You must install License Manager on a computer with the correct time. If 
the time on the computer is even slightly off, in either direction, from Greenwich 
Mean Time (GMT), you cannot reset licenses without contacting SolarWinds 
Customer Service. Time zone settings neither affect nor cause this issue. 

To install License Manager: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager 
Setup. 

2. Click I Accept to accept the SolarWinds EULA. 

3. If you are prompted to install the SolarWinds License Manager 
application, click Install. 
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Using License Manager 

You must run License Manager on the computer where the currently licensed 
SolarWinds product is installed before you can migrate licenses to a new 
installation. The following procedure deactivates currently installed licenses that 
can then be transferred to a new installation. 

To deactivate currently installed licenses: 

1. Click Start > All Programs > SolarWinds > SolarWinds License Manager. 

2. Check the products you want to deactivate on this computer, and then click 
Deactivate. 

3. Specify your SolarWinds Customer ID and password when prompted, and 
then click Deactivate. 

Note: Deactivated licenses are now available to activate on a new computer. 

When you have successfully deactivated your products, log on to the computer 
on which you want to install your products, and then begin installation. When 
asked to specify your licenses, provide the appropriate information. The license 
you deactivated earlier is then assigned to the new installation. 

Enabling Secure Channels with SSL  

Orion supports the use of Secure Sockets Layer certificates to enable secure 
communications with the Orion Web Console. The following sections provide 
procedures for enabling SSL connections to the Orion Web Console: 

¶ Enabling SSL Connections on Windows Server 2003 

¶ Enabling SSL Connections on Windows Server 2008 

Enabling SSL Connections on Windows Server 2003 

The following procedure enables SSL connections to an Orion Web Console 
installed on Windows Server 2003. 

Notes: 

¶ Secure SSL communications are conducted over port 443. 

¶ The following procedure does not describe the processes either of obtaining 
a required certificate or of generating a certificate signing request for a third-
party certificate authority. Your Orion server must already have the required 
SSL certificate installed. For more information, see the article from which the 
following procedure was adapted at http://support.microsoft.com/kb/298805. 

http://support.microsoft.com/kb/298805
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To enable SSL connections to the web console on Windows Server 2003: 

1. Log on to your Orion server using an account with administrative privileges. 

2. Click Start > Control Panel > Administrative Tools > Computer 
Management. 

3. Expand Services and Applications > Internet Information Services (IIS) 
Manager > Web Sites. 

4. Click SolarWinds NetPerfMon, and then click Action > Properties. 

5. Open the Web Site tab, confirm that SSL port is set to 443 , and then click 

Apply. 

6. Click Advanced. 

7. If the Multiple SSL identities for this Web site field does not list the IP 
address for the Orion Web Console with SSL port 443, complete the 
following steps. 

a. Click Add, and then select the IP address of the Orion Web Console. 

Note: As it was set initially in the Configuration Wizard, this option is 
usually set to (All Unassigned). If the IP address of the Orion Web 
Console was not initially set to (All Unassigned), select the actual, 
configured IP address of the Orion Web Console. 

b. Type 443  as the TCP port, and then click OK. 

8. Click the Directory Security tab. 

9. Click Edit in the Secure communications section. 

10. Check Require secure channel (SSL). 

11. Select Accept client certificates in the Client certificates area. 

12. Click OK on the Secure Communications window. 

13. Click Apply, and then click OK to exit. 

Enabling SSL Connections on Windows Server 2008 

The following procedure enables SSL connections to an Orion Web Console 
installed on Windows Server 2008. 

Note: Secure SSL communications are conducted over port 443. 

To enable SSL connections to the web console on Windows Server 2008: 

1. Log on to your Orion server using an account with administrative privileges. 

2. Click Start > Administrative Tools > Internet Information Services (IIS) 
Manager. 
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3. In the Connections pane, expand the name of your Orion server, and then 
expand Sites. 

4. Click SolarWinds NetPerfMon, and then click Bindings in the Actions pane 
on the right. 

5. Click Add in the Site Bindings window. 

6. In the Type: field, select https, and then confirm that Port is set to 443 . 

7. In the SSL Certificate field, select a certificate, and then click OK. 

8. Click Close on the Site Bindings window. 

9. In the IIS group, click SSL Settings. 

10. Check Require SSL, and then click Apply in the Actions group on the right. 

11. In the Connections pane, click SolarWinds NetPerfMon. 

12. Click Restart in the Manage Web Site group on the right. 

Configuring the Orion Web Console for SSL 

The following procedure enables Secure Sockets Layer (SSL) security (https) for 
the Orion Web Console. 

To enable SSL for the Orion Web Console: 

1. Log on to your Orion server using an account with administrative rights. 

2. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Orion Service Manager. 

3. Click Shutdown Everything. 

Note: It may take a few minutes to stop all services. 

4. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

5. If your Orion database is not listed in the left pane, complete the 
following steps: 

a. Click Add SQL Server. 

b. Using the format Server /Instance , select or provide the SQL Server 

instance you are using as your Orion database. 

c. Select the appropriate login method, providing credentials as required, 
and then click Connect to Database Server. 

6. Expand your Orion database in the left pane. 

7. Right-click the Websites table, and then click Query Table. 
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8. Replace the default query with the following query: 

UPDATE dbo.Websites  

SET SSLEnabled= 1 

WHERE WebsiteID=1  

9. Click Refresh. 

10. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Orion Service Manager. 

11. Click Start Everything. 

Note: It may take a few minutes to restart all services. 

12. If you want to use a designated SSL port, such as the default https port 
443, for the web console, complete the following procedure to change the 
web console port: 

a. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Configuration Wizard. 

b. Check Website, and then click Next on the Welcome window. 

c. Enter the designated SSL port number in the Port field, and then click 
Next. 

Note: Port 443 is typically reserved for SSL traffic. 

d. Review the configuration summary, and then click Next. 

e. Click Finish when the Configuration Wizard completes. 

Antivirus Directory Exclusions 

To ensure that all Orion products have access to all required files, the following 
directories, listed by operating system, should be excluded from antivirus 
protection: 

Notes: 

¶ Do not exclude executable files. 

¶ C: \  is the default install volume. 

Windows Server 2003 and Windows XP: 

¶ C:\Documents and Settings\All Users\Application Data\SolarWinds\ 

Windows Server 2007, Windows Vista, and Windows 2008 

¶ C:\ProgramData\SolarWinds\ 
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Chapter 3 

Discovering and Adding Network Devices 

There are two waysðWeb Node Management and network discovery using the 
Network Sonar Wizardðto add nodes to the Orion database, The method 
recommended largely depends on the number of devices added. To discover and 
add a larger number of devices across your enterprise, the Network Sonar and 
Network Sonar Results Wizards are available. This chapter provides instructions 
for quickly populating your Orion database with the network objects you want to 
monitor and manage with Orion. The Orion Web Console also provides an easy-
to-use Web Node Management wizard suited to discovering and adding 
individual network objects. For more information, see ñManaging Devices in the 
Web Consoleò on page 75. 

Network Discovery Using the Network Sonar Wizard 

Orion products employ the easy-to-use Network Sonar Wizard to direct you in the 
discovery of devices on your network. Before using the Network Sonar Wizard, 
consider the following points about network discovery in Orion: 

¶ The Network Sonar Wizard recognizes network devices that are already in 
your Orion database and prevents you from importing duplicate devices.  

¶ CPU and Memory Utilization charts are automatically enabled for your 
Windows, Cisco Systems, VMware, and Foundry Networks devices. 

¶ The community strings you provide in the Network Sonar Wizard are only 
used for SNMP GET requests, so read-only strings are sufficient. 

The following procedure steps you through the discovery of devices on your 
network using the Network Sonar Wizard. 

To discover devices on your network: 

1. If the Network Sonar Wizard is not already open, click Start > All 
Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Network Discovery. 

2. If you want to create a new discovery, click Add New Discovery, click 
Add New Discovery.  

3. If you have already defined a network discovery, a number of options are 
available on the Network Sonar Discovery tab. Select one of the following: 

¶ If you want to edit an existing discovery before using it, select the 
discovery you want to edit, and then click Edit. 
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¶ If you want to use an existing discovery to rediscover your network, 
select the discovery you want to use, click Discover Now, and then 
complete the Network Sonar Results Wizard after dicovery completes. 
For more information about network discovery results, see ñUsing the 
Network Sonar Results Wizardò on page 22. 

¶ If you want to import some or all devices found in a defined 
discovery that you may not have already imported for monitoring, 
select a currently defined discovery, and then click Import All Results. 
For more information about network discovery results, see ñUsing the 
Network Sonar Results Wizardò on page 22. 

¶ If you want to import any newly enabled devices matching a defined 
discovery profile, select a currently defined discovery, and then click 
Import New Results. For more information about network discovery 
results, see ñUsing the Network Sonar Results Wizardò on page 22. 

¶ If you want to delete an existing discovery profile, select a currently 
defined discovery and then click Delete. 

4. If the devices on your network do not require community strings other 

than the default strings public  and private  provided by Orion, click 

Next on the SNMP Credentials view. 

5. If any of your network devices require community strings other than 

public  and private  or if you want to use an SNMPv3 credential, 

complete the following steps to add the required SNMP credential. 

Note: Repeat the following procedure for each new community string. To 
speed up discovery, highlight the most commonly used community strings on 
your network, and then use the arrows to move them to the top of the list.  

a. Click Add New Credential, and then select the SNMP Version of your 
new credential. 

b. If you are adding an SNMPv1 or SNMPv2c credential, provide the 
new SNMP Community String. 

c. If you are adding an SNMPv3 credential, provide the following 
information for the new credential: 

¶ User Name, Context, and Authentication Method 

¶ Authentication Password/Key, Privacy/Encryption Method and 
Password/Key, if required. 

d. Click Add. 

6. Click Next on the SNMP Credentials view. 
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7. If you want to discover any VMware VCenter or ESX Servers on your 
network, confirm that Poll for VMware is checked, and then complete the 
following steps to add or edit required VMware credentials. 

Note: Repeat the following procedure for each new credential. To speed up 
discovery, use the arrows to move the most commonly used credentials on 
your network to the top of the list. 

a. Click Add vCenter or ESX Credential. 

b. If you are using an existing VMware credential, select the appropriate 
credential from the Choose Credential dropdown menu. 

c. If you are adding a new VMware credential, select <New Credential> 
in the Choose Credential dropdown menu, and then provide a new 
credential name in the Credential Name field. 

Note: SolarWinds recommends against using non-alphanumeric 
characters in VMware credential names. 

d. Add or edit the credential User Name and Password, as necessary. 

e. Confirm the password, and then click Add. 

8. Click Next on the Local vCenter or ESX Credentials for VMware view. 

9. If you want to discover devices located on your network within a 
specific range of IP addresses, complete the following procedure. 

Note: Only one selection method may be used per defined discovery.  

a. Click IP Ranges in the Selection Method menu, and then, for each IP 
range, provide both a Start address and an End address. 

Note: Scheduled discovery profiles should not use IP address ranges 
that include nodes with dynamically assigned IP addresses (DHCP). 

b. If you want to add another range, click Add More, and then repeat the 
previous step. 

Note: If you have multiple ranges, click X to delete an incorrect range. 

c. If you have added all the IP ranges you want to poll, click Next. 

10. If you want to discover devices connected to a specific router or on a 
specific subnet of your network, complete the following procedure: 

Note: Only one selection method may be used per defined discovery.  

a. Click Subnets in the Selection Method menu. 

b. If you want to discover on a specific subnet, click Add a New 
Subnet, provide both a Subnet Address and a Subnet Mask for the 
desired subnet, and then click Add. 

Note: Repeat this step for each additional subnet you want to poll. 
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c. If you want to discover devices using a seed router, click Add a 
Seed Router, provide the IP address of the Router, and then click Add. 

Notes: 

¶ Repeat this step for each additional seed router you want to use. 

¶ Network Sonar reads the routing table of the designated router and 
offers to discover nodes on the Class A network (255.0.0.0 mask) 
containing the seed router and, if you are discovering devices for an 
Orion NPM installation, the Class C networks (255.255.255.0 mask) 
containing all interfaces on the seed router, using the SNMP version 
chosen previously on the SNMP Credentials page. 

¶ Networks connected through the seed router are NOT automatically 
selected for discovery. 

d. Confirm that all networks on which you want to conduct your network 
discovery are checked, and then click Next. 

11. If you already know the IP addresses or hostnames of the devices you 
want to discover and include in the Orion database, complete the 
following procedure: 

a. Click Specific Nodes in the Selection Method menu. 

b. Type the IPv4 addresses or hostnames of the devices you want to 
discover for monitoring into the provided field. 

Note: Type only one IPv4 address or hostname per line. 

c. Click Validate to confirm that the provided IPv4 addresses and 
hostnames are assigned to SNMP-enabled devices. 

d. If you have provided all the IPv4 addresses and hostnames you 
want to discover, click Next. 

12. Configure the options on the Discovery Settings view, as detailed in the 
following steps. 

a. Provide a Name and Description to distinguish the current discovery 
profile from other profiles you may use to discover other network areas. 

Note: This Description displays next to the Name in the list of available 
network discovery configurations on the Network Sonar view. 

b. Position the slider or type a value, in ms, to set the SNMP Timeout. 

Note: If you are encountering numerous SNMP timeouts during Network 
Discovery, increase the value for this setting. The SNMP Timeout should 
be at least a little more than double the time it takes a packet to travel 
the longest route between devices on your network. 
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c. Position the slider or type a value, in ms, to set the Search Timeout. 

Note: The Search Timeout is the amount of time Network Sonar 
Discovery waits to determine if a given IP address has a network device 
assigned to it. 

d. Position the slider or type a value to set the number of SNMP Retries. 

Note: This value is the number of times Network Sonar Discovery will 
retry a failed SNMP request, defined as any SNMP request that does not 
receive a response within the SNMP Timeout defined above. 

e. Position the slider or type a value to set the Hop Count. 

Note: If the Hop Count is greater than zero, Network Sonar Discovery 
searches for devices connected to any discovered device. Each 
connection to a discovered device counts as a hop. 

f. Position the slider or type a value to set the Discovery Timeout. 

Note: The Discovery Timeout is the amount of time, in minutes, Network 
Sonar Discovery is allowed to complete a network discovery. If a 
discovery takes longer than the Discovery Timeout, the discovery is 
terminated. 

13. If you only want to discover devices that respond to SNMP, check Use 
SNMP only. 

Note: By default, Network Sonar uses ICMP ping  requests to locate devices. 

Most information about monitored network objects is obtained using SNMP 
queries. 

14. If multiple Orion polling engines are available in your environment, 
select the Polling Engine you want to use for this discovery. 

15. Click Next. 

16. If you want the discovery you are currently defining to run on a regular 
schedule, select either Custom or Daily as the discovery Frequency, as 
shown in the following steps: 

Notes: 

¶ Scheduled discovery profiles should not use IP address ranges that 
include nodes with dynamically assigned IP addresses (DHCP). 

¶ Default Discovery Scheduling settings execute a single discovery of your 
network that starts immediately, once you click Discover. 

¶ Results of scheduled discoveries are maintained on the Scheduled 
Discovery Results tab of Network Discovery. For more information about 
managing scheduled discovery results, see ñManaging Scheduled 
Discovery Resultsò on page 25. 
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a. If you want to define a custom discovery schedule to perform the 
currently defined discovery repeatedly in the future, select Custom 
and then provide the period of time, in hours, between discoveries. 

b. If you want your scheduled discovery to run once daily, select Daily, 
and then provide the time at which you want your discovery to run every 

day, using the format HH:MM AM/PM. 

17. If you do not want to run your network discovery at this time, select No, 
donôt run now, and then click Save or Schedule, depending on whether you 
have configured the discovery to run once or on a schedule, respectively. 

18. If you want your Network Sonar discovery to run now, click Discover to 
start your network discovery. 

Note: Because some devices may serve as both routers and switches, the 
total number of Nodes Discovered may be less than the sum of reported 
Routers Discovered plus reported Switches Discovered. 

Using the Network Sonar Results Wizard 

The Network Sonar Results Wizard directs you through the selection of network 
devices for monitoring, and it opens whenever discovery results are requested, 
either when the Network Sonar Wizard completes or when either Import All 
Results or Import New Results is clicked for a selected discovery. For more 
information, see ñNetwork Discovery Using the Network Sonar Wizardò on 
page 17. 

The following steps detail the selection of discovered objects for monitoring in 
Orion. 

To select the results of a network discovery for monitoring in Orion: 

1. On the Device Types to Import page, check the device types you want Orion 
to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific device type, check 
the device type in question. If, later, you do not want to monitor a selected 
device, simply delete the device using Web Node Management. For more 
information, see ñManaging Devices in the Web Consoleò on page 75. 

2. If you are discovering devices for an Orion NPM installation, check the 
interface types you want Orion to monitor on the Interface Types to Import 
page, and then click Next. 

Note: If you are not sure you want to monitor a specific interface type, check 
the interface type in question. If, later, you do not want to monitor a selected 
interface, delete it using Web Node Management. For more information, see 
ñManaging Devices in the Web Consoleò on page 75. 
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3. On the Volume Types to Import page, check the volume types you want 
Orion to monitor, and then click Next. 

Note: If you are not sure you want to monitor a specific volume type, check 
the volume type in question. If, later, you do not want to monitor any volume 
of the selected type, delete the volume using Web Node Management. For 
more information, see ñManaging Devices in the Web Consoleò on page 75. 

4. If you want to import nodes, even when they are already known to be 
polled by another polling engine, check the option in the Allow Duplicate 
Nodes section. For more information about working with multiple polling 
engines, see ñManaging Orion Polling Enginesò on page 107. 

5. If you are discovering devices for an Orion NPM installation, check valid 
states for imported interfaces on the NPM Import Settings page, and then 
click Next. 

Note: By default, Orion NPM imports interfaces that are discovered in an 
Operationally Up state. However, because interfaces may cycle off and on 
intermittently, the Import Settings page allows you to select interfaces found 
in Operationally Down or Shutdown states for import, as well. 

6. If there are any devices on the Import Preview that you do not ever want 
to import, check the device to ignore, and then click Ignore. Selected nodes 
are added to the Discovery Ignore List. For more information, see ñUsing the 
Discovery Ignore Listò on page 26. 

7. Confirm that the network objects you want to monitor are checked on the 
Import Preview page, and then click Import. 

8. If you are discovering devices for an Orion NPM installation, after the 
import completes, click Finish. 

Note: Imported devices display in the All Nodes resource. 

Importing a List of Nodes Using a Seed File 

In versions of Orion products following the release of Orion NPM version 10.0, 
the Specific Nodes option in the Network Discovery Wizard may be used to 
import devices from a seed file. The following procedure details how the Specific 
Nodes option is used with a seed file to import devices into the Orion database. 

Note: A Seed File discovery option is available in Orion NPM prior to version 10. 

To import devices from a seed file: 

1. Open your seed file. 

2. If the Network Sonar Wizard is not already open, click Start > All 
Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Network Discovery. 



Administrator Guide Ö SolarWinds Orion Core 
 

 
24 Ö Discovering and Adding Network Devices 

3. If you want to create a new discovery, click Add New Discovery. 

4. If you have already defined a network discovery, a number of options are 
available on the Network Sonar Discovery tab. Select one of the following: 

¶ If you want to edit an existing discovery before using it, select the 
discovery you want to edit, and then click Edit. 

¶ If you want to use an existing discovery to rediscover your network, 
select the discovery you want to use, click Discover Now, and then 
complete the Network Sonar Results Wizard after dicovery completes. 
For more information about network discovery results, see ñUsing the 
Network Sonar Results Wizardò on page 22. 

¶ If you want to import some or all devices found in a defined 
discovery that you may not have already imported for monitoring, 
select a currently defined discovery, and then click Import All Results. 
For more information about network discovery results, see ñUsing the 
Network Sonar Results Wizardò on page 22. 

¶ If you want to import any newly enabled devices matching a defined 
discovery profile, select a currently defined discovery, and then click 
Import New Results. For more information about network discovery 
results, see ñUsing the Network Sonar Results Wizardò on page 22. 

¶ If you want to delete an existing discovery profile, select a currently 
defined discovery and then click Delete. 

5. If the devices on your network do not require community strings other 

than the default strings public  and private  provided by Orion, click 
Next on the SNMP Credentials view. 

6. If you need to supply new SNMP credentials to discover the devices in 
your seed file, click Add New Credential, provide the required information, 
and then click Add. For more information, see ñNetwork Discovery Using the 
Network Sonar Wizardò on page 17. 

7. Click Next on the SNMP Credentials view. 

8. If you intend to import known VMware vCenter or ESX servers and you 
need to supply new VMware credentials to discover these servers in 
your seed file, complete the following steps on the Local vCenter or ESX 
Credentials for VMware view: 

a. Check Poll for VMware, and then click Add vCenter or ESX 
Credential. 

b. Provide the required information, and then click Add. 

Note: For more information, see ñNetwork Discovery Using the Network 
Sonar Wizardò on page 17. 
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9. Click Next, and then click Specific Nodes in the Selection Method menu. 

10. Copy and then paste the IP addresses or hostnames of the devices you want 
to discover from your seed file into the provided field. 

Note: Confirm that there are no more than one IPv4 address or hostname 
per line. 

11. Click Validate to confirm that the provided IP addresses and hostnames are 
assigned to SNMP-enabled devices. 

12. If you have provided all the IP addresses and hostnames you want to 
discover, click Next. 

13. Complete the Network Discovery and Network Discovery Results Wizards. 
For more information, see ñNetwork Discovery Using the Network Sonar 
Wizardò on page 17. 

Managing Scheduled Discovery Results 

The Scheduled Discovery Results tab of Network Discovery provides a list of all 
recently discovered, changed, or imported devices on your monitored network. 
Results are compared between discoveries, and results are listed on this tab. 
The following procedure provides guidelines for managing discovery results. 

To manage scheduled discovery results: 

1. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Network Discovery. 

2. Click Scheduled Discovery Results. 

3. Select the type of devices you want to view from the Status menu in the left 
pane. The following options are available: 

¶ Select Found to view all devices discovered by a scheduled discovery. 

¶ Select Changed to view all devices that have changed between recent 
scheduled discoveries. Changes include the addition of interfaces and 
device configuration changes. 

¶ Select Imported to view all devices you have recently imported youôre 
your Orion database. For more information about importing devices, see 
ñUsing the Network Sonar Results Wizardò on page 22. 

¶ Select Ignored to view all devices you have added to your Discovery 
Ignore List. For more information about the Discovery Ignore List, see 
ñUsing the Discovery Ignore Listò on page 26. 
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¶ Select Found and Changed to view a combined list of all devices found 
or changed as described above. 

¶ Select All except Ignored to view all discovered, changed or imported 
devices you have not already designated as Ignored, as detailed above. 

4. If you want to apply a grouping criterion to organize your listed results, 
select an appropriate criterion from the Group by menu in the left pane. 

5. If there are changed or discovered nodes in the results list that you 
want to update your Orion database to include, check all nodes to update 
or to add, and then click Import Nodes. 

6. If there are devices you want Orion to ignore in future discoveries, 
regardless of discovered updates or changes, check all nodes to ignore, 
and then click Add to Ignore List. For more information about the Discovery 
Ignore List, see ñUsing the Discovery Ignore Listò on page 26. 

Using the Discovery Ignore List 

Often, devices are found during a network discovery that you never intend to 
monitor with Orion. The Discovery Ignore List is a record of all such devices on 
your network. By placing a device on the Discovery Ignore List you can minimize 
the SNMP processing load associated with discovering devices that you never 
intend to monitor. 

To manage devices on the Discovery Ignore List: 

1. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Network Discovery. 

2. If you want to view the current Discovery Ignore List, click Discovery 
Ignore List. 

3. If you want to add devices to the Discovery Ignore List, complete the 
following procedure: 

a. Click Scheduled Discovery Results. 

b. Check devices you want to ignore, and then click Add to Ignore List. 

4. If you want to remove devices from the Discovery Ignore List, complete 
the following procedure: 

a. Click Scheduled Discovery Results, and then  

b. Check the devices you want to remove from the list. 

c. Click Remove from Ignore List. 

d. Confirm that you want to stop ignoring selected items by clicking OK. 
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Discovery Central 

Discovery Central provides a centralized overview of the types and number of 
network objects you are monitoring with your currently installed Orion products. 
The Discovery Central view is subdivided into sections corresponding to the 
Orion products you have installed. The Network Discovery section displays for all 
node-based Orion products. For more information about Network Discovery, see 
ñNetwork Discoveryò on page 27. For more information about specific sections, 
see the Administrator Guide for the corresponding Orion product. 

Clicking Go to Orion Home opens the Orion Summary Home view for your 
entire monitored network. 

Network Discovery 

The Network Discovery resource provides the number of nodes and volumes that 
are currently monitored. This information is both available and applicable to all 
installed Orion products. 

Click Network Sonar Discovery to start a Network Sonar Discovery. For more 
information, see ñDiscovering and Adding Network Devicesò on page 17. 

Click Add a Single Device to open the Add Node ï Define Node view of the 
Orion Node Management utility. For more information, see ñAdding Devices for 
Monitoring in the Web Consoleò on page 75. 

Additional Discovery Central Resources 

As they are released following the release of Orion NPM 10.1.2, each Orion 
module will provide its own Discovery Central resource. These additional 
Discovery Central resources provide the number of module-related network 
objects that are currently monitored. For more information about any of these 
additional Discovery Central resources, see the corresponding Orion module 
Administrator Guide. 
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Chapter 4 

Managing the Orion Web Console 

The Orion Web Console is an integral part of the Orion family of products that 
can be configured for viewing from virtually any computer connected to the 
Internet. You can also customize the web console for multiple users and store 
individually customized views as user profiles. Administrator functions are 
accessed by clicking Settings in the top right of all Orion Web Console views. 

Logging in for the First Time as an Administrator 

When you launch the Orion Web Console, you are presented with a login view 
requiring both a User Name and a Password. 

To log in to the Orion Web Console: 

1. Launch the Orion Web Console using either of the following methods: 

¶ Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

¶ Or launch a browser on your Orion server and enter http: // ip _address  

or http:// hostname , where ip _address  is the IP address of your Orion 

host server, or where hostname  is the domain name of your Orion server. 

2. Enter Admin  as your User Name, and then click Login. 

Notes: Until you set a password, you can log in as Admin  with no Password. 

After your first login, you may want to change the Admin password. For more 
information, see ñChanging an Account Passwordò on page 33. 

Windows Authentication with Active Directory 

As of Orion Core version 2010.2, the Orion Web Console can authenticate Active 
Directory users and users who are members of Active Directory security groups. 

To enable Active Directory Windows authentication to the web console: 

1. Install and configure Active Directory on your local network. 

Notes: 

¶ For more information about installing Active Directory on Windows 
Server 2003, see the Microsoft Support article, ñHow To Create an Active 
Directory Server in Windows Server 2003ò. 

¶ For more information about Active Directory on Windows Server 2008, 
see the Microsoft TechNet article, ñActive Directory Servicesò. 

http://support.microsoft.com/kb/324753
http://support.microsoft.com/kb/324753
http://technet.microsoft.com/en-us/library/dd578336%28WS.10%29.aspx
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2. If you want to enable automatic login for web console accounts using 
Windows Authentication, configure the Orion Web Console as shown in the 
following steps: 

a. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Configuration Wizard. 

b. Check Website, and then click Next. 

c. After providing the appropriate IP Address, Port, and Website Root 
Directory, select Yes ï Enable automatic login using Windows 
Authentication. 

d. Click Next, and then complete the Configuration Wizard. 

3. Log in to the web console using the appropriate domain and user, providing 

Domain \User name or Username@Domain as the web console User name. 

Using the Web Console Notification Bar 

Below the web console menu bar, the Orion notification bar provides 
informational messages related to the following Orion features: 

¶ If you have configured the Orion Web Console to check for product updates, 
an announcement displays in the notification bar when an update, including 
any upgrade, service pack, or hotfix, to Orion or any other Orion modules you 
currently have installed becomes available. For more information about Orion 
Product Updates, see ñProduct Updatesò on page 36. 

¶ If you have configured the Orion Web Console to store blog posts, new and 
unread posts to the Orion Product Team Blog are announced in the 
notification bar. For more information about the Orion Product Team Blog, 
see ñProduct Updatesò on page 36. 

¶ If you have currently configured a scheduled discovery, results display in the 
notification bar when the discovery completes. For more information about 
Scheduled Discovery, see ñDiscovering and Adding Network Devicesò on 
page 17. 

¶ If you are currently using Orion to monitor any VMware ESX or ESXi Servers, 
the notification bar can display messages communicating the number of ESX 
nodes found during any discovery, and, if any discovered ESX nodes require 
credentials, the notification bar tells you. For more information about 
managing ESX Servers, see ñVirtualizationò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

For more information about any displayed notification bar message, click More 
Details and a web console view relevant to the displayed message opens. 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Managing the Orion Web Console Ö 31 

To delete a posted message, either click Dismiss Message next to the displayed 
message, or properly address the situation mentioned in the posted notification. 

To remove the notification bar from your web console, click Close (X) at the right 
end of the notification bar. 

Navigating the Orion Web Console 

The Orion Web Console offers two primary methods of navigation: top-level web 
console tabs and view-level breadcrumbs. The following sections describe how 
these navigation methods are used: 

Using Web Console Tabs 

In the case of a basic Orion installation, the Orion Web Console displays the 
following tabs: 

Home 

The Home tab provides a menu bar of links to views aiding you in general 
network management and monitoring. Information, like events and Top 10 
lists, and technologies, like alerts, used to generate the views linked from the 
Home menu are generally available to all Orion modules. By default, the 
Orion Summary Home view displays when you click Home from any view in 
the web console. 

Applications (Orion APM) 

If you are viewing the Orion Web Console on a server on which Orion APM is 
also installed, the Applications tab opens a menu of default views for some 
of the many different types of applications Orion APM can monitor. If Orion 
APM is installed without Orion NPM, the APM Summary Home view 
displays by default when you click Home from any web console view.  

Network (Orion NPM) 

The Network tab opens a menu bar of links to views and technologies, like 
EnergyWise, wireless network and interface monitoring, that are specific to 
the features provided by Orion NPM. If Orion NPM is installed, the NPM 
Summary Home view displays by default when you click Home from any 
web console view. 

Configs (Orion NPM and NCM) 

If the Orion NCM Integration for Orion NPM is installed, the Configs tab 
provides links to default device configuration management views. If Orion 
NPM is installed, clicking Home from any web console view displays the 
NPM Summary Home view by default.  
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Virtualization 

The Virtualization tab provides access to specific views and resources that 
are tailored for monitoring virtual devices. For more information about 
virtualization monitoring in Orion, see the SolarWinds Orion Integrated Virtual 
Infrastructure Monitor Administrator Guide. 

The web console provides an additional module-specific tab for each installed 
Orion module. These tabs offer access to views and tools specific to the Orion 
module added. For more information about additional Orion modules, see 
www.solarwinds.com. For more information about customizing menu bars, see 
ñCustomizing Web Console Menu Barsò on page 57.  

Using and Disabling Web Console Breadcrumbs 

As you navigate web console views, your location is recorded as a series of links, 
or breadcrumbs, to the views you have opened. Each breadcrumb offers the 
following navigation options: 

¶ Clicking a breadcrumb opens the corresponding view directly. 

¶ Clicking > next to a breadcrumb opens a clickable list of all other views at the 
same navigation level in the web console. For example, if you are on a Node 
Details view, clicking > displays a list of other monitored nodes. 

Note: Only the first 50 monitored nodes, listed in alphanumeric order by IP 
address, are displayed. 

Customizing Web Console Breadcrumbs 

Dropdown breadcrumb lists are customizable, as shown in the following steps. 

To customize the items in a breadcrumb dropdown: 

1. Click > at an appropriate level in a breadcrumb to open the dropdown. 

2. Click Customize this list. 

3. Select a criterion from the menu, and then click Submit. 

Note: All items in the customized list will be identical for the selcted criterion. 

Disabling Web Console Breadcrumbs 

To ensure access is appropriately restricted for account-limited users, you may 
want to disable breadcrumbs, as indicated in the following procedure. 

To disable web console breadcrumb navigation: 

1. Log on to your Orion server using an account with administrative access. 

2. Open web.config  (default location C: \ I netpub \ SolarWinds \ ) for editing. 

http://www.solarwinds.com/
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3. In the <appsettings>  section, locate the following setting: 

<add key=òDisableBreadCrumbsò value=òfalseò/> 

4. Change ñfalseò to ñtrueò, as follows: 

<add key=òDisableBreadCrumbsò value=òtru eò/> 

5. Save web.config . 

Note: If you run the Configuration Wizard after editing this setting, your 
changes may be overwritten. 

Administrative Functions of the Orion Web Console 

The following sections describe the primary administrative functions performed 
by an Orion Web Console administrator. 

¶ Changing an Account Password 

¶ Orion Website Administration 

¶ Viewing Secure Data on the Web 

¶ Handling Counter Rollovers 

Changing an Account Password 

Orion Web Console administrators may change user account passwords at any 
time, as shown in the following procedure. 

Note: In environments where security is a priority, SolarWinds recommends 
against providing a view where users may change their own web console 
account passwords. 

To change an account password: 

1. Log in to the web console as an administrator. 

2. Click Settings in the top right corner of the web console. 

3. Click Manage Accounts in the Accounts grouping of the Orion Website 
Administration page. 

4. Select the user account with the password you want to change, and then 
click Change Password. 

5. Complete the New Password and Confirm Password fields, and then click 
Change Password. 

6. Click Continue when the password is successfully changed. 
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Orion Website Administration 

If you are logged in to the web console as an administrator, clicking Settings in 
the top right corner of the web console.displays the Orion Website Administration 
page, presenting a variety of tools to control the appearance and delivery of 
information to Orion Web Console users. The following options are available on 
the Orion Website Administration page. 

Node & Group Management 

Before you can start monitoring your network you must designate the network 
objects you want your Orion installation to monitor. The Getting Started with 
Orion grouping provides direct links to the following discovery-related views so 
you can quickly and easily start monitoring your network: 

¶ Discovery Central provides a centralized overview of the types and number 
of network objects you are monitoring with your Orion installation. For more 
information, see ñDiscovery Centralò on page 27. 

¶ Clicking Network Sonar Discovery opens the Network Sonar Discovery 
Wizard. Network Discovery enables you to quickly discover devices across 
your entire network for monitoring. For more information, see ñNetwork 
Discovery Using the Network Sonar Wizardò on page 17. 

¶ Clicking Add a Node opens the Add Node Wizard directly. For more 
information about adding nodes individually, see ñAdding Devices for 
Monitoring in the Web Consoleò on page 75. 

Node & Group Management 

The Node & Group Management grouping of the Orion Website Administration 
page gives you access to the following web console views for managing nodes 
and groups: 

¶ Clicking Manage Nodes displays the Node Management page, where an 
Orion Web Console administrator can immediately add, view, and manage all 
network objects currently managed or monitored by your Orion installation. 
For more information, see ñManaging Devices in the Web Consoleò on 
page 75. 

¶ Clicking VMware Settings opens the VMware Settings view, where you can 
view both a list of currently monitored VMware ESX Servers and a library of 
the VMware credentials Orion uses to monitor your ESX Servers. For more 
information, see ñVirtualizationò in the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

¶ Clicking Manage Dependencies opens the Manage Dependencies view. 
Dependencies allow you to formalize dependent relationships between 
monitored objects based on network topology or priority to eliminate the 
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potential for duplicated or redundant polling and alerting. For more 
information, see ñManaging Dependenciesò on page 91. 

¶ Clicking Manage Groups opens the Manage Groups view. To a greater 
degree than previously available with custom properties, groups enable you 
to logically organize your monitored network objects. For more information, 
see ñManaging Groupsò on page 87. 

Accounts 

The Accounts grouping of the Orion Website Administration page gives a web 
console administrator access to the following web console configuration pages: 

¶ The Manage Accounts link provides web console administrators access to 
set and change account passwords, set user rights and access, and 
configure the web console experience for all users. For more information 
about managing accounts, see ñManaging Web Accountsò on page 97. 

¶ Clicking Account List opens the Orion Website Accounts view, providing an 
immediate overview of web console user account settings. You may use this 
view to make changes to multiple accounts simultaneously and immediately 
by clicking to check or clear options. Clicking an Account user name opens 
the Account Manager for the selected account. For more information about 
managing accounts, see ñManaging Web Accountsò on page 97. 

Customize 

The Customize grouping of the Orion Website Administration page offers options 
to customize the navigation and appearance of your Orion Web Console on the 
following pages: 

¶ The Customize Menu Bars page allows an Orion Web Console 
administrator to configure the menu bars seen by individual users. For more 
information, see ñCustomizing Web Console Menu Barsò on page 57. 

¶ The Color Scheme page gives a web console administrator the ability to 
select a default color scheme for resource title bars. The color scheme 
selection takes effect immediately throughout the web console. For more 
information, see ñChanging the Web Console Color Schemeò on page 58. 

¶ The External Websites page enables an Orion Web Console administrator 
to designate any external website as an Orion Web Console view, appearing 
in the Views toolbar. For more information, see ñCreating and Editing 
External Website Viewsò on page 56. 

Manage Alerts 

The Manage Alerts grouping provides a link to the Manage Advanced Alerts 
view, where you can edit, enable, disable, and delete advanced alerts directly 
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from the web console. For more information about manage advanced alerts in 
the web console, see ñUsing Orion Advanced Alertsò on page 119.  

Product Updates 

The Product Updates grouping provides links to web console views offering 
up-to-date information about using and upgrading Orion. 

¶ The Available Product Updates view allows you to configure regular checks 
for Orion updates that can include version upgrades and service packs. 

¶ The Orion Product Team Blog offers regular posts from members of the 
Orion product team to help you take full advantage of features provided by 
Orion and its modules. 

Views 

The Views grouping of the Orion Website Administration page gives an Orion 
Web Console administrator access to the following view configuration pages: 

¶ The Manage Views page enables a web console administrator to add, edit, 
copy, or remove individual web console views. For more information about 
managing Orion Web Console views, see ñCustomizing Viewsò on page 40. 

¶ Clicking Add New View opens the Add New View page, where you can 
define new web console views.  

¶ The Views by Device Type page gives an Orion Web Console administrator 
the ability to designate default views for network devices. For more 
information, see ñViews by Device Typeò on page 44. 

Settings 

The Settings grouping of the Orion Website Administration page gives an Orion 
Web Console administrator access to the following settings configuration pages: 

Note: If you currently have any Orion modules installed, links to module settings 
pages display in the Settings grouping. For more information about configuring 
Orion module settings, see the Administrator Guide for your Orion module. 

¶ Web Console Settings allow an Orion Web Console administrator to 
customize the function and appearance of both the Orion Web Console and 
the charts that are displayed as resources in Orion Web Console views. For 
more information about configuring Orion Web Console and Chart Settings, 
see ñOrion Web Console and Chart Settingsò on page 60. 

¶ Polling Settings define the configuration of polling intervals, timeouts, 
statistics calculations, and database retention settings for your Orion polling 
engine. For more information about configuring Orion Polling Settings, see 
ñOrion Polling Settingsò on page 107. 
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¶ The Orion Thresholds page opens the Orion General Thresholds page, 
where Orion threshold settings are configured. For more information, see 
ñOrion General Thresholdsò on page 38. 

Details 

The Details grouping of the Orion Website Administration page provides links to 
the following pages containing information about your Orion installation: 

Database Details 

This is an information-only page that displays details about the SQL Server 
database currently used by your Orion installation. In addition to current 
version information and configuration settings for both your Orion server and 
your database server, this page displays the total number of monitored 
objects in the Orion database. 

Polling Engines 

Orion supports the implementation of multiple distributed polling engines. 
Each engine can monitor and collect data from different parts of your 
network. This page shows the status and selected configuration information 
for each currently operational polling engine. 

Orion Core Details 

This is an information-only page that displays details about your installation 
of the common components and resources that all Orion products share, 
including information about your Orion server, monitored object counts, and 
the version numbers of the executables and DLLs required by any and all 
installed Orion products. 

License Details 

This is an information-only page that displays details about all Orion products 
that you currently have installed. about both your Orion license and your 
monitored network. This page also shows the version numbers of the Orion 
products you are running and the versions of associated DLLs. For more, 
see ñMaintaining Licenses with License Managerò on page 12. 

Viewing Secure Data on the Web 

In the interest of security, sensitive network information, such as community 
strings, logins, and passwords, is not viewable in the web console. However, if 
you have secured your network, you may check Allow Secure Data On Web 
(advanced) in the Calculations & Thresholds area of the Orion Polling Settings 
page to allow the passage of community strings through the web console. 

Note: This setting does not affect the display of custom reports that you export to 
the web. For more information see ñCreating and Viewing Reportsò on page 161. 
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Handling Counter Rollovers 

The Counter Rollover setting configures Orion to properly handle counter 
rollovers. Orion is capable of handling either 32-bit or 64-bit counters, but, by 
default, Orion assumes counters are 32-bit. 32-bit counters have a maximum 
value of 2

32
, or 4,294,967,296, and 64-bit counters, if they are supported by your 

network devices, have a maximum value of 2
64

, or 18,446,744,073,709,551,616. 

Note: The 32-bit counters option is designated as Method 1 in the Counter 
Rollover field on the Orion Polling Settings page. 

The following procedure designates the type of counter-hanlding used by Orion. 

To designate the type of counter-handling used by Orion: 

1. Log in to the web console as an administrator. 

2. Click Settings in the top right of the web console, and then click Polling 
Settings in the Settings grouping of the Orion Website Administration page. 

3. If you are using 64-bit counters, select Method 2 in the Counter Rollover 
field in the Calculations & Thresholds area. 

Notes: 

¶ If Method 2 is selected, Orion will intentionally skip a poll if a polled 
value is less than the previous polled value to permit counting to 2

64
. 

¶ Orion fully supports the use of 64-bit counters; however, these 64-bit  
counters can exhibit erratic behavior in some implementations. If you 
notice peculiar results when using these counters, disable the use of 64-
bit counters for the problem device and contact the device manufacturer. 

4. If you are using of 32-bit counters, select Method 1 in the Counter 
Rollover field in the Calculations & Thresholds area. 

Note: If Method 1 is selected, when a rollover is detected, the time between 
polls is calculated as (2

32
 ï Last Polled Value) + Current Polled Value. 

Orion General Thresholds 

Many of the resources available in the Orion Web Console are capable of 
displaying error and warning conditions for the devices on your network. Errors 
and warnings display in the Orion Web Console. Orion uses the values provided 
on the thresholds pages to determine when and how to display errors and 
warnings in the Orion Web Console. The following sections provide more 
information about threshold types and configuration: 

¶ Orion General Threshold Types 

¶ Setting Orion General Thresholds 
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Orion General Threshold Types 

The following device conditions may be configured as Orion General Thresholds: 

CPU Load 

Monitored network devices experiencing CPU loads higher than the value set 
for the High Level display in High CPU Load reports and resources. Gauges 
for these devices also display as bold red. Monitored network devices 
experiencing a CPU load higher than the value set for the Warning Level, 
but lower than the value set for the High Level, display as red in High CPU 
Load reports and resources. Gauges for these devices also display as red. 

Disk Usage 

Monitored network devices experiencing a disk usage higher than the value 
set for the High Level display as bold red in Disk Usage reports and 
resources. Monitored network devices experiencing a disk usage higher than 
the value set for the Warning Level, but lower than the value set for the 
High Level, display as red in High Disk Usage reports and resources. 

Percent Memory Used 

Monitored network devices experiencing a percent memory usage higher 
than the value set for the Error Level display in High Percent Utilization 
reports and resources. Gauges for these devices also display as bold red. 
Monitored network devices experiencing a percent memory usage higher 
than the value set for the Warning Level, but lower than the value set for the 
Error Level, display in High Percent Utilization reports and resources. 
Gauges for these devices also display as red. 

Percent Packet Loss 

Monitored network devices experiencing a percent packet loss higher than 
the value set for the Error Level display in High Percent Loss reports and 
resources. Gauges for these devices also display as bold red. Monitored 
network devices experiencing a percent packet loss higher than the value set 
for the Warning Level, but lower than the value set for the Error Level, 
display in High Percent Loss reports and resources. Gauges for these 
devices also display as red. 

Orion calculates percent packet loss using ICMP ping requests made on the 
Default Poll Interval. Orion pings monitored devices and records the results 
of the ten most recent ping attempts. Percent packet loss is expressed as the 
number of failed ping requests, X, divided by the number of ping requests, 
10. For more information about the Default Poll Interval, see ñOrion Polling 
Settingsò on page 107. 
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For example, if, at a given point in time, the last ten ping requests made of a 
selected device resulted in 2 failures and 8 successes, the percent packet 
loss for the selected device at the given time is reported as 2/10, or 20%. 

Response Time 

Monitored devices experiencing response times longer than the value set for 
the Error Level display in High Response Time reports and resources. 
Gauges for these devices also display as bold red. Devices experiencing 
response times longer than the value set for the Warning Level, but shorter 
than the value set for the Error Level, also display in High Response Time 
reports and resources. Gauges for these devices also display as red. 

Orion calculates response time using ICMP ping requests made on the 
Default Node Poll Interval. Orion pings monitored devices and records the 
results of the ten most recent ping attempts. Average Response Time is 
expressed as the average response time of these last 10 ping requests. If 
Orion does not receive a ping response within the Default Poll Interval, Orion 
will attempt to ping the nonresponsive device once every 10 seconds for the 
period designated as the Warning Interval. For more information, see ñOrion 
Polling Settingsò on page 107. 

Setting Orion General Thresholds 

The following procedure configures Orion General Thresholds. 

To set Orion thresholds: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Orion Thresholds in the Settings group of the Orion Website 
Administration page. 

Note: For more information about Orion General Thresholds, see ñOrion 
General Threshold Typesò on page 39. 

4. Provide appropriate values for Error Level, High Level, or Warning Level 
for selected thresholds. 

Customizing Views 

Orion Web Console views are configurable presentations of network information 
that can include maps, charts, summary lists, reports, events, and links to other 
resources. Customized views can then be assigned to menu bars. 

Note: In environments where security is a priority, SolarWinds recommends 
against providing a view where users may change their own web console 
account passwords.  
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Creating New Views 

You can customize the Orion Web Console for individual users by logging in as 
an administrator and creating new views as shown in the following procedure. 

Note: In environments where security is a priority, SolarWinds recommends 
against providing a view where users may change their own web console 
account passwords. 

To create a new view: 

1. Click Settings in the top right of the web console. 

2. Click Manage Views in the Views group of the Orion Website Administration 
page. 

3. Click Add. 

4. Enter the Name of New View. 

5. Select the Type of View. 

Note: The Type of View selection affects how the view is made accessible 
to users, and your choice may not be changed later. For more information, 
see ñViews by Device Typeò on page 44. 

6. Click Submit. 

After you have created a new view, the Customize YourView page opens. For 
more information, see ñEditing Viewsò on page 41. 

Editing Views 

The Orion Web Console allows administrators to configure views for individual 
users. The following steps are required to configure an existing view. 

To edit an existing view: 

1. Click Settings in the top right of the web console. 

2. Click Manage Views in the Views group of the Orion Website Administration 
page. 

3. Select the view you want to customize from the list, and then click Edit. 

4. If you want to change the column layout of your view, complete the 
following steps. 

a. Click Edit to the right of the column widths. 

b. Select the number of columns under Layout. 

c. Provide the width, in pixels, of each column in the appropriate fields, and 
then click Submit. 
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5. If you want to add a resource, repeat the following steps for each resource: 

Notes: 

¶ Resources already in your view will not be checked on this page listing 
all web console resources. It is, therefore, possible to pick duplicates of 
resources you are already viewing. 

¶ Some resources may require additional configuration. For more 
information, see ñResource Configuration Examplesò on page 44. 

¶ Several options on the Add Resources page are added to the list of 
resources for a page, but the actual configuration of a given map, link, or 
code is not added until the page is previewed. 

a. Click + next to the column in which you want to add a resource. 

b. Click + next to a resource group on the Add Resources page to expand 
the resource group, displaying available resources. 

c. Check all resources you want to add. 

d. If you have completed the addition of resources to the selected 
view, click Submit. 

6. If you want to delete a resource from a column, select the resource, and 
then click X next to the resource column to delete the selected resource. 

7. If you want to copy a resource in a column, select the resource, and then 

click  next to the resource column to delete the selected resource. 

8. If you want to rearrange the order in which resources appear in your 
view, select resources, and then use the arrow keys to rearrange them. 

9. If you have finished configuring your view, click Preview. 

Note: A preview of your custom web console displays in a new window. A 
message may display in the place of some resources if information for the 
resource has not been polled yet. For more information, see ñResource 
Configuration Examplesò on page 44. 

10. Close the preview window. 

11. If you are satisfied with the configuration of your view, click Done. 

Notes: 

¶ For more information about adding a customized view to menu bars as a 
custom item, see ñCustomizing Web Console Menu Barsò on page 57. 

¶ For more information about assigning your customized view as the 
default view for a user, see ñEditing User Accountsò on page 98. 
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Configuring View Limitations 

As a security feature, the web console gives administrators the ability to apply 
device-based view limitations. The following limitations are defined by default: 

Orion Web Console View Limitations 

Single Network Node Group of Nodes System Location Pattern 

Node Name Pattern System Name Pattern Single Interface (Orion NPM) 

Machine Type Pattern Group of Machine Types Interface Status (Orion NPM) 

Hardware 
Manufacturer 

Single Hardware 
Manufacturer 

Interface Alias Pattern (Orion 
NPM) 

System Location System Contact Pattern Group of Interfaces (Orion NPM) 

System Contact IP Address Pattern 
Interface Name Pattern (Orion 
NPM) 

Group of Volumes Device Status Interface Type (Orion NPM) 

Single Machine Type Single Group Group of Groups 

Group Name Pattern   

 

The following procedure configures a view limitation. 

To enable a view limitation: 

1. Click Settings in the top right of the web console, and then click Manage 
Views in the Views group of the Orion Website Administration page. 

2. Select the view to which you want to add a limitation, and the click Edit. 

3. In the View Limitation area of the Customize View page, click Edit. 

4. Select the type of view limitation you want to apply, and then click Continue. 

5. Provide or check appropriate strings or options to define the device types to 
include or exclude from the selected view, and then click Submit. 

Note: The asterisk (*) is a valid wildcard. Pattern limitations restrict views to 
devices for which the corresponding fields include the provided string. 

Copying Views 

When you want to create multiple views based on the same device type, copying 
views allows you to create one view, and then use that view as a template to 
create other new views. The following steps copy an existing view. 

To copy a view: 

1. Click Settings in the top right of the web console. 

2. Click Manage Views in the Views group. 
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3. Select the view you want to copy, and then click Copy. 

4. If you want to edit a copied view, follow the procedure in the ñEditing 
Viewsò section on page 41. 

Deleting Views 

The following steps delete an existing view. 

To delete an existing view: 

1. Click Settings in the top right of the web console. 

 2. Click Manage Views in the Views grouping of the Orion Website 
Administration page. 

3. Select the view you want to delete, and then click Delete. 

Views by Device Type 

There are vast differences among network objects and the statistics they report, 
but the Orion Web Console can make it easier to view network data by displaying 
object details by device type, giving you the ability to have a different view for 
each unique type of device you have on your network, including routers, firewalls, 
and servers. The following steps assign a view by any available device type. 

To assign a view by device type: 

1. Click Settings in the top right of the web console, and then click Views by 
Device Type in the Views group of the Orion Website Administration page. 

2. Select available Web Views for the different types of devices that Orion is 
currently monitoring or managing on your network. 

3. Click Submit. 

Resource Configuration Examples 

Several resources that may be selected from the Add Resources page require 
additional configuration. Included in this section are examples of these resources 
and the steps that are required for their proper configuration. 

Selecting a Network Map 

Network maps created with Orion Network Atlas can give a quick overview of 
your network, right from the main web console view. For more information about 
creating maps, see ñCreating Network Mapsò on page 159. 

Note: Clicking the resource title in the title bar menu displays the resource by 
itself in a browser window. 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Managing the Orion Web Console Ö 45 

The following procedure adds a network map to the Orion Web Console. 

To add a network map to the web console: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to which you want to add the map, and then click Edit. 

3. Click + next to the view column in which you want to display the new map. 

4. Click + next to Network Maps, check Network Map, and then click Submit. 

5. Click Preview on the Customize YourView  page. 

6. Click Edit in the Network Map resource title bar. 

7. If you do not want to use the default title provided, enter a new Title for 
the title bar of the added map. 

8. If you want a subtitle, enter a new Subtitle for the added map. 

Note: Titles and subtitles may be entered as either text or HTML. 

9. Select from the list of available maps. 

10. Select the Scale at which you want to display the map. 

Note: If you leave the Scale field blank, the map will display at full scale, 
based on the size of the column in which the map displays. 

11. Click Submit. 

Displaying a List of Objects on a Network Map 

When your web console view includes a network map, it can be helpful to 
maintain a list of network objects that appear on the map. The following 
procedure enables a resource listing network map objects. 

Note: Clicking the resource title displays the resource in a new browser window. 

To display a list of network map objects: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to display the list of network map objects, and then click Edit. 

3. Click + next to the view column in which you want to display the new list of 
network map objects. 

4. Click + next to Network Maps, check List of Objects on Network Map, and 
then click Submit. 



Administrator Guide Ö SolarWinds Orion Core 
 

 
46 Ö Managing the Orion Web Console 

5. Click Preview on the Customize YourView  page. 

6. Click Edit in the title bar of the List of Objects on Network Map resource.  

7. If you do not want to use the default title provided, enter a new Title for 
the header of the objects list. 

8. If you want a subtitle, enter a new Subtitle for the added objects list. 

Note: Titles and subtitles may be entered as either text or HTML. 

9. Select from the list of available maps for the objects that you want to 
populate your list, and then click Submit. 

Displaying a Custom List of Maps 

The web console allows you to populate a custom view with a list of available 
network maps. Each map in your custom list, when clicked, opens in a new 
window. The following procedure enables a custom network maps list resource. 

Note: Clicking the resource title displays the resource in its own browser window. 

To display a custom list of maps: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to which you want to add the custom list of network maps, 
and then click Edit. 

3. Click + next to the view column in which you want to display the custom list 
of network maps. 

4. Click + next to Network Maps. 

5. Check Custom List of Maps, and then click Submit. 

6. Click Preview on the Customize YourView  page, and then click Edit in the 
title bar of the Custom List of Maps resource. 

7. If you do not want to use the default title provided, enter a new Title for 
the header of the maps list. 

8. If you want a subtitle, enter a new Subtitle for the custom list of maps. 

Note: Titles and subtitles may be entered as either text or HTML. 

9. Check the maps you want to include in your maps list. 

10. Click Submit. 
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Displaying an Event Summary - Custom Period of Time 

You may want your web console view to display an event summary for a 
specified period of time. The following procedure details the steps to include an 
event summary in your web console. 

Note: Clicking the resource title in the title bar menu displays the resource by 
itself in a browser window. 

To display an event summary: 

1. Create a new view or edit an existing view. 

Note: For more information about creating a new view or editing an existing 
view, see ñCustomizing Viewsò on page 40. 

2. Select the view to include the event summary, and then click Edit. 

3. Click + next to the view column that will display the event summary. 

4. Click + next to Events. 

5. Check Event Summary ï Custom Time Period, and then click Submit. 

6. Click Preview on the Customize YourView  page. 

7. Click Edit in the title bar of the Event Summary resource. 

8. If you do not want to use the default title provided, enter a new Title for 
the header of the event summary. 

Note: Titles may be entered as either text or HTML. 

9. Select the time period for displaying events from Display Events for the 
following Time Period. 

10. Click Submit. 

Specifying User-Defined Links 

The User-Defined Links option may be used to create quick access to external 
websites or customized views. URLs of your customized views can be copied 
from their preview pages and pasted in a User-Defined Links field. The following 
steps enable user-defined links from within your web console. 

Note: Clicking the resource title in the title bar menu displays the resource by 
itself in a browser window. 

To enable a user-defined links resource: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to which you want to add the user-defined links resource. 
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3. Click Edit. 

4. Click + next to the view column to display the user-defined links resource. 

5. Click + next to Miscellaneous 

6. Check User Defined Links. 

7. Click Submit. 

8. Click Preview on the Customize YourView  page. 

9. Click Edit in the title bar of the User Defined Links resource. 

10. If you do not want to use the default title provided, enter a new Title for 
the links list. 

11. If you want a subtitle, enter a new Subtitle for the links list. 

Note: Titles and subtitles may be entered as either text or HTML. 

12. Enter the following information for each link you want to define: 

a. A link Name and the URL of your link. 

b. If you want your links to open in a new browser window, check 
Open in New Window. 

13. Click Submit. 

Specifying Custom HTML or Text 

In situations where you have static information that you want to provide in the 
web console, use the Custom HTML or Text option. The Custom HTML or 
Text option may also be used to create quick access to your customized views. 
The following procedure will create a static content area within your web console 
for displaying text or HTML content. 

Note: Clicking the resource title displays the resource in a new browser window. 

To specify custom HTML or text: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to include the custom HTML or text. 

3. Click Edit. 

4. Click + next to the column to display the custom HTML or text. 

5. Click + next to Miscellaneous, and then check Custom HTML or Text. 

6. Click Submit. 

7. Click Preview on the Customize YourView  page. 
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8. Click Edit in the title bar of the Custom HTML or Text resource. 

9. If you do not want to use the default title provided, enter a new Title for 
the specified content area. 

10. If you want a subtitle, enter a new Subtitle for the specified content area. 

Note: Titles and subtitles may be entered as either text or HTML. 

11. Enter content as either text or HTML into the Raw HTML field. 

12. Click Submit. 

Specifying an Orion Report 

The web console is able to incorporate reports that you have created in Orion 
Report Writer into any view. The following procedure will take a report that you 
have created with Report Writer and include it within a web console view. 

Note: Clicking the resource title in the title bar menu displays the resource by 
itself in a browser window. 

To include an Orion report: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to which you want to add the report. 

3. Click Edit. 

4. Click + next to the view column in which you want to display the report. 

5. Click + next to Report Writer. 

6. Check Report from Orion Report Writer. 

7. Click Submit. 

8. Click Preview on the Customize YourView  page. 

9. Click Edit in the title bar of the Report from Orion Report Writer resource. 

10. If you do not want to use the default title provided, enter a new Title for 
the included report. 

11. If you want a subtitle, enter a new Subtitle for the included report. 

Note: Titles and subtitles may be entered as either text or HTML. 

12. Select a Report to include. 
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13. If you want to add a filter to the included report, enter an appropriate 
query in the Filter Nodes field. 

Note: Filter Nodes is an optional, advanced, web console feature that 
requires some knowledge of SQL queries. Click + next to Show Filter 
Examples to view a few example filters. 

14. Click Submit. 

Displaying a Custom List of Reports 

The web console allows you to populate a custom view with a custom reports list. 
When clicked from the list, each report opens in a new window. The following 
procedure details the steps required to enable a custom list of network reports. 

Note: Clicking the resource title displays the resource in a new browser window. 

To display a custom list of reports: 

1. Create a new view or edit an existing view. For more information, see 
ñCustomizing Viewsò on page 40. 

2. Select the view to which you want to add the custom list of reports, and then 
click Edit. 

3. Click + next to the column to display the custom list of reports. 

4. Click + next to Report Writer. 

5. Check Custom List of Reports, and then click Submit. 

6. Click Preview on the Customize YourView  page, and then click Edit in the 

title bar of the Report from Orion Report Writer resource. 

7. If you do not want to use the default title provided, enter a new Title for 
the header of the reports list. 

8. If you want a subtitle, enter a new Subtitle for the custom list of reports. 

Note: Titles and subtitles may be entered as either text or HTML. 

9. Check the reports that you want to include in your custom list of reports. 

Note: To allow a user to view a report included in the custom list, you must 
set the report access for the account. For more information, see ñConfiguring 
an Account Report Folderò on page 104. 

10. Click Submit. 
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Filtering Nodes 

Your Orion Web Console can maintain a customizable node list for your network. 
Node lists may be configured for specific views using SQL query filters. The 
following steps set up node filtering for node lists included in web console views. 

Note: Clicking the resource title displays the resource in a new browser window. 

To enable filtering on a node list: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to which you want to add the node list 

3. Click Edit. 

4. Click + next to the view column in which you want to display the node list. 

5. Click + next to Node Lists. 

6. Check All Nodes ï Table, and then click Submit. 

7. Click Preview on the Customize YourView  page, and then  

8. Click Edit in the title bar of the All Nodes ï Table resource. 

9. If you do not want to use the default title provided, enter a new Title for 
the node list. 

10. If you want a subtitle, enter a new Subtitle for the node list. 

Note: Titles and subtitles may be entered as either text or HTML. 

11. If you want to filter your node list by text or IP address range, provide 
the text or IP address range by which you want to filter your node list in the 
Filter Text field, as shown in the following examples: 

¶ Type Home in the Filter Text field to list all nodes with ñHomeò in the node 

name or as a location. 

¶ Type 192.168.1.*  in the Filter Text field to list all nodes in the 

192.168.1.0-255 IP address range. 

12. Select the property that is appropriate to the filter text provided above, as 
shown in the following examples: 

¶ If you typed Home in the Filter Text area, select Node Name or 

Location to list nodes with ñHomeò in the node name or as a location.  

¶ If you typed 192.168.1.*  in the Filter Text area, select IP Address to 

list only nodes in the 192.168.1.0-255 IP address range. 
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13. If you want to apply a SQL filter to the node list, enter an appropriate 
query in the Filter Nodes (SQL) field. 

Notes: 

¶ Filter Nodes (SQL) is an optional, advanced, web console feature that 
requires some knowledge of SQL queries. Click + next to Show Filter 
Examples to view a few example filters. 

¶ By default, node list resources are designed to sort nodes alphabetically 
by node caption. This configuration can not be overwritten using a SQL 

filter, so order by  clauses included in SQL filters are redundant and will 

result in Custom SQL filter formatting errors. 

14. Click Submit. 

Grouping Nodes 

Your Orion Web Console can maintain a customizable node list for your network. 
Node lists may be configured for specific views with node grouping. The following 
steps set up node grouping for node lists included in web console views. 

Note: Clicking the resource title in the title bar menu displays the resource by 
itself in a browser window. 

To enable grouping on a node list: 

1. Create a new view or edit an existing view. 

Note: For more information, see ñCustomizing Viewsò on page 40. 

2. Select the view to which you want to add the node list, and then click Edit. 

3. Click + next to the view column in which you want to display the node list. 

4. Click + next to Node Lists. 

5. Check an appropriate node list, and then click Submit. 

6. Click Preview on the Customize YourView  page. 

7. Click Edit in the title bar of the All Nodes ï Tree (AJAX) resource. 

8. If you do not want to use the default title provided, enter a new Title for 
the node list. 

9. If you want a subtitle, enter a new Subtitle for the node list. 

Note: Titles and subtitles may be entered as either text or HTML. 

10. Select up to three criteria, in specified levels, for Grouping Nodes within 
your web console view. 
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11. If you want to apply a SQL filter to the node list, enter an appropriate 
query in the Filter Nodes field. 

Notes: 

¶ Filter Nodes (SQL) is an optional, advanced, web console feature that 
requires some knowledge of SQL queries. Click + next to Show Filter 
Examples to view a few example filters. 

¶ By default, node list resources are designed to sort nodes alphabetically 
by node caption. This configuration can not be overwritten using a SQL 

filter, so order by  clauses included in SQL filters are redundant and will 

result in Custom SQL filter formatting errors. 

12. Click Submit. 

Adding a Service Level Agreement Line to Charts (Orion NPM) 

The Orion Web Console can display a service level agreement (SLA) line on any 
Min/Max/Average bps chart. When you add a customer property named ñSLAò 
and populate the field with your device SLA values, the Orion Web Console will 
display the appropriate line on your charts. 

Notes: 

¶ Interface data is only available in Orion NPM. For more information, see the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

¶ The SLA line may not appear immediately. It may take several minutes for 
the change to be detected by the Orion web engine. 

To add a Service Level Agreement line to Min/Max/Average bps charts: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Add Custom Property, and then confirm that Add Predefined 
Properties is selected. 

3. Check SLA in the list of predefined properties, and then click OK. 

4. Click Properties > Edit Interfaces Properties. 

5. Enter the SLA value (in bps) in the SLA column for each interface you want 

to label with SLA values. For example, type 1544000  for a T1 interface (1.544 

Mbps) or 225000  for a serial connection running at 225 Kbps. 

6. Close the Custom Property Editor. 

7. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

8. Browse to the Interface Details view of one of the interfaces you edited. The 
SLA line displays on any chart showing Min/Max/Average bps. 
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Using the Orion Web Console Message Center 

The Message Center provides a single, customizable view in the web console 
where, in a single table, you can review all events, alerts, traps and Syslog 
messages on your network. 

To view and configure the Message Center: 

1. Click Home > Message Center. 

2. If you only want to see messages for specific devices, select appropriate 
device properties in the Filter Devices area. 

3. In the Filter Messages area, select the Time period for the messages you 
want to review, and then provide the number of messages you want to show. 

4. If you want to show all messages, Including messages that have been 
acknowledged, check Show acknowledged in the Filter Messages area. 

5. If you only want to see certain types of messages, filter messages as 
shown in the following steps: 

a. If you want to view alerts, confirm that Show triggered alerts is 
checked, and then select the type of alerts to display. 

b. If you want to view event messages, confirm that Show event 
messages is checked, and then select the type of events to display. 

c. If you want to view Syslog messages, confirm that Show syslog 
messages is checked, and then select the Severity and Facility of the 
Syslog messages you want to display. 

Note: For more information about Syslog severities and facilities, see 
ñSyslog Message Prioritiesò on page 197. 

d. If you want to view received traps, confirm that Show received traps 
is checked, and then select the Trap type and Community String of the 
traps you want to display. 

6. Click Refresh to update the list of displayed messages. 

Exporting Views to PDF 

Many views in the Orion Web Console may be exported directly to portable 
document format (.pdf). Views that may be exported display Export to PDF in 
the top right corner of the exportable view. 

Note: The Export to PDF feature requires IIS Anonymous Access. Confirm that 
the IUSR_SERVERNAME user is in the local Users group on your Orion server. 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Managing the Orion Web Console Ö 55 

To export a view to PDF: 

1. Open the web console view to export. 

2. Click Export to PDF in the top right corner of the view. 

3. If you are prompted to save the .pdf file, click Save. 

4. Navigate to an appropriate location, provide an appropriate file name, and 
then click Save. 

Creating a Custom Summary View 

The Orion Custom Summary View enables you to create a fully customized 
object-based view composed solely of resources you have selected. The 
following procedure creates a custom summary view in the web console. 

To create or edit a custom summary view in the web console: 

1. Click Home > Custom Summary. 

2. Click Edit in any Custom Object Resource. 

3. Provide a Title and Subtitle for the selected Custom Object Resource. 

4. Click Select Orion Object. 

5. On the Select a network object window, use the Show only and Group by 
selection fields, as appropriate, to filter the list of monitored objects. 

6. Select the Orion object on which you want to base the selected Custom 
Object resource, and then click Select Orion object. 

7. Select the type of information you want the custom resource to display about 
the selected object, and then customize the resource, as indicated in the 
following steps: 

a. If you have selected an alerts resource, indicate whether or not you 
want to display acknowledged alerts by checking or clearing Show 
Acknowledged Alerts, as appropriate. 

b. If you have selected a resource to which SQL filters may be applied, 
edit available SQL filters as appropriate. For more information, see 
ñUsing Node Filtersò on page 63. 

c. If you have selected a resource with an Auto-Hide option, select Yes 
or No to enable or to disable the Auto-Hide feature, respectively. If 
enabled, the resource is automatically hidden if and when related data is 
not present in the Orion database. 

d. If you have selected a sortable list resource, in the Sort By field 
select the property by which you want the list sorted. 
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e. If you have selected a gauge-style resource, select a gauge Style and 
provide a  Gauge Size. 

f. If you have selected a chart-style resource, select an appropriate 
Time Period and Sample Interval, and then indicate whether or not you 
want to show a Trend Line. 

g. If you have selected a Universal Device Poller resource, select the 
Universal Device Poller and Chart Format, and then configure all other 
options as required for similar resource types.  

8. Click Submit. 

Note: For more information about customizing available resource types, click 
Help in the header of any resource on the Custom Summary view, and then 
click the corresponding resource type.  

Creating and Editing External Website Views 

With the external website view feature, any Orion administrator can select any 
external website and designate it as an Orion Web Console view, as shown in 
the following procedure. 

To create or edit an external website view in the web console: 

1. Click Settings in the top right of the web console. 

2. Click External Websites in the Customize grouping of the Orion Website 
Administration page. 

3. If you want to delete an existing external website, click Delete next to the 
website you want to delete, and then click OK to confirm the deletion. 

4. If you want to add a new external website, click Add. 

5. If you want to edit an existing external website, click Edit next to the 
name of the website you want to edit. 

6. Provide a Menu Title for the external website to display in the Views toolbar. 

7. If you want to include a heading within the view, provide an optional 
Page Title to display within the view. 

8. Provide the URL of the external website, in http:// domain_name  format. 

9. Select the Menu Bar to which you want to add the new external website link. 

Note: For more information about customizing menu bars, see ñCustomizing 
Web Console Menu Barsò on page 57. 

10. Click OK. 

11. Click Preview to view the external website as the web console will display it.  
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Customizing the Orion Web Console 

The following sections provide details for customizing your Orion Web Console: 

¶ Customizing Web Console Menu Bars 

¶ Changing the Web Console Color Scheme 

¶ Changing the Web Console Site Logo 

Customizing Web Console Menu Bars 

The menu bars displayed at the top of every page may be configured to display 
various menu items. You can also define menu items and add them to custom 
menu bars. For more information about customizing menu bars for individual 
accounts, see ñEditing User Accountsò on page 98. 

The following procedure customizes a web console menu bar. 

To customize web console menu bars: 

1. Click Settings in the top right of the web console. 

2. Click Customize Menu Bars in the Customize grouping of the Orion Website 
Administration page. 

3. If you want to modify an existing menu, click Edit beneath the menu bar 
you want to modify, and then click and drag items between the Available 
items list on the left and the Selected items list on the right until the Selected 
items list includes all the items you want to include in your edited menu. 

Note: Hover over any view title to read a description. Selected items display 
from left to right in the edited menu bar as they are listed from top to bottom. 

4. If you want to create a new menu bar, complete the following steps: 

a. Click New Menu Bar, and then provide a Name for the New Menu Bar. 

b. Click and drag the buttons you want to include in your new menu bar 
from the Available items list on the left to their correct relative locations in 
the Selected items list on the right. 

Note: Hover over any view title to read a view description. Selected 
items display from left to right in the new menu bar as they are listed 
from top to bottom. 

5. If you want to add menu items, complete the following steps: 

a. Click Edit under the menu bar to which you are adding the new item. 
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b. Click and drag the items you want to include in your new menu from the 
Available items list on the left to their correct relative locations in the 
Selected items list on the right. 

Notes: 

¶ Hover over any view title to read a view description. Selected items 
display from left to right in the new menu bar as they are listed from 
top to bottom. 

¶ If you check Reports from the Select Menu Items page, you must 
also enable reports for the accounts that use the menu bar. For more 
information, see ñConfiguring an Account Report Folderò on 
page 104. 

6. If you want to add a custom menu item, complete the following steps: 

a. Click Edit under the menu bar to which you are adding the custom item. 

b. Click Add. 

c. Provide the Name, URL, and Description of your custom menu item. 

d. If you want the menu option to open in a new window, check Open 
in a New Window. 

e. Click OK. 

7. If you want to delete a menu item, click and drag the item to delete from 
the Selected items list on the right to the Available items list on the left. 

Warning: Do not delete the Admin option from the Admin menu bar. 

8. If you want to change the location of an item in your menu, click and 
drag items to move them up and down in the Selected items list. 

9. If you have finished editing your menu bar, click Submit. 

Changing the Web Console Color Scheme 

The overall color scheme of the Orion Web Console may be changed to any of 
several color schemes that are viewable by all users, as shown in the following 
procedure. 

To change the web console color scheme: 

1. Click Settings in the top right of the web console. 

2. Click Color Scheme in the Customize grouping. 

3. Select the desired color scheme, and then click Submit. 
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Changing the Web Console Site Logo 

The Orion Web Console can be configured to display your logo instead of the 
default SolarWinds banner across the top of every web console page. The 
following steps change the default SolarWinds web console banner. 

To change the web console banner: 

1. Create an appropriately sized graphic to replace the SolarWinds logo. 

Notes: 

¶ The SolarWinds banner file is 271x48 pixels at 200 pixels/inch. 

¶ The SolarWinds.com End User License Agreement prohibits the 
modification, elimination, or replacement of either the SolarWinds.com 
logo and link on the menu bar or the SolarWinds copyright line at the 
bottom of the page. 

2. Place your graphic in the images  directory.  

Note: By default, it is in  C: \ Inetpub \ SolarWinds \ NetPerfMon \ . 

3. Log in to the web console as an administrator. 

4. Click Settings in the top right of the web console. 

5. Click Web Console Settings in the Settings grouping of the Orion Website 
Administration page. 

6. Type the new logo image name as a replacement for SolarWinds .Logo.jpg  

in the Site Logo URL field. 

Configuring the Available Product Updates View 

The Orion Web Console can automatically check for the availability of any 
updates to your currently installed Orion products. By default, the web console 
regularly checks for product updates automatically, as indicated by the dates and 
times reported as Last Check and Next Check, but you can click Check Now at 
any time to see an up-to-the-minute update. If updates are available, a note is 
posted in the web console notification bar and updates are listed in this view, 
where you can then select and download them as needed.  

Note: For more information about downloading listed product updates, see 
ñUpdating your Orion Installationò on page 60. 

To configure product updates: 

1. Log in to the web console as an administrator, and then click Settings in the 
top right corner of the web console. 

2. Click Available Product Updates in the Product Updates grouping. 
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3. If you want to disable the automatic check for product updates, clear 
Check for product updates, and then click Save Settings. 

4. If you want to ensure that updates are listed for all currently installed 
Orion products, including Orion NPM, Orion APM, and all Orion 
modules, check Show all updates. 

5. Click Save Settings. 

Updating your Orion Installation 

If your Product Updates view is configured to list Orion updates, you can 
download them directly from the Product Updates view. 

To update your Orion installation: 

1. Log in to the web console as an administrator, and then click Settings in the 
top right corner of the web console. 

2. Click Available Product Updates in the Product Updates grouping. 

3. Click Check Now to refresh the updates list. 

4. If there are any updates you want to ignore, check the updates to ignore, 
and then click Ignore Selected. 

5. Check the updates you want to apply, and then click Download Selected. 

6. Save and then execute downloaded installers. For more information, see 

either the readme.txt  file packaged with the downloaded update or review 

related documentation available at www.solarwinds.com. 

Orion Web Console and Chart Settings 

The Orion Website Settings page allows an Orion Web Console administrator to 
set a number of options that apply to the web console user environment. The 
following settings are configured on this page: 

¶ Web Console Settings 

¶ Chart Settings 

¶ Discovery Settings 

The following procedure configures web console settings. 

To configure Orion Website and Chart Settings: 

1. Click Settings in the top right of the web console, and then click Web 
Console Settings in the Settings group. 

2. When you finish configuring web console and chart settings, click Submit. 

http://www.solarwinds.com/support/documentation.aspx


SolarWinds Orion Core Ö Administrator Guide 
 

 
Managing the Orion Web Console Ö 61 

Web Console Settings 

The following options are configured on the Orion Web Console Settings page: 

¶ Session Timeout is the amount of time (in minutes) the Orion Web Console  
waits through user inactivity before the user is logged out. 

¶ Windows Account Login allows you to select whether or not you want to 
enable automatic login with Windows Active Directory credentials. By 
enabling this feature, in the future, the current user will be automatically 
logged-in. 

¶ Page Refresh specifies the amount of time that passes before a web 
console page, or view, reloads automatically. 

¶ Site Logo URL is the local path to the banner graphic that appears at the top 
of every web console page. For more information about changing the banner 
to display your logo, see ñChanging the Web Console Site Logoò on page 59. 

¶ Site Login Text is optional text displayed on the Orion Web Console login 
page. The text entered here is seen by all web console users when they log 
in. HTML tags are allowed. 

¶ Help Server is the URL of the server where online help for Orion products is 
stored. The default location is http://www.solarwinds.com. If you are in an 
Internet-restricted network environment but require access to online help, 
download the entire online help, copy it to a web server, and then change the 
Help Server URL to that of the web server. You can download the online help 
from http://www.solarwinds.com/support/Orion/docs/OrionLocalHelp.zip. 

¶ Status Rollup Mode establishes the way the availability status of a 
collection of nodes on the node tree or on a map is displayed in the web 
console. For more information about the types of information communicated 
using status icons, see ñStatus Icons and Identifiersò on page 265. For more 
information, see ñStatus Rollup Modeò on page 267. 

There are two options for the case when there are nodes of differing statuses 
in a selected group: 

¶ Mixed Status shows Warning, the default status, ensures the status of 
a node group displays the worst warning-type state in the group. If none 
of the group members have a warning-typed state but the group contains 
both up and down nodes, a Mixed Availability warning state is displayed 
for the whole group. For example, Critical  + Down = Critical , 

Critical  + Warning  = Critical , and Up + Down = Mixed 

Availability . 

¶ Show Worst Status ensures the worst state in a node group is 

displayed for the whole group. For example, Up + Down = Down and 

Unreachable  + Shutdown  = Shutdown . 

http://www.solarwinds.com/
http://www.solarwinds.com/support/Orion/docs/OrionLocalHelp.zip
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¶ Child Status Rollup Mode indicates how the status of any single node on 
the node tree or on a map is displayed. You can show the status of the node 
and its children, node status and interfaces, if you have Orion NPM installed, 
or just node ICMP status. 

Select Show Worst Status to ensure that the worst status of the node group 
is displayed for the whole group (e.g. red if any of the nodes are down). 
Select Show Worst Status (Interfaces only) to ensure that the worst status 
of any of the interfaces on a selected node is displayed. Select Show only 
ICMP Status to only display up/down status for monitored interfaces. 

¶ Child Status Display Mode designates how the status of the children of any 
single node on the node tree or on a map is displayed. You can show the 
status of the node and any of its children with either a static of a blinking 
icon. By default, Orion uses a static icon to display the status of child objects. 

Chart Settings 

The following chart settings may be configured in the Chart Settings section of 
the Web Console Settings page: 

¶ Chart Aspect Ratio is the height/width ratio for web console charts. This 

ratio should be set between 0.25  and 3.0  to avoid erratic display problems, 

though the performance of individual systems may differ. 

¶ Thumbnail Aspect Ratio is the height/width ratio for chart thumbnails. 

¶ 95th Percentile Calculations is a setting that adds annotation lines to charts 
at the entered percentile. This value is normally set to 95. For more 
information, see ñ95th Percentile Calculationsò on page 285. 

¶ Font Size sets the default relative size, Small, Medium, or Large, of the text 
that is displayed within charts in the Orion Web Console. This setting is 
independent of your browser settings. The font settings in your browser will 
affect resource headers and some resource contents. 

Discovery Settings 

The Discovery Settings section provides the Notify about new removable 
volumes option. This option allows you to indicate whether or not you want to be 
notified when removable volumes are added to your network and discovered 
during network discovery. For more information about network discovery in 
Orion, see ñDiscovering and Adding Network Devicesò on page 17. 
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Using Node Filters 

When you are managing or monitoring large numbers of network devices, node 
list resources can easily become very large and difficult to navigate. Filters are 
optional SQL queries that are used to limit node list displays for easier resource 
navigation. SQL queries can be made on any predefined or custom properties. 
For more information about defining custom properties, see ñCreating Custom 
Propertiesò on page 209. 

To apply a node filter: 

1. Click Edit in any node list resource. 

2. Provide an appropriate SQL query in the Filter Nodes (SQL) field, and then 
click Submit. 

The following are a few example filters with associated SQL queries. 

Note: By default, node list resources are designed to sort nodes alphabetically 
by node caption. This configuration can not be overwritten using a SQL filter, so 
order by  clauses included in SQL filters are redundant and will result in Custom 

SQL filter formatting errors. 

¶ Filter the results to only show nodes that are not Up: 

Status<>1  

The following are valid status levels: 

o 0 = Unknown (current up/down status of the node is unknown)  

o 1 = Up (The node is responding to PINGs)  

o 2 = Down (The node is not responding)  

o 3 = Warning (The node may be responding, but the connection from 

the server to the Node is dropping packets)  

¶ Only show Cisco devices: Vendor = 'Cisco'  

¶ Only show devices in Atlanta. (using a custom property named City): 

City = 'Atlanta'  

¶ Only show devices beginning with "AX3-": Caption Like 'AX3 - *'  

¶ Only show Nortel devices that are Down:  

Vendor Like 'Nortel*' AND Status=2  

¶ Only show devices ending in '-TX': Vendor Like '* - TX'  
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Custom Charts in the Orion Web Console 

The Orion Web Console provides charts for all monitored objects that you can 
customize for your own use, as detailed in the following sections. 

Customizing Charts in the Orion Web Console 

Clicking any chart opens the Custom Chart view in a new window, displaying the 
selected chart with additional chart customization options. For more information 
about the Custom Chart view, see ñCustom Chart Viewò on page 67. 

You can also configure any custom chart resource in the Orion Web Console 
directly from the resource title bar either by selecting from the dropdown menu of 
options or by clicking Edit to display the Edit Chart Title view, as described in the 
following sections.  

Custom Chart Resource Title Bar Options 

The title bar menu of the custom chart resource provides the following options for 
viewing chart data: 

¶ View chart data over the Last 7 Days or over the Last 30 Days 

¶ Select Edit Chart to view and modify chart settings. 

Note: This is the same as clicking Edit in the title bar. 

¶ View Chart Data as an HTML format document 

¶ View Chart Data in Excel to see chart data in an ExcelÊ-compatible format 

Edit Chart Title View 

Click Edit in the title bar of a custom chart resource to display the Edit Chart Title 
view. This view provides the following options to configure your chart resource: 

¶ Select a Chart allows you to change the chart type displayed in the current 
resource. Chart options are determined in accordance with the type of view 
displaying the resource you are currently editing. For more information about 
available node charts, see ñCustom Node Chartsò on page 65. For more 
information about available volume charts, see ñCustom Volume Chartsò on 
page 66. 

¶ The Time Period for the selected chart may be any of the following: 

Last Hour Last 2 Hours Last 24 Hours Today 

Yesterday Last 7 Days This Month Last Month 

Last 30 Days Last 3 Months This Year Last 12 Months 
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¶ The Sample Interval for the selected chart may be any of the following: 

Every Minute Every 5 Minutes Every 10 Minutes Every 15 Minutes 

Every 30 Minutes Every Hour Every 2 Hours Every 6 Hours 

Every 12 Hours One a Day Every 7 Days  

 

Notes: 

¶ Each sample interval is represented on a chart by a single point or bar. 
Data within a selected sample interval is summarized automatically. 

¶ Due to limits of memory allocation, some combinations of time periods 
and sample intervals require too many system resources to display, due 
to the large number of polled data points. As a result, charts may not 
display if the time period is too long or if the sample interval is too small. 

¶ The Trend Line option allows you to enable the trend line feature of Orion 
charts. By enabling trend lines on Orion charts, you can see potential future 
results as they are extrapolated from collected historical data. 

Note: Due to the broad array of factors that can affect the performance of 
devices on your network, trend lines provided on Orion charts are intended 
as approximate predictions of future data only. 

For more information about customizing web console views, see ñCustomizing 
Viewsò on page 40. Some charts also provide a 95

th
 Percentile marker for your 

reference. For more information, see ñ95
th
 Percentile Calculationsò on page 285. 

Custom Node Charts 

The following node-related charts, grouped by type, are available as resources 
within the Orion Web Console. To add any of these charts to a web console view 
dealing with monitored nodes, add the Custom Node Chart resource to the Node 
Details view. For more information about adding resources to Orion Web 
Console views, see ñCustomizing Viewsò on page 40. For more, see ñOrion Web 
Console and Chart Settingsò on page 60. 

Availability 

The following charts are available to display node availability information over 
custom time periods for nodes monitored by Orion. 

¶ Availability 

¶ Availability ï Autoscale 

¶ Availability and Response Time 
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CPU Load 

The following charts display CPU loading information over specified periods of 
time for nodes monitored by Orion.  

¶ Average CPU Load 

¶ Min/Max/Average CPU Load 

Memory Usage 

The following charts present memory usage information over custom time 
periods for nodes monitored by Orion. 

¶ Average Memory Usage 

¶ Memory/Buffer Failures 

¶ Min/Max/Average Memory Usage 

¶ Percent Memory Used 

Packet Loss and Response Time 

The following charts are available to display historical statistics about packet loss 
and response time for nodes monitored by Orion. 

¶ Availability and Response Time 

¶ Average Response Time 

¶ Average Response Time and Packet Loss 

¶ Min/Max/Average Response Time 

¶ Min/Max/Average Response Time and Packet Loss 

¶ Percent Loss ï Bar Chart 

¶ Percent Loss ï Line Chart 

Custom Volume Charts 

The following volume-related charts, grouped by type, are available as resources 
within the Orion Web Console. To add any of these charts to a web console view 
dealing with monitored volumes, add the Custom Volume Chart resource to the 
Volume Details view. For more information about adding resources to Orion Web 
Console views, see ñCustomizing Viewsò on page 40. For more information about 
customizing the following charts, see ñOrion Web Console and Chart Settingsò on 
page 60. 
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Allocation Failures 

Shows the number of disk allocation failures that have occurred on the 
selected volume. 

Min/Max/Average Disk Usage 

Shows both the total disk space available and the average amount of disk 
space used on the selected volume. Bars are also included to show minimum 
and maximum levels of disk usage. 

Percent Disk Usage 

Shows the total available disk space and the average amount of disk space 
used, as a percentage of the total available, on the selected volume. 

Volume Size 

Shows the total disk space available on the selected volume. 

Custom Chart View 

Charts in the Orion Web Console are easily customizable. Clicking a chart opens 
the Custom Chart view in a new window. The following sections describe options 
that are available on the Custom Chart page to modify the presentation of a 
selected chart. 

Note: Click Refresh at any time to review changes you have made. 

Printing Options 

To print your customized chart, click Printable Version and a printable version of 
your customized chart displays in the browser. 

Chart Titles 

Chart Titles are displayed at the top center of a generated chart. The Chart Titles 
area allows you to modify the Title and Subtitles of your generated chart. 

Note: Orion may provide default chart titles and subtitles. If you edit any of the 
Chart Titles fields on the Custom Chart page, you can restore the default titles 
and subtitles by clearing the respective fields, and then clicking Submit. 

Time Period 

Predefined and custom time periods are available for generated charts. You may 
designate the time period for a chart by either of the following methods: 

¶ Select a predefined period from the Select a Time Period: menu. 

¶ Provide custom Beginning and Ending Dates/Times in the appropriate 
fields in the Time Period area. 
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Sample Interval 

The sample interval dictates the precision of a given chart. A single point or bar is 
plotted for each sample interval. If a sample interval spans multiple polls, data is 
automatically summarized and plotted as a single point or bar on the chart. 

Note: Due to limits of memory allocation and the large number of polled data 
points, some combinations of time periods and sample intervals may require too 
many system resources to display. As a result, charts may not display if the time 
period is too long or if the sample interval is too small. 

Chart Size 

Chart Size options configure the width and height, in pixels, of the chart. You can 
maintain the same width/height aspect ratio, or scale the chart in size, by 
entering a width in the Width field and then entering 0 for the Height. 

Font Size 

Font sizes for generated charts are variable. The Font Size option allows you to 
select a Small, Medium, or Large size font for your chart labels and text.  

Note: Font Size selections are maintained in the printable version of your chart. 

Data Export Options 

The Display Data from Chart area provides the following options to export chart 
data as either Excel-compatible Raw Data or as HTML-formatted Chart Data: 

¶ To view chart data in an Excel-compatible format, click Raw Data, and then 
follow the prompts, if provided, to open or save the resulting raw data file. 

¶ To view HTML-formatted chart data in a new browser, click Chart Data. 

Custom Object Resources in the Orion Web Console 

The Orion Web Console provides a Custom Object resource that enables you to 
configure any of a wide array of resources to display performance data for any 
specific monitored objects. The following sections provide more information 
about editing a Custom Object resource, selecting monitored objects, and 
configuring the data displayed in a Custom Object resource: 

¶ Editing a Custom Object Resource 

¶ Selecting Custom Objects and Resources 

¶ Available Custom Resources 
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Editing a Custom Object Resource 

The following procedure edits a Custom Object resource. 

To edit a Custom Object resource: 

1. Click Edit in the header of a Custom Object resource. 

2. Edit the resource Title and Subtitle as appropriate. 

3. Click Select Orion Object to select an appropriate monitored object. For 
more information, see ñSelecting Custom Objectsò. 

4. If you have completed your edits, click Submit. 

Selecting Custom Objects and Resources 

The following procedure selects a network object for a selected Custom Object 
resource. 

To select a custom monitored object for a Custom Object resource: 

1. Click Edit in the header of a Custom Object resource. 

2. Click Select Orion Object. 

3. In the Show only: field, select the type of object you want to monitor in the 
Custom Object resource. 

4. In the Group by: field, select an appropriate object grouping criterion. 

Note: Defined custom properties are listed for all grouping types. 

5. Click the object to monitor in the list on the left, ad then select it in the main 
pane.grouping criterion. 

6. Click Select Orion Object. 

7. Select the desired resource type in the Select object resource field, and 
then configure options as required. For more information about available 
resources, see ñAvailable Custom Resourcesò. 

Available Custom Resources 

A Custom Object resource may be configured to provide the same data as any of 
a number of Orion Web Console resources for a selected network object: 

Notes: 

¶ Resource availability is dependent on the Orion products installed. 

¶ For more information about any available custom resource, click Help in the 
resource title to view the corresponding help topic. 
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Integrating SolarWinds Engineerôs Toolset 

When you are browsing the Orion Web Console from a computer that already 
has a SolarWinds Toolset installed, Orion allows you to launch Toolset tools 
directly from your web browser. Right-clicking any monitored object listed in an 
Orion Web Console running the Toolset Integration displays a menu of available 
Toolset tools and functions. The following sections detail the configuration of the 
available Toolset integration. 

Note: For more information about the SolarWinds Engineerôs Toolset tools, see 
www.solarwinds.com. 

Configuring a Toolset Integration 

The following procedure configures SolarWinds Toolset for integration within the 
Orion Web Console. 

Note: The first time the Toolset tools are accessed, a security warning may be 
displayed. Click Yes to allow the toolset integration. 

To configure SolarWinds Toolset integration settings: 

1. Right-click any monitored object displayed within the Orion Web Console. 

2. Click Settings. 

3. Click SNMP Community String. 

Note: The first time you launch a tool requiring an SNMP community string 
from the right-click menu, the SNMP Community String window displays. 

4. If you want to delete any or all saved community strings, select the 
strings that you want to delete, and then click Remove, or click Remove All. 

5. Click Menu Options, and then configure the right-click menu as follows: 

a. If you want either to add menu items to the right-click menu or to 
remove menu items from the right-click menu, move menu items 
between the list of Available Menu Options on the left and Selected 
Menu Options on the right by selecting items in either column and 
clicking the right and left arrows, as appropriate. 

b. If you want to change the order of menu items, select items and then 
click the up and down arrows next to the Selected Menu Options list. 

c. If you want to add a separator between items, move the -------------- 
menu option from the Available list to the Selected list, and then move it 
to your preferred location within the Selected Menu Options list. 

6. Click Automatic Menu Items. 
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7. Check either or both, if available, of the following options: 

¶ Automatically add sub-menu items to the ñMIB Browser (Query 
MIB)ò menu option from the MIB Browerôs Bookmarks. 

¶ Automatically add sub-menu items to the ñReal Time Interface 
Monitorò menu option from the Real-Time Interface Monitor saved 
report types. 

Note: These options expand the list of available menu items by incorporating 
menu links to MIB browser bookmarks and Real-Time Interface Monitor 
saved reports, respectively. 

Adding Programs to a Toolset Integration Menu 

The following procedure provides the steps required to add any external scripts 
or applications to the SolarWinds Toolset integration menu. 

To add a program to the SolarWinds Toolset Integration menu: 

1. If you want to add an external script to the Toolset Integration menu, 
save the script in an appropriate location on the install volume of your Orion 

server (e.g. <InstallVolume >: \ \ Scripts \ ). 

2. If you want to add an external application to the Toolset Integration 
menu, install the application in an appropriate location on the install volume 

of your Orion server (e.g. <InstallVolume >: \ \ Application \ ). 

3. Open SWToolset. MenuOptions , the Toolset Integration menu configuration 

file,  in a text editor. 

Note: By default, SWToolset. MenuOptions  is located in the following folder: 

<InstallVolume >: \ \ Program Files \ SolarWinds \ Common\ . 

4. Save a copy of SWToolset. MenuOptions  as SWToolset _Old . MenuOpt ions . 

5. Add the following line between the <MenuOptions>< / MenuOptions>  tags of 

the SWToolset. MenuOptions  file: 

<MenuOption Visible="TRUE" Title=" ApplicationName " 

BeginGroup="FALSE" HasSubMenu="FALSE" 

ExecString=" <Ins tallVolume >: \ \ Application \ ExecutableFile " 

Icon="" Extra="" Parent="" Required="4"/>  

Note: The string supplied for Title  is the name for the added script or 

application that will display in the menu. The string supplied for the 

ExecString  is the path to the script or application executable file.  

6. Save the new SWToolset. MenuOptions  to automatically update the Toolset 

Integration menu. 
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Accessing Nodes Using HTTP, SSH, and Telnet 

The Orion Web Console supports the use of HTTP, SSH, and Telnet protocols 
for remote device access if associated applications like PuTTy and FiSSH on 
your Orion server are properly registered. For more information, see the MSDN 
article, ñRegistering an Application to a URL Protocolò. Launch remote access 
applications from any Details view as follows: 

¶ To browse directly to the viewed device using a web browser, click . 

¶ To open a secure shell (SSH) to a monitored device, click . 

¶ To open a Telnet session with a monitored device, click . 

Using Integrated Remote Desktop 

Sometimes it is necessary to console into a remote server to troubleshoot an 
issue. This can be accomplished within the Orion Web Console as follows. 

Note: Press Ctrl+Alt+Break  to enter/exit full screen mode. 

To launch Integrated Remote Desktop: 

1. Open the Node Details view for the server you want to view remotely. 

Note: The easiest way to open the Node Details view is to click the remote 
server you want to view in any All Nodes resource.  

2. Click , located at the of the Node Details view. 

Note: Depending on the security settings of your browser, you may be asked 
to install an ActiveX control for remote desktop viewing. Follow all prompts to 
install this required control. 

3. Verify the Server IP address or hostname, select an appropriate Screen 
Size, and then click Connect. 

Managing Orion Web Console Configurations 

Orion Web Console configurations store all account, menu bar, and view settings 
The Orion Web Configuration Backup/Restore utility allows you to complete each 
of the following related tasks: 

¶ Creating a Web Console Configuration Backup 

¶ Restoring a Web Console Configuration Backup 

¶ Clearing a Web Console Configuration 

http://msdn.microsoft.com/en-us/library/aa767914(VS.85).aspx
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Creating a Web Console Configuration Backup 

The following procedure uses the Orion Web Configuration Backup/Restore utility 
to create a backup of your Orion Web Console configuration. 

Note: The Orion Web Configuration Backup/Restore utility does not create a 
backup of the Orion database. As a result, configuration backups do not retain 
any of the network device data or statistics for any monitored network objects. 
For more information about creating a backup of your Orion database, see 
ñManaging the Orion Databaseò on page 217. 

To create an Orion Web Console configuration backup: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Web Configuration Backup. 

3. Click Create Backup. 

4. Confirm that the Orion folder is open or browse to it, located, by default within 

<Vol ume:> \ Program Files \ Solarwinds \ . 

5. Provide an appropriate file name and location, click Save, and then click OK 
when the web console configuration backup is completed. 

Restoring a Web Console Configuration Backup 

The following procedure uses the Orion Web Configuration Backup/Restore utility 
to restore a saved backup of your Orion Web Console configuration. 

Warning: Do not restore web console configurations from any version of Orion 
prior to the version currently installed. 

To restore an Orion Web Console configuration backup: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Web Configuration Backup. 

3. In the Restore Web Site Configuration area, select the configuration backup 
file you want to restore. 

4. If you want the restored web console configuration to overwrite your 
current configuration, select Overwrite, and then click Restore Backup. 

5. If you want the restored web console configuration to merge with your 
current configuration, select Merge, and then click Restore Backup. 

6. Click Yes to confirm the restoration of the selected configuration backup. 
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Clearing a Web Console Configuration 

The following procedure clears an existing Orion Web Console configuration. 

Warning: Clearing a web console configuration deletes all existing user 
accounts, account and view settings, and menu bar customizations. SolarWinds 
recommends you create a backup of your current Orion Web Console 
configuration before you clear it to confirm that no issues arise as a result of the 
deletion of your web console customizations. 

To clear your Orion Web Console configuration: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Web Configuration Backup. 

3. Click File > Clear Web Configuration. 

4. Click Yes to confirm the deletion of your current web console configuration. 

5. Click OK after the web console configuration is cleared. 
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Chapter 5 

Managing Devices in the Web Console 

Managing all the monitored devices on your network is greatly simplified with the 
Node Management feature of the Orion Web Console. Using this tool, you can 
easily add and remove devices and quickly view and edit device properties. Any 
user that has been granted node management rights can directly access the 
Node Management tool either from any All Nodes resource or through the Orion 
Website Administration page. For more information about granting node 
management rights, see ñEditing User Accountsò on page 98. The following 
sections describe the various functions that allow you to view and manage all 
your network devices from the Orion Web Console. 

Note: The Node Management feature is accessible by clicking Manage Nodes 
either in the header of any All Nodes resource or in the Node & Group 
Management grouping of the Orion Website Administration page. The All Nodes 
resource is included on the Orion Summary Home view by default, but you can 
include it on any other web console view as well. Confirm that the All Nodes 
resource is available on an appropriate Web Console view before continuing. For 
more information about adding resources to Orion Web Console views, see 
ñEditing Viewsò on page 41. 

Adding Devices for Monitoring in the Web Console 

The following procedure details the steps required to add a device for monitoring 
in the Orion Web Console. 

Note: This procedure does not specifically address the addition of objects that 
are specifically monitored solely by individual Orion products, as in the case of 
monitoring interfaces with Orion NPM and monitoring applications with Orion 
APM. For more information about adding interfaces and applications, see the 
SolarWinds Orion Network Performance Monitor Administrator Guide and the 
SolarWinds Orion Application Performance Monitor Administrator Guide, 
respectively. 

To add a device for monitoring in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. Click Add Node on the Node Management toolbar. 
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5. Provide the hostname or IP Address of the node you want to add in the 
Hostname or IP Address field. 

6. If the IP address of the node you are adding is dynamically assigned, 
check Dynamic IP Address. 

7. If you only want to use ICMP to monitor node status, response time, or 
packet loss for the added node, check ICMP (Ping only). 

8. If you want to add an External node to monitor a hosted application 
with Orion Application Performance Monitor, check External. 

Note: The External status is reserved for nodes hosting applications that are 
to be monitored with Orion Application Performance Monitor. Orion will not 
collect or monitor any data about a node itself, if it is marked as External,. 

9. If you are adding a VMware device, check Poll for VMware to ensure that 
Orion NPM acquires any data the Vmware device provides to SNMP polling 
requests, and then complete the following steps to provide required vCenter 
or ESX Server credentials. For more information, see ñVirtualizationò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

a. Select an appropriate vCenter or ESX credential. 

Notes: 

¶ If you are creating a new credential, select <New Credential>. 

¶ If you are editing an existing credential, select the credential you 
want to edit. 

¶ SolarWinds recommends against using non-alphanumeric characters 
in VMware credential names. 

b. If you are creating a new credential, provide a Credential name. 

c. Provide an appropriate User name and a Password, and then provide 
the password again in the Confirm password field. 

d. Click Test to confirm the VMware credentials you have provided. 

10. If you want to use SNMP to monitor the added node, confirm that ICMP 
(Ping only) is cleared, and then complete the following steps: 

a. Select the SNMP Version for the added node. 

Notes: 

¶ Orion uses SNMPv2c by default. If the device you are adding 
supports or requires the enhanced security features of SNMPv3, 
select SNMPv3. 

¶ If SNMPv2c is enabled on a device you want Orion to monitor, by 
default, Orion will attempt to use SNMPv2c to poll for performance 

../Orion-NPM/OrionNPMAdministratorGuide.doc#Virtualization
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information. If you only want Orion to poll using SNMPv1, you must 
disable SNMPv2c on the device to be polled. 

b. If you have installed multiple polling engines, select the Polling 
Engine you want to use to collect statistics from the added node. 

Note: This option may not be available if you are only using one polling 
engine to collect information from your network. 

c. If the SNMP port on the added node is not the Orion default of 161, 
provide the actual port number in the SNMP Port field. 

d. If the added node supports 64-bit counters and you want to use 
them, check Allow 64-bit counters. 

Note: Orion fully supports the use of 64-bit counters; however, these 
high capacity counters can exhibit erratic behavior depending on 
manufacturer implementation. If you notice peculiar results when using 
these counters, use the Node Details view to disable the use of 64-bit 
counters for the device and contact the hardware manufacturer. 

11. If you want Orion to use SNMPv2c to monitor the added node, provide 
valid community strings for the added node. 

Note: The Read/Write Community String is optional, but Orion does 

require the public  Community String, at minimum, for node monitoring. If 

you want to use read/write SNMPv3 credentials, complete the following steps 
in the Read / Write SNMPv3 Credentials area.  

12. If you want Orion to use SNMPv3 to monitor the added node, provide the 
following SNMP Credentials, Authentication, and Privacy/Encryption 
settings: 

¶ SNMPv3 Username, Context, Authentication Method, and Password. 

Note: If this password is a key, check Password is a key. 

¶ SNMPv3 Privacy/Encryption Method and Password. 

Note: If this password is a key, check Password is a key. 

13. If you want to save the provided credentials as a credential set, provide 
a Name, and then click Save. 

14. If you want to delete a currently saved credential set, select the set to 
delete, and then click Save. 

15. If you are using SNMP to communicate with your added node, click 
Validate SNMP after entering all credentials to confirm your SNMP settings. 

16. Click Next. 
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17. Check the objects for the added node that you want Orion to monitor or 
manage. The following options are available in the selection toolbar: 

¶ Clicking All selects all listed devices and charts for monitoring. 

¶ Clicking None clears any checked interfaces, volumes, or interface 
charts that have been selected for monitoring. 

¶ Clicking All Volumes selects all listed volumes for monitoring. 

18. After you have selected objects for monitoring, click Next. 

19. If you want to edit the SNMP settings you provided earlier, change the 
appropriate values in the SNMP area of the Change Properties page, and 
then click Validate SNMP to confirm your new settings. 

20. If you want to edit the default polling settings for your added node, 
change the Node Status Polling or Collect Statistics Every values in the 
Polling area of the Change Properties page, as appropriate. 

Note: The Node Status Polling value refers to the number of seconds, 
between the node status checks Orion performs on the added node. The 
Collect Statistics Every value refers to the period of time between the 
updates Orion makes to displayed statistics for the added node. 

21. If you have defined any custom properties for monitored nodes, provide 
appropriate values for the added node in the Custom Properties area of the 
Change Properties page. 

Note: The Custom Properties area is empty if you have not defined any 
custom properties for monitored network objects. 

22. Click OK, Add Node when you have completed properties configuration. 

23. If you have successfully added the node, click OK on the dialog. 

Deleting Devices from Monitoring 

The following procedure deletes devices from monitoring in the web console. 

Warning: Deleting nodes from monitoring in the web console automatically stops 
monitoring of all applications, interfaces, and volumes on the deleted nodes. 

Note: You can select multiple devices to delete at the same time. Additionally, 
using the search tool above the node list, you can select multiple interfaces on 
different nodes for simultaneous deletion.  

To delete devices from monitoring in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 
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3. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. If you want to delete a node and all its applications, interfaces, and 
volumes from monitoring, complete the following steps. 

a. Locate the node to delete using either of the following methods: 

¶ Use the search tool above the node list to search your Orion 
database for the node you want to delete. 

¶ Select an appropriate Group by: criterion, and then click the 
appropriate group including the node to delete. 

b. Check the node to delete in the list, and then click Delete on the toolbar. 

5. If you want to delete a monitored application, interface, or volume, use 
the following steps. 

a. Locate the element to delete using either of the following methods: 

¶ Use the search above the node list to search your Orion database 
either for the object to delete or for its parent object to delete. 

¶ Select a Group by: criteria, and then click the appropriate group 
including the parent node of the object to delete. 

b. If you have a list of node results, click + to expand the parent node of 
the object you want to delete. 

c. Check the object to delete, and then click Delete on the toolbar. 

6. Click OK to confirm deletion. 

Viewing Node Data in Tooltips 

Node tooltips in Orion provide immediate status overviews of monitored nodes. 
To view a quick overview of any monitored node in the web console, hover over 
the device name. The information in the following tables displays immediately. 

Notes: If Orion NPM is installed, interface data is also available in tooltips,. For 
more information, see ñViewing Interface Data in Orion NPM Tooltipsò in the 
SolarWinds Orion Network Performance Monitor Administrator Guide. 

Node Data 

Node Status 
Current status of the node. (up, down, warning,  unmanaged, 
or unreachable) 

IP Address The IP address currently assigned to the selected node 

Machine Type The vendor icon and vendor description of the selected node 

Average Response Time 
The measured average response time of the selected node 
as of the last node poll 
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Node Data 

Packet Loss 
The percent of all transmitted packets that are lost by the 
selected node as of the last node poll 

CPU Load 
The percent of available processing capacity on the selected 
node that is currently used as of the last node poll 

Memory Used 
The percent of available memory on the selected node that 
is currently used as of the last node poll 

 

Editing Object Properties 

The following procedure provides the steps required to edit monitored object 
properties using the Node Management utility of the Orion Web Console. 

To edit object properties in the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Nodes in the Node & Group Management grouping. 

3. Locate the object to edit using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database 
for either the object you want to edit or the parent node of the volume 
you want to edit. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including either the node to edit or the parent of the object to edit. 

4. If you want to edit the properties of a monitored node, check the node 
you want to edit, and then click Edit Properties. 

5. If you want to edit the properties of a monitored object, click + next to the 
parent node of the object you want to edit, check the object you want to edit, 
and then click Edit Properties. 

6. If you are editing the SNMP properties of a node, click Test after 
providing new settings to confirm they are valid for the edited node. 

7. If the selected node is a VMware ESX Server and you want to poll it for 
data using the VMware API, Confirm that Poll for VMware is checked. 

8. If you want to poll for ESX data using an existing ESX credential, select 
the appropriate credential from the VMware credentials dropdown menu. 
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9. If you want to poll for ESX data using a new ESX credential, complete 
the following steps: 

a. Select <New Credential> in the Choose Credential dropdown menu, 
and then provide a new credential name in the Credential Name field. 

Note: SolarWinds recommends against using non-alphanumeric 
characters in VMware credential names. 

b. Add the credential User name and Password, as necessary. 

c. Confirm the password, and then click Validate VMware to confirm the 
credentials you have provided are valid for the edited node. 

10. Edit additional device properties as needed, and then click Submit. 

Promoting a Node from ICMP to SNMP Monitoring 

After adding a node to the Orion database as an ICMP only node, you may need 
to promote the node to SNMP to start collecting additional statistics. the Node 
Management utility of the Orion Web Console can easily promote your node to 
SNMP without any loss of historical data. 

To promote an ICMP only node to SNMP: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

and then click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

3. Locate the device to promote using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database 
for the node you want to promote. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including the node to promote. 

4. Click Edit Properties, and then clear ICMP (Ping only). 

5. In the SNMP area, select the SNMP Version for the promoted node. 

Note: Orion uses SNMPv2c by default. If the promoted device supports or 
requires the enhanced security features of SNMPv3, select SNMPv3. 

6. If you have installed multiple polling engines, select the Polling Engine 
you want to use to collect statistics from the added node. 

Note: This option may not be available if you are only using one polling 
engine to collect information from your network. 
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7. If the SNMP port on the added node is not the Orion default of 161, 
provide the actual port number in the SNMP Port field. 

8. If the added node supports 64 bit counters and you want to use them, 
check Allow 64 bit counters. 

Note: Orion fully supports the use of 64-bit counters; however, these high 
capacity counters can exhibit erratic behavior depending how they are used. 
If you notice peculiar results when using these counters, use the Edit 
Properties view to disable the use of 64-bit counters on the device in 
question, and then contact the hardware manufacturer. 

9. If you want to use SNMPv2c to monitor the promoted node, provide valid 
community strings for the added node. 

Note: The Read/Write Community String is optional, but Orion does 

require the public  Community String, at minimum, for node monitoring. 

10. If you want to use SNMPv3 to monitor the promoted node, provide the 
following SNMPv3 credential settings: 

¶ SNMPv3 Username and Context 

¶ SNMPv3 Authentication Method and Password/Key 

¶ SNMPv3 Privacy/Encryption Method and Password/Key 

Note: Read/Write SNMPv3 Credentials are optional, but the public  

Community String is required, at a minimum, for node monitoring. 

11. If you want to edit an existing SNMPv3 credential set, select the name of 
your set from the Saved Credential Sets list, and then edit the stored 
settings.. 

12. If you want save the provided SNMPv3 credentials as a credential set, 
provide a Name for your new credential set, and then click Save. 

13. Click Validate SNMP after entering all required credentials to confirm your 
SNMP settings. 

14. If you want to change the default polling settings for your promoted 
node, edit the Node Status Polling or Collect Statistics Every values in 
the Polling area, as appropriate. 

Note: The Node Status Polling value refers to the period of time, in 
seconds, between the node status checks Orion performs on the promoted 
node. The Collect Statistics Every value refers to the period of time 
between updates Orion makes to displayed statistics for the promoted node. 

15. If you have defined any custom properties for monitored nodes, provide 
appropriate values for the promoted node in the Custom Properties. 
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16. Click Submit when you have completed properties configuration for your 
promoted node. 

17. If you have successfully added the node, click OK on the dialog. 

Viewing Node Resources 

The List Resources feature of the Orion Web Console Node Management utility 
allows you to immediately see all monitored interfaces, volumes, and interface 
charts on a selected node, as shown in the following procedure. 

To view a list of all resources present on a node: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. Locate the node to view using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database 
for the node you want to view. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including the node to view. 

5. Check the node you want to view from the list, and then click List 
Resources on the Node Management toolbar. 

Setting Device Management States 

Monitored devices are regularly polled for operational status. Collected statistics 
are displayed in the Orion Web Console. Using the Node Management feature of 
the Orion Web Console, the management status of monitored nodes, is easily set 
or changed, allowing you to either temporarily suspend data collection or resume 
polling and statistics collection, as necessary. The following procedure sets or 
changes management states for monitored nodes in the Orion Web Console. 

Note: Setting a node to an unmanaged state automatically suspends the 
management of all interfaces and volumes on the selected node. 

To set or change the management state of a node: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 
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4. Locate the node to manage using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database 
for the device you want to manage. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including the node to manage. 

5. Check the node to change, and then click Unmanage or Remanage, as 
appropriate, for the selected node. 

6. If you have selected Unmanage, provide start and end times and dates for 
your management suspension, and then click OK. 

Unscheduled Device Polling and Rediscovery 

Orion polls devices for statistics and status regularly, according to the polling 
settings available for configuration on the Polling Settings view in the Orion Web 
Console. For more information, see ñOrion Polling Settingsò on page 107. 
Sometimes, however, it may be necessary to conduct an unscheduled poll or 
rediscovery of a monitored device. The Node Management utility gives you this 
ability, as shown in the following procedure. 

To perform an unscheduled poll or rediscovery: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. Locate and check the node or interface you want to poll or locate and check 
the node to rediscover, using either of the following methods: 

¶ Use the search tool above the node list to search your Orion database. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including either the node or interface you want to poll or the node 
you want to rediscover. 

5. If you want to poll the selected node or interface, click More Actions > 
Poll Now. 

6. If you want to rediscover the selected node, click More Actions > 
Rediscover. 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Managing Devices in the Web Console Ö 85 

Monitoring Windows Server Memory 

When Orion polls a Windows server for CPU load and memory utilization, it pulls 
the amount of physical memory to define the 100% level, and then it totals the 
amount of memory in use by each allocation to compute what percentage of the 
physical memory is in use. This can result in memory utilization readings over 
100%, as many applications pre-allocate memory and swap before it is actually 
needed. To work around this, you can also add physical memory as a volume for 
these servers within Orion. When monitored as a volume, the values will be more 
in line with your expectations. 

Scheduling a Node Maintenance Mode Time Period 

When you need to perform maintenance on a node or its components, such as 
upgrading firmware, installing new software, or updating security, you may want 
to discontinue polling while the device is down for maintenance. Disabling polling, 
or setting a node status as Unmanaged, while performing node maintenance, 
maintains the accuracy of your data and prevents unnecessary alert messages. 
For more information about disabling node polling to perform node maintenance, 
see ñSetting Device Management Statesò on page 83. 
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Chapter 6 

Managing Groups and Dependencies 

Dependencies and groups enable you to more effectively manage your network. 
Groups give you the ability to logically organize monitored objects, regardless of 
device type or location, and dependencies allow you to more faithfully represent 
what can actually be known about your network, eliminating ñfalse positiveò alert 
triggers and providing more accurate insight into the state of your network. 

Managing Groups 

Groups contain Orion objects that report a status such as nodes, volumes, 
applications, interfaces, and even other groups. You create, delete, and modify 
groups from the Manage Groups page. 

Note: Nesting a group within another does not create a strict parent/child 
relationship. You can include any group as a member in any number of other 
groups. 

To access the Manage Groups page: 

1. Log on to the Orion Web Console. 

2. Click Settings in the top right of the web console. 

3. Click Manage Groups in the Node & Group Management grouping of the 
Orion Website Administration page. 

The following sections provide more information about creating and managing 
groups in Orion: 

¶ Creating Groups 

¶ Editing Existing Groups 

¶ Managing Group Members 

¶ Deleting Groups 

¶ Managing the Display of Group Status 

Creating Groups 

Creating a group is a straightforward process of selecting the Orion objects you 
want the group to contain. At creation time, you can also decide how you want 
SolarWinds Orion to roll up the status of the group members. 
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 It is also possible to specify group members on the basis of shared properties by 
adding them with a dynamic query. Orion objects added through dynamic queries 
are automatically added or removed from the group. 

To create a new group: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console. 

3. Click Manage Groups in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. Click Add New Group. 

5. Enter a name for the group in the Name field, and then expand Advanced. 

6. If you want the group to roll up the worst status of the group members, 
select Show Worst Status. 

7. If you want the group to roll up the best status of the group members, 
select Show Best Status. 

8. If you want the group to display a warning status if the group members 
have a mixture of different statuses, select Mixed Status shows 
warning. 

9. Click Next. 

10. If you want to individually select group members, follow these steps: 

a. In the Show Only list, select the type of Orion object you want to add as 
a group member. 

b. Check the checkbox of the Orion object and then click Add to Group. 

11. If you want to dynamically select group members based on shared 
properties, follow these steps: 

a. Click Add dynamic query. 

b. Type a name for the query in the Dynamic query object name field. 

c. Select an Orion object type in the Orion Object is list. 

d. Click Add Condition to specify further selection properties. 

Note: Use the question mark (?) character as a multiple character 

wildcard. Use the underscore (_) character as a single character 

wildcard. 

e. Click Preview to verify that the dynamic query is selecting your intended 
objects. 

f. Click Save. 
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12. Continue adding individual Orion objects or dynamic queries until you have 
finished building your group. 

13. Click Create Group. 

Editing Existing Groups 

You can edit the properties of an existing group or add and remove objects. 
These are separate editing tasks. 

To edit properties of an existing group: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console. 

3. Click Manage Groups in the Node & Group Management grouping of the 
Orion Website Administration page. 

4. Check the group you want to edit, and then click Edit Properties. 

5. Edit the Name and Description of the selected group, as appropriate. 

6. If you want to manage the members of the selected group, click Add & 
Remove Objects. For more information about managing group members, 
see ñManaging Group Membersò on page 89. 

Note: Expand the Contains summary for the selected group to see all 
member objects in the group. 

7. If you want to configure the calculation of displayed group status or the 
frequency with which group status is refreshed, expand Advanced, 
select a Status rollup mode, and then provide a Refresh frequency. 

Note: For more information about status rollup for groups, see ñManaging the 
Display of Group Statusò on page 90. 

8. Click Submit. 

Managing Group Members 

The following procedure manages the objects included within a defined group. 

To add and remove the objects of an existing group: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console, and then click Manage 
Groups in the Node & Group Management grouping of the Orion Website 
Administration page. 

3. Check the group you want to edit, and then click Add & Remove Objects. 
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Deleting Groups 

Deleting an existing dependency is a straightforward process, as shown in the 
following procedure. 

To delete a group: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console, and then click Manage 
Groups in the Node & Group Management grouping of the Orion Website 
Administration page. 

3. Check the group you want to delete, and then click Delete. 

Managing the Display of Group Status 

The status of any particular group is determined by the status of the members of 
the group. There are three methods for determining the status displayed for a 
selected group of monitored objects: 

Note: For more information about object states in Orion, see ñStatus Icons and 
Identifiersò on page 265. 

¶ Show Best Status is most useful for displaying groups that are defined as 
collections of redundant or backup devices. The following table indicates how 
the Show Best Status option operates: 

Note: Compare Group Status results under the Show Best Status option with 
results for the same groups of objects under the Show Worst Status option. 

Object States Group Status 

 (Up, Warning, Down)  (Up) 

 (Warning, Up)  (Up) 

 (Warning, Down, Unknown)  (Warning) 

 

¶ Show Worst Status ensures that the worst status in a group of objects is 
displayed for the whole group. The following table indicates how the Show 
Worst Status option operates: 

Object States Group Status 

 (Up, Warning, Down)  (Down) 

 (Warning, Up)  (Warning) 

 (Warning, Down, Unknown)  (Down) 
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¶ Mixed Status shows Warning ensures that the status of a group displays 
the worst warning-type state in the group. If there are no warning-type states, 
but the group contains a mix of up and down states, then a Mixed Availability 

( ) warning status is displayed for the whole group. The following table 
indicates how the Mixed Status shows Warning option operates: 

Object States Group Status 

  (Critical) 

  (Critical) 

  (Mixed Availability) 

 

The following procedure configures the method used to determine group status. 

To configure the method used to determine the status of a selected group: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console, and then click Manage 
Groups in the Node & Group Management grouping of the Orion Website 
Administration page. 

3. Check the group you want to edit, and then click Edit Properties. 

4. Expand Advanced, and then select a Status rollup mode, as follows: 

a. If you want the group to roll up the worst status of the group 
members, select Show Worst Status. 

b. If you want the group to roll up the best status of the group 
members, select Show Best Status. 

c. If you want the group to display a warning status if the group 
members have a mixture of different statuses, select Mixed Status 
shows warning. 

5. Click Submit. 

Managing Dependencies 

Dependencies in Orion allow you to account for topological constraints on your 
network. These constraints may be either the result of the design of a specific 
device, as in the case of interfaces on a switch or router, or the result of the 
physical architecture of your network itself. Orion offers an Unreachable status to 
account for the case when a device may appear to be down when its status is 
actually indeterminate, due to another device being down or unresponsive. 

For example, in the case of a typical switch monitored by Orion NPM, when the 
switch itself goes down or becomes unresponsive, all interfaces on the switch will 
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also be unresponsive, even though they may functioning perfectly well. By 
default, in Orion NPM these child interfaces display as Unreachable because 
their parent node is reporting as down. 

Likewise, Orion also makes it possible to define dependencies among distinct 
devices, as in the case of a subnet of devices on your network that depends on a 
single WAN link to connect with the rest of your network. In this case, if you have 
defined a group consisting of the devices in this dependent subnet, you can then 
define a dependency where the dependent subnet is a child group to the parent 
router that is serving as the WAN link to the rest of your network. For more 
information about groups, see ñManaging Groupsò on page 87. 

The power of dependencies becomes evident when considering alerts. If you 
have an alert configured to trigger when a monitored object is down, you only 
want that alert to trigger if a monitored objects is positively down. In other words, 
you do not want an down object alert to trigger for an object that is not actually 
down. Without dependencies, all monitored objects on a monitored node that is 
unresponsive to ICMP queries will also report as down. With dependencies in 
use, these child objects will instead display as Unreachable, saving you the 
hassle of sorting through numerous false alerts resulting from the failure of a 
single node to respond promptly to a status query. 

Note: Interfaces may be defined as parent objects, but they cannot be defined as 
child objects. Orion NPM determines interface status directly by polling parent 
nodes. If the node on which an interface exists goes down, Orion NPM 
automatically reports any and all interfaces on that node as unreachable. 

Creating a New Dependency 

Creating a new dependency is a straightforward process of selecting the parent 
and children objects, as shown in the following procedure. 

To create a new dependency: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console, and then click Manage 
Dependencies in the Node & Group Management grouping of the Orion 
Website Administration page. 

3. Click Add new dependency. 

4. On the Select Parent page, complete the following steps: 

a. Use the Show only: and Group by: selection fields to customize the list 
of displayed objects and groups. 

Note: The properties listed in the Group by selection field are dynamic.  
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b. Select the parent object or group in the main pane, and then click Next. 

Note: If you want to define a dependency so that the reported states of 
child objects are dependent on the status of multiple parent objects, 
create a group including all parent objects, and then select it on this 
view. For more information, see ñCreating Groupsò on page 87. 

5. On the Choose Child page, complete the following steps: 

a. Edit the Dependency name, as appropriate. 

b. Use the Show only: and Group by: selection fields to customize the list 
of displayed objects and groups. 

Note: Properties listed in the Group by: selection field are dynamically 
dependent on the selection in the Show only: field. 

c. Select the child object or group in the main pane, and then click Next. 

Note: If you want to define a dependency so that the reported states of 
multiple child objects are dependent on the status one or more parent  
objects, create a group including all child objects, and then select it on 
this view. For more information, see ñCreating Groupsò on page 87. 

6. On the Review Dependency view, review the current settings for the 
configured dependency. 

Notes: 

¶ If any advanced alerts are configured on parent or child objects, they will 
be listed on this view. Click + to expand alert details. 

¶ In the event that a parent object is down, all alerts configured on any 
child objects in a dependency on the down parent object are 
automatically suppressed. 

7. Click Submit to accept the dependency definition. 

Editing an Existing Dependency 

Editing an existing dependency is a straightforward process, as shown in the 
following procedure. 

To edit an existing dependency: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console, and then click Manage 
Dependencies in the Node & Group Management grouping of the Orion 
Website Administration page. 

3. Check the dependency you want to edit, and then click Edit. 
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4. On the Select Parent page, complete the following steps: 

a. Use the Show only: and Group by: selection fields to customize the list 
of displayed objects and groups. 

Note: Properties listed in the Group by: selection field are dynamically 
dependent on the selection in the Show only: field.  

b. Select the parent object or group in the main pane, and then click Next. 

Note: If you want to define a dependency so that the reported states of 
child objects are dependent on the status of multiple parent objects, 
create a group including all parent objects, and then select it on this 
view. For more information, see ñCreating Groupsò on page 87. 

5. On the Choose Child page, complete the following steps: 

a. Edit the Dependency name, as appropriate. 

b. Use the Show only: and Group by: selection fields to customize the list 
of displayed objects and groups. 

Note: Properties listed in the Group by: selection field are dynamically 
dependent on the selection in the Show only: field.  

c. Select the child object or group in the main pane, and then click Next. 

Note: If you want to define a dependency so that the reported states of 
multiple child objects are dependent on the status one or more parent  
objects, create a group including all child objects, and then select it on 
this view. For more information, see ñCreating Groupsò on page 87. 

6. On the Review Dependency view, review the current settings for the 
configured dependency. 

Notes: 

¶ If any advanced alerts are configured on parent or child objects, they will 
be listed on this view. Click + to expand alert details. 

¶ If a parent object is down, all alerts configured on any child objects in a 
dependency on the down parent object are automatically suppressed. 

7. Click Submit to accept the dependency definition. 

Deleting an Existing Dependency 

Deleting an existing dependency is a straightforward process, as shown in the 
following procedure. 

To delete an existing dependency: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 
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2. Click Settings in the top right of the web console, and then click Manage 
Dependencies in the Node & Group Management grouping of the Orion 
Website Administration page. 

3. Check the dependency you want to delete, and then click Delete. 

4. Click Yes to confirm deletion of the selected dependency. 

Viewing Alerts on Child Objects 

In the event that a parent object is down, all advanced alerts configured on any 
child objects in a dependency on the down parent object are automatically 
suppressed. The following procedure displays all advanced alerts currently 
configured on any child objects in a selected dependency. 

To view alerts on child objects in a selected dependency: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Settings in the top right of the web console. 

3. Click Manage Dependencies in the Node & Group Management grouping of 
the Orion Website Administration page. 

4. Check the dependency that includes the child object on which the alerts you 
want to view are configured, and then click Alerts on Child. 
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Chapter 7 

Managing Web Accounts 

Orion Web Console user accounts, permissions, and views are established and 
maintained with the Orion Account Manager. When Advanced Customization is 
enabled on the Orion Website Settings page, you can use Account Manager to 
customize menu bars and views for different users. For more information about 
Orion Website Settings and Advanced Customization, see ñOrion Web Console 
and Chart Settingsò on page 60. 

Notes: 

¶ This guide assumes that Advanced Customization has been enabled. If it has 
not been enabled, the range of options available on the pages referenced in 
the following sections is much more limited. For more information, see ñOrion 
Website Administrationò on page 34. 

¶ To prevent issues with web console accounts, your SQL Server should not 

be configured with the no count  connection option enabled. The no count  
option is set in the Default connection options area of the Server 
Properties > Connections window of SQL Server Management Studio 

Creating New Accounts 

New Orion Web Console user accounts may be created by any web console 
administrator. The following procedure creates a new web console user account. 

To create a new user account: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Account in the Accounts grouping of the Orion Website 
Administration page. 

4. Click Add New Account. 

5. Select the type of account you want to add, and then click Next. 

6. If you selected Orion individual account, complete the following steps: 

a. Provide a User Name and a Password for the Orion individual account. 

b. Confirm the password, and then click Next. 

c. Define user settings and privileges, as appropriate. For more information, 
see ñEditing User Accountsò on page 98. 
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7. If you selected Windows individual account, complete the following steps: 

a. Provide the User Name and Password for a user that has administrative 
access to your Active Directory or local domain. 

b. In the Search for Account area, enter the User name of the Active 
Directory or local domain user for whom you want to create a new web 
console account, and then click Search. 

c. In the Add Users area, select the users for whom you want to create new 
web console accounts, and then click Next. 

8. If you selected Windows group account, complete the following steps: 

a. Provide the User Name and Password for a user that has administrative 
access to your Active Directory or local domain. 

b. In the Search for Account area, enter the Group name of the Active 
Directory or local domain group for which you want to create a new web 
console account, and then click Search. 

c. In the Add Users area, select the users for whom you want to create new 
web console accounts, and then click Next. 

When the new account is created, the Edit User Account view displays, showing 
all configurable account options. For more information about editing account 
settings, see ñEditing User Accountsò on page 98. 

Note: For more information about using Windows Pass-through security, Active 
Directory, and DirectLink accounts for automatic login to the Orion Web Console, 
see ñConfiguring Automatic Loginò on page 281. 

Editing User Accounts 

The Edit User Account page provides options for configuring web console user 
accounts. On the Edit User Account page, administrators can disable an account, 
set an account expiration date, grant administrator and node management rights, 
set user view limitations, define a default menu bar, and set several other 
defaults defining how a user account views and uses the Orion Web Console.  

The following sections and procedures detail the configuration of user accounts. 

Note: To reset a password, click Change Password at the bottom of the page. 

¶ User Account Access Settings 

¶ Setting Account Limitations 

¶ Defining Pattern Limitations 

¶ Setting Default Account Menu Bars and Views 
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¶ Configuring an Account Report Folder 

¶ Configuring Audible Web Alerts 

User Account Access Settings 

The following procedure is a guide to setting user account access. 

To edit a user account: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Accounts in the Accounts grouping of the Orion Website 
Administration page. 

4. Select the account that you want to edit, and then click Edit. 

5. Set Account Enabled to Yes or No, as appropriate. 

Note: Accounts are enabled by default, and disabling an account does not 
delete it. Account definitions and details are stored in the Orion database in 
the event that the account is enabled at a later time. 

6. If you want the account to expire on a certain date, click Browse (é) 
next to the Account Expires field, and then select the account expiration 
date using the calendar tool. 

Note: By default, accounts are set to Never expire. Dates may be entered in 
any format, and they will conform to the local settings on your computer. 

7. If you want to allow the user to remain logged-in indefinitely, select Yes 
for the Disable Session Timeout option. 

Note: By default, for added security, new user accounts are configured to 
timeout automatically. 

8. If you want to grant administrator rights to the selected account, set 
Allow Administrator Rights to Yes. 

Notes: 

¶ Granting administrator rights does not also assign the Admin menu bar 
to a user. If the user requires access to Admin options, they must be 
assigned the Admin view. For more information, see ñSetting Default 
Account Menu Bars and Viewsò on page 103. 

¶ Administrator rights are not granted by default, but they are required to 
create, delete, and edit accounts. User accounts without administrator 
rights cannot access Admin page information. 
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9. If you want to allow the user to manage nodes directly from the Orion 
Web Console, set Allow Node Management Rights to Yes. 

Note: By default, node management rights are not granted. For more 
information about node management in the Orion Web Console, see 
ñManaging Devices in the Web Consoleò on page 75. 

10. If you want to allow the user to customize views, set Allow Account to 
Customize Views to Yes. 

Note: By default, customized view creation is not allowed. Changes made to 
a view are seen by all other users that have been assigned the same view. 

11. Designate whether or not to Allow Account to Clear Events and 
Acknowledge Alerts. 

12. Select whether or not to Allow Browser Integration. 

Note: Browser integration can provide additional functionality, including 
access to right-click menu options, depending on client browser capabilities. 

13. If you want to enable audible alerts through the client browser, select a 
sound from the Alert Sound list. 

Note: By default, sounds are stored in the Sounds  directory, located at 

C: \ Inetpub \ SolarWinds \ NetPerfMon \ Sounds . Sounds in .wav  format that 

are added to this directory become available as soon as the Edit User 
Account page refreshes. 

14. Provide the maximum Number of items in the breadcrumb list. 

Note: If this value is set to 0, all available items are shown in breadcrumb 

dropdown lists. 

Setting Account Limitations 

Account limitations may be used to restrict user access to designated network 
areas or to withhold certain types of information from designated users. The 
following procedure sets user account limitations. 

To set user account limitations: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Accounts in the Accounts group of the Orion Website Administration page. 

3. If you want to limit an individual user account, complete the following 
steps: 

a. On the Individual Accounts tab, check the account you want to limit. 

b. Click Edit. 
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c. Click Add Limitation in the Account Limitations section. 

d. Select the type of limitation to apply, and then click Continue. 

Notes: 

¶ Because Orion NetFlow Traffic Analyzer (NTA) initially caches 
account limitations, it may take up to a minute for account limitations 
related to Orion NTA to take effect in Orion NTA. 

¶ Account limitations defined using the Account Limitation Builder 
display as options on the Select Limitation page. Account limitations 
can be defined and set using almost any custom properties. For 
more information, see ñCreating Account Limitationsò on page 215. 

e. Define the limitation as directed on the Configure Limitation page that 
follows. For more information about defining pattern-type limitations, see 
ñDefining Pattern Limitationsò on page 102. 

4. If you want to limit an group account, complete the following steps: 

Note: Limitations applied to a selected group account only apply to the group 
account and not, by extension, to the accounts of members of the group.  

a. On the Groups tab, check the group account you want to limit. 

b. Click Edit. 

c. Click Add Limitation in the Account Limitations section. 

d. Select the type of limitation to apply, and then click Continue. 

Notes: 

¶ Because Orion NetFlow Traffic Analyzer (NTA) initially caches 
account limitations, it may take up to a minute for account limitations 
related to Orion NTA to take effect in Orion NTA. 

¶ Account limitations defined using the Account Limitation Builder 
display as options on the Select Limitation page. Account limitations 
can be defined and set using almost any custom properties. For 
more information, see ñCreating Account Limitationsò on page 215. 

e. Define the limitation as directed on the Configure Limitation page that 
follows. For more information about defining pattern-type limitations, see 
ñDefining Pattern Limitationsò on page 102. 

5. Click Add Limitation in the Account Limitations section. 

6. Select the type of limitation to apply from the list, and then click Continue. 

Notes: 

¶ Account limitations defined using the Account Limitation Builder display 
as options on the Select Limitation page. Account limitations can be 
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defined and set using almost any custom properties. For more 
information, see ñCreating Account Limitationsò on page 215. 

¶ Because Orion NetFlow Traffic Analyzer (NTA) initially caches account 
limitations, it may take up to a minute for account limitations related to 
Orion NTA to take effect in Orion NTA. 

7. Define the limitation as directed on the Configure Limitation page that 
follows. For more information about defining pattern-type limitations, see 
ñDefining Pattern Limitationsò on page 102. 

Defining Pattern Limitations 

Pattern limitations may be defined using OR, AND, EXCEPT, and NOT operators with 

_ and *  as wildcard characters. The following examples show how to use 

available operators and wildcard characters: 

Note: Patterns are not case sensitive. 

¶ foo  matches only objects named "foo". 

¶ foo_  matches all objects with names consisting of the string "foo" followed by 

only one additional character, like foot  or food , but not seafood  or 

football . 

¶ foo*  matches all objects with names starting with the string "foo", like 

football  or food , but not seafood . 

¶ *foo*  matches all objects with names containing the string "foo", like 

seafood  or Bigfoot . 

¶ *foo* OR *soc*  matches all objects containing either the string "foo" or the 

string "soc", including football , socks , soccer , and food . 

¶ *foo* AND *ball*  matches all objects containing both the string "foo" and 

the string "ball", including football  but excluding food . 

¶ *foo* NOT * ball *  matches all objects containing the string "foo" that do not 

also contain the string "ball", including food  but excluding football . 

¶ *foo* EXCEPT *ball*  matches all objects containing the string "foo" that do 

not also contain the string "ball", including food  but excluding football . 

You may also group operators using parentheses, as in the following example. 

(*foo* EXCEPT * b* ) AND ( * all *  OR * sea * )  matches seafood  and 

footfall , but not football  or Bigfoot . 
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Setting Default Account Menu Bars and Views 

The Default Menu Bar and Views section provides several options for configuring 
the default menu bar and views for your user account. The following procedure is 
a guide to setting these options. 

To set default menu bar and view options: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Accounts in the Accounts grouping of the Orion Website Administration 
page. 

3. Select the account that you want to configure, and then click Edit. 

4. Scroll down to Default Menu Bar and Views. 

5. Select a Home Tab Menu Bar from the available list. 

Note: This is the default menu bar displayed when you click Home in the 
Orion Web Console. If you are editing a user account that must have 
administrator privileges, set the Home Tab Menu Bar to Admin. 

6. Select a Network Tab Menu Bar from the available list. 

Note: This is the default menu bar displayed when you click Network in the 
Orion Web Console. If you are editing a user account that must have 
administrator privileges, select Admin. 

7. Select a Virtualization Tab Menu Bar from the available list. 

Note: This is the default menu bar displayed when you click Virtualization in 
the Orion Web Console. If you are editing a user account that must have 
administrator privileges, select Admin. 

8. If you have installed any additional Orion modules, select an Orion Module 
Tab Menu Bar from each available list. 

Note: This step configures the default menu bar displayed when you click the 
tab corresponding to an installed module in the Orion Web Console. If you 
are editing an account that must have administrator privileges, select Admin. 

9. Select a Home Page View. 

Note: If no Home Page View is specified, the default is designated to be the 
same as the page that is specified in the Default Summary View field below. 

10. If the Home Page View you have selected refers to a specific network 
device, select a Default Network Device by clicking Edit and selecting from 
the list of available devices on the next page. 

Note: If the Home Page View you have selected does not require a specific 
network device, Orion will select a device to display, automatically. 
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11. Select a Default Summary View for the account. 

Note: This is typically the same as the Home Page View. 

12. If you want all reports to be available for the account, select \Reports 
from the Report folder list in the Default Menu Bars and Views area. 

Note: If you are creating a new user, you must designate the Report Folder 
the new account is to use to access Orion reports. By default, no report 
folder is configured for new users.The Reports directory is located in the 

Orion installation directory: C: \ Program  Files \ SolarWinds \ Orion \ . 

13. If you want to designate default Node, Volume, and Group Details Views 
for this account, expand Orion General Settings, and then select 
appropriate Node Detail, Volume Detail, and Group Detail Views.  

14. If you want to designate default Virtualization Summary Manager, 
Cluster Details, and Datacenter Details Views for this account, expand 
Integrated Virtual Infrastructure Monitor Settings, and then select 
appropriate default views.  

15. Click Submit. 

Configuring an Account Report Folder 

Reports may be assigned to an account by creating sub-directories within the 
Reports directory. Desired reports are included within the sub-directory, and the 
sub-directories are then made available for assignment to an account. This 
provides a level of security when reports are included in a view or added as 
custom menu items. For more information, see ñCreating and Editing External 
Website Viewsò on page 56. 

To configure an account report folder: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Accounts in the Accounts group of the Orion Website Administration page. 

3. Select the account you want to configure, and then click Edit. 

4. If you want all reports to be available for the account, select \Reports 
from the Report folder list in the Default Menu Bars and Views area. 

Note: If you are creating a new user, you must designate the Report Folder 
the new account is to use to access Orion reports. By default, no report 
folder is configured for new users.The Reports directory is located in the 
Orion installation directory: C: \ Program  Files \ SolarWinds \ Orion \ . 

5. Click Submit. 
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Configuring Audible Web Alerts 

When browsing the Orion Web Console, audible alerts can be sounded 
whenever new alerts are generated. When enabled, you will receive an audible 
alert the first time, after login, that an alert is displayed on the page. This alert 
may come from either an alert resource or the Alerts view. You will not receive 
audible alerts if the Alerts view or the alert resource you are viewing is empty. 

Following the initial alert sound, you will receive an audible alert every time an 
alert is encountered that was triggered later than the latest alert that has already 
been viewed. 

For example, a user logs in and sees a group of alerts with trigger times ranging 
from 9:01AM to 9:25AM, and the user receives an audible alert. If the user 
browses to a new page or allows the current page to auto-refresh, a new alert 
sounds if and only if an alert triggered later than 9:25AM is then displayed. 

To enable audible web alerts: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Manage Accounts in the Accounts grouping of the Orion Website 
Administration page. 

4. Select the account you want to configure. 

5. Click Edit. 

6. Select the sound file you want to play when new alerts arrive from the Alert 
Sound list. 

Note: By default, sounds are stored in the Sounds  directory, located at 

C: \ Inetpub \ SolarWinds \ NetPerfMon \ Sounds . Sounds in .wav  format that 

are added to this directory become available as soon as the Edit User 
Account page refreshes. 

7. Click Submit. 

 

 

 

 

 

 

 



Administrator Guide Ö SolarWinds Orion Core 
 

 
106 Ö Managing Web Accounts 

 

 

 

 

 

 

 

 

 

 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Managing Orion Polling Engines Ö 107 

Chapter 8 

Managing Orion Polling Engines 

To ensure that your polling engines are optimized to run at peak performance, 
you will need to occasionally tune them. If you use more than one polling engine, 
you will need to balance the load so that each engine can perform optimally. 

Viewing Polling Engine Status in the Web Console 

The Orion Web Console provides the Polling Engines view, giving you immediate 
insight into the performance of all polling engines in your Orion installation. 

To display the Polling Engine view: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Polling Engines in the Details group. 

For more information about configuring the settings on this view in addition to 
configuring all other available polling engine variables, see ñConfiguring Polling 
Engine Settingsò on page 107. 

Configuring Polling Engine Settings 

Settings for your Orion polling engine are configured on the Orion Polling 
Settings view within the Orion Web Console.  

To open the Orion Polling Settings view: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console. 

3. Click Polling Settings in the Settings group. 

The following section provides descriptions of the settings configurable on the 
Orion Polling Settings view. 

Orion Polling Settings 

The following poller settings are configurable on the Orion Polling Settings view. 

Note: Depending on the Orion products and modules you have installed, 
additional Polling Settings may be available. For more information about any 
additional polling settings, see the Administrator Guide for your Orion product. 
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Polling Intervals 

The following settings configure default polling intervals. To apply poller settings, 
click Re-Apply Polling Intervals. 

Default Node Poll Interval 

Devices are regularly polled to determine status and response time on this 
designated interval. By default, this interval is 120 seconds. 

Default Volume Poll Interval 

Volumes are regularly polled to determine status and response time on this 
designated interval. By default, this interval is 120 seconds. 

Default Rediscovery Interval 

Your entire network is polled on this interval to detect any re-indexed 
interfaces. Monitored network devices are also checked for IOS upgrades 
permitting EnergyWise support. By default, this interval is 30 minutes. 

Note: In Orion products released prior to Orion NPM version 10.1, the 
minimum interval allowed is 1 minute. Beginning with Orion NPM version 
10.1, the minimum rediscovery interval is 5 minutes. Polling interval settings 
may not be submitted if the default rediscovery interval is not set to at least 5 
minutes. 

Lock custom values 

This option is enabled by default. Enabling this option automatically saves 
any polling customizations made on the Orion Polling Settings view. 

Polling Statistics Intervals 

The following settings configure default polling intervals for device statistics. To 
apply poller settings, click Re-Apply Polling Statistic Intervals. 

Default Node Statistics Poll Interval 

Device performance statistics are regularly polled on this interval. By default, 
this interval is 10 minutes. 

Default Volume Statistics Poll Interval 

Volume performance statistics are regularly polled on this interval. By default, 
this interval is 15 minutes. 
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Database Settings 

The following options configure Orion database maintenance and retention 
settings. 

Note: Changes to database maintenance and retention settings do not take 
effect until the SolarWinds Network Performance Monitor service is restarted. 

Archive Time 

The Archive Time is the time of day when Orion database maintenance 
occurs. For more information, see ñDatabase Maintenanceò on page 227. 

Detailed Statistics Retention 

All statistics collected on any basis shorter than 1 hour are summarized into 
hourly statistics after the period of time designated as the Detailed Statistics 
Retention period. By default, this period is 7 days. 

Hourly Statistics Retention 

All statistics collected on any basis shorter than 1 day but longer than 1 hour 
are summarized into daily statistics after the period of time designated as the 
Hourly Statistics Retention period. By default, this period is 30 days. 

Daily Statistics Retention 

All statistics in the Orion database that are collected on a daily basis are kept 
for this designated period of time. By default, this period is 365 days. 

Events Retention 

All network events data is deleted from the Orion database after the period of 
time designated by the Events Retention has passed after the event ending 
time. By default, this period is 30 days. 

Syslog Messages Retention 

All received Syslog messages are kept for the period of time designated. By 
default, this period is 7 days. 

Trap Messages Retention 

All received trap messages are kept for the period of time designated. By 
default, this period is 30 days. 

Max Alert Execution Time 

If it takes longer than the value specified here for an alert to execute, Orion 
will disable the alert. Alert execution time includes the amount of time 
required to trigger any configured alert actions. 
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Discovery Retention 

All configured discovery profiles are kept for the period of time designated. 
By default, this period is 60 days. For more information about discovery 
profiles, see ñDiscovering and Adding Network Devicesò on page 17. 

Network 

The following settings configure ICMP and SNMP requests. 

ICMP Timeout 

All ICMP (ping) requests made by the Orion poller time out if a response is 
not received within the period designated. By default, this period is 2500ms. 

ICMP Data 

This string is included within all ICMP packets sent by Orion. 

SNMP Timeout 

All SNMP requests made by the Orion poller time out if a response is not 
received within the period designated. By default, this period is 2500ms. 

SNMP Retries 

If a response to an SNMP poll request made by the Orion poller is not 
received within the configured SNMP Timeout, the Orion poller will conduct 
as many retries as designated by this value. By default, this value is 2. 

ESX API Timeout 

All VMware ESX API requests made by the Orion poller time out if a 
response is not received within the period designated. By default, this period 
is 30000ms. For more information about VMware ESX polling, see 
ñVirtualizationò in the SolarWinds Orion Network Performance Monitor 
Administrator Guide. 

UCS API Timeout 

All UCS API requests made by the Orion poller time out if a response is not 
received within the period designated. By default, this period is 240 seconds. 

Perform reverse DNS lookup 

If you want Orion to perform reverse DNS lookups on monitored DHCP 
nodes, confirm that this option is checked. By default, reverse DNS lookup 
for DHCP nodes is enabled. 
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Calculations & Thresholds 

The following settings designate methods for calculating availability and 
transmission rate baselines, select the Orion node warning level and counter 
type, and indicate security preferences for community strings and other 
potentially sensitive information in the web console. 

Availability Calculation (advanced) 

This setting designates the type of calculation Orion performs to determine 
device availability. For more information, see ñCalculating Node Availabilityò 
on page 111. 

Baseline Calculation (advanced) 

Upon startup, Orion can calculate a baseline for the transmission rates of the 
various elements of your network. This baseline is used as a starting point for 
any comparison statistics. For more information, see ñCalculating a Baselineò 
on page 112. 

Allow Secure Data on Web (advanced) 

In the interest of security, sensitive information about your network is not 
viewable in the Orion Web Console. However, if your network is properly 
secured, you may check this option to allow the viewing of community strings 
and other potentially sensitive information within the web console. 

Note: This setting does not affect the display of custom reports that you 
export to the web. For more information see ñCreating and Viewing Reportsò 
on page 161. 

Node Warning Level 

Devices that do not respond to polling within this designated period of time 
display as Down in the web console. By default, this value is 120 seconds. 

Counter Rollover 

This option sets the type of counter Orion is to use. For more information, 
see ñHandling Counter Rolloversò on page 38. 

Calculating Node Availability 

The Availability Calculation setting on the Orion Polling Settings view provides a 
choice between the following two methods for determining device availability. 

Node Status: 

The default method is based upon the historical up or down status of the selected 
node. The selected node is polled for status on the Default Node Poll Interval 
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defined on the Orion Polling Settings view. For more information, see ñOrion 
Polling Settingsò on page 107. 

If the selected node responds to a ping within the default interval, the node is 

considered up, and a value of 100  is recorded in the Response Time table of the 

Orion database. If the node does not respond to a ping within the default interval, 
the node is considered down and a value of 0 is recorded in the Response Time 

table of the Orion database. To calculate node availability over a selected time 
period, the sum of all Response Time table records for the selected node over 
the selected time period is divided by the selected time period, providing an 
average availability over the selected time period. 

Percent Packet Loss: 

The second method is a more complicated calculation that effectively bases the 
availability of a selected node on its packet loss percentage. As in the Node 
Status method, the selected node is polled for status. If it responds within the 
Default Node Poll Interval defined on the Orion Polling Settings view, a value of 

100  is averaged with the previous 10 availability records. For more information, 

see ñOrion Polling Settingsò on page 107. 

The result of the Percent Packet Loss calculation is a sliding-window average. To 
calculate node availability over a selected time period, the sum of all results in 
the Response Time table for the selected node over the selected time period is 
divided by the selected time period, providing an average availability over time. 

Note: The Percent Packet Loss method introduces a historical dependency into 
each availability node record. In general, it is best to leave calculations based on 
Node Status unless you specifically need node availability based on packet loss. 

Calculating a Baseline 

Much of the raw data that Orion polls from monitored network objects is provided 
initially as coutner values. For example, one of the values that Orion NPM polls 

from interfaces is ifInOctets , which returns the number of bytes the polled 

interface has received since the device last booted. While this value can be 
useful information in itself, generally, from a network performance monitoring 
standpoint, it is more useful to know the rate of bytes received by the interface. 

In order to determine a rate, two values are required. On a new install or after a 
shutdown, when the SolarWinds Network Performance Monitor service starts, 
there is no current network data in your Orion database. In this situation, by 
default, Orion calculates a baseline for the transmission rates of the various 
elements of your network. To calculate this baseline, all network resources are 
polled immediately upon startup, and then, as soon as the initial poll is complete, 
the network is polled again. The resulting two sets of data are used to calculate a 
nearly instant baseline view of your network performance.  
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If you do not need statistics immediately, or if you do not want Orion to calculate 
a baseline at startup, disable baseline calculation at startup by setting the 
Baseline Calculation option on the Orion Polling Settings view to False. For more 
information, see ñConfiguring Polling Engine Settingsò on page 107. 

Note: Baseline calculation requires significant data gathering and processing. 
Until baseline calculation is completed, both Orion server performance and the 
CPU performance of some of network routers may be adversely affected.  

Using the Polling Engine Load Balancer 

The Polling Engine Load Balancer is a useful tool for reassigning nodes to a new 
polling engine, deleting an unused polling engine, and performing load balancing 
between multiple polling engines. The tool is available within the Monitor Polling 
Engines application, which is an advanced feature of Orion. Reassigning nodes 
to new polling engines may be required in the following situations: 

¶ Moving or renaming your Orion server 

¶ Merging two or more Orion servers 

If these or any other conditions present the need for reassignment, complete the 
following procedure to reassign nodes to a new polling engine. 

To reassign nodes to a different polling engine: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Orion Service Manager. 

2. Click Shutdown Everything. 

Note: Confirm that you stop the SolarWinds Network Performance Monitor 
Service on all polling engines. 

3. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Monitor Polling Engines. 

4. Click Servers > Poller Load Balancing. 

5. Select the nodes you want to reassign. 

Note: Use Shift  + click  to highlight multiple consecutive rows, and use 

Ctrl  + click  to highlight multiple non-consecutive rows. 

6. Click Polling Engines > Move Selected Nodes to *, substituting the target 
polling engine for *. The node is reassigned, and it reflects the name of the 
polling engine in the polling engine column. 

7. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Orion Service Manager to restart Orion services. 
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Setting the Node Warning Level 

A device may drop packets or fail to respond to a poll for many reasons. Should 
the device fail to respond, the device status is changed from Up to Warning. On 
the Orion Polling Settings view, you can specify the Node Warning Level, which 
is the length of time a device is allowed to remain in the Warning status before it 
is marked as Down. During the interval specified, the service performs "fast 
polling" (ICMP) to continually check the node status. 

Note: You may see events or receive alerts for down nodes that are not actually 
down. This can be caused by intermittent packet loss on the network. Set the 
Node Warning Interval to a higher value to avoid these false notifications. For 
more information about packet loss reporting, see ñManaging Packet Loss 
Reportingò on page 114. 

To set the Node Warning Level: 

1. Log in to the Orion Web Console using an account with administrative rights. 

2. Click Settings in the upper right of the web console, and then click Polling 
Settings in the Settings group of the Orion Website Administration view. 

3. In the Calculations and Thresholds group, set the Node Warning Level to an 
appropriate interval, in seconds. 

Note: The default Node Warning Level interval is 120 seconds. 

4. Click Submit. 

Managing Packet Loss Reporting 

To manage the amount of network-wide packet loss reported by Orion, configure 
the Response Time Retry Count for your polling engine. This setting designates 
the number of times Orion retries ICMP pings on a monitored device before 
packet loss is reported. 

Note: This configuration change requires an insertion into your Orion database. If 
possible in your environment, SolarWinds recommends installing and using the 
SQL Server Management Studio to perform this insertion. 

To configure the Response Time Retry Count for your polling engine: 

1. Create a full backup of your Orion database. For more information, see the 
SolarWinds Technical Reference, ñMoving Your Orion NPM Databaseò. 

2. On your Orion server, click Start > All Programs > SolarWinds Orion > 
Advanced Features > Orion Service Manager. 

3. Click Shutdown Everything. 

http://www.solarwinds.com/support/Orion/docs/OrionServerMigration.pdf
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4. On your Orion database server, click Start > All Programs > Microsoft SQL 
Server > SQL Server Management Studio. 

5. Select your Orion database Server name. 

6. Select an appropiate Authentication type, provide any required credentials, 
and then click Connect. 

7. Expand Databases > OrionDatabaseName > Tables. 

8. Click New Query. 

9. Type the following query into the empty SQL query field: 

Note: Specify your own custom values for Maximum, CurrentValue , and 

DefaultValue . 

INSERT INTO [OrionDatabaseName].[ dbo].[Settings] (SettingID, 

Name, Description, Units, Minimum, Maximum, CurrentValue, 

DefaultValue) VALUES ( óSWNetPerfMon- Settings - Response Time 

Retry Countô,  óResponse Time Retry Countô, óNumber of times 

Orion retries ICMP pings on a monitored device before reporting 

packet loss ô, óô, 1, Maximum, CurrentValue, DefaultValue )  

10. Click Execute. 

11. Close SQL Server Management Studio. 

12. On your Orion server, click Start > Run, type regedit , and then click OK. 

13. Expand HKEY_LOCAL_MACHINE > SOFTWARE > SolarWinds.Net > 
SWNetPerfMon. 

14. Right-click Settings, and then click New > String Value. 

15. Enter Response Time Retry Count  as the New Value. 

16. Right-click Response Time Retry Count, and then click Modify. 

17. In the Value data field, enter the CurrentValue  provided in the query above, 
and then click OK. 

18. Close the Registry Editor. 

19. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Orion Service Manager. 

20. Click Start Everything. 

 

 

 

 



Administrator Guide Ö SolarWinds Orion Core 
 

 
116 Ö Managing Orion Polling Engines 

 

 

 

 

 

 

 

 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Monitoring Network Events in the Web Console Ö 117 

Chapter 9 

Monitoring Network Events in the Web Console 

Orion automatically logs all events that occur to any monitored devices on your 
network. These events are then displayed in the Orion Web Console, so you can 
view and acknowledge them as your network management policies require. 

Viewing Event Details in the Web Console 

Orion logs network events and lists them in the readily customizable Events view 
of the Web Console. Events are shown in order of occurrence, and they may be 
viewed by device, date and time, and event or device type. 

Note: The Network Event Log is maintained as part of the Nightly Database 
Maintenance plan defined within the Database Settings area of the Orion Polling 
Setting page in the Orion Web Console. Records are kept for the number of days 
specified Events Retention field (the default is 30 days). For more information, 
see ñOrion Polling Settingsò on page 107. 

To view event details in the Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Orion Web Console, and then click Events in the Views toolbar. 

3. If you want to filter your events view by object, select the Network 
Object or Type of Device to which you want to limit your view in the Filter 
Devices area. 

4. If you want to limit your events view to show only events of a specific 
type, select the appropriate Event Type in the Filter Events area. 

5. If you only want to see events from a specific period of time, complete 
either of the following options: 

¶ Select a predefined period from the Time Period menu. 

¶ Select Custom from the Time Period menu, and then click the 
appropriate fields to provide Begin and End dates and times. 

6. In the Show X Events field, provide the maximum number of events you 
want to view. 

7. If you want to show all events, including events that have already been 
cleared, check Show Cleared Events. 

8. Click Refresh to complete your events view configuration. 
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Acknowledging Events in the Web Console 

Acknowledging network events is straightforward in the Web Console, as shown 
in the following procedure. 

To acknowledge events in the Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Orion Web Console, and then click Events in the Views toolbar. 

3. Provide appropriate filter criteria for the displayed events. For more 
information, see ñViewing Event Details in the Web Consoleò on page 117. 

4. Click Refresh to ensure that all selected view criteria take effect. 

5. Check individual events to acknowledge or click Select All. 

6. Click Clear Selected Events. 
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Chapter 10 

Using Orion Advanced Alerts 

Alerts are generated for network events, and they may be triggered by the simple 
occurrence of an event or by the crossing of a threshold value for a monitored 
Interface, Volume, or Node. Alerts can be set to notify different people on 
different days, different times of the day, different people for different events, or 
any combination of times, events, and people. Alerts may be configured to notify 
the people who need to know about the emergent event by several mediums, 
including: 

¶ Sending an e-mail or page 

¶ Playing a sound on the Orion Network Performance Monitor server 

¶ Logging the alert details to a file 

¶ Logging the alert details to the Windows Event Log 

¶ Logging the alert details to the NetPerfMon Event Log 

¶ Sending a Syslog message 

¶ Executing an external program 

¶ Executing a Visual Basic script 

¶ E-mailing a web page 

¶ Playing text-to-speech output 

¶ Sending a Windows Net Message 

¶ Dialing a paging or SMS service 

¶ Sending an SNMP trap 

¶ GETting or POSTing a URL to a web server 

Creating and Configuring Advanced Alerts 

Orion allows you to configure advanced alerts with the following features: 

¶ Sustained state trigger and reset conditions 

¶ Multiple condition matching 

¶ Automatic alert escalation 

¶ Separate actions for triggers and resets 
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Advanced alerts are configured using the Advanced Alert Manager, as shown in 
the following section. 

Note: If you want to configure advanced alert features, such as timed alert 
checking, delayed alert triggering, timed alert resets, or alert suppression, check 
Show Advanced Features at the lower left of any Advanced Alert windows. For 
the purposes of this document, Show Advanced Features is always enabled. 

Creating a New Advanced Alert 

The following procedure creates a new advanced alert. 

To create a new advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

 

 

3. Click New. 
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The Edit Alert window displays, providing an array of configurable alerting 
options, including trigger and reset conditions, suppressions, and date and time 
limitations. The following sections provide more information about configuring 
alert options. 

Naming, Describing, and Enabling an Advanced Alert 

Use the following steps, after clicking New, Copy, or Edit from the Manage 
Alerts Window, to name and describe an advanced alert. 

To name and describe an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. If you want to create a new alert, click New. 

4. If you want to copy or edit an existing alert, select an alert from the list, 
and then click Copy or Edit, as appropriate. 

 

 

5. Click General, type the name of your alert in the Name of Alert field, and 
then type a description of your alert in the description field. 
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6. Check Enable this Alert. 

 

 

7. Type the Alert Evaluation Frequency and select Seconds, Minutes, or Hours 
from the list to set the checking interval for your alert. 

 

 

8. Click Trigger Condition to set the trigger condition for your alert. For more 
information, see ñSetting a Trigger Condition for an Advanced Alertò on 
page 123. 
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Setting a Trigger Condition for an Advanced Alert 

You can set the specific conditions for triggering an advanced alert with the 
following procedure. 

Note: Properly defining alert trigger conditions to address specifc network 
conditions on selected network objects can eliminate the need for alert 
suppression conditions. SolarWinds recommends the use of appropriately 
specific trigger conditions to define alerts instead of suppression conditions, if 
possible. For more information about defining conditions, see ñUnderstanding 
Condition Groupsò on page 130. 

To set the trigger conditions for an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. If you want to create a new alert, click New. 

4. If you want to copy or edit an existing alert, select an alert from the list, 
and then click Copy or Edit, as appropriate. 

5. Click Trigger Condition. 

6. Select the Type of Property to Monitor from the list. 

Note: The following image is a screen capture from an Orion Network 
Performance Monitor installation. Other modules will look similar, but 
different objects may be present. 

 

 

7. If you select Custom SQL Alert, complete the following steps: 

a. Select the object on which you want to alert in the Set up your Trigger 
Query field. 

b. Provide your custom SQL in the field below the object selection query. 

c. If you want to delay the trigger of this alert, provide the value and unit 
of your desired alert trigger delay. 

d. If you want to confirm your provided SQL, click Validate SQL. 
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8. If you select a type of monitored object, complete the following steps: 

a. Generate trigger conditions in the text field by selecting appropriate 
descriptors from the linked context menus and by clicking Browse (é) 
on the left of the text field. 

b. Click the linked text to select the number of conditions that you want to 
apply (all, any, none, not all). For more information about linked text 
conditions, see ñUnderstanding Condition Groupsò on page 130. 

 

 

c. Click Browse (é) to view the following condition options: 

Note: The has changed condition is only valid for the Last Boot, IOS 
Version, and IOS Image Family device characteristics. 

 

 

¶ To generate a condition based on a comparison of device states, 
click Add a Simple Condition. 

 

 

¶ To generate a condition based on a comparison of device fields and 
values, click Add a Complex Condition. 

¶ To define more conditions, click Add a Condition Group. 

¶ To remove a selected condition, click Delete Current Condition. 

¶ To change the order of your conditions, click Move Down or Move 
Up, as appropriate. 
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d. If you need an additional condition, click Browse (é), and then click 
Add ConditionType, as appropriate for the condition you want to add. 

e. If you need to delete a condition, click Browse (é), next to the 
condition you want to delete, and then click Delete Current Condition. 

Notes:  

¶ Conditions may be exported for use with other alerts by clicking 
Export Conditions and saving as appropriate. 

¶ Click Import Conditions to import existing conditions from other 
alerts. Imported trigger conditions automatically overwrite any 
existing trigger conditions. 

f. If you want to specify a time duration for the condition to be valid, 
type the interval and select Seconds, Minutes, or Hours from the list. 

Note: You may need to delay alert trigger actions until a condition has 
been sustained for a certain amount of time. For example, an alert based 
on CPU load would not trigger unless the CPU Load of a node has been 
over 80% for more than 10 minutes. To set up a sustained-state trigger 
condition, at the bottom of the Trigger Condition tab, provide an 
appropriate amount of time the alert engine should wait before any 
actions are performed. By default, the alert triggers immediately, if the 
trigger condition exists. The maximum alert action delay is eight hours 
after the trigger condition is met. 

g. If you are finished configuring your advanced alert, click OK. 

Setting a Reset Condition for an Advanced Alert 

Set specific conditions for resetting an advanced alert using the following steps. 

To set the conditions for resetting an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts, and then click New or select an alert from 
the list and click Copy or Edit. 

3. Click Reset Condition. 

4. If you want a simple alert reset when trigger conditions no longer exist, 
select Reset when trigger conditions are no longer true. 

5. If you want a conditional alert reset, select Reset this alert when the 
following conditions are met. 

Notes: Generate reset conditions in the text field by selecting appropriate 
descriptors from the linked context menus and by clicking Browse (é). 
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6. If you want to copy the condition used on the Trigger Condition tab, 
click Copy From Trigger. 

7. Click the linked text to select the number of conditions to apply. For more 
information, see ñUnderstanding Condition Groupsò on page 130. 

8. Click Browse (é) to view the following condition options: 

¶ To generate a condition based on a comparison of device states, click 
Add a Simple Condition. 

¶ To generate a condition based on a comparison of device fields and 
values, click Add a Complex Condition. 

¶ To further define condition application, click Add a Condition Group. 

¶ To remove a selected condition, click Delete Current Condition. 

¶ To change the order of your conditions, click Move Down or Move Up. 

9. If you need an additional condition, click Add, and then select the type of 
condition you want to add. 

10. If you need to delete a condition, select the condition from the condition 
list, and then click Delete. 

Notes:  

¶ Conditions may be exported for use with other alerts by clicking Export 
Conditions and saving as appropriate. 

¶ Conditions from other alerts may be imported to the current alert by 
clicking Import Conditions. 

Warning: Imported trigger conditions automatically overwrite any 
existing trigger conditions. 

¶ Because there are many situations where the reset conditions are the 
opposite of, or are very similar to, the trigger conditions, SolarWinds has 
provided a function that copies the trigger conditions to the reset 
conditions. Click Copy From Trigger to add the trigger condition. 

11. If you want to specify a time duration for the condition to be valid, type 
the time interval and select Seconds, Minutes, or Hours from the list. 

Note: It is often appropriate to delay alert reset actions until a condition has 
been sustained for a certain amount of time. For example, an alert based on 
node status would not reset until the node has been up for more than five 
minutes. To establish a sustained-state reset condition, provide an 
appropriate interval at the bottom of the Reset Condition tab for the amount 
of time that the alert engine should wait before any actions are performed. 
The default setting is to reset the alert immediately, once the reset condition 
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exists. The maximum interval between when the trigger condition first exists 
and when the corresponding alert action is performed is eight hours. 

12. If you are finished configuring your advanced alert, click OK. 

Setting a Suppression for an Advanced Alert 

You can set the specific conditions for suppressing an advanced alert using the 
following procedure. 

Notes: 

¶ Alert Suppression is only available if you have checked Show Advanced 
Features in the lower left of the Edit Advanced Alert window. 

¶ In many cases, because suppression conditions are checked against all 
monitored objects on your network, properly defining alert trigger conditions 
may eliminate the need for alert suppression. For more information about 
defining alert trigger conditions, see ñSetting a Trigger Condition for an 
Advanced Alertò on page 123 and ñUnderstanding Condition Groupsò on 
page 130. 

To set conditions for advanced alert suppression: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New or select an alert from the list. 

4. Click Copy or Edit, as appropriate. 

5. Click Alert Suppression. 

Note: Generate suppression conditions in the text field by selecting 
appropriate descriptors from the linked context menus and by clicking 
Browse (é) on the left of the text field. 

6. If you want to copy the condition used on the Trigger Condition tab, 
click Copy From Trigger. 

7. Click the linked text to select the number of conditions that you want to apply 
(all, any, none, not all). For more information about linked text conditions, 
see ñUnderstanding Condition Groupsò on page 130. 

8. Click Browse (é) to view the following condition options: 

¶ To generate a condition based on a comparison of device states, click 
Add a Simple Condition. 

¶ To generate a condition based on a comparison of device fields and 
values, click Add a Complex Condition. 
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¶ To further define the application of your conditions, click Add a 
Condition Group. 

¶ To remove a selected condition, click Delete Current Condition. 

¶ To change the order of your conditions, click Move Down or Move Up. 

9. If you need an additional condition, click Add and then select the type of 
condition you want to add. 

10. If you need to delete a condition, select the condition from the condition 
list, and then click Delete. 

Note: Conditions may be exported for use with other alerts by clicking 
Export Conditions and saving as appropriate. Conditions from other alerts 
may be imported to the current alert by clicking Import Conditions. 

Warning: Imported conditions automatically overwrite existing conditions. 

11. If you are finished configuring your advanced alert, click OK. 

Setting the Monitoring Period for an Advanced Alert 

You can select the specific time periods and days that your advanced alert will 
monitor your network objects with the following procedure. 

To set the monitoring time period and days for an advanced alert: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New or select an alert from the list. 

4. Click Copy or Edit. 

5. Click Time of Day. 

6. Enter the time period over which you want to monitor your network. 

Note: Alerts only trigger if the trigger condition is met within this time period. 

7. Select the days on which you want to monitor your network. 

Note: Alerts will only trigger if your trigger condition is met on the days 
selected. 

8. If you are finished configuring your advanced alert, click OK. 
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Setting a Trigger Action for an Advanced Alert 

Select actions that will occur when your advanced alert is triggered as follows. 

To set a trigger action for an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New or select an alert from the list, and then click Copy or Edit, as 
appropriate. 

4. Click Trigger Actions. 

5. If you are adding a new advanced alert action, click Add New Action, 
and then select the actions you want to occur when the alert triggers. 

6. If you are editing an existing advanced alert action, select the existing 
alert action, and then click Edit Selected Action. 

7. Follow the instructions to configure each action.   

Note: Depending on the type of action selected, different options will be 
displayed to configure the alert action. For more information about individual 
alert actions, see ñAvailable Advanced Alert Actionsò on page 136. 

8. If you need to delete an action, select the action and then click Delete 
Selected Action. 

9. If you are finished configuring your advanced alert, click OK. 

Setting a Reset Action for an Advanced Alert 

Select actions that will occur when your advanced alert is reset with the following 
procedure. 

To set a reset action for an advanced alert: 

1. Click Start > SolarWinds Orion > Alerting, Reporting, and Mapping > 
Advanced Alert Manager. 

2. Click View > Configure Alerts. 

3. Click New Alert, Copy Alert, or Edit Alert, as appropriate. 

4. Click Reset Actions. 

5. If you are adding a new advanced alert action, click Add New Action, 
and then select the actions you want to occur when the alert triggers. 

6. If you are editing an existing advanced alert action, select the existing 
alert action, and then click Edit Selected Action. 
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7. Follow the instructions to configure each action.   

Note: Depending on the type of action selected, different options display 
configuring the alert action. For more information about individual alert 
actions, see ñAvailable Advanced Alert Actionsò on page 136. 

8. If you need to delete a selected action, click Delete Selected Action. 

9. If you are finished configuring your advanced alert, click OK. 

Alert Escalation 

When editing any trigger or reset action, use the Alert Escalation tab, if it is 
available, to define additional alert action options. Depending on the alert action 
being configured, any or all fo the following options may be available on the Alert 
Escalation tab: 

¶ To disable the action when the alert has been acknowledged, check Do not 
execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered and 
then provide an appropriate action execution interval. 

¶ To delay the execution of the alert action, check Delay the execution of this 
Action and then provide an appropriate interval that the alert engine should 
wait after the alert condition is met before the alert action is executed. 

For more information, see ñEscalated Advanced Alertsò on page 152. 

Understanding Condition Groups 

A condition group is a set of user-defined rules governing alert triggers and 

resets. By default, the condition group Trigger Alert when all of the 

following apply  is added when new alert triggers or reset conditions are 

created. Four different logical descriptors are used to create conditions: all , any , 

none , and not all , and clicking the word all  and enables you to select different 

values. The following sections describe these logical descriptors. 

All Condition Group 

Trigger Alert when all  of the following apply  means that every 

condition in the group must be true before the alert is triggered.  

In the following example, there are three conditions within the condition group: 

¶ Node Status is equal to Up 

¶ Percent Loss is greater than or equal to 75 

¶ CPU Load is greater than or equal to 85 
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This alert will not trigger unless the Node is Up, packet loss is greater than or 
equal to 75%, and CPU load is greater than or equal to 85%. 

When setting the condition group to all , picture every condition as being 

separated by an and  statement. So, in this example, the alert trigger would read: 

Alert when: (Node Status  = Up) and (Percent Loss  >= 75) and (CPU 

Load  >= 85)  

Any Condition Group 

Changing the condition group to Trigger Alert when any  of the following 

apply  changes the logic to or  statements. In this example, changing the 

condition group to any  would change the alert trigger to: 

Alert when: (Node Status  = Up) or (Percent Loss  >= 75) or (CPU 

Load  >= 85)  

In this situation, if any of the three conditions become true, the alert will trigger. 

None Condition Group 

Changing the condition group to Trigger Alert when none  of the 

following apply  means that all conditions in the group must be false before the 

alert is triggered. 

In this example the alert trigger would read: 

Alert when: (Node Status  = Down) and (Percent Loss  <= 75) and 

(CPU Load  <= 85)  

Each condition is separated by an and  statement just like the all  condition 

group; however, the conditions have been inverted (Node Status = Down  

instead of Node Status = Up ). 

Not All Condition Group 

Changing the condition group to Trigger Alert when not all  of the 

following apply  means that any condition in the group must be false before 

the alert is triggered. So, in this example the alert trigger would read: 

Alert when: (Node Status  = Down) or (Percent Loss  <= 75) or (CPU 

Load  <= 85)  

Each condition is separated by an or  statement just like the any  condition group; 

however, the conditions have been inverted (Node St atus  = Down instead of 

Node Status  = Up). 
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Using the Advanced Alert Manager 

The Advanced Alert Manager is an interface used to view network events and 
alerts. You can also use Advanced Alert Manager to create and manage 
advanced alerts. The following procedures introduce the main features of the 
Advanced Alert Manager showing how to configure and view advanced alerts. 

Current Events Window 

The Current Events window of the Advanced Alert Manager shows the most 
recent network events with their descriptions and other information from the 
events log.  

To use the Current Events window to view network events: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Current Events. 

3. Select one of the following Group By criteria for grouping events: Event 
Type, Object Type, Network Node, Acknowledged, or No Grouping. 

4. If you want to change the viewable category columns in the Current 
Events window, click Include, and then complete the following procedure: 

a. Click the Event View Columns tab, and then select column IDs from the 
All Columns field. 

b. Click the right arrow to move your column IDs into the Selected 
Columns field. 

c. If there are any column IDs in the Selected Columns field that you 
do not want to view, select them, and then click the left arrow to move 
your selected column IDs to the All Columns field. 

d. Click the up or down arrows to change the order of your selected 
columns accordingly. 

e. Position the slider to set the Event View refresh rate. 

f. Type the number of events that you want to be able to review in the 

Display a maximum of XXXX events in the Event View field. 

g. If you are finished configuring your Current Events View, click OK. 

5. Click Refresh to update the Current Events window with the latest events 
and column IDs. 

6. If you want to acknowledge a network event, click X next to the event. 
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Active Alerts Window 

The Active Alerts window of the Advanced Alert Manager shows network alerts 
with their descriptions and other information from the alerts log.  

To use the Active Alerts window to view active network alerts: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click View > Active Alerts. 

3. Select one of the Group By criteria for grouping alerts: Alert Name, Object 
Type, Object Name, Alert State, Acknowledged, Acknowledged By, or 
No Grouping. 

4. Click Include, and then check the types of alerts that you want to view: 
Acknowledged, Trigger Pending, Triggered, or Reset Pending. 

5. If you want to change the viewable category columns in the Current 
Events window, click Include > Select Alert Columns, and then complete 
the following procedure: 

a. Select column IDs from the All Columns field. 

b. Click the right arrow to move your column IDs into the Selected 
Columns field. 

c. If there are any column IDs in the Selected Columns field that you 
do not want to view, select them, and then click the left arrow to move 
your selected column IDs to the All Columns field. 

d. Click the up or down arrows to change the order of your selected 
columns accordingly. 

e. Position the slider to set the Alert View refresh rate. 

f. If you are finished configuring your Active Alerts View, click OK. 

6. Click Refresh to update the Active Alerts window with the latest alerts and 
column IDs. 

7. Click Configure Alerts to change the settings for individual alerts. For more 
information, see ñMonitoring Network Eventsò on page 117. 

8. If you want to acknowledge an active alert, check the alert in the 
Acknowledged column. 

Note: As soon as the alert is acknowledged, the user information and 
date/time is recorded in the database. 
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Alert Viewer Settings 

Alert views in the Orion Advanced Alert Manager are configured in the Alert 
Viewer Settings window, as presented in the following procedure. 

To configure alert views in the Advanced Alert Manager: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click File > Settings. 

Note: The Configure Alerts tab of the Alert Viewer Settings window displays 
all available network alerts, and from this window you can create, copy, edit, 
and delete alerts. For more information, see ñCreating and Configuring 
Advanced Alertsò on page 119. 

3. Click Alert View Columns. 

4. Select the information titles that you want to see about your alerts from the 
All Columns list. 

5. Click the right arrow to transfer them to the Selected Columns list. 

Note: The Selected Columns list provides a list of all the information that the 
Alert Viewer will show for each active alert. 

6. If you want to remove titles from the Selected Columns list, select titles 
that you want to remove from the active view in the Selected Columns list, 
and then click the left arrow. 

7. If you want to rearrange the order in which the different pieces of alert 
information are presented in the Alert Viewer, select titles from the 
Selected Columns list and use the up and down arrows to arrange the titles 
accordingly. 

8. Position the slider at the bottom of the tab to set the Alert View refresh rate. 

9. Click Event View Columns. 

10. Select the information titles that you want to see about events from the All 
Columns list. 

11. Click the right arrow to transfer them to the Selected Columns list. 

Note: The Selected Columns list provides a list of all the information that the 
Alert Viewer will show for each recorded event. 

12. If you want to remove titles from the Selected Columns list, select titles 
that you want to remove from the active view in the Selected Columns list, 
and then click the left arrow. 

13. If you want to rearrange the order in which the different pieces of event 
information are presented in the Alert Viewer, select titles from the 
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Selected Columns list and use the up and down arrows to arrange the titles 
accordingly. 

14. Position the slider at the bottom of the tab to set the Event View refresh rate. 

15. Enter the number of events that you want to see in the Event View. 

Adding Alert Actions 

Orion Network Performance Monitor provides a variety of actions to signal an 
alert condition on your network. These alert actions are available for both basic 
and advanced alerts, and the following procedure assigns actions to the alert 
conditions that you have defined for your network. 

To add an alert action: 

1. Click Start > All Programs > SolarWinds Orion > Network Performance 
monitor > System Manager. 

2. Click Alerts > Active Alerts, and then click either Configure Basic Alerts 
or Configure Advanced Alerts, as appropriate. 

3. Check the alert to which you want to add the action, and then click Edit 
Alert. 

4. Click Actions, and then select the action you want to edit. 

5. Click Add Alert Action, and then click the action to add to your chosen alert. 
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For more information about individual alert actions, see ñAvailable Advanced 
Alert Actionsò on page 136. 

Available Advanced Alert Actions 

The following sections detail the configuration of available alert actions: 

¶ Sending an E-mail / Page 

¶ Playing a Sound 

¶ Logging an Advanced Alert to a File 

¶ Logging an Advanced Alert to the Windows Event Log 

¶ Logging an Advanced Alert to the NetPerfMon Event Log 

¶ Sending a Syslog Message 

¶ Executing an External Program 

¶ Executing a Visual Basic Script 

¶ Emailing a Web Page 

¶ Using Text to Speech Output 

¶ Sending a Windows Net Message 

¶ Sending an SNMP Trap 

¶ Using GET or POST URL Functions 

¶ Dial Paging or SMS Service 

Sending an E-mail / Page 

The following procedure configures an e-mail/page action for an advanced alert. 

Note: Emails and pages are sent in plain text. 

To configure an email/page action for an advanced alert: 

1. Click E-mail/Pager Addresses, and then  

2. Complete the To, CC, BCC, Name, and Reply Address fields. 

Note: You must provide at least one email address in the To field, and 
multiple addresses must be separated with commas. Some pager systems 
require a valid reply address to complete the page. 

3. Click Message. 

4. Select the format (Plain text or HTML) for your alert email. 
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5. Type the Subject and Message of your alert trigger email/page. 

Note: Messaging is disabled if both Subject and Message fields are empty. 

6. If you want to insert a variable into the Subject or Message field, click 
the location of the new variable, and then complete the following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category, and then select the variable to add. 

c. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

d. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

e. Click Build Selected Variable. 

Note: For more information on the use of variables, see ñOrion Variables 
and Examplesò on page 269. For more information about messages that 
use variables, see ñExample Messages Using Variablesò on page 277. 

7. Click SMTP Server. 

8. Type the Hostname or IP Address of your SMTP Server and the 
designated SMTP Port Number. 

Note: The SMTP server hostname or IP address field is required. You 
cannot send an email/page alert without identifying the SMTP server. 

9. If you want to use SSL/TLS encryption for your alert email, check 
Enable SSL. 

10. If your SMTP server requires authentication, check This SMTP Server 
requires Authentication. 

11. Click Time of Day. 

12. Enter the time period over which you want to activate your alert action, and 
then select the days on which you want to activate your alert action. 

13. If you want to enable alert escalation, click the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 



Administrator Guide Ö SolarWinds Orion Core 
 

 
138 Ö Using Orion Advanced Alerts 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

14. If you are finished configuring your email/page alert action, click OK. 

Playing a Sound 

Orion can be configured to play a sound upon alert trigger or reset. The following 
procedure configures a sound to play for an advanced alert. 

Note: Due to restrictions on Windows service applications, the Play a Sound 
action is not available to Orion installations on either Windows 7 or Windows 
Server 2008 and higher. 

To configure a play sound action for an advanced alert: 

1. Click Play Sound. 

2. Specify a sound file for the alert trigger by doing either of the following in the 
Sound file to play field: 

¶ Type the complete directory path and file name. 

¶ Click Browse (é) to navigate your file system and select the target file. 

3. Click the musical note button to the right of either text field to test the sound 
file you have specified. 

4. Click Time of Day. 

5. Enter the time period over which you want to activate your alert action, and 
then select the days on which you want to activate your alert action. 

6. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

7. If you are finished configuring your play a sound alert action, click OK. 
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Logging an Advanced Alert to a File 

Orion can be configured to log alerts to a designated file. The following 
procedure logs an advanced alert to a designated file 

To configure an alert log file for an advanced alert: 

1. Click Event Log, and then specify an alert log file by doing either of the 
following in the Alert Log Filename field: 

Note: If the file specified does not exist, it will be created with the first alert 
occurrence. 

¶ Type the complete path and name of the target file. 

¶ Click Browse (é) to navigate your file system and select the target file. 

2. Type the message you want to log to your alert log file in the Message field. 

3. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable, and then select a Variable Category. 

b. Select the variable you want to add. 

c. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

d. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

e. Click Build Selected Variable. 

Note: For more information on the use of variables, see ñOrion Variables 
and Examplesò on page 269. 

4. Click Time of Day. 

5. Enter the time period over which you want to activate your alert action. 

6. Select the days on which you want to activate your alert action. 

7. If you want to enable alert escalation, click the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 
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¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

8. If you are finished configuring your alert log file, click OK. 

Logging an Advanced Alert to the Windows Event Log 

You may specify that an alert be logged to the Windows Event Log either on the 
Orion server or on a remote server. The following procedure logs an advanced 
alert to the Windows Event Log on a designated server. 

To configure advanced alert logging to the Windows Event Log: 

1. Click Windows Event Log. 

2. If you want your alert to write to the Windows Event Log on your Orion 
server, select Use Event Log Message on Network Performance Monitor 
Server. 

3. If you want your alert to write to the Windows Event Log on a remote 
server, select Use Event Log Message on a Remote Server, and then 
provide the Remote Server Name or IP Address. 

4. Type the message you want to log to the Windows Event Log in the 
Message to send to Windows Event Log field. 

5. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category. 

c. Select the variable you want to add. 

d. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

e. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

f. Click Build Selected Variable. 

Note: For more information on the use of variables, see ñOrion Variables 
and Examplesò on page 269. 

6. Click Time of Day. 

7. Enter the time period and select the days over which you want to activate 
your alert action. 
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8. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

9. If you are finished configuring your alert log file, click OK. 

Logging an Advanced Alert to the NetPerfMon Event Log 

You may specify that an alert be logged to the NetPerfMon Event Log either on 
the Orion server or on a remote server. The following procedure logs an 
advanced alert to the NetPerfMon Event Log on a designated server. 

To configure advanced alert logging to the NetPerfMon Event Log: 

1. Click NPM Event Log. 

2. Type the message you want to log to the NetPerfMon Event Log in the 
Message to send to Network Performance Monitor Event Log field. 

3. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category. 

c. Select the variable you want to add. 

d. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

e. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

f. Click Build Selected Variable. 

Note: For more information on the use of variables, see ñOrion Variables 
and Examplesò on page 269. 

4. Click Time of Day. 

5. Enter the time period and select the days over which you want to activate 
your alert action. 
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6. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

7. If you are finished configuring your alert log file, click OK. 

Sending a Syslog Message 

Orion can log received alerts to the Syslog of a designated machine. The 
following procedure configures an advanced alert to send a message to a 
designated Syslog server. 

To configure an advanced alert to send a Syslog message: 

1. Click Syslog Message. 

2. Type the Hostname or IP Address of the Syslog Server to which you want 
to send Syslog messages. 

3. Select the Severity of your alert Syslog message. 

Note: For more information, see ñSyslog Severitiesò on page 198. 

4. Select Facility of your alert Syslog message. 

Note: For more information, see ñSyslog Facilitiesò on page 197. 

5. Type the Syslog Message you want to send. 

6. If you want to insert a variable into the Message field, complete the 
following procedure: 

a. Click Insert Variable. 

b. Select a Variable Category. 

c. Select the variable you want to add. 

d. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

e. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 
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f. Click Build Selected Variable. 

Note: For more information on the use of variables, see ñOrion Variables 
and Examplesò on page 269. 

7. Click Time of Day. 

8. Enter the time period over which you want to activate your alert action. 

9. Select the days on which you want to activate your alert action. 

10. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

11. If you are finished with the configuration of your send Syslog message 
action, click OK. 

Executing an External Program 

There are several circumstances where you may want to execute a program 
when a specific network event occurs. Use the Edit Execute Program Action 
window to specify the executable that should be started when the specified alert 
is triggered or reset, as shown in the following procedure. 

Note: External programs selected for this action must be executable using a 
batch file called from the command line. 

To configure an advanced alert to execute an external program: 

1. Click Execute Program. 

2. Specify the batch file to execute, either by typing the complete path and 
name of the target file into the Program to execute field or by clicking 
Browse (é), to browse your folder structure and select the target 
executable. 

3. Click Time of Day, and then enter the time period when you want to execute 
the external program. 

4. Select the days on which you want to execute the external program. 
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5. Click Alert Escalation, and then check any of the following options, as 
appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly, while the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered, 
and then provide an action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide the interval the alert engine should wait. 

6. If you are finished configuring your external program execution action, 
click OK.  

Executing a Visual Basic Script 

In some situations you may want to execute a Visual Basic (VB) script when a 
network event occurs. The Edit Execute VB Script Action window is used to 
specify the name and complete path of the file that shall be executed when the 
specified alert is triggered or reset.  

To configure alerts to execute a Visual Basic (VB) script: 

1. Click VB Script. 

2. Select an available VB Script Interpreter. 

3. Specify a VB script to execute either by typing the complete path and name 
of the VB script into the VB Script to execute field or by clicking Browse 
(é) to browse your folder structure and select the script. 

4. Click Time of Day, and then enter the time period and select the days on 
which you want to execute the selected VB script. 

5. Click Alert Escalation, and then check any of the following options, as 
appropriate for your alert: 

¶ To disable the script when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the script repeatedly as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay script execution, check Delay the execution of this Action, 
and then provide an appropriate interval the alert engine should wait 
after the alert condition is met before the script executes. 

6. If you are finished configuring your VB script execution action, click OK.  
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Emailing a Web Page 

The Edit E-mail Web Page Action window includes several tabs for configuration. 
The following procedure configures an e-mail URL action for an advanced alert. 

Note: Emails are sent in plain text. 

To configure an email web page action for an advanced alert: 

1. Click E-mail a Web Page, and then then click OK.  

2. Complete the To, CC, BCC, Name, and Reply Address fields. 

Note: You must provide at least one address in the To field. When entering 
multiple addresses, you may only separate addresses with a comma. Some 
pager systems require a valid reply address to complete the page. 

3. Click SMTP Server. 

4. Type the Hostname or IP Address of your SMTP Server and the 
designated SMTP Port Number. 

Note: The SMTP server hostname or IP address field is required. You 
cannot email a web page without identifying the SMTP server. 

5. Click URL, and then type the Subject of your alert email. 

Note: Messaging is disabled if both Subject and URL fields are empty. 

6. If you want to insert a variable into the Subject field, click the location of 
the new variable, and then complete the following procedure: 

a. Click Insert Variable, select a Variable Category, and then select the 
variable to add. 

b. If you want to change the parser, check Change Parser, and then 
select the parser you want to use. 

c. If you want to define the SQL variable to copy to the clipboard, 
check Define SQL Variable, and then click Insert Variable From 
Above List. 

d. Click Build Selected Variable. 

Note: For more information on the use of variables, see ñOrion Variables 
and Examplesò on page 269. For more information about messages that 
use variables, see ñExample Messages Using Variablesò on page 277. 

7. Provide the URL of your alert email. 

Note: Messaging is disabled if both Subject and URL fields are empty. 
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8. If the web server of the URL you want to email requires user access 
authentication, provide both the Web Server UserID and the Web Server 
Password in the Optional Web Server Authentication area. 

9. Click Time of Day, and then enter the time period and select the days when 
you want to activate your alert action. 

10. If you want to enable alert escalation, click Alert Escalation, and then 
check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

11. If you are finished configuring your URL email alert action, click OK. 

Using Text to Speech Output 

You may specify a phrase that will be spoken upon alert trigger and a separate 
phrase for the alert reset. Orion uses Microsoft Speech Synthesis Engine version 
5.0, as included with Windows 2003 and XP Professional. If you have Orion 
maintenance, you may also install and use other text-to-speech engines by 
visiting the SolarWinds website. The following procedure configures text-to-
speech output for an advanced alert trigger or reset. 

Note: Due to restrictions on Windows service applications, the Text to Speech 
action is not available to Orion installations on either Windows 7 or Windows 
Server 2008 and higher. 

To configure a text-to-speech output action for an advanced alert: 

1. Click Text to Speech output, and then then click OK.  

2. On the General tab, Select a Speech Engine, and then use the sliders to set 
the required Speed, Pitch and Volume.  

3. On the Phrase tab, type the text you want to output as speech in the Phrase 
to speak field. 

Note: Click Speak to hear the text, as provided, with the options configured 
as set on the General tab. 

4. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 
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5. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

6. If you are finished configuring your text-to-speech alert action, click OK. 

Sending a Windows Net Message 

Alerts can be configured to display a pop-up Windows Net Message either on a 
specific computer or on all computers in a selected domain or workgroup. The 
following steps configure Windows Net messaging for triggered or reset alerts. 

Note: The only operating systems supporting Windows Net Messaging on which 
SolarWinds supports Orion installations are Windows Server 2003 and Windows 
XP. SolarWinds only supports evaluation installations of Orion on Windows XP. 

To configure Orion to send a Windows Net message upon alert: 

1. Click Send a Windows Net Message, and then then click OK.  

2. On the Net Message tab, enter the Computer Name or IP Address of the 
machine where you want to send a Windows Net message upon an alert 
trigger or reset. 

3. If you want to send the message to all computers in the domain or 
workgroup of your target computer, check Send to all Computers in the 
Domain or Workgroup. 

4. Enter the Windows Net message you want to send in the Message to send 
field. 

Note: You may use variables in this message. For more information on the 
use of variables, see ñOrion Variables and Examplesò on page 269. 

5. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 
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6. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

7. If you are finished configuring your text-to-speech alert action, click OK. 

Sending an SNMP Trap 

The following steps configure an alert to send an SNMP trap on trigger or reset.  

To configure Orion to send an SNMP trap upon alert: 

1. Click Send an SNMP Trap, and then then click OK.  

2. On the SNMP Trap tab, in the SNMP Trap Destinations field, enter the IP 
addresses of the servers to which you want to send your generated SNMP 
traps. 

Note: Use commas to separate multiple destination IP addresses.  

3. Select the type of trap to send on alert trigger from the Trap Template list. 

Note: Some trap templates may use an alert message. You may change any 
provided text, if you want, but it is important that you understand the use of 
variables beforehand. For more information about using variables, see ñOrion 
Variables and Examplesò on page 269. 

4. Enter the SNMP Community String for your network in the designated field. 

5. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 

6. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 
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¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

7. If you are finished configuring your SNMP trap alert action, click OK. 

Using GET or POST URL Functions 

Orion can be configured to communicate alerts using HTTP GET or POST 
functions. As an example, a URL may be used as an interface into a trouble 
ticket system, and, by correctly formatting the GET function, new trouble tickets 
may be created automatically. The following procedure configures Orion to use 
GET or POST HTTP functions to communicate alert information. 

The  

To configure Orion to use GET or POST URL functions with alerts: 

1. Click Get or Post a URL to a Web Server, and then then click OK.  

2. Select either Use HTTP GET or Use HTTP POST to set the function that you 
want to use to communicate alert information. 

3. If you selected Use HTTP GET, enter the URL you want to GET. 

4. If you selected Use HTTP POST, enter the URL you want to POST, and 
then enter the Body to POST. 

5. On the Time of Day tab enter the time period and select the days on which 
you want to activate your alert action. 

6. If you want to enable alert escalation, open the Alert Escalation tab, and 
then check any of the following options, as appropriate for your alert: 

¶ To disable the action when the alert has been acknowledged, check Do 
not execute this Action if the Alert has been Acknowledged. 

¶ To execute the action repeatedly, as long as the trigger condition exists, 
check Execute this Action repeatedly while the Alert is Triggered 
and then provide an appropriate action execution interval. 

¶ To delay alert action execution, check Delay the execution of this 
Action, and then provide an appropriate interval for the alert engine to 
wait after the alert condition is met before executing the alert action. 

7. If you are finished with the configuration of Orion to use HTTP GET or 
POST URL functions, click OK. 
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Dial Paging or SMS Service 

If NotePager Pro is installed Orion can be configured to communicate alerts 
using paging and SMS services. For more information about installation and 
configuration, see ñSolarWinds Orion Network Performance Monitor Integrationò 
at www.notepage.net. 

Testing Alert Actions 

The Advanced Alert Manager provides an alert action test feature so you can 
confirm the desired function for actions you have configured to fire when Orion 
detects an alert condition on your network. Complete he following procedure to 
test an alert action. 

To test an alert action: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click Configure Alerts. 

3. Click the alert for which the action you want to test is configured. 

4. Click Test. 

5. If the alert is configured to fire on a node condition, select Alert on 
Network Node, and then select the node against which you want to test the 
action. 

6. If the alert is configured to fire on an interface condition, complete the 
following steps: 

Note: Testing alert actions against interfaces is only available if Orion 
Network Performance Monitor is installed and monitoring interfaces on your 
network. For more information, see the SolarWinds Orion Network 
Performance Monitor Administrator Guide. 

a. Select Alert on Network Node, and then select the parent node of the 
interface against which you want to test the action. 

b. Select Select Interface on ParentNode, and then select the interface 
against which you want to test the action. 

7. If the alert is configured to fire on a volume condition, complete the 
following steps: 

a. Select Alert on Network Node, and then select the parent node of the 
volume against which you want to test the action. 

b. Select Select Volume on ParentNode, and then select the volume 
against which you want to test the action. 

http://www.notepage.net/solar-winds/orion.htm
http://www.notepage.net/
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8. If you are testing an alert trigger action, click Test Alert Trigger. 

9. If you are testing an alert reset action, click Test Alert Reset. 

10. When the test completes, as indicated by the test log, click Done. 

Confirm that the expected action occurred as a result of the selected alert trigger 
or reset. 

Viewing Alerts in the Orion Web Console 

The Triggered Alerts for All Network Devices page provides a table view of your 
alerts log. You can customize the list view by using the following procedure to 
select your preferred alert grouping criteria. 

To view alerts in the Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Alerts in the Views toolbar. 

3. If you want to filter your alerts table view by device, select the device to 
which you want to limit your alerts view in the Network Object field. 

4. If you want to filter your alerts table by type of device, select the device 
type to which you want to limit your alerts view in the Type of Device field. 

5. If you want to limit your alerts table to show a specific type of alert, 
select the alert type in the Alert Name field. 

6. In the Show Alerts field, provide the number of alerts you want to view. 

7. If you want to show all alerts, even if they have already been cleared or 
acknowledged, check Show Acknowledged Alerts. 

8. Click Refresh to complete your Alerts view configuration. 

Acknowledging Advanced Alerts in the Web Console 

Orion allows you to acknowledge advanced alerts in the Orion Web Console, 
allowing you to eliminate time lost either when multiple users attempt to resolve 
the same issue or when a user tries to address an issue that has already been 
resolved. 

To acknowledge advanced alerts using the Orion Web Console: 

1. Log in to the Orion Web Console using an account that has been granted 
alert acknowledgement privileges. 

Note: For more information about access privileges for Orion Web Console 
users, see ñUser Account Access Settingsò on page 99. 

2. Click Alerts on the Views toolbar. 
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3. If you want to limit the list of alerts to only those dealing with a single 
device, select the specific device from the Network Object list. 

Note: This option is only available if alerts fire on multiple network devices. 

4. If you want to limit the list of alerts to only those dealing with a single 
type of device, select the device type from the Type of Device list. 

Note: This option is only available if Orion is monitoring multiple types of 
network devices. 

5. If you want to limit the list of alerts to only those of a single type, select 
the specific alert type from the Alert Name list. 

Note: This option is only available when multiple types of Orion alerts have 
been triggered. 

6. Confirm the number of alerts displayed in the Show Alerts field. 

7. If you want acknowledged alerts to remain in the Alerts view, even after 
they have been acknowledged, check Show Acknowledged Alerts. 

8. Click Refresh to update the alerts list with your new settings. 

9. Check Acknowledged next to the alerts you want to acknowledge. 

10. Click Acknowledge Alerts. 

Escalated Advanced Alerts 

By creating an escalated alert, Orion enables you to customize a series of alerts 
to trigger successive actions as an alert condition persists. The following sections 
provide both a scenario where an escalated alert may be useful and the steps 
required to create one using the Orion Advanced Alert Manager. 

Escalated Alert Example 

WidgetCo is a business with a small IT staff, consisting of two technicians and an 
IT manager. To ensure that issues are addressed appropriately, the IT manager 
has created multiple escalated alerts for a range of potential network events, 
including device failures and excessive disk space or bandwidth usage. Typically, 
the escalated alerts configured by the WidgetCo IT manager proceed as follows: 

1. Immediately, as soon as Orion recognizes an alert condition, Orion 
generates both an email and a page that are sent to one of the two 
technicians. An entry is also recorded in the Orion events log. 

2. If the alert is not acknowledged in the Orion Web Console within 20 minutes, 
a second alert is fired, generating another email and another page, both sent 
to both technicians. An entry is also recorded in the Orion events log. 
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3. If the second alert is not acknowledged within 20 minutes, Orion fires a third 
alert that sends both an email and a page to both technicians and to the IT 
manager. An entry is also recorded in the Orion events log. 

Escalated alerts ensure that everyone on the WidgetCo IT staff is notified of any 
significant network alert conditions within 45 minutes without burdening the IT 
manager with excessive alert notifications. The following section provides a 
procedure to create a similar escalated alert scheme. 

Creating a Series of Escalated Alerts 

The following procedure creates a series of escalated alerts similar to the 
scheme described in the preceding example. 

Note: Repeat these steps to create a separate alert for each notification level. 
The example provided in the previous section uses a three-level escalated alert, 
The following procedure should be completed three times, once for each alert, to 
replicate the escalated alert of the previous section. 

To create an escalated alert: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click Configure Alerts. 

3. Click New, and then click General. 

4. Type Level X , where X is the level corresponding to the currently configured  

alert, as the name of your escalated alert in the Name of Alert field. 

Note: The example provided in the previous section uses a three-level 
escalated alert. 

5. Type a description of your first level escalated alert in the description field, 
and then check Enable this Alert. 

6. Type the Alert Evaluation Frequency and select Seconds, Minutes, or Hours 
from the list to set the checking interval for your alert. 

7. Click Trigger Condition. 

Note: For more information about configuring trigger conditions, see ñSetting 
a Trigger Condition for an Advanced Alertò on page 123. 

8. Select Node as the Type of Property to Monitor. 

9. Confirm that the linked text in the alert definition field displays all. 

Note: Click the linked text to select the number of conditions that you want to 
apply (all, any, none, not all). For more information about linked text 
conditions, see ñUnderstanding Condition Groupsò on page 130. 
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10. Click Browse (é), and then click Add a Simple Condition. 

11. Click the first asterisk (*), and then select Network Nodes > Node Details > 
Node Name. 

12. Confirm that is equal to is the linked condition text in the trigger definition. 

Note: Click the linked text to select the condition you want to apply (equal, 
greater, less, é). For more information about linked text conditions, see 
ñUnderstanding Condition Groupsò on page 130. 

13. Click the second asterisk (*), and then select your production web server 
from the list of monitored nodes. 

14. Click Add, and then click Simple Condition. 

15. Click the first asterisk (*) in the second condition, and then select Network 
Nodes > Node Status > Node Status. 

16. Confirm that is equal to is the linked condition text in the second trigger 
definition. 

Note: Click the linked text condition to select the condition you want to apply 
(equal, greater, less, é). For more information about linked text conditions, 
see ñUnderstanding Condition Groupsò on page 130. 

17. Click the second asterisk (*) in the second condition, and then select Down. 

18. If you want to apply any reset conditions to your escalated alert, click 
Reset Condition, and then provide appropriate conditions. For more 
information, see ñSetting a Reset Condition for an Advanced Alertò on 
page 125. 

19. If you want to apply any alert suppressions to your escalated alert, click  
Alert Suppression, and then provide appropriate suppression conditions. 
For more information, see ñSetting a Suppression for an Advanced Alertò on 
page 127. 

20. If you want to restrict when your escalated alert is valid, click Time of 
Day, designate the Valid Time of Day for your escalated alert, and then 
select the Days of the Week on which your escalated alert is valid. For more 
information, see ñSetting the Monitoring Period for an Advanced Alertò on 
page 128. 

Note: By default, your escalated alert is always valid. 

21. Click Trigger Actions, and then click Add New Action. 

22. Select Send an E-mail / Page, and then click OK. 
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23. Click E-mail/Pager Addresses, and then complete the To, CC, BCC, Name, 
and Reply Address fields for your Level 1 contact. 

Note: You must provide at least one email address in the To field. When 
entering multiple addresses in a field, y separate addresses with a comma. 

24. Click Message, and then type the Subject and Message of your escalated 
alert email. 

Notes: 

¶ Messaging is disabled if both Subject and Message fields are empty. 

¶ For more information about variables in email subjects and messages, 
see ñSending an E-mail / Pageò on page 136. 

25. Click SMTP Server, and then provide the Hostname or IP Address of your 
SMTP Server and the designated SMTP Port Number. 

Note: The SMTP server hostname or IP address field is required. You 
cannot send an email/page alert without identifying the SMTP server. 

26. If your SMTP server requires authentication, check This SMTP Server 
requires Authentication. 

27. If you want to restrict when your escalated alert is valid, check Execute 
this Action only between specific hours, and then configure the 
appropriate settings. 

Note: By default, your escalated alert is always valid. For more information, 
see ñSetting the Monitoring Period for an Advanced Alertò on page 128. 

28. Click Alert Escalation. 

29. Check Do not execute this Action if the Alert has been Acknowledged. 

30. If you want to execute the action repeatedly as long as the trigger 
condition exists, check Execute this Action repeatedly while the Alert is 
Triggered, and then provide an appropriate action execution interval. 

31. If you want to delay alert action execution, check Delay the execution of 
this Action, and then provide an appropriate interval the alert engine should 
wait after the alert condition is met before the alert action is executed. 

Note: Typically, if you are configuring the first level alert, you should leave 
this option unchecked. If you are configuring the second level alert, check 
this option and provide the desired delay between the first and second 
notifications. If you are configuring the third level alert, check this option and 
provide the desired delay between the first and third notifications. 

32. Click OK. 
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33. If you want your escalated alert to perform any actions upon reset, click 
the Reset Action tab, and then configure appropriate actions. For more 
information, see ñSetting a Reset Action for an Advanced Alertò on page 129. 

34. If you are finished configuring your escalated alert, click OK. 

Viewing Alerts from Mobile Devices 

Orion is capable of detecting when you are accessing the Orion Web Console 
from a mobile device. This mobile alerts view allows you to view and 
acknowledge existing active alerts. 

To view and acknowledge alerts from a mobile device: 

1. Using a browser on your mobile device, log in to your Orion Web Console as 
a user with alert management rights. 

2. Click Alerts in the Views toolbar. 

Note: If you want to view the mobile alerts view from a desktop or server 

browser, add ?I sMobileView=true  to the URL of the Alerts view in your 

Orion Web Console. 

3. Check alerts you want to acknowledge, and then click Acknowledge. 

Clickable links in alert messages provide more information about triggered alerts. 
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Chapter 11 

Creating Network Maps 

Orion Network Atlas is a powerful tool for creating custom maps and network 
diagrams. The maps created in Orion Network Atlas enable users to view a 
graphical depiction of their network in the Orion Web Console. You can also use 
the maps to create network documentation, which can then be printed and 
exported as needed. 

Map objects may include monitored Orion NPM nodes, interfaces, and volumes; 
Orion APM applications and components; nested maps; and network links. The 
numerous presentation options for your network maps include the following: 

¶ A large set of predefined background colors, textures, and images is 
available for you to use in your maps. You can also provide your own custom 
background graphics. 

¶ Real-time weather or natural disaster maps may be projected directly onto 
your network maps using linked web graphics as a background. 

¶ The shape, size, color, and style of map links may be customized to illustrate 
the status or the relative bandwidth of associated objects. 

¶ Map objects may be presented in a unique set of graphical styles to portray 
network status 

¶ Maps may be nested to selectively reveal increasing levels of map detail, and 
the status of nested map child objects may be bubbled up to the parent map 

Orion Network Atlas is also fully compatible with all network maps created with 
Orion Map Maker used with earlier versions of Orion products. For more 
information, see the SolarWinds Orion Network Atlas Administrator Guide at 
http://www.solarwinds.com/support/orionModules/modulesDoc.aspx. 
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Chapter 12 

Creating and Viewing Reports 

Over time, your Orion database accumulates a great deal of information. 
SolarWinds has developed Report Writer to provide a quick and easy way for you 
to extract data from your database and present it in a useful form. Several 
standard reports that you can modify are included in the Report Writer 
distribution, and you can create new reports as necessary. Report Writer 
includes powerful tools to help you format your information and easily preview 
your reports before you display them. When you have finished editing your 
reports, you can print them with the click of a button, and most reports are also 
enabled for viewing through the Orion Core Web Console, by default. For more 
information about adding reports to Orion Web Console views, see ñCustomizing 
Viewsò on page 40. 

Note: Report Writer capabilities are enhanced when used in conjunction with the 
Custom Property Editor. Once added, properties are available for report sort and 
filter functionality. For more information, see ñCreating Custom Propertiesò on 
page 209. 

Predefined Orion Reports 

The following sections describe the reports that are immediately available with 
your Orion installation. These reports may be modified, as necessary, to suit your 
network performance reporting requirements. 

Note: If the report you require is not listed in any of the following sections, you 
can use Orion Report Writer to create your own custom report. For more 
information about creating your own custom reports, see ñUsing Report Writerò 
on page 168. 

Availability 

The following network availability reports are provided by default with Orion. 

Availability ï Last Month 

Displays the IP address and average availability of all monitored nodes over 
the last month. 

Availability ï This Year 

Displays the IP address and average availability of all monitored nodes over 
the last year. 
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Availability ï Yesterday 

Displays the IP address and average availability of all monitored nodes over 
the previous day. 

Availability of Entire Network ï Last Month 

Displays the availability of all monitored nodes on the entire network over the 
last month. 

Top 25 Percent Down ï Last Month 

Displays the top 25 nodes, by percent downtime, over the last month. 

Current Node Status 

The following node status reports are provided by default with Orion. 

Average Response Time 

Displays both average and peak response times for all monitored nodes. 

Current CPU Load 

Displays current CPU load percentage for all monitored nodes with CPUs. 

Current Response Time 

Displays the IP address and current, average, and peak response times for 
all monitored nodes. 

Current Status of each Node 

Displays the IP address and a verbal statement of the current operational 
status of all monitored nodes. 

Down Nodes 

Displays all monitored nodes that are currently down.   

Last Boot Time for each Node 

Displays the machine type and the date and time of last boot for all nodes. 

Current Volume Status 

Orion provides an Available Space on each Volume report by default. This 
report displays the volume size, available space on the volume, and a 
percentage measure of the available space on the volume for all monitored 
volumes. Volumes are listed beneath their respective parent nodes. 
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Daily Node Availability 

The following node availability reports are provided by default with Orion. 

Availability - Last Month 

Displays the IP address and average daily availability of all monitored nodes 
over the current month. 

Availability - This Month 

Displays the IP address and average daily availability of all monitored nodes 
over the current month. 

Availability - This Year 

Displays the IP address and average daily availability of all monitored nodes 
over the last 12 months. 

Events 

The following network events reports are provided by default with Orion. 

All Down Events 

Displays a list of all events in the database involving nodes that have 
stopped responding to polling over the last 12 months. For each down event, 
this report displays the down event date and time, the node name and IP 
address, and a verbal statement of the down event. 

Down Events - Windows Devices 

Displays a list of all events in the database involving Windows devices that 
have stopped responding to polling over the last month. For each down 
event, this report displays the down event date and time, the node name, and 
a verbal statement of the down event. 

Last 250 Events 

Displays the last 250 events involving any monitored device. For each event, 
this report displays the event date and time, the node involved, and a 
message describing the event.    

Nodes that went down - Last 24 Hours 

Displays a list of all nodes that have stopped responding over the last 24 
hours. For every event of a node going down, this report displays the event 
date and time, an icon representing the current node status, the node name, 
and a verbal statement of the down event.  
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Triggered Alerts - Last 30 Days 

Displays a list of all triggered alerts over the past 30 days. For each triggered 
alert event, this report displays the date and time of the alert trigger, the node 
that triggered the alert, and a message describing the triggered alert event.   

Triggered and Reset Alerts - Last 30 Days 

Displays a list of all triggered and reset alerts over the past 30 days. For 
each triggered or reset alert event, this report displays the date and time of 
the alert event, the node that triggered or reset the alert, and a message 
describing the alert event.   

Historical CPU and Memory Reports 

Orion provides a CPU Load - Last Month report by default. This report displays 
the vendor icon and average and peak CPU load percentages for all monitored 
nodes with CPUs over the previous calendar month. 

Historical Response Time Reports 

The following response time reports are provided by default with Orion. 

Response Time - Last Month 

Displays average and peak response times for all monitored nodes over the 
previous calendar month.   

Response Time - Top 10 Last Month 

Displays the average and peak response times for the top ten monitored 
nodes over the previous calendar month.   

Historical VMware ESX Server Reports 

Orion provides the following VMware ESX Server performance reports by default 
with Orion. 

Network Traffic by VM for Last 7 Days 

For each monitored VMware ESX Server, this report displays the average 
daily network traffic on the ESX Server per hosted VM for the last 7 days. 

Network Traffic by VM for Last Month 

For each monitored VMware ESX Server, this report displays the average 
daily network traffic on the ESX Server per hosted VM for the last month. 
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Percent of CPU by VM for Last 7 Days 

For each monitored VMware ESX Server, this report displays the average 
daily CPU load on the ESX Server due to each hosted VM for the last 7 days. 

Percent of CPU by VM for Last Month 

For each monitored VMware ESX Server, this report displays the average 
daily CPU load on the ESX Server due to each hosted VM for the last month. 

Percent of Memory by VM for Last 7 Days 

For each monitored VMware ESX Server, this report displays the average 
daily memory load on the ESX Server due to each hosted VM for the last 7 
days. 

Percent of Memory by VM for Last Month 

For each monitored VMware ESX Server, this report displays the average 
daily memory load on the ESX Server due to each hosted VM for the last 
month. 

Percent of Time Running vs. Stopped 

For each monitored VMware ESX Server, this report displays both the 
percentage of time that each hosted VM has been running and the 
percentage of time that each hosted VM has been stopped.  

Groups: Current Groups and Groups Members Status 

The following group and group members status reports are provided by default 
with Orion. 

Current Status of each Group 

Current Status of each Group 

Current Status of each Group Member 

Current Status of each Group Member 

Groups and Group Members 

Groups and Group Members 

Groups: Daily Group Availability 

The following group availability reports are provided by default with Orion. 

Group Availability ï Last Month 

Group Availability ï Last Month 
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Group Availability ï This Month 

Group Availability ï This Month 

Group Availability ï This Year 

Group Availabilityï This Year 

Groups: Group Availability (with members) 

The following group availability reports that include member availability are 
provided by default with Orion. 

Group Availability (with members) ï Last Month 

Group Availability (with members) ï Last Month 

Group Availability (with members) ï This Month 

Group Availability (with members) ï This Month 

Group Availability (with members) ï This Year 

Group Availability (with members) ï This Year 

Groups: Historical Groups Status 

The following historical group status reports are provided by default with Orion. 

Historical Status of each Group ï Last 7 Days 

Historical Status of each Group ï Last 7 Days 

Historical Status of each Group ï Last Month 

Historical Status of each Group ï Last Month 

Historical Status of each Group ï This Month 

Historical Status of each Group ï This Month 

Historical Volume Usage Reports 

Orion provides an Average Disk Space Used - Last 12 Months report by 
default. For all monitored volumes, this report displays the volume type and size, 
percentage of the volume space that is currently available, amount of the 
available space that is currently used, and the amount of volume space that is 
currently available. Volumes are listed beneath their respective parent nodes. 

Inventory 

The following network inventory reports are provided by default with Orion. 
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All Disk Volumes 

For all monitored volumes, this report displays the volume type and size, 
available space on the volume, amount of the available space that is 
currently used, and the peak amount of the available space that has been 
used on the volume, with the month in which peak usage occurred, over the 
last 12 months. Volumes are listed beneath their respective parent nodes. 

Device Types 

Displays a list of monitored machine types and the number of each type that 
are currently monitored. 

IOS Versions of Cisco Devices 

For all monitored Cisco devices, this report displays the device name, 
machine type, and Cisco IOS Version and Image. 

Viewing Reports 

All reports, custom or predefined, are available for viewing in both the Orion Web 
Console and in Report Writer, as shown in the following procedures: 

¶ Viewing Reports in the Orion Web Console 

¶ Viewing Reports in the Orion Report Writer 

Note: By default, no report folder is configured for newly created users. If a new 
user is not seeing reports, you may need to select a Report Folder for the new 
user. For more information, see ñConfiguring an Account Report Folderò on 
page 104. 

Viewing Reports in the Orion Web Console 

The following procedure opens reports for viewing in the Orion Web Console. 

To view reports in the Orion Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Orion Web Console, and then click Home > Reports. 

3. Select a report group name to expand the report group. 

4. Click the title of the report you want to view, and it displays directly in the web 
console browser. 

It is also possible to include a report within a web console view as a Report from 
Orion Report Writer resource. For more information about adding the Report from 
Orion Report Writer resource, see ñEditing Viewsò on page 41. 
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Viewing Reports in the Orion Report Writer 

The following procedure opens reports for viewing in the Orion Report Writer. 

To view reports with Orion Report Writer: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Report Writer. 

2. If report groups are not already expanded in the left pane, click + next to 
a report group name to expand the group, and then click the title of the report 
you want to view. 

3. Click Preview. 

Using Report Writer 

Before using Report Writer, you must have collected at least a few minutes worth 
of data in a database populated with devices you want to monitor. A variety of 
reports are included with Report Writer, and icons that precede report names 
distinguish available report types. The following procedure starts Report Writer. 

To start Report Writer: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Report Writer. 

2. Click File > Settings. 

3. In the General tab of the Report Writer Settings window, select either of the 
following as a default viewing mode: 

¶ Preview displays the report as it will appear in printed form. For more 
information, see ñPreview Modeò on page 169. 

¶ Report Designer is the report creation and editing interface. For more 
information, see ñDesign Modeò on page 169. 

Note: You can toggle between Preview and Report Designer modes at any 
time by clicking Preview or Design, respectively, on the toolbar. 

4. If you want to separate the data for individual network objects with 
horizontal lines, click Report Style, and then check Display horizontal 
lines between each row. 

5. Click OK to exit Report Writer Settings. 
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Preview Mode 

Preview mode shows a report as it will print. When you open a report in Preview 
mode, or switch to Preview mode from Design mode, Orion runs the query to 
generate the report, and then Report Writer displays the results. 

The Preview window toolbar provides the following actions and information: 

¶ Current page number and total number of pages in the report. 

¶ Page navigation buttons: First Page, Page Up, Page Down, and Last Page 

¶ Zoom views 

Note: Double-click a preview to zoom in and double-right-click to zoom out. 

¶ Print report 

Design Mode 

Use Design mode to create new reports and modify or rename existing reports. 
The options available for both creating and modifying reports are the same. 
Design mode options are also dynamic, based upon the type of report, included 
report data, and report presentation. Available options differ according to the type 
of report that you are designing, but all reports require that you select the data to 
include and decide how that data will be sorted, ordered, filtered, and presented. 

Creating and Modifying Reports 

Use the following procedure to modify or create reports in Report Writer. 

To open a report with Report Writer: 

1. If you want to modify an existing report, click an existing report from the 
inventory in the left pane of the main Report Writer window. 

2. If you want to create a new report, click File > New Report, select the type 
of report that you would like to create, and then click OK. 

Each report offers different configuration options, so, depending on the report, 
some formatting tabs described in the following sections may not be available.  

Notes: 

¶ The SQL query used to generate a report may be viewed in an additional tab. 
Click Report > Show SQL to add a read-only SQL tab to the Design window. 

¶ A preview of your report is also available at any time. Click Preview to enter 
Preview Mode, and then click Design to return to Design Mode. 
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General Options Tab 

The General tab opens by default and shows titling and display options. 

To configure General options: 

1. Specify the Report Group, Report Title, Subtitle, and Description. 

Note: If you use an existing report group name, the new report is added to 
that existing group in the left pane of the main window. 

2. Select the display Orientation of your report. 

3. If you are configuring an historical report and you do not want to group 
data by days, clear Group historical data by days. 

Note: By default, data in some availability and historical reports is grouped 
by days when displayed in the Orion Web Console. Data grouping by days is 
not viewable in Report Viewer.  

4. If you do not want to make this report available on your Orion Web 
Console, clear Make this Report available from the Orion website. 

Note: By default, most reports are made available for display in the Orion 
Web Console. For more information, see ñCustomizing Viewsò on page 40. 

Select Fields Options Tab 

The Select Fields tab allows you to select the data fields in a report. 

To select and configure fields: 

1. Click Select Fields. 

2. If you are creating a new report or adding fields to an existing report, 
click the ellipsis, select Add a new field, and then dynamically define each 
new report field as follows: 

a. Click the asterisk after Field:, and then select the type of information to 
include in the current report field. 

b. If you want to sort the data in the current field, click the sort asterisk 
and select a sort order. 

c. If you want to perform an operation on the data in the current field, 
click the function asterisk and select an operation. 

3. If you are modifying an existing report, click the Field, sort, or function 
that you want to change and select a new value as follows. 

a. Click the asterisk after Field:. 

b. Select the type of information to include in the current report field. 
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c. If you want to sort the data in the current field, click the sort asterisk 
and select a sort order. 

d. If you want to perform an operation on the data in the current field, 
click the function asterisk and select an operation. 

4. If you want to test your selections as you assemble your report, click 
Execute SQL Query to view the current query results. 

5. If you want to delete a field or rearrange the order of the fields that are 
listed in your report, select a field, click Browse (é), and then select the 
appropriate action. 

Note: Unchecked fields are not displayed in your report, but their sort and 
function configurations are retained. 

6. If you want to preview your report, click Preview. 

Filter Results Options Tab 

The Filter Results tab allows you to generate filter conditions for field data by 
selecting appropriate descriptors from the linked context menus. Results filters 
are configured as follows. 

To configure results filters: 

1. Click Browse (é), and then select from the following options: 

¶ Select Add a new elementary condition to generate a condition that is 
based on a direct comparison of network object data fields. 

¶ Select Add a new advanced elementary condition to generate a 
condition based on a comparison of device data fields and values. 

¶ Select Add a new complex condition to define a condition that filters 
other defined conditions. 

¶ Select Delete current condition to remove a selected condition. 

¶ Select Move current condition forward or Move current condition 
backward to change the order of your conditions accordingly. 

Note: The lists of available linked descriptors are dynamically generated in 
consideration of all other variables within the same condition. For more 
information about condition groups and their application, see ñUnderstanding 
Condition Groupsò on page 130. 

2. Check or clear individual filter conditions to enable or disable their 
application, respectively, to your report. 
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Top XX Records Options Tab 

The Top XX tab allows you to limit the number of records that are shown in your 

report to either a top number  or a top percentage  of all results. Top XX options 

are configured as shown in the following procedure. 

To configure Top XX records: 

1. If you want to show all records in your report, select Show All Records. 

2. If you want to specify a truncated list of eligible items for your report, 
complete the following steps: 

a. select either Show only the Top number  Records or Show the Top 

percentage  % of Records 

b. Provide appropriate number  or percentage  values. 

Time Frame Options Tab 

The Time Frame options tab allows you to limit the scope of your report to a 
specific period of time. To configure Time Frame options, select a Named, 
Relative, or Specific Time Frame, and then select or provide required values. 

Notes: 

¶ If you receive a SQL Timeout error message, you may edit the timeout 
setting in the SWNetPerfMon.db file. By default, this file is located in the 

C: \ Program  Files \ SolarWinds \ Orion  directory 

¶ Since the Relative Time Frame is continuously variable, reports run with it 
may show different results, even if they are run close together in time. 

Summarization Options Tab 

The Summarization tab allows you to generate summaries of your results over 
specific periods of time. Summarization options are configured as follows. 

To configure results summarization: 

1. If you do not want to summarize your results, confirm that Do not 
Summarize the Results is selected. 

2. If you want to summarize your results, complete the following steps: 

a. Select Summarize the Results by Hour, Date, Month, etc, and then 
select the summarization period. 

b. Specify the location of the summary field for your report. 

c. Select a location for the Summary Date/Time field. 
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Report Grouping Options Tab 

The Report Grouping tab allows you to group results by field descriptor within 
your report. Add, edit and delete report groups to organize the data in your 
report. Establish and edit report groups as follows. 

To add and edit report groups: 

1. If you want to add a new report group, select a field from the list to define 
your group, and then click Add Report Group to add your selected field to 
the Report Groups list.  

Note: Use up and down arrows to change the grouping order accordingly. 

2. If you want to edit an existing report group, select the field from the 
Report Groups list, and then click Edit Report Group.  

3. The following options may be changed as needed: 

¶ The Group Header is the text that designates groups on your report. 

¶ The Web URL is the dynamic location of your published report with 
respect to your Orion Web Console. 

¶ Font size, face, color, and background may all be modified by clicking 
associated ellipses. 

¶ Alignment may be left, center, or right. 

¶ Check Transparent Background for better results when publishing your 
report to the Web. 

¶ If you want to change the grouping order, use the up and down arrows to 
change the grouping order accordingly. 

Field Formatting Options Tab 

The Field Formatting tab allows you to customize the format of the various 
results fields in your report. To format results fields, select the field you want 
to format, and then edit labels and select options as appropriate. 

Notes: 

¶ The formatting options available for each field may be different according to 
the nature of the data contained in that field. 

¶ Check Hidden Field to hide any field in your report. 

¶ To view your changes at any time, click Preview. 
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Customizing the Report Header and Footer Image 

The image that is displayed at the top and bottom of each report can be 
changed. To add your company logo as the report header and footer, save your 

logo as Header.jpg  in the SolarWinds \ Common\ WebResources  folder, typically 

located in C: \ Program Files \ , and then click Refresh. 

Note: The image must be in JPEG format with a height of 150 pixels or less. 

Exporting Reports 

Orion Report Writer gives you the ability to present your created reports in any of 
the following industry-standard formats: 

¶ Comma-delimited (*.csv, *.cdf) 

¶ Text (*.txt) 

¶ HTML (*.htm, *.html) 

¶ MIME HTML, with embedded images (*.mhtml) 

¶ Excel® spreadsheet (*.xls) 

¶ Adobe® PDF (*.pdf) 

¶ Image (*.gif) 

The following procedure presents the steps required to export an open report 
from Orion Report Writer into any of the previously listed formats. 

To export a report from Report Writer: 

1. Select a report to export by clicking any of the following: 

¶ Select a report from the file tree in the left pane 

¶ File > Open to open an existing report 

¶ File > New Report to create a new report. For more information about 
creating reports, see ñCreating and Viewing Reportsò on page 161. 

2. Select File > Export and then click the format in which you want to export 
your report: 

3. Check the fields in your open report that you want to export into the selected 
format, and then click OK. 

4. Select a location to save your file. 

5. Provide a File name, and then click Save. 
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Example Device Availability Report 

The following procedure generates an example report of network device 
availability information over the previous week. The final report is sorted so that 
the worst errors are viewed first. Down nodes that are still down are at the top 
with all devices listed in order of increasing availability. 

Note: At any point during the creation of a report (or perhaps at many points), 
you may save what you have done by clicking File > Save. The first time you 
save you must give your report a filename or accept the default, which will be the 
report title that you assign in the following procedure. 

To generates an example report of network device availability information: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Report Writer. 

2. Click File > New Report. 

3. The example calls for a report on availability over the past week, so select 
Historical Availability Details, and then click OK. 

 

 

4. Type My Reports  in the Report Group field, and then enter Last Weekôs 

Availability  as the Report Title. 
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5. Select Portrait for the paper orientation, and then confirm that Make this 
Report availablefrom the Orion website is checked. 

  

 

6. Click Select Fields. 

 

 

7. Click Browse (é), and then select Add a new field. 

 

 

8. Click the Field asterisk, and then select Network Nodes > Node Details > 
Node Name. 
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9. Click Browse (é), and then select Add a new field. 

 

 

10. Click the Field asterisk, and then select Network Nodes > Node Status > 
Status Icon. 

Note: While this field makes a distinct visual difference for a report viewed in 
color, it will make little or no difference if printed in black and white. 

 

 

11. Click Browse (é), and then select Add a new field. 

12. Click the Field asterisk, and then select Network Nodes > Node Status > 
Status. 
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13. Click Execute SQL Query to view the report data in the preview window. 

Note: The report preview should show information about both current and 
historical status. Current status entries must be relabeled to avoid confusion. 

 

 

14. Click Field Formatting. 

 

 

15. Click Status in the Select a Field list, and then change the Column Header 

entry to Current Status . 

 

 

16. Click Status_Icon in the Select a Field list, and then change the Column 

Header entry to Current Status . 
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17. Click Execute SQL Query. 

Note: Column widths are adjustable. To change a column width, place your 
cursor on the column divider and drag it to a different position. 

18. Click Select Fields. 

19. Click the sort asterisk on the Status field line, and then select descending. 

 

 

20. Click Execute SQL Query to confirm your choice. 

21. Click Browse (é), and then select Add a new field. 

22. Click the Field asterisk, and then select Historical Response Time and 
Availability > Availability. 

 

 

23. Click the sort asterisk on the new line, and then select ascending. 

24. Click Execute SQL Query to view the report. 

25. Click Time Frame. 
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26. Select Relative Time Frame, type 7 in the text field, and then select Days 

from the list. 

 

 

27. If you want to break down the report day-by-day, click Summarization and 
specify your choices. 

 

 

 

 

28. If you want to filter your report, click Filter Results and specify filter rules, 
as on the Select Fields tab. 

 

 

29. Click File > Save to save your work. 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Creating and Viewing Reports Ö 181 

Using Orion Report Scheduler 

Orion provides the Orion Report Scheduler to configure reports for automatic 
generation and distribution. 

Creating a Scheduled Report Job 

The following procedure creates a scheduled report job for regularly printed or 
emailed Orion reports. 

To schedule a report: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Reports. 

3. Click + as required to locate the report you want to schedule. 

4.  Click the name of the report you want to schedule. 

5. Copy the URL of the report you want to schedule. 

6. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Orion Report Scheduler. 

7. Click Edit > Add New Job. 

8. Provide a job name for this scheduled report, and then click Continue. 

9. Paste the URL of the report you want to schedule into the link field. 

10. If you need to provide Windows login credentials to view the report you 
are scheduling, click the NT Account login tab, and then provide the user 
account details needed to log in. 

11. If you want to create a printable report that excludes the Orion Web 
Console banner and menu bar, on the Orion Web Login tab, check 
Retrieve a Printable Version of this Page. 

12. If the report you are scheduling requires an Orion user account, on the 
Orion Web Login tab, check Send Orion Username / Password in URL, 
and then provide the required user credentials to view the Orion report. 

13. Click Continue. 

14. Configure the scheduling for your report job, and then click Continue. 

15. If you want to email the report, complete the following procedure: 

a. Confirm that either Email the Web Page (as HTML) or Email the Web 
Page (as PDF) are selected, and then click Continue. 

b. Provide required email addresses and a subject in the appropriate fields 
on the Email To tab. 
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c. Provide a name and reply address on the Email From tab. 

d. On the SMTP Server tab, type the hostname or IP address and confirm 
the port number of the server used to send email from the Orion server. 

e. Click Continue. 

16. If you want to print the report, complete the following steps: 

a. Select Print the Web Page, and then click Continue. 

b. Select the Printer, Orientation, and number of Copies you want to print. 

c. Click Continue. 

17. Enter the user name and password for the Windows account that will email 
the report. 

18. Click Continue. 

19. Add any additional comments or notes about this job, and then click Finish. 

Using Orion Report Scheduler with HTTPS 

If you are using HTTPS to view reports in the Orion Web Console, your HTTPS 
server may require the Orion Report Scheduler to provide a trusted certificate 
before the requested report may be printed or sent. To use Orion Report 
Scheduler with HTTPS, either provide valid certificates to all users accounts 
requesting reports from the HTTPS server using Orion Report Scheduler or 
disable certificate checking in each of the browsers used by your Orion Report 
Scheduler users, as shown in the following procedure. 

To disable certificate checking: 

1. If you are configuring Internet Explorer, complete the following steps: 

a. Open Internet Explorer on the user computer. 

b. Click Tools > Internet Options, and then click the Advanced tab. 

c. In the Security section, confirm that the following options are cleared: 

¶ Check for publisherôs certificate revocation 

¶ Check for server certificate revocation (requires restart) 

¶ Warn about invalid site certificates 

d. Click OK. 

2. If you are configuring Mozilla Firefox, complete the following steps: 

a. Open Mozilla Firefox on the user computer. 

b. Click Tools > Options. 
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c. Click Advanced, and then click the Encryption tab. 

d. In the Protocols area, clear both Use SSL 3.0 and Use TLS 1.0. 

e. In the Certificates area, select Select one automatically, and then click 
Validation. 

f. Clear the option Use the Online Certificate Status Protocol (OCSP) to 
confirm the current validity of certificates, and then click OK. 

Troubleshooting the Orion Report Scheduler 

The following known issues have been encountered while using the Orion Report 
Scheduler: 

¶ Printing Web Pages from Report Scheduler 

¶ Orion Report Scheduler and Internet Explorer Enhanced Security 

Printing Web Pages from Report Scheduler 

If any warning dialogs are open on the Orion server when a web page is 
scheduled for printing in Report Scheduler, the print job may not complete. To 
ensure that print jobs configured in the Report Scheduler complete, confirm the 
following: 

¶ Print the Web Page is selected when the scheduled task is configured in 
Report Scheduler. 

¶ All open dialogs, including SWToolset.exe  and javascript warnings, are 

closed. 

¶ All scheduled print tasks are configured to run even when the current user is 
not logged in. 

Orion Report Scheduler and Internet Explorer Enhanced Security 

When Internet Explorer (IE) Enhanced Security Configuration is installed, Orion 
report Scheduler may hang intermittently when attempting to perform a 
scheduled report print job. To address this issue, complete either of the following 
procedures: 

¶ (Recommended) Add the Orion Web Console as a trusted site in your 
browser. For more information about Internet Explorer Enhanced Security 
Configuration and adding sites to the trusted sites list, see the microsoft 
document, "Adding Sites to the Enhanced Security Configuration Zones". 

¶ Uninstall IE Enhanced Security Configuration. 

http://msdn.microsoft.com/en-us/library/ms537181(v=VS.85).aspx
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Reports and Account Limitations 

Reports created with Orion Report Writer respect Orion Web Console account 
limitations. For security, by default, reports are not available to users with limited 
accounts unless an Orion administrator specifically provides access. The 
following procedure creates a reports folder for an account-limited user and 
configures the account-limited user to access Orion reports from it. 

Note: For more information about creating user accounts, see ñCreating New 
Accountsò on page 97. For more information about applying account limitations to 
user accounts, see ñSetting Account Limitationsò on page 100. 

To allow account-limited users access to reports: 

1. Open the Orion Reports folder. 

Note: All reports created or predefined in Orion Report Writer are, by default, 

stored, in C: \ Program Files \ Solarwin ds \ Orion \ Reports . 

2. Create a new folder using the name of the account-limited user. 

3. Copy the reports you want the account-limited user to see from the Orion 
Reports folder into the new, account-limited  user folder. 

4. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

5. Log in to the Orion Web Console as an administrator. 

6. Click Settings in the top right of the web console. 

7. Click Manage Accounts in the Accounts grouping of the Orion Website 
Administration page. 

8. Select the account-limited user, and then click Edit. 

9. In the Default Menu Bar and Views section, select the Report Folder you 
created in the Orion Reports folder for the account-limited user. 

10. Click Submit. 
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Chapter 13 

Monitoring Syslog Messages 

Syslog messages are one type of realtime notification that network devices can 
send in response to designated network events. Orion provides the SolarWinds 
Syslog Service, allowing Orion to receive Syslog messages from any monitored 
network device. The SolarWinds Syslog Service also has the ability to open 
multiple connections to your SQL server, so it can handle large numbers of 
simultaneously incoming Syslog messages from all your monitored devices. 

Orion uses the SolarWinds Syslog Service to listen on UDP port 514 for incoming 
Syslog messages. Received messages are then decoded and stored in the Orion 
database. Until they are acknowledged, Syslog messages are available for 
viewing either in the web console Syslog view or in the Syslog Viewer 
application. The Syslog view in the Orion Web Console provides quick access to 
current messages, filtered by any or all of the following criteria: 

¶ Name or type of network object sending the message. 

¶ Message Severity, Facility, Type, or Pattern 

¶ Time Period in which the message was sent.  

The Syslog Viewer application also allows you to tailor your view of Syslog 
messages using fully customizable rules. Additionally, the Syslog Viewer gives 
you the ability both to search your Orion database and to configure 
Syslog-specific alerts for received Syslog messages. 

Note: When configuring your network devices to send Syslog messages, confirm 
that messages are sent to the IP address assigned to your Orion server. To 
ensure the proper configuration of a network device for Syslog messaging, refer 
to the documentation supplied by the device vendor. 

Configuring the Orion Syslog Port 

Orion listens for Syslog messages on port 514 (UDP). You can configure this port 
in the SyslogService.exe.config  file, as indicated in the following procedure. 

Note: Running the Configuration Wizard will revert any and all changes made to 

the  SyslogService.exe.config  file. If you run the Configuration Wizard, you 

must repeat this procedure to restore your required port setting. 

To configure the Syslog port: 

1. Log on to your Orion server using an account with administrative privileges. 
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2. Open SyslogService.exe.config  in a text editor. 

Note: By default, SyslogService.exe.config  is located in C: \ Program 

Files \ SolarWinds \ Orion \ Orion \ SyslogService \ . 

3. Locate the following line: 

<add key="UDPListenPort" value="514">  

4. Edit value="5 14"  as required to indicate the port on which your monitored 

devices are configured to send Syslog messages to your Orion server. 

5. Save SyslogService.exe.config . 

Syslog Messages in the Web Console 

The Orion Web Console provides both Syslog-specific resources and a Syslog 
view that provides a table of Syslog messages received by your Orion server. 
The following sections provide an overview of available Syslog resources and 
procedures for viewing and acknowledging Syslog messages within the Orion 
Web Console. 

Syslog Resources 

Orion provides the following Syslog-related resources for inclusion within web 
console views. 

Advanced Syslog Counts 

Every Syslog message has a designated severity. For more information 
about Syslog severities, see ñSyslog Severitiesò on page 198. The Advanced 
Syslog Counts resource groups by severity all Syslog messages received by 
the currently viewed node. For each severity, this resource provides the 
number of received Syslog messages. 

Advanced Syslog Parser 

The Advanced Syslog Parser resource provides a comprehensive view of the 
Syslog messages most recently received by the viewed node. The most 
recent messages of each severity are listed. For more information about 
Syslog severities, see ñSyslog Severitiesò on page 198. 

Advanced Syslog Summary 

The Advanced Syslog Summary resource groups by message type all Syslog 
messages received by the currently viewed node, where the message type is 
encoded in the Syslog message packet. For each message type, this 
resource provides the severity, the hostname or IP address of the message 
originator, and the total number of Syslog messages received. 
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Last 25 Syslog Messages 

The Last 25 Syslog Messages resource provides a list of the last 25 syslog 
messages that have been sent by monitored network devices to the viewed 
node. For each message, this resource presents the date and time the 
message was sent, the hostname and IP address of the device sending the 
message, and the message text. 

Clicking the hostname, IP address, or message text opens the corresponding 
Object Details page, providing extensive diagnostic information about the 
monitored network object sending the message. 

Clicking Edit opens the Edit Last 25 Syslog Messages page where you can 
set the maximum number of displayed messages, select the time period for 
viewing messages, and establish filters to limit the messages this resource 
displays. For more information, see ñUsing Node Filtersò on page 63. 

Syslog Summary 

The Syslog Summary resource lists the number of Syslog messages 
received by the viewed node from monitored network devices over a 
specified period of time. 

Viewing Syslog Messages in the Web Console 

You can customize the list view by using the following procedure to select your 
preferred message grouping criteria. 

To view Syslog messages in the Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Orion Web Console, and then click Syslog in the Views toolbar. 

3. If you want to view Syslog messages for a specific Syslog-enabled 
network object, specify the selected object in the Network Object field. 

Note: Only objects that have sent a Syslog message to the Orion server will 
be listed in this field. 

4. If you want to filter your Syslog messages table by device type, select 
the type to which you want to limit your view in the Type of Device field. 

5. If you want to filter your Syslog messages table by severity, select the 
severity level to which you want to limit your view in the Select Severity field. 

Note: For more information, see ñSyslog Severitiesò on page 198. 

6. If you want to filter your Syslog messages table by facility, select the 
facility to which you want to limit your view in the Select Facility field. 

Note: For more information, see ñSyslog Facilitiesò on page 197. 
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7. If you want to limit your Syslog messages table to show only messages 
of a designated type, type the appropriate string in the Message Type field. 

8. If you want to limit your Syslog messages table to show only messages 
containing a designated pattern, provide the appropriate string in the 
Message Pattern field. 

Note: An asterisk (*) is required as a wildcard character, both before and 
after the pattern string, unless the provided pattern is any of the following: 

¶ The beginning of the message 

¶ The end of the message 

¶ The full message 

9. If you only want to see Syslog messages from a specific period of time, 
select a time period from the Time Period menu. 

10. Confirm the number of messages displayed in the Show Messages field. 

11. If you want cleared or acknowledged messages to remain in the Syslog 
view, check Show Cleared Messages. 

12. Click Refresh to update the Syslog messages list with your new settings. 

Acknowledging Syslog Messages in the Web Console 

Acknowledging Syslog messages is straightforward in the Orion Web Console, 
as shown in the following procedure. 

To acknowledge Syslog messages in the Orion Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the Orion Web Console. 

3. Click Syslog in the Views toolbar. 

4. Provide filter criteria for the Syslog messages table. For more information, 
see ñViewing Syslog Messages in the Web Consoleò on page 187. 

5. Click Refresh to ensure that all selected view criteria take effect. 

6. Check the messages you want to acknowledge, and then click Clear 
Selected Messages. 

Using the Syslog Viewer 

Orion also provides the standalone Syslog Viewer application for viewing and 
acknowledging Syslog messages on your network. Syslog Viewer collects Syslog 
messages from your network and presents them in a readily reviewable and 
searchable list so that you can easily monitor your network. The following 
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sections provide a guide to using the Syslog Viewer application for viewing, 
acknowledging, and triggering alerts in response to Syslog messages on your 
network. 

To open the Syslog Viewer, click Start > All Programs > SolarWinds Orion > 
Syslog and SNMP Traps > Syslog Viewer.  

Viewing and Acknowledging Current Messages 

The Syslog Viewer makes it easy to view and acknowledge messages. The 
following procedure views and then acknowledges current Syslog messages. 

To view and acknowledge current Syslog messages: 

1. Click View > Current Messages 

2. Acknowledge current messages using either of the following methods: 

¶ Right-click any message, and then select Acknowledge Selected. 

¶ Add an Acknowledged column to the Syslog Viewer, and then check 
each message that you want to acknowledge. For more information, see 
ñSyslog Server Settingsò on page 190. 

Searching for Syslog Messages 

Collected Syslog messages may be searched within Syslog Viewer. The 
following steps both search for Syslog messages and format search results. 

To search the Syslog message list: 

1. Click View > Search Messages. 

2. Enter appropriate search criteria, and then click Search Database. 

3. If you want to group messages for easier navigation, select the type of 
grouping from the Grouping list. 

Note: Messages can be acknowledged in the search results just as they can 
be acknowledged in the Current Messages view. For more information, see 
ñSyslog Server Settingsò on page 190. 

4. If you want to limit the number of messages that are shown, enter or 
select a number in the Maximum number of messages to display field. 

5. If you want to view messages that meet your search criteria as they 

arrive, select a number for the Auto Refresh every number  seconds field. 

Note: Auto Refresh is only available when you are viewing current 
messages. The Date/Time Range must be set to Today, Last 24 Hours, 
Last 2 Hours, or Last Hour. 
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Syslog Server Settings 

Use the following procedure as a guide to starting and configuring the Syslog 
Viewer.  

To start and configure the Syslog Viewer: 

1. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Syslog Viewer. 

2. Click File > Settings. 

3. Click the General tab in the Syslog Server Settings window. 

4. Adjust the Maximum number of messages to display in Current 
Messages view slider to set the number of messages you want to display. 

5. If you want to Automatically Refresh the Current Messages View, check 
the option accordingly, and then set the refresh rate with the middle slider. 

6. Adjust Retain Syslog messages for how many days? to set the length of 
time Syslog messages should stay in the database. 

7. Click the Displayed Columns tab. 

8. Use the arrow keys to select and order the fields of information you want to 
see in the Current Messages view. 

Note: You can make it easier to acknowledge Syslog messages by selecting 
the Acknowledged column to add to your view. 

9. If you want to wrap Syslog message text in the Current Messages view, 
check Word wrap long messages. 

10. If you do not expect to use Syslog Server as your primary viewer for 
Syslog messages, select the Message Parsing tab, and then complete the 
following steps: 

Note: The following data points are saved within the Syslog tables in your 
Orion database. Removing the added data from each record helps you to 
proactively reduce the size of your database. 

11. Check Remove embedded Date/Time from Syslog Messages, Remove 
Message Type from Syslog Messages, and Remove Domain Name from 
DNS Lookups. 
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Configuring Syslog Viewer Filters and Alerts 

The Syslog Viewer can be configured to signal Orion alert actions when Syslog 
messages that are received from network devices match defined rules. The steps 
in the following procedure establish rules that filter Syslog messages and initiate 
alert actions as you determine. 

Note: Syslog rules may not be applied to nodes in an unmanaged state. For 
more information about designating nodes as unmanaged, see ñSetting Device 
Management Statesò on page 83. 

To configure Syslog Viewer filters and alerts: 

1. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Syslog Viewer. 

2. Click File > Settings. 

3. Click Alerts/Filter Rules. 

4. If you are creating a new rule, click Add New Rule. 

5. If you are editing an existing rule, select the rule, and then click Edit 
Selected Rule. 

6. On the General tab, complete the following steps: 

a. Provide or edit the Rule Name, and then check Enabled. 

b. Select appropriate servers from the Apply this Rule to list. 

c. Enter the IP addresses or subnets to which this rule applies in the 
Source IP Addresses area.  

Note: Use the examples provided on this tab to ensure that the list of 
source IP addresses is properly formatted. 

7. If you want to limit the rule to only messages from specific hosts, 
domains, or hostname patterns, on the DNS Hostname tab enter a DNS 
Hostname Pattern. 

Notes: 

¶ The DNS Hostname Pattern rule is case-sensitive. 

¶ When Use Regular Expressions in this Rule is checked, you may use 
regular expressions in place of ñlikeò statements. For more information 
about using regular expressions in Orion, see ñRegular Expression 
Pattern Matchingò on page 287. 
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8. If you want to limit the rule to only specific message types or text within 
a Syslog message, on the Message tab enter rules as appropriate for 
Message Type Pattern and Syslog Message Pattern. 

Notes: 

¶ Use the examples listed on this tab to format the list properly. 

¶ When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of ñlikeò statements. For more 
information about using regular expressions in Orion, see ñRegular 
Expression Pattern Matchingò on page 287. 

9. If you want to apply specific severity or facility types, on the Severity / 
Facility tab check the severity and facility types you want to apply. 

Note: By default, all message severities and facilities are selected. For more 
information about Syslog severities and facilities, see ñ 

Syslog Message Prioritiesò on page 197. 

10. If you want to limit rule application to within a specific period of time, 
select the Time of Day tab, check Enable Time of Day checking, enter the 
time period, and then check the days of the week on which to apply the rule. 

Notes: 

¶ Enabling Time of Day checking creates more overhead for the CPU. 

¶ Messages received outside the specified timeframe will not trigger alerts. 

11. If you want to suppress alert actions until a specified number of 
messages arrive that match the rule, complete the following procedure: 

a. Select the Trigger Threshold tab. 

b. Check Define a Trigger Threshold for this Rule. 

c. Enter option values as appropriate. 

Note: When Suspend further Alert Actions for is checked, alert actions 
are not sent until the specified amount of time has expired. Once the time 
period has expired, only new alerts are sent. All alerts suppressed during the 
time period are discarded. 

12. Configure Syslog alert actions on the Alert Actions tab, as shown in the 
following steps: 

a. If you are associating a new action to the rule, click Add New Action. 
For more information about available actions, see ñAvailable Syslog Alert 
Actionsò on page 193. 

b. If you want to edit an existing action for the rule, select an action 
from the list, and then click Edit Selected Action. 
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c. Configure the action as appropriate. For more information about 
available actions, see ñAvailable Syslog Alert Actionsò on page 193. 

Note: Syslog alerts use a unique set of variables. For more information 
about available Syslog variables, see ñExample Messages Using 
Variables 

The following examples illustrate some of the uses of variables. 

¶ Previous reboot was at ${LastBoot - Previous}.  

¶ Alert: ${NodeName} has exceptionally high response time. 

Average Response Time is ${AvgResponseTime} and is varying from 

${MinResponse Time} to ${MaxResponseTime}.  

¶ Current packet loss for ${NodeName} is ${%Loss}. Average 

Response time is ${AvgResponseTime} and is varying from 

${MinResponseTime} to ${MaxResponseTime}.  

¶ Alert: The SNMP Community string used to query ${NodeName} has 

been chan ged from ${Community - Previous} to ${Community}.  

¶ Orion use s the new Community String to  query ${NodeName}.  

Syslog Alert Variablesò on page 277. 

d. If you need to delete an action, select the action, and then click Delete 
Action. 

e. Use the arrow buttons to set the order in which actions are performed. 

Note: Actions are processed in the order listed, from top to bottom. 

f. Click OK to save all changes and return to Syslog Viewer Settings. 

13. Use the arrow buttons to arrange the order in which the rules are applied. 

Note: Rules are processed in the order they appear, from top to bottom. 

Available Syslog Alert Actions 

The following list provides definitions of the actions available for each Syslog 
alert type. For more information about how to assign alert actions, see 
ñConfiguring Syslog Viewer Filters and Alertsò on page 191. 

Discard the Syslog Message 

Allows you to delete unwanted Syslog messages sent to the Syslog server. 

Tag the Syslog Message 

Allows you to add a custom tag to received Syslog messages. Ensure you 
include the Tag column in the viewer when assigning a tag. 
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Modify the Syslog Message 

Modify the severity, facility, type, or contents of a Syslog message. 

Log the Message to a file 

Allows you to specify a file and a series of variables with which to tag Syslog 
messages sent to the file. Ensure you have already created the log file you 
want to use. The alert cannot create a file. 

Windows Event Log 

Write a message to local or remote Windows Event Logs. 

Forward the Syslog message 

Specify the IP address or hostname and the port to forward a Syslog event. 

Send a new Syslog message 

Trigger a new Syslog message, sent to a specific IP address or hostname, 
on a specific port, with a customizable severity, facility, and message. 

Send an SNMP Trap 

Allows you to send a trap to an IP address following a specific trap template 
and using a specific SNMP community string. 

Play a sound 

Allows you to play a sound when a matching Syslog message is received. 

Text to Speech output 

Define the speech engine, speed, pitch, volume, and message to read. 

Execute an external program 

Allows you to specify an external program to launch using a batch file. This 
action is used when creating realtime change notifications in Orion. 

Execute an external VB Script 

Allows you to launch a VB Script using the selected script interpreter engine 
and a saved script file. 

Send a Windows Net Message 

Allows you to send a net message either to a specific computer or to an 
entire domain or workgroup. 

Note: The only operating systems supporting Windows Net Messaging on 
which SolarWinds supports Orion installations are Windows Server 2003 and 
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Windows XP. SolarWinds only supports evaluation installations of Orion on 
Windows XP. 

Send an E-mail / Page 

Send an email from a specified account to a specified address, using a 
specific SMTP server, and containing a customizable subject and message. 

Stop Processing Syslog Rules 

Stops the processing of Syslog rules for the matching Syslog message. 

Forwarding Syslog Messages 

The Syslog message forwarding action allows you to forward received Syslog 
messages. Additionally, if you have WinPCap version 3.0 or higher installed on 
your Orion server, you can forward Syslog messages as spoofed network 
packets. The following procedure configures available options for forwarded 
Syslog messages. 

Note: The following procedure assumes you are editing a Forward the Syslog 
Message alert action. For more information about Syslog alert actions, see 
ñConfiguring Syslog Viewer Filters and Alertsò on page 191. 

To configure the forward syslog message action: 

1. Provide the hostname or IP address of the destination to which you want to 
forward the received Syslog message. 

2. Provide the UDP Port you are using for Syslog messaging. 

Note: The default is UDP port 514 . 

3. If you want to retain the IP address of the source device, complete the 
following steps: 

a. Check Retain the original source address of the message. 

b. If you want to designate a specific IP address or hostname as the 
Syslog source, check Use a fixed source IP address (or hostname), 
and then provide the source IP address or hostname. 

c. If you want to spoof a network packet, check Spoof Network Packet, 
and then select an appropriate Network Adapter. 

4. Click OK to complete the configuration of your Syslog forwarding action. 
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Syslog Alert Variables 

The following variables can be used in Syslog alert messages. Each variable 
must begin with a dollar sign and be enclosed in curly braces as, for example, 

${ VariableName } . Syslog alerts also support the use of Node alert variables. 

For more information, see ñOrion Variables and Examplesò on page 269. 

Syslog Date/Time Variables 

Syslog Date/Time 
Variable 

Description 

${AbbreviatedDOW} Current day of the week. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (Short Date format) 

${DateTime} 
Current date and time. (Windows control panel defined ñShort 
Dateò and ñShort Timeò format) 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Hour} Current hour. 24-hour format 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (Long Date format) 

${LocalMonthName} Current month name in the local language. 

${LongTime} Current Time. (Long Time format) 

${M} Current numeric month 

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MediumDate} Current date. (Medium Date format) 

${Minute} Current minute. Two digit format, zero padded. 

${Month} Full name of the current month 

${N} Current month and day 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (Short Time format) 

${Year2} Two digit year 

${Year} Four digit year 
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Other Syslog Variables 

Syslog Variable Description 

${Application} SolarWinds application information 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${Hostname} Host name of the device triggering the alert 

${IP_Address} IP address of device triggering alert 

${Message} Status of device triggering alert 

${MessageType} The name of the triggered alert 

${Severity} 
A number (0-7) corresponding to the designated severity of a 
message. For more information, see ñSyslog Severitiesò on page 198. 

${Version} Version of the SolarWinds software package 

 

Syslog Message Priorities 

Included at the beginning of each Syslog message is a priority value. The priority 

value range spans between 0 and 191 and is enclosed in angle bracket (< and >) 

delimiters. The priority value is calculated using the following formula: 

Priority  = Facility * 8 + Severity  

Syslog Facilities 

The facility value indicates which machine process created the message. The 
Syslog protocol was originally written on BSD Unix, so Facilities reflect the 
names of UNIX processes and daemons, as shown in the following table. 

Note: If you are receiving messages from a UNIX system, consider using the 

User  Facility as your first choice. Local0 through Local7 are not used by UNIX 

and are traditionally used by networking equipment. Cisco routers, for example, 
use Local6 or Local7. 

Number Source Number Source 

0 kernel messages 12 NTP subsystem 

1 user-level messages 13 log audit 

2 mail system 14 log  alert 

3 system daemons 15 clock daemon 

4 security/authorization messages 16 local use 0 (local0) 

5 messages generated internally by Syslog 17 local use 1 (local1) 

6 line printer subsystem 18 local use 2 (local2) 

7 network news subsystem 19 local use 2 (local3) 

8 UUCP subsystem 20 local use 2 (local4) 
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Number Source Number Source 

9 clock daemon 21 local use 2 (local5) 

10 security/authorization messages 22 local use 2 (local6) 

11 FTP daemon 23 local use 2 (local7) 

 

Syslog Severities 

The following table provides a list of Syslog severity levels with descriptions and 
suggested actions for each. 

Number Severity Suggested Actions 

0 Emergency 
A "panic" condition affecting multiple applications, servers, 
or sites. System is unusable. Notify all technical staff on call. 

1 Alert 
A condition requiring immediate correction, for example, the 
loss of a backup ISP connection. Notify staff who can fix the 
problem. 

2 Critical 

A condition requiring immediate correction or indicating a 
failure in a primary system, for example, a loss of a primary 
ISP connection. Fix CRITICAL issues before ALERT-level 
problems. 

3 Error 
Non-urgent failures. Notify developers or administrators as 
errors must be resolved within a given time. 

4 Warning 

Warning messages are not errors, but they indicate that an 
error will occur if required action is not taken. An example is 
a file system that is 85% full. Each item must be resolved 
within a given time. 

5 Notice 

Events that are unusual but are not error conditions. These 
items might be summarized in an email to developers or 
administrators to spot potential problems. No immediate 
action is required. 

6 Informational 
Normal operational messages. These may be harvested for 
network maintenance functions like reporting and throughput 
measurement. No action is required. 

7 Debug 
Information useful to developers for debugging an 
application. This information is not useful during operations. 
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Chapter 14 

Monitoring SNMP Traps 

SNMP traps signal the occurrence of significant events by sending unsolicited 
SNMP messages to a monitoring device. The SolarWinds Trap Server listens for 
incoming trap messages on UDP port 162 and then decodes, displays, and 
stores the messages in the Orion database. The SolarWinds Trap Service allows 
Orion to receive and process SNMP traps from any type of monitored network 
device, and, because the SolarWinds Trap Service is multi-threaded, it can 
handle large numbers of simultaneously incoming traps. 

You can view SNMP traps in the Trap Viewer application. The Trap Viewer 
application allows you to configure trap-specific alerts, to view and search traps, 
and to apply powerful trap filtering. 

Note: When configuring devices to send SNMP traps, confirm that traps are sent 
to the IP address assigned to the Orion server. To ensure proper configuration, 
refer to the documentation supplied by the vendor of your devices. 

The SNMP Trap Protocol 

SNMPv1 (Simple Network Management Protocol) and SNMPv2c, along with the 
associated Management Information Base (MIB), allow you to take advantage of 
trap-directed notification. When monitoring a large number of devices, where 
each device may have a large number of its own connected objects, it can 
become impractical to request information from every object on every device. 
Consider having each managed device notify the Orion SNMP Trap Server of 
any issues without solicitation. In this configuration, a problem device notifies the 
server by sending a message. This message is known as a trap of the event. 
After receiving the event, the Trap Viewer displays it, allowing you to choose to 
take action or automatically trigger an action based on the nature of the event. 

Viewing SNMP Traps in the Web Console 

Customize the Traps view as shown in the following procedure. 

To view SNMP traps in the Web Console: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Traps in the Views toolbar. 

3. If you want to filter your traps table view by device, select the device to 
which you want to limit your view in the Network Object field. 
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4. If you want to filter your traps table by device type, select the device 
types you want to view in the Type of Device field. 

5. If you want to limit your traps table to show only traps of a designated 
type, select the appropriate type in the Trap Type field. 

6. If you want to limit your traps table to show only traps originating from 
a specific IP address, type the IP Address in the Source IP Address field. 

7. If you want to limit your traps table to show only traps with a 
designated community string, select the appropriate community string in 
the Community String field. 

8. If you only want to see traps from a specific period of time, select the 
time period from the Time Period menu. 

9. Confirm the number of traps displayed in the Show Traps field. 

10. Click Refresh to update the Traps view with your new settings. 

Using the Trap Viewer 

After the monitored devices on your network are configured to send traps to the 
Orion server, configure the Orion Trap Viewer to display received trap 
information, as shown in the following sections. 

Notes: 

¶ To ensure proper configuration of your network devices, refer to the 
documentation supplied by the vendor of your network devices. 

¶ The Orion Trap Viewer receives traps on UDP port 162. 

Viewing Current Traps 

Trap Viewer makes it easy to view trap messages, as shown in the following 
steps. 

To view current trap messages: 

1. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Trap Viewer. 

2. Click View > Current Traps. 

3. Click a column header to order listed traps by the selected trap characteristic. 

4. Configure the Trap Viewer by clicking and dragging columns to order the 
presentation of trap characteristics. 
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Searching for Traps 

Collected trap messages may be searched within Trap Viewer. The following 
steps both search for trap messages and format the search results list. 

To search the trap message list: 

1. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Trap Viewer. 

2. Click View > Search Traps. 

3. Enter appropriate search criteria, and then click Search Database. 

4. If you want to group messages for easier navigation, select the type of 
grouping from the Grouping list. 

5. If you want to limit the number of messages that are shown, enter or 
select a number in the Maximum number of messages to display field. 

6. If you want to view messages that meet your search criteria as they 

arrive, select a number for the Auto Refresh every number  seconds field. 

Note: Auto Refresh is only available when you are viewing current 
messages. The Date/Time Range must be set to Today, Last 24 Hours, 
Last 2 Hours, or Last Hour. 

7. If you want to hide the search criteria pane, toggle the pane open and 
closed by clicking the double up arrows in the top right of the page. 

Trap Viewer Settings 

Use the following procedure to start and configure the Trap Viewer. 

To start and configure the Trap Viewer: 

1. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Trap Viewer. 

2. Click File > Settings. 

3. On the General tab, configure the following Trap server settings: 

a. Position the top slider to set the Maximum number of traps to display 
in Current Traps view. 

b. If you want Orion NPM to Automatically Refresh the Current Traps 
View, check the option accordingly, and then position the middle slider to 
set the refresh rate. 

c. Position the Retain Trap messages for how many days? slider to set 
the length of time that traps remain in the database. 
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4. On the Displayed Columns tab, use the arrow keys to select and order the 
fields of information you want to see in the Current Traps view. 

5. If you do not need the domain name from your trap messages, check 
Remove Domain Name from DNS Lookups on the Message Parsing tab. 

Note: Checking this option will remove the domain name from your trap 
messages, and this will help to reduce the size of your database. 

Configuring Trap Viewer Filters and Alerts 

The Trap Viewer can be configured to trigger Orion NPM alert actions when 
received trap messages match defined rules. The following steps establish rules 
to filter trap messages and initiate alert actions as you determine. 

Notes: 

¶ With the exception of the asterisk (* ) wildcard, SolarWinds recommends 

against using non-alphanumeric characters in filter definitions. 

¶ Trap rules are not applied to unmanaged nodes. For more information, see 
ñSetting Device Management Statesò on page 83. 

To configure Trap Viewer filters and alerts: 

1. Click Start > All Programs > SolarWinds Orion > Syslog and SNMP 
Traps > Trap Viewer. 

2. Click File > Settings, and then click the Alerts / Filter Rules tab. 

3. If you are creating a new rule, click Add Rule. 

4. If you are editing an existing rule, click Edit Rule. 

5. Click the General tab,  

6. Enter a Rule Name, and then check Enabled to enable the rule. 

7. Select appropriate servers from the Apply this Rule to list. 

8. Enter the IP addresses or subnets to which this rule applies.  

Note: Use the examples listed on this tab to format the list properly. 

9. If you want the rule limited to messages from specific hosts, domains, 
or hostname patterns, click DNS Hostname, and then enter a DNS 
Hostname Pattern. 

Notes: 

¶ The DNS Hostname Pattern rule is case-sensitive. 

¶ When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of ñlikeò statements. For more 
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information about using regular expressions in Orion, see ñRegular 
Expression Pattern Matchingò on page 287. 

10. If you want the rule limited on the basis of content within the Trap 
Details field, click Trap Details, and then enter a Trap Details Pattern. 

Note: When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of ñlikeò statements. For more information 
about using regular expressions in Orion, see ñRegular Expression Pattern 
Matchingò on page 287. 

11. If you want the rule limited to specific community strings, click 
Community String, and then enter apprporiate patterns in the Community 
String Pattern field. 

Notes: When Use Regular Expressions in this Rule is checked, regular 
expressions can be used in place of ñlikeò statements. For more information 
about using regular expressions in Orion, see ñRegular Expression Pattern 
Matchingò on page 287. 

12. Click Conditions, and then generate trigger conditions for rule application in 
the text field as follows: 

¶ Select appropriate object identifiers and comparison functions from the 
linked context menus. 

¶ Click Browse (é) to Insert an ñORò condition, to Insert an ñANDò 
condition, or to Delete a condition as necessary. 

Note: For more information about conditions and condition groups, see 
ñUnderstanding Condition Groupsò on page 130. 

13. If you want to limit rule application to within a specific period of time, 
click Time of Day, check Enable Time of Day checking, enter the time 
period, and then select days of the week on which to apply the rule. 

Notes: 

¶ Enabling Time of Day checking creates more overhead for the CPU. 

¶ Messages received outside the specified timeframe will not trigger alerts. 

14. If you want to suppress alert actions until a specified number of traps 
arrive that match the rule, click Trigger Threshold, check Define a Trigger 
Threshold for this Rule, and then enter option values as appropriate. 

Note: When Suspend further Alert Actions for is checked, alert actions 
are not sent until the specified amount of time has expired. Once the time 
period has expired, only new alerts are sent. All alerts that are suppressed 
during the time period will never be sent. 

15. Click Alert Actions. 
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16. If you are associating a new action to the rule, click Add New Action, 
and then select an action from the list to configure. For more information 
about adding alert actions, see ñAdding Alert Actionsò on page 135. 

17. If you are editing an existing action for the rule, select an action from the 
list, click Edit Action, and then configure the action. For more information 
about adding alert actions, see ñAdding Alert Actionsò on page 135. 

18. Use the arrow buttons to set the order in which actions are performed. 

Note: Actions are processed in the order they appear, from top to bottom. 

19. If you need to delete an action, select the action, and then click Delete 
Action. 

20. Click OK to save all changes and return to Trap Viewer Settings. 

21. Use the arrow buttons to arrange the order in which the rules are applied. 

Note: Rules are processed in the order they appear, from top to bottom. 

Available Trap Alert Actions 

The following actions are available for trap alerts. For more information about 
assigning and configuring alert actions, see ñAdding Alert Actionsò on page 135. 

Discard the Trap 

Allows you to delete unwanted traps sent to the SNMP Trap server. 

Tag the Trap 

Allows you to add a custom tag to received traps. Ensure you include the 
Tag column in the viewer when assigning a tag. 

Flag the Trap with a specific color 

Allows you to assign a specific color for display in the Orion Web Console 
and the Trap Viewer to flag traps matching the rule. 

Log the Trap to a file 

Allows you to specify a file and a series of variables with which to tag traps 
sent to the file. Ensure you have already created the log file you want to use. 
The alert cannot create a file. 

Windows Event Log 

Allows you to write a message to the local Windows Event Log or to a remote 
Windows Event Log. 
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Forward the Trap 

Allows you to specify the IP address or hostname and the port on which to 
forward the trap. Specify the IP address or hostname of the trap destination 
and the port on which the trap should be sent. Check Include Source 
Address to include the IP address of the trap source. 

Play a sound 

Allows you to play a sound when a matching SNMP trap is received. 

Text to Speech output 

Allows you to define a specific speech engine, the speed, pitch, volume, and 
message to read. 

Execute an external program 

Allows you to specify an external program to launch using a batch file. This 
action is used when creating realtime change notifications in Orion. 

Execute an external VB Script 

Allows you to launch a VB Script using the selected script interpreter engine 
and a saved script file. 

Send a Windows Net Message 

Allows you to send a Windows Net message either to a specific computer or 
to an entire domain or workgroup. 

Note: The only operating systems supporting Windows Net Messaging on 
which SolarWinds supports Orion installations are Windows Server 2003 and 
Windows XP. SolarWinds only supports Orion evaluations on Windows XP. 

Send an E-mail / Page 

Allows you to send an email from a specified account to an address, using a 
specific SMTP server, and containing a customizable subject and message. 

Stop Processing Trap Rules 

Stops the processing of SNMP trap rules for the matching trap. 

Change the status of an interface 

Orion NPM can change the status of an interface from which a trap is 
received. Designate the status to which .the interface should change. 

Note: This action is only available and functional for installations of Orion 
Network Performance Monitor. For more information, see the SolarWinds 
Orion Network Performance Monitor Administrator Guide. 
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Trap Alert Variables 

The following variables can be used in trap alert messages with the Orion Trap 
Server. You must begin each variable with a dollar sign and enclose each 

variable identifier in curly braces as, for example, ${ VariableName } . 

Note: Trap alerts may also use any valid node variables. For more information 
about node alert variagles, see ñOrion Variables and Examplesò on page 269. 

Trap Date/Time Variables 

Trap Date/Time 
Variable 

Description 

${AbbreviatedDOW} Current day of the week. Three character abbreviation. 

${AbbreviatedMonth} Current month of the year. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current date. (MM/DD/YYYY format) 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (MM/DD/YYYY format) 

${DateTime} 
Current day, date and time. (DAY NAME MONTH DD, YYYY 
HH:MM AM/PM) 

${Day} Current date. (MM/DD/YYYY format) 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H}, ${Hour}  Current hour. 24-hour format 

${HH} Current hour. Two digit format, zero padded. 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (DAY NAME, MONTH DAY, YEAR) 

${LongTime} Current Time. (HH:MM:SS AM/PM) 

${M} Current numeric month  

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MMMM} Full name of the current month 

${MediumDate} Current date. (DAY NAME, MONTH DAY, YEAR) 

${MediumTime} Current Time. (HH:MM:SS AM/PM) 

${Minute} Current minute. Two digit format, zero padded. 

${MonthName} Full name of the current month 

${S} Date-time to current second (YYYY-MM-DDTHH:MM:SS) 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (HH:MM AM/PM) 

${Year} Four digit year 

${Year2} Two digit year 
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Other Trap Variables 

Trap Variable Description 

${Application} SolarWinds application information 

${Community} Node community string 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${Hostname} Host name of the device triggering the trap 

${IP} IP address of device triggering alert 

${IP_Address} IP address of device triggering alert 

${Message} 
Message sent with triggered trap and displayed in Trap Details 
field of Trap Viewer 

${MessageType} Name or type of trap triggered 

${Raw} 
Raw numerical values for properties sent in the corresponding 
incoming trap. 

${RawValue} 
Raw numerical values for properties sent in the corresponding 
incoming trap. The same as ${Raw}. 

${vbData1} Trap variable binding value 

${vbName1} Trap variable binding name 
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Chapter 15 

Creating Custom Properties 

 All Orion product installations have access to the Custom Property Editor, which 
allows you to add a custom property to any monitored device. Custom properties 
are additional fields, such as country, building, asset tag, or serial number, that 
you can define and store in your Orion database. After properties are added, they 
are available for display and filtering both within the Orion Web Console and 
within the Report Writer application.  A few more examples of how custom 
properties may be used are as follows: 

¶ Add information to nodes, such as contact, owner, or support contract. 

¶ Add a custom property that is used as an account limitation on nodes. 

¶ Add a custom property to nodes for grouping them on the web or in a report. 

¶ Add a custom property and display it as an annotation on a chart. 

Custom Property Editor lets you choose from a provided collection of the most 
commonly used properties, or you can easily and efficiently build your own 
custom properties. For more information, see ñCreating a Custom Propertyò on 
page 209. 

Once your custom property is defined, the Import Wizard allows you to populate 
your new property from either a text- or comma-delimited file. For more 
information, see ñImporting Custom Property Dataò on page 211. 

Alternatively, if you only have a few individual changes or additions, you may 
choose to make those changes using the Edit view. For more information, see 
ñEditing Custom Propertiesò on page 212. 

Creating a Custom Property 

The following procedure provides steps required to create a custom property 
using the Custom Property Editor.  

To create a property with Custom Property Editor: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Add Custom Property. 
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3. If you want to add predefined properties, complete the following 
procedure: 

a. Select Add Predefined Properties. 

b. Check Show Advanced Properties to view additional predefined 
properties. 

c. Check the properties you want to add, and then click OK. 

4. If you want to generate a completely new custom property, complete the 
following procedure: 

a. Select Build a Custom Property from scratch. 

b. Select the Orion database table to which you want to add the new 
custom property. 

c. Provide the new Property Name. 

Notes: 

¶ To ensure full custom property functionality, do not leave the 
Property Name field empty. 

¶ Although most non-alphanumeric characters used in custom property 

names are replaced by underscores (_) when names are stored in 

the Orion database, SolarWinds recommends against using 
non-alphanumeric characters in custom property names. Hash 

characters (#) are not allowed in any property name. 

d. Select the Property Type. 

e. Enter a Max. Text length. 

Note: Regardless of the value provided in this field, Orion does not 
support custom properties defined with more than 4000 characters. 

f. Click OK. 

Removing a Custom Property 

Custom properties are easily removed using the Custom Property Editor, as 
shown in the following procedure. 

To remove a custom property: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Remove Custom Properties. 
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3. Check each property you want to remove. 

4. If you are satisfied with your selections, click OK. 

Importing Custom Property Data 

Once you have defined custom properties, the Custom Property Editor Import 
tool assists in populating the custom property data. For example, you may 
already possess a spreadsheet listing the asset tags of all your network nodes, 
and you would like to have this information available for reporting and publication 
in the web console. In this scenario, Asset Tag is added as a custom property, 
and then the import wizard is used to populate the asset tag values from the 
spreadsheet. The following steps outline the process for importing custom 
properties data. For more information, see ñCreating Custom Propertiesò on 
page 209. 

To import custom property data: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click File > Import, and then select Import from Comma Delimited File or 
Import from Text File as appropriate. 

3. Navigate to the file that contains your custom property data. 

4. Select the file that contains your custom property data, and then click Open. 

5. Select the delimiter that separates the data in your file.  

6. If your data file contains a header row, check First row contains field 
names. 

7. Specify the characters that may surround text fields in your file, and then 
click Next. 

8. Select the data table that has the custom properties into which you want to 
import your data, and then click click Next. 

9. Use the drop down menus to select the key field from your file on the left and 
the corresponding field of the table on the right. 

Note: Depending on your file data, you may need to specify multiple key 
fields so that the import wizard properly matches your data to the table fields. 

10. Click Next. 

11. Specify the fields from your file on the left that you want to import by clicking 
corresponding blank cell on the right, and then select the target field that you 
want your data field to populate. 

Note: Click the cell to enable a menu. Use the menu items to select the 
target field that you want your data to populate. 
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12. If you have specified all cell matches between your data and the Orion 
database, click Import. 

13. If your import is successful, confirm the count of successfully imported 
rows, and then click OK. 

Custom Property Editor Settings 

The Custom Property Editor Settings window allows you to customize the display 
for nodes and volumes. 

Note: Orion Network Performance Monitor users may also customize the display 
for interfaces. 

To configure Custom Property Editor settings: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click File > Settings. 

3. Click Node Editing and check the system properties you want to see in the 
Edit Node Properties window. Repeat for Volume Editing. 

4. If you want to enable Auto-Search, click Auto-Search, and then check 
Enable Auto-Search. 

Note: With Auto-Search enabled, the current column is searched as you 

type. Select a cell and then press Enter  to edit its contents. With Auto-

Search disabled, typing will begin editing the cell. 

Editing Custom Properties 

The Custom Property Editor allows you to easily modify custom properties. 

Note: Orion Network Performance Monitor users may also edit custom properties 
for interfaces. 

To edit a custom property: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Edit Object Properties, where Object is Node or 
Volume, as appropriate. 

3. Click the cells in the table that you want to edit, and then enter or modify the 
cell contents, as necessary. 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Creating Custom Properties Ö 213 

4. If you want to create or edit a filter for your custom properties, click No 
Active Filter or Filter Active, and then define the filter that you want to 
apply. For more information, see ñUsing Filters in Edit Viewò on page 213. 

5. If you are satisfied with your edits, click OK. 

Using Filters in Edit View 

Filtering is available in the Edit Custom Properties windows for all devices, and 
you can apply filters to manipulate available data views. Custom Property Editor 
allows you to edit the text within custom property fields to which a filter is applied. 
The following procedures show how to use filters within Custom Property Editor. 

Creating Custom Properties Filters 

The following procedure creates a custom properties filter. 

Note: Orion Network Performance Monitor users may also create filters for 
interface custom properties. 

To create a filter: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Edit Object Properties, where Object is Node or 
Volume, as appropriate. 

3. Click Filter Active or No Active Filter, and then click Apply Filter. 

Note: The text of the Filter Active / No Active Filter button changes 
dynamically, indicating the filter status for the currently viewed data. 

4. Click the hyperlinked text to select the appropriate criteria. 

5. Click the ellipsis, and then select from the following options: 

Note: The lists of available linked descriptors are dynamically generated in 
consideration of all other variables within the same condition. For more 
information, see ñUnderstanding Condition Groupsò on page 130.Click 
Browse (é) to select a condition type. 

¶ Select Add a new elementary condition to generate a condition that is 
based on a direct comparison of network object data fields. 

¶ Select Add a new advanced elementary condition to generate a 
condition based on a comparison of device data fields and values. 

¶ Select Add a new complex condition to define a condition that filters 
other defined conditions. 

javascript:fD(58);
javascript:fD(58);
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¶ Select Delete current condition to remove a selected condition. 

¶ Select Move current condition forward or Move current condition 
backward to change the order of your conditions accordingly. 

6. Continue to click hyperlinked text and use the cascading menus to select 
filtering criteria. 

7. If you have completed the configuration of your filter, click OK. 

Note: The Edit Object Properties view changes, based upon the selected 
filter, and the text of the Filter Active / No Active Filter now displays ñFilter 
Activeò, indicating that the filter is being applied to the currently viewed 
properties. 

Removing Custom Properties Filters 

The following procedure removes a custom properties filter. 

Note: Orion Network Performance Monitor users may also remove filters for 
interface custom properties. 

To remove a filter: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Properties > Edit Object Properties, where Object is Node or 
Volume, as appropriate. 

3. Click Filter Active, and then click Remove Filter. 

Note: The Edit Object Properties view now displays all custom properties. 
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Chapter 16 

Creating Account Limitations 

The Account Limitation Builder application allows you to create and customize 
account limitations for the Orion Web Console. These limitations ensure that 
users of the web console can only view the network objects that are pertinent to 
their job duties. The following are but a few examples of the uses of account 
limitation in the Orion Web Console: 

¶ Limit customer views to specific network nodes 

¶ Limit views by department or functional area 

¶ Limit views by device type or device role 

¶ Limit views based on the geographic location of devices 

Orion provides predefined account limitations that use built-in Orion property to 
limit user access. For greater flexibility, however, you can use the Account 
Limitation Builder to create your own account limitations based on predefined or 
custom properties. For more information about enabling account limitations in the 
Orion Web Console, see ñSetting Account Limitationsò on page 100. For more 
information about custom properties, see ñCreating Custom Propertiesò on 
page 209. 

Using the Account Limitation Builder 

Before you can use the Account Limitation Builder, you must have first created 
the custom property that you want to use to limit the Orion Core Web Console 
view. For more information, see ñCreating Custom Propertiesò on page 209. After 
you have defined custom properties and populated them with data, you may use 
the Account Limitations Builder as directed in the following procedure. 

Creating an Account Limitation 

The following steps create an account limitation. 

To create an account limitation: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Account Limitation Builder. 

2. Click Start on the splash screen. 

3. Click Edit > Add Limitation. 
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4. Select a Custom Property.  

Notes: 

¶ If Custom Property is empty, you need to define a custom property. For 
more information, see ñCreating Custom Propertiesò on page 209. 

¶ The remaining boxes are populated automatically, based upon your 
selection. 

5. Choose a Selection Method.  

Note: This is the selection format that will appear when you are choosing 
values for the account limitation through the web Account Manager. For more 
information, see ñSetting Account Limitationsò on page 100. 

6. If you want to include your own description of your account limitation, type 
your description over the default text provided in the Description field. 

7. Click OK.  

Your newly defined account limitation is added to the top of the table view. You 
may now use the new limitation in the Orion Web Console Account Manager. For 
more information, see ñSetting Account Limitationsò on page 100. 

Deleting an Account Limitation 

The following steps delete an account limitation using the Account Limitation 
Builder utility. 

To delete an account limitation: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Account Limitation Builder. 

2. Click Start on the splash screen. 

3. Click the row of the limitation that you want to delete. 

Note: Use Shift+click  to highlight multiple consecutive rows or 

Ctrl+Click  to highlight multiple non-consecutive rows. 

4. Click Edit > Delete Selected Limitations.  

Note: Although Orion deletes the selected limitations from the table, ensuring 
that they will no longer be available through the web Account Manager, if you 
delete a limitation using the Account Limitation Builder, all accounts that have 
been assigned that limitation will remain limited. Deleting a limitation simply 
makes it unavailable for future use in the Orion Web Console. 
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Chapter 17 

Managing the Orion Database 

All Orion network monitoring and management products use a Microsoft SQL 
Server database to store web console settings and collected network 
performance and configuration data. The following database utilities are 
packaged with Orion products to help you manage your Orion database. 

Database Manager  

Allows you to perform queries, edit database values, export data, and 
perform database repair and compaction on your Orion database. For more 
information, see ñUsing Database Managerò on page 217. 

Database Maintenance 

Allows you to summarize, clean, and compact your Orion database. For 
more information, see ñDatabase Maintenanceò on page 227. 

The database Orion uses is hosted on a Microsoft SQL Server. When installing 
SQL Server, you have the option of installing the SQL Server Management 
Studio. If you are the database administrator for the SQL Server hosting your 
Orion database, SolarWinds generally recommends that you install this utility as 
it provides a number of features that are not currently available in the Orion 
Database Manager. For more information, see ñUsing SQL Server Management 
Studioò on page 225. 

Note: Orion Network Configuration Manager maintains its own additional 
database for device configurations and user activity logging. 

Using Database Manager 

The Database Manager can be used to perform queries, view database and table 
details, export data, and edit database values. You may also repair, compact, 
restore, or backup the database from the Database Manager application. The 
following procedures present some of the basic database management 
operations that are available with Database Manager. 

Adding a Server 

If you have not already designated a database for use with Orion as a backup or 
supplement, use the following steps to add a SQL server to the Database 
Manager. Once added, your selected server and associated databases display in 
the tree structure in the left pane of Database Manager. 
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To add a SQL server to Database Manager: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. Click File > Add Server. 

3. Select from the SQL Server list or enter the IP address of the SQL server. 

4. Select the login style. 

Note: You may choose to Log in using Windows NT Integrated Security 
to automatically pass the Windows user ID and password to the SQL server, 
or select Log in using an SQL Server userid and password to use a 
separate login. Upon selecting the latter option, the window changes to 
provide fields to enter the separate SQL Server User Name and Password 
that you want to use. 

5. Click Connect to Database Server. 

Creating Database Backups 

You should periodically back-up your Orion Core databases. For more 
information about scheduling regular database backups, see ñCreating a 
Database Maintenance Planò on page 224. The following procedure is used to 
back-up your databases in Database Manager. 

To back-up a database in Database Manager: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

3. Click + to expand the SQL Server hosting your Orion database.. 

4. Right-click the name of the database you want to back-up, and then click 
Backup Database. 

5. Provide a Description of the database backup. 

6. Specify a path for the Backup Filename either by clicking Browse (é) and 
navigating to the location or by entering the path directly. 

Note: Typically, the default backup location for an Orion database is 

designated as C: \ Program  Files \ SolarWinds \ . Ensure that the target 

location for the database backup has sufficient available disk space. 

7. Select either Append to the end of the Backup File or Overwrite Backup 
File, as appropriate, and then click OK. 
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Restoring a Database 

The following steps restore a database that you have backed up. 

To restore a database from backup: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

3. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click your Orion database. 

4. Click Database > Restore Database. 

5. Click Browse (é) to navigate to the database that you want to restore, or 
enter a valid SQL backup database name and path. 

Note: Typically, the default location for an Orion database backup is 

C: \ Program  File s\ SolarWinds \ . 

6. Click Verify to ensure that you have selected a valid SQL database. 

Notes: 

¶ When you select a database, the remaining fields are completed for you. 
The Database Name field is populated with the name that SQL Server 
uses to refer to the specified database. The remaining two fields display 

the data (.mdf ) and transaction log (.ldf ) files for the database. You can 

change the values provided. 

¶ Database Manager does not create directories. You may only specify a 
path that already exists. 

¶ You also cannot restore a database that is currently in use. 

7. Click OK to restore the selected database. 

Compacting your Database 

Compacting a database shrinks it, reindexes it, and removes whitespace. You 
can compact a database by performing the following steps. 

To compact a database with Database Manager: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 
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2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

3. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click your Orion database. 

4. Click Database > Compact Database. 

Note: Upon completion, Database Manager displays a window comparing 
the size of the database before and after compaction. If the sizes are the 
same, there may not be enough free space in the database to rearrange 
data.If you need to free up more space for database compaction to occur, 
see ñCompacting Individual Tablesò on page 220. 

Compacting Individual Tables 

If you are not able to perform a full database compaction due to limited server 
disk space, you can compact database tables individually, using the Database 
Manager application, as shown in the following procedure. 

To compact individual tables: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

3. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click your Orion database. 

Note: SolarWinds Orion  is the default name of the Orion database.  

4. Click a table to compact in the expanded database, and then click Table > 
Compact/Rebuild Indexes. 
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Viewing Database Details 

The Database Details window in Database Manager presents two tabs that 
display property and tables information about a selected database. The following 
procedure is a guide to the information that is available in the Database Details 
window. 

To view database details: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

3. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click your Orion database. 

Note: SolarWinds Orion  is the default name of the Orion database.  

4. Click Database > Database Details. 

Notes: 

¶ The Properties tab provides general statistics and descriptions of the 
selected database. 

¶ The Tables tab shows a list of the tables in the selected database and 
their respective sizes. 

5. If the Last Backup field on the Properties tab is blank, you have not 
generated a backup of the selected database. For more information about 
scheduling a recommended regular database backup, see ñCreating a 
Database Maintenance Planò on page 224. 

Viewing Table Details 

The Database Manager Table Details window provides property, column, and 
index information about the selected table. You can also query the selected table 
directly from the Table Details window., as shown in the following procedure. 

To view table details: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 
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3. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click + to expand your Orion database. 

Note: SolarWinds Orion  is the default name of the Orion database.  

4. Click a table to view in the expanded database. 

5. Click Table > Table Details. 

Note: The Properties tab includes general statistics relating to the table size 
and creation date; the Columns tab describes the columns in the table, table 
keys, and field types; and the Indexes tab lists indexes used within the table. 

6. If you want to query the open table, click Query in the tool bar. 

Warning: Special care should be taken while editing database values as you 
can easily compromise the integrity of your database. For more information, 
see ñEditing Database Fieldsò on page 222. 

Note: A default SQL statement is provided, as well as radio buttons for 
displaying the data in read or read/write view. 

Editing Database Fields 

Database fields may be edited within the Database Manager application from the 
query view. The following procedure directs you in editing database fields in 
Orion Database Manager. 

Warning: Be very careful when you are editing database values, as you can 
jeopardize the integrity of your database. 

To edit database fields with Database Manager: 

1. Stop the SolarWinds Network Performance Monitor service as follows: 

a. Click Start > All Programs > SolarWinds Orion > Advanced 
Features > Orion Service Manager 

b. Click SolarWinds Network Performance Monitor under Services, and 
then click Stop. 

2. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

3. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

4. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click + to expand your Orion database. 

Note: SolarWinds Orion  is the default name of the Orion database.  
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5. Click a table to view in the expanded database. 

6. Click Table > Query Table. 

7. Use the provided SQL statement or enter your own in the query field. 

8. If you want to view the query results in table view, click Refresh. 

9. If you want to edit table fields, select Read/Write at the top of the window, 
and then edit fields as necessary. 

10. If you use the same SQL query often, you can save time by making the query 
a favorite, as follows: 

a. Enter the query in the query field. 

b. Click Add to Favorites. 

c. Enter a name for the command, and then click OK. 

Note: Database Manager saves the command with the name that you 
have provided. You can now use this command again, directly, by 
clicking Paste from Favorites. 

Detaching a Database 

Detaching a database removes its reference from the SQL Server, allowing you 
to safely move files to different locations. Database Manager allows you to 
detach a database and leave the data files of a database intact, as shown in the 
following procedure. 

Note: SolarWinds does not recommend using the Detach Database option to 
migrate a database from one SQL Server to another. For more information, see 
ñMigrating your Databaseò on page 228. 

To detach a database: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

3. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click your Orion database. 

Note: SolarWinds Orion  is the default name of the Orion database.  

4. Click Database > Detach Database from the menu. 
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Creating a Database Maintenance Plan 

Using Database Manager, you can create a database maintenance plan that will 
automatically compact and backup the database on a scheduled basis. As a 
security and information integrity issue, it is very important to regularly back-up 
your databases. Database Manager allows you to do this easily, using the 
following steps. 

Note: SQL Server Agent must be running to execute database maintenance. 

To create a database maintenance plan for an Orion Core database: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

2. If the SQL Server hosting your Orion database is not listed in the left 
pane, you must add the SQL Server hosting your Orion database. For more 
information, see ñAdding a Serverò on page 217. 

3. Click + in the left pane to expand the SQL Server hosting your Orion 
database, and then click your Orion database. 

Note: SolarWinds Orion  is the default name of the Orion database.  

4. Click Database > Database Backup Schedule. 

5. Select to run the backup either once a Day or once a Week. 

6. If you to want to run the backup once a week, choose the Backup Day. 

7. Set the Backup Time. 

8. Click Next. 

9. If you want to compact and shrink the database before the backup, 
check Compact and Shrink Database before Backup. 

Note: SolarWinds recommends both that you perform database compaction 
weekly and that you compact and shrink databases before backups. 

10. Enter the path to the directory where you would like to place backup files or 
click Browse (é) and then navigate to an appropriate directory. 

11. If you want to keep backup reports, check Generate a backup report 
each time the backup Job runs, and then enter the path to the directory 
where you would like to Place Backup reports or click Browse (é) and then 
navigate to an appropriate directory. 

12. Click Finish. 
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Using SQL Server Management Studio 

If you have a licensed, Standard or Enterprise Edition copy of SQL Server 2005 
or 2008 with SQL Server Management Studio installed, you can use it to 
maintain your Orion database. The following procedure is a basic guide to 
configuring a daily Orion database maintenance plan in SQL Server 
Management Studio.  

Notes: 

¶ Your specific environment may require additional configuration. 

¶ You may need to contact your database administrator to gain access to SQL 
Server Management Studio for your Orion database. 

¶ The following procedure clears historical maintenance records and creates a 
backup of your Orion database. In general, however, SolarWinds 
recommends that you contact your database administrator and reference the 
Microsoft documentation provided with SQL Server for instructions on using 
SQL Server Management Studio to manage your Orion database. 

To use SQL Server Management Studio to manage your Orion database: 

1. Click Start > Microsoft SQL Server > SQL Server Management Studio. 

2. Click View > Object Explorer.  

3. Expand the SQL Server instance containing your Orion database in the 
Object Explorer pane on the left. 

Note: Expand the Databases folder for any instance to confirm included 

databases. By default, the Orion database is named SolarWinds Orion .  

4. Expand the Management folder, right-click the Maintenance Plans folder, and 
then click Maintenance Plan Wizard. 

5. Click Next to start the SQL Server Maintenance Plan Wizard. 

6. Provide an appropriate Name and Description for your maintenance plan. 

7. Click Browse (é) next to the Server field. 

8. Check your SQL Server\Instance, and then click OK. 

Note: If your SQL Server\Instance is not in the list, provide it manually. 

9. Select the authentication type that is used to connect to the SQL server, and, 
if required, provide appropriate User name and Password credentials. 

Note: Use the same authentication type and credentials you provided in the 
Orion Configuration Wizard to access your Orion database. 
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10. Check Clean Up History and Back Up Database (Full) 

Note: When a task is clicked, the Maintenance Plan Wizard provides a brief 
task description. 

11. Click Next. 

12. Set the order of task execution, top to bottom, by selecting tasks and clicking 
Move Up and Move Down as needed. 

Note: The following steps assume the Clean Up History task precedes the 
Back Up Database (Full) task. 

13. Click Next when the task execution order is set. 

14. On the Define Cleanup History Task view, check the types of historical data 
to delete, and then set the threshold age for historical data removal. 

15. Click Next. 

16. On the Database Back Up (Full) view, complete the following steps: 

a. Click the Databases field. 

b. Select These databases. 

c. Check your Orion database. 

17. Click OK. 

18. Select Database in the Backup component area. 

19. In the Destination area, complete the following steps: 

a. Select Disk. 

b. Select Create a backup file for every database. 

c. Click Browse (é) to select an appropriate database backup file 
destination with sufficient free space.  

20. Click Next. 

21. On the Select Plan Properties view, click Change. 

22. Configure the database maintenance job schedule as follows: 

a. Provide an appropriate Name for the new job schedule. 

b. Select Recurring as the Schedule type. 

c. Check Enabled, and then select Daily in the Occurs field. 

d. Provide an off-peak network usage time in the Occurs once at field. 

e. Select a Start date, and then select No end date. 

23. Click OK. 
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24. Click Next, and then check Write a report to a text file. 

25. Click Browse (é) to select an appropriate maintenance report file 
destination. 

26. Review wizard results, click Finish, and then, when the wizard successfully 
finishes, click Close. 

For additional help with using SQL server Management Studio, visit the Microsoft 
Support Website at http://support.microsoft.com. 

Database Maintenance 

The primary tasks that are available for maintaining a SQL database are data 
summarization and database compaction. Data summarization occurs 
automatically as a part of the nightly maintenance program. You can also run 
database maintenance on demand from the Windows Start menu. 

Running Database Maintenance 

Database maintenance performs a series of data summarizations that help you 
optimize the size of your Orion database. Data summarization consists of 
gathering all the collected network data for a defined period of time, calculating 
statistics from the data, and then discarding the data itself while retaining the 
statistics. By regularly running database maintenance, you can realize significant 
space savings and performance improvements.  

Database maintenance can either be run directly from the Start menu, or 
scheduled for a set Archive Time and initiated from the Orion Polling Settings 
view in the Orion Web Console. In either case, once started, database 
maintenance normally proceeds without further attention. For more information 
about setting the Archive Time for database maintenance on the Orion Polling 
Settings view, see ñOrion Polling Settingsò on page 107. The following procedure 
provides the steps to perform Database Maintenance: 

Note: Administrative privileges are required to run Database Maintenance. 

To run the Database Maintenance utility: 

1. If you want to run database Maintenance from the Orion Web Console, 
complete the following steps: 

a. Click Settings in the top right of the web console, and then click Poller 
Settings in the Settings group. 

b. Click Perform Maintenance Now in the Database Settings area. 

2. If you want to run database Maintenance from the Start menu, click 
Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Maintenance, and then click Start. 

http://support.microsoft.com/
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Migrating your Database 

If you are modifying your Orion implementation to use a different database 
server, you can migrate data from one Orion database to another. Both the 
database from which you export data and the database into which you want to 
import data must be from the same version of Orion. 

Warning: You will not lose Web Console customizations when you overwrite 
your website, unless you have manually overwritten or modified the HTML within 

the .asp  pages. 

Note: Do not skip tabs or deviate from the tab order. Click Start, and then click 
Continue to complete the wizard in order. Completing tabs out of order may 
adversely affect the install process. For more information, see ñPreparing a 
SolarWinds ò on page 9. 

To export data from one Orion database and import it into another: 

1. Connect to your database server with Database Manager. For more 
information, see ñAdding a Serverò on page 217. 

2. Select your database, and then click Database > Backup Database. 

3. Enter a Description of the database backup. 

4. Enter a path or click Browse (é) and then navigate to a Backup Filename. 

5. Click OK. 

6. Copy the newly created backup file to a folder on the new server. 

Note: The backup file is named after your Orion database and given a .bak  

extension. For example, if you have designated OrionDB  as the name of your 

Orion database, the backup is named OrionDB .bak . 

7. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Database Manager. 

8. Click Add Server. 

9. Select the name of the SQL instance from the SQL Server list. If your server 
is not listed, complete the procedure in ñAdding a Serverò on page 217. 

10. Select the appropriate authentication type, and then click Connect to 
Database Server. 

11. Select your new server in the list, and then click Server > Connect to 
Server. 

12. Click Server > Restore Database. 

13. Enter the path to the database backup file on the server or click Browse (é) 
and then navigate to the location of the database backup file. 
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14. Click OK. 

15. Close the Database Manager. 

16. Click Start > All Programs > SolarWinds Orion > Configuration and 
Auto-Discovery > Configuration Wizard. 

17. Specify the newly restored database in the Database Setup section of the 
wizard. 

18. When prompted, click Yes to use the existing database. 
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Chapter 18 

Common Orion Tasks 

The following chapter provides a number of common network monitoring and 
management scenarios for which Orion provides solutions. 

Creating an Alert to Discover Network Device Failures 

With advanced alerting, Orion gives you the ability to immediately discover 
whenever any device on your network is experiencing a problem. The following 
procedure creates an advanced alert that uses a custom location property to alert 
you to a node failure on your monitored network. 

Creating a Custom Property 

Orion NPM provides the Custom Property Editor that allows you to choose from a 
provided collection of many commonly used properties, or you can easily and 
efficiently build your own custom properties. Once your custom property is 
defined, the Import Wizard allows you to populate your new property from either 
a text- or comma-delimited file. For more information, see ñImporting Custom 
Property Dataò on page 211.  

Alternatively, if you only have a few individual changes or additions, you may 
choose to make those changes using the Edit view. For more information, see 
ñEditing Custom Propertiesò on page 212. 

The following procedure uses the Custom Property Editor to create a custom 
location property that is applied to monitored nodes. 

To create and apply a custom location property: 

1. Click Start > All Programs > SolarWinds Orion > Grouping and Access 
Control > Custom Property Editor. 

2. Click Add Custom Property. 
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3. Select Add Predefined Properties, check State, and then click OK. 

 

 

4. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

5. Log in to the Orion Web Console as an administrator. 

6. Click Settings in the top right corner of the web console. 

7. Click Manage Nodes in the Node & Group Management grouping of the 
Orion Website Administration page. 

8. Select the type of nodes to which you want to apply the State property using 
either of the following methods: 

¶ Use the search tool above the node list to search your Orion database. 

¶ Select an appropriate Group by criteria, and then click the appropriate 
group including the node. 

 

 

9. Check all nodes to which you want to apply the State property, and then click 
Edit Properties on the Node Management toolbar. 
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10. Check State, type the appropriate state name for the node or group of nodes 
you selected, and then click Submit. 

 

 

Creating an Alert Using a Custom Property 

The following example creates multiple alerts using the State custom property 
defined previously. Each alert will trigger when a node goes down. Upon 
triggering, each alert will perform a specific action that depends on the value of 
the State custom property for the node triggering the alert. 

To create a new advanced alert: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click Configure Alerts. 

3. Check Alert me when a node goes down, and then click Edit. 
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4. Click the Trigger Actions tab, and then click Add New Action. 

 

 

The following section provides instructions for adding a number of alert actions to 
a selected alert. 

Configuring Alert Actions 

The following sections create three different actions for the same alert: 

¶ Create a Local Alert Log 

¶ Send a Syslog Message 

¶ Send an SNMP Trap 

The following sections assume that you have already created a State custom 
property and that you are adding an action to an existing alert. For more 
information about creating the State custom property, see ñCreating Custom 
Propertiesò on page 209. For more information about creating alerts, see 
ñCreating and Configuring Advanced Alertsò on page 119. 

Create a Local Alert Log 

The following procedure configures a local alert log on the computer hosting your 
Orion NPM evaluation. 

To create a local alert log: 

1. Open an alert you want to enable on your network for editing. 

Note: For more information about opening an alert for editing, see ñCreating 
and Configuring Advanced Alertsò on page 119. 

2. Click the Trigger Actions tab, and then click Add New Action. 
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3. Select Log the Alert to a file, and then click OK. 

 

 

4. Click Browse (é) to open the default Orion directory.  

 

 

5. Browse to an appropriate folder, and then type Example AlertLo g as the alert 

log file name. 

 

 

6. Click Save. 
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7. In the Message text box, type Node $ {N odeName} in ${ State }  network  

is currently  down.  

 

 

8. Click OK. 

 

 

The next section configures an additonal action that sends a Syslog message to 
a designated server when this alert triggers. 

Send a Syslog Message 

The following procedure configures an alert Syslog message. 

To configure an alert Syslog message action: 

1. Open an alert for editing and then click Add New Action. 

 

 

2. Select Send a Syslog Message, and then click OK. 
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3. Click the Syslog Message tab.  

4. Type 127.0.0.1  as the Hostname or IP Address of the Syslog Server, 

and then type Node ${NodeName} in ${ State } network is currently 

down in the Syslog Message field. 

Note: The ${ variable }  syntax is required for Orion NPM variables. For 

more information, see ñOrion Variables and Examplesò on page 269. 

 

 

5. Click OK. 

Send an SNMP Trap  

The following procedure configures an SNMP trap alert action. 

To configure an SNMP trap action: 

1. Open an alert for editing and then click Add New Action. 

2. Select Send an SNMP Trap, and then click OK. 

 

 

3. Click the SNMP Trap tab.  
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4. Type 127.0.0.1  as the SNMP Trap Destination, and then type Node 

${NodeName} in ${ State } network is currently down  in the éAlert 

Message field. 

Note: The ${ variable }  syntax is required for Orion NPM variables. For 

more information about available variables, see ñOrion Variables and 
Examplesò on page 269. 

 

 

5. Click OK. 

6. If you are finished configuring alert actions, click OK. 

Testing Alerts 

You do not have to actually experience a device failure to confirm that your alerts 
are working. Orion NPM provides a Test Alerts function that allows you to ensure 
that you have configured your alerts properly, as shown in the following 
procedure. 

To test a configured alert: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Advanced Alert Manager. 

2. Click Configure Alerts. 
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3. Check the alert you want to test, and then click Test. 

Note: For purposes of this example, check Alert me when a node goes 
down as it is the same alert that was configured previously. 

 

 

4. Select Alert on Network Node, and then select your Orion server. 

 

 

5. In the Test Alert Definition area, click Test Alert Trigger. 
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6. Review the alert test log as the test completes. 

After the alert test completes, you can view the results of each of your alert 
actions as follows: 

¶ To view the results of your email alert action, open EvaluationAlertLog  in 

your Orion folder, typically <Volume: >\ Program Files \ Solarwinds \ Orion . 

¶ To view results of your Syslog message action, click Start > All Programs > 
SolarWinds Orion > Syslog and SNMP Traps > Syslog Viewer. 

¶ To view the results of your Syslog message action, click Start > All 
Programs > SolarWinds Orion > Syslog and SNMP Traps > Trap Viewer. 

Scheduling and Emailing Business Hours Reports 

Orion Report Writer is a component available to all Orion products. Using Orion 
Report Writer with Orion Report Scheduler, you can create reports that you can 
then distribute as regularly scheduled emails. The following sections create and 
schedule for email delivery an example report of network node availability and 
response time during peak business hours. 

Creating a Business Hours Report 

The following procedure creates a monthly report of network node availability and 
response time during peak business hours, defined as between 7:00 AM and 
7:00 PM. 

To create a business hours node availability and response time report: 

1. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Report Writer. 

2. In the left pane, click Historical Response Time Reports > Response 
Time ï Last Month. 

3. On the General tab, edit the Report Group, Report Title, and Description 
as appropriate. 

4. On the Select Fields tab, click Browse (...), and then click Add a new field. 

5. In the new field, click the Field asterisk (*), and then select Network 
Nodes > Historical Response Time and Availability > Availability. 

6. On the Filter Results tab, click Browse (...), and then select Add a new 
elementary condition. 

7. In the new field, click the first asterisk (*), and then select Date/Time 
(Response Time Filtering Only) > Time of Day (24 hour format). 

8. Click is equal to, and then select greater or equal. 
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9. Click the second asterisk (*), and then enter the start time of your peak 

business hours in 24-hour hh:mm format (e.g. 07:00 ). 

10. Click Browse (...), and then select Add a new elementary condition. 

11. Click the first asterisk (*), and then select Date/Time (Response Time 
Filtering Only) > Time of Day (24 hour format). 

12. Click is equal to, and then select less. 

13. Click the second asterisk (*), and then enter the end time of your peak 

business hours in 24-hour hh:mm format (e.g. 19:00 ). 

14. Click Browse (...), and then select Add a new elementary condition. 

15. Click the first asterisk (*), and then select Date/Time (Response Time 
Filtering Only) > Day of Week. 

16. Click is equal to, and then select not equal. 

17. Click the second asterisk (*), and then select Saturday. 

18. Click Browse (...), and then select Add a new elementary condition. 

19. Click the first asterisk (*), and then select Date/Time (Response Time 
Filtering Only) > Day of Week. 

20. Click is equal to, and then select not equal. 

21. Click the second asterisk (*), and then select Sunday. 

22. On the Field Formatting tab, click AVERAGE of Average Response Time, 

and then append (ms)  to Average Response Time  in the Column Header 

field.  

23. On the Field Formatting tab, click Max of Peak Response Time, and then 

append (ms)  to Average Response Time  in the Column Header field.  

24. Click Preview on the right of the Report Designer pane. 

25. Click File > Save. 

The report is now saved to the Reports folder on your Orion server, and it will 
display as a member of the Report Group designated on the General tab of the 
Report Designer. 

Scheduling and Emailing a Report 

The following procedure schedules a selected report for distribution using email. 

To schedule an emailed report: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Click Reports. 
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3. Click + as required to locate the report you want to schedule for email. 

4.  Click the name of the report you want to schedule for email. 

5. Copy the URL of the report you want to schedule for email. 

6. Click Start > All Programs > SolarWinds Orion > Alerting, Reporting, and 
Mapping > Orion Report Scheduler. 

7. Click Edit > Add New Job. 

8. Provide an appropriate job name for this scheduled report email, and then 
click Continue. 

9. Paste the URL of the report you want to schedule for email into the link field. 

10. If you need to provide Windows login credentials to view the report you 
are scheduling, click the NT Account login tab, and then provide the user 
account details needed to log in. 

11. If you want to create a printable report that excludes the Orion Web 
Console banner and menu bar, on the Orion Web Login tab, check 
Retrieve a Printable Version of this Page. 

12. If the report you are scheduling requires an Orion user account, on the 
Orion Web Login tab, check Send Orion Username / Password in URL, 
and then provide the required user credentials to view the Orion report. 

13. Click Continue. 

14. Configure the scheduling for your report job, and then click Continue. 

15. Confirm that either Email the Web Page (as HTML) or Email the Web Page 
(as PDF) are selected, and then click Continue. 

16. Provide required email addresses and a subject in the appropriate fields on 
the Email To tab. 

17. Provide a name and reply address on the Email From tab. 

18. On the SMTP Server tab, type the hostname or IP address and confirm the 
port number of the server used to send email from the Orion server. 

19. Click Continue. 

20. Enter the user name and password for the local Windows account that will 
email the report, and then click Continue. 

21. Add any additional comments or notes about this job, and then click Finish. 
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Creating Geographic or Departmental Views 

Using groups, it is a straightforward process to create custom web console views 
displaying informaton about monitored objects distinguished by geographic or 
departmental location. The following procedures create custom views that are 
then populated with appropriate group-based resources. 

Creating a Custom Group 

The following procedure creates a custom group of monitored objects in a 
defined geographic location. 

To create a custom group: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the web console as an administrator. 

3. Click Settings in the top right corner of the web console. 

4. Click Manage Groups in the Node & Group Management grouping of the 
Orion Website Administration page. 

5. Click Add New Group. 

6. Provide an appropriate Name and Description for the custom group. For 

example, a group named Austin  could be described as, All monitored 

network object s in the Austin office . 

7. Click Next. 

8. In the Available Objects pane, check all monitored objects fitting the group 
definition. For example, using the example above, select all objects located 
in the Austin office. 

9. Click Add to Group. 

10. Select all monitored objects in the new group pane on the right, and then 
click Create Group. 

The new group of monitored objects located in the same geographic location is 
now listed on the Manage Groups view. 
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Creating a Custom View 

The following procedure creates a custom view that will be used to display 
monitoring information g for devices in a selected group. 

To create a custom, group-based view: 

1. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

2. Log in to the web console as an administrator. 

3. Click Settings in the top right corner of the web console. 

4. Click Add New View in the Views grouping of the Orion Website 
Administration page. 

5. In the Name of New View field, provide a name for the custom view. 

6. In the Type of View selection field, select Group Details. 

7. Click Submit. 

8. If you want to change the column layout of your custom view, click Edit 
to the right of the column widths, and then configure the column layout of 
your view as follows: 

a. Select the number of columns under Layout. 

b. Provide the width, in pixels, of each column in the appropriate fields.. 

c. Click Submit. 

9. Repeat the following steps for each resource added to your custom view: 

Notes: 

¶ Resources already in your view will not be checked on this page, as it is 
a view of all web console resources. It is, therefore, possible to pick 
duplicates of resources you are already viewing. 

¶ Several options on the Add Resources page are added to the list of 
resources for a page, but the actual configuration of a given map, link, or 
code is not added until the page is previewed. 

¶ Some resources may require additional configuration. For more 
information, see ñResource Configuration Examplesò on page 44. 

a. Click + next to the column in which you want to add a resource. 

b. Click + next to a resource group on the Add Resources page to expand 
the resource group, displaying available resources. 

c. Check all resources you want to add. 

d. If you have completed the addition of resources to the selected 
view, click Submit. 
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10. If you want to delete a resource from a column, select the resource, and 
then click X next to the resource column to delete the selected resource. 

11. If you want to copy a resource in a column, select the resource, and then 

click  next to the resource column to delete the selected resource. 

12. If you want to rearrange the order in which resources appear in your 
view, select resources, and then use the arrow keys to rearrange them. 

13. If you have finished configuring your view, click Preview. 

Note: A preview of your custom web console displays in a new window. A 
message may display in the place of some resources if information for the 
resource has not been polled yet. For more information, see ñResource 
Configuration Examplesò on page 44. 

14. Close the preview window. 

15. If you are satisfied with the configuration of your view, click Done. 

Notes: 

¶ For more information about applying limitations to this custom view, see 
ñConfiguring View Limitationsò on page 43. 

¶ For more information about adding a custom view to menu bars as a 
custom item, see ñCustomizing Web Console Menu Barsò on page 57. 

¶ For more information about assigning your custom view as the default 
view for a user, see ñEditing User Accountsò on page 98. 
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Chapter 19 

Orion Product Family 

The SolarWinds Orion family of products delivers easy-to-use, scalable solutions 
to meet your network, systems, and storage monitoring and management needs. 
The following sections provide more information about individual products in the 
Orion family: 

¶ Monitoring Network Performance (Orion NPM) 

¶ Monitoring Network Application Data (Orion APM) 

¶ Managing IP Addresses (Orion IPAM) 

¶ Managing IP Service Level Agreements (Orion IP SLA Manager) 

¶ Monitoring NetFlow Traffic Analysis Data (Orion NTA) 

¶ Orion Scalability Engines 

¶ Using an Orion Additional Web Server 

¶ Orion Failover and Disaster Recovery 

Monitoring Network Performance (Orion NPM) 

Orion Network Performance Monitor (Orion NPM) delivers comprehensive fault 
and network performance management that scales with rapid network growth 
and expands with your network monitoring needs, allowing you to collect and 
view availability and realtime and historical statistics directly from your web 
browser. While monitoring, collecting, and analyzing data from routers, switches, 
firewalls, servers, and any other SNMP-enabled devices, Orion NPM 
successfully offers you a simple-to-use, scalable network monitoring solution for 
IT professionals juggling any size network. Orion NPM does not require a team of 
consultants and months of unpleasant surprises to get Orion NPM up and 
running because Orion NPM far more intuitive than conventionally complex 
enterprise network management systems. In less than an hour, you can have 
cost-effective, realtime visibility into the health of the devices on your network, 
ensuring that can keep your systems running at peak performance. Out of the 
box, Orion NPM monitors the following critical performance metrics for devices 
on your network: 

¶ Network availability 

¶ Bandwidth capacity utilization 

¶ Buffer usage and errors 
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¶ CPU and memory utilization 

¶ Interface errors and discards 

¶ Network latency 

¶ Node, interface, and volume status 

¶ Volume usage 

These monitoring capabilities, along with a fully customizable web-based 
interface, alerting, reporting engines, and flexible expansion capabilities, make 
SolarWinds Orion Core the easiest choice you will make involving your network 
performance monitoring needs. 

For more information about monitoring network performance with SolarWinds 
Orion Network Performance Monitor, see the SolarWinds Orion Application 
Monitor Administrator Guide at www.solarwinds.com. 

Monitoring Network Application Data (Orion APM) 

The Orion Application Performance Monitor (Orion APM) module provides 
focused application monitoring for network engineers, but it is much more than m 
erely up/down status checks and process monitoring. By allowing you to create 
and monitor your own custom collection of monitored components, Orion APM 
provides an open field of opportunity to the network engineer. With Orion APM 
you can focus monitoring on your core services while easily ensuring application 
outages do not originate in the network. Orion APM provides the following 
features to help: 

¶ Network service monitoring 

¶ General TCP port monitoring 

¶ WMI and SNMP process monitoring 

¶ Service monitoring 

¶ User experience monitoring using HTTP or HTTPS content checking 

Built on the proven capabilities and solid architecture of Orion Network 
Performance Monitor, you know your current needs will be met and, as your 
needs grow, both the Orion platform and the Orion APM module will scale with 
you. 

For more information about monitoring network applications with SolarWinds 
Orion Application Performance Monitor, see the SolarWinds Orion Application 
Monitor Administrator Guide at www.solarwinds.com. 

http://www.solarwinds.com/support/apm/docs/APMAdministratorGuide.pdf
http://www.solarwinds.com/support/apm/docs/APMAdministratorGuide.pdf
http://www.solarwinds.com/
http://www.solarwinds.com/support/apm/docs/APMAdministratorGuide.pdf
http://www.solarwinds.com/support/apm/docs/APMAdministratorGuide.pdf
http://www.solarwinds.com/
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Managing IP Addresses (Orion IPAM) 

Orion IP Address Manager (Orion IPAM) is an Orion NPM module that leverages 
the intuitive point-and-click interface of the Orion Web Console to allow you to 
easily investigate IP address space issues. By periodically scanning the network 
for IP address changes, Orion IPAM maintains a dynamic list of IP addresses 
and allows engineers to plan for network growth, ensure IP space usage meets 
corporate standards, and reduce IP conflicts. Using Orion IPAM, network 
engineers can discover non-responsive IP addresses, coordinate team access to 
your IP space, and track network changes. 

Built on the enterprise Orion core, Orion IPAM allows network engineers to 
create, schedule, and share IP space reports from a single reporting engine. 
Finally, network engineers can monitor network devices for fault, performance, 
configuration, and now IP address health indicators. 

¶ Manage your entire IP infrastructure from an intuitive web console 

¶ Consolidate your IP addresses into a single repository 

¶ Keep better records by periodically scanning your network for IP address 
changes 

¶ Create, schedule and share reports on the IP address space percent 
utilization 

¶ Keep network devices up by identifying and eliminating IP address conflicts 

¶ Coordinate team access to your address space with role-based access 
control and track changes 

¶ Identify non-responsive IP addresses to optimize your IP space  

For more information about Orion IP Address Manager, see the SolarWinds 
Orion IP Address Manager Administrator Guide at www.solarwinds.com. 

Managing IP Service Level Agreements (Orion IP SLA 
Manager) 

SolarWinds Orion IP Service Level Agreement (IP SLA) Manager is an Orion 
NPM module offering an easy-to-use, scalable IP SLA network monitoring 
solution that integrates seamlessly into the Orion Web Console. 

Why Install Orion IP SLA Manager 

Internet Protocol Service Level Agreement (IP SLA) technology offers a 
cost-effective and efficient response to the needs of enterprises of all sizes. As a 
network manager, you face more than the simple question of whether your 
network is up or down. You need to know specific quality of service measures for 

http://www.solarwinds.com/support/IPAM/docs/OrionIPAMAdministratorGuide.pdf
http://www.solarwinds.com/support/IPAM/docs/OrionIPAMAdministratorGuide.pdf
http://www.solarwinds.com/
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your network, and you need to know them both historically and in realtime. Orion 
IP SLA Manager gives you the tools to quickly test your current network fitness 
and then determine and track quality of service on your network over time. 

Orion IP SLA Manager leverages the proven functionality of Orion NPM, adding a 
number of IP SLA-specific data collection and presentation tools that enable IP 
SLA network monitoring and realtime status reporting. Because it is a module of 
Orion NPM, Orion IP SLA Manager maintains the function of Orion NPM while 
allowing you to narrow your network management and monitoring focus to the IP 
SLA-capable devices of your wider network. 

What Orion IP SLA Manager Does 

Orion IP SLA Manager provides a full-featured solution that gives you the ability 
to monitor and report both realtime and historical performance statistics for your 
IP SLA-capable network. Orion IP SLA Manager offers the following features to 
help you manage your entire network. 

¶ Quality of Service (QoS) Monitoring with Cisco IP SLA Operations 

¶ Custom Charts and Gauges 

¶ Custom Alerts and Actions 

¶ Custom Reporting 

¶ Call Manager Monitoring 

For more information about Orion IP SLA Manager, see the SolarWinds Orion IP 
SLA Manager Administrator Guide at www.solarwinds.com. 

Monitoring NetFlow Traffic Analysis Data (Orion NTA) 

Orion NetFlow Traffic Analyzer (Orion NTA) is an Orion NPM module providing 
an easy-to-use, scalable network monitoring solution for IT professionals who are 
juggling any size Cisco NetFlow-enabled network. NetFlow-enabled Cisco 
routers and switches provide a wealth of IP-related traffic information. Orion NTA 
collects this NetFlow data, correlates the data into a useable format, and then 
provides this data, along with detailed network performance data collected by 
Orion NPM, as easily read graphs and reports on bandwidth use in and to your 
network. These reports help you monitor bandwidth, track conversations between 
internal and external endpoints, analyze traffic, and plan bandwidth capacity 
needs. 

Orion NTA also provides the same flow data analysis capabilities for devices 
using sFlow and J-flow packets.   

For more information about Orion NetFlow Traffic Analyzer, see the SolarWinds 
Orion NetFlow Traffic Analyzer Administrator Guide at www.solarwinds.com. 

http://www.solarwinds.com/support/IPSLA/docs/IPSLAManagerAdministratorGuide.pdf
http://www.solarwinds.com/support/IPSLA/docs/IPSLAManagerAdministratorGuide.pdf
http://www.solarwinds.com/
http://www.solarwinds.com/support/NetFlow/docs/NetFlowAdministratorGuide.pdf
http://www.solarwinds.com/support/NetFlow/docs/NetFlowAdministratorGuide.pdf
http://www.solarwinds.com/


SolarWinds Orion Core Ö Administrator Guide 
 

 
Orion Product Family Ö 251 

Orion Scalability Engines 

Orion Scalability Engines allow you to scale the monitoring and management 
capabilities of your primary Orion installation as your enterprise network expands 
and your network management needs change. SolarWinds offers the following 
scalability engine options: 

¶ Distribute polling across multiple servers with Additional Polling Engines. 
Both Orion APM and Orion NPM may be installed as primary Orion servers. 
For more information about installing an Additional Polling Engine for Orion 
APM or Orion NPM, see the SolarWinds Orion Application Performance 
Monitor Administrator Guide and the SolarWinds Orion Network Performance 
Monitor Administrator Guide, respectively.  

¶ Enable more users to access the Orion Web Console with Orion Additional 
Web Servers. For more information, see ñUsing an Orion Additional Web 
Serverò on page 251. 

¶ Protect against monitoring outages with the Orion Failover Engine and Hot 
Standby Server. For more information, see ñOrion Failover and Disaster 
Recoveryò on page 255. 

Using an Orion Additional Web Server 

The Orion Additional Website enables remote access to the Orion Web Console 
from a location other than your primary Orion server. With an Additional Website 
installed, remote users can view the primary Orion Web Console without 
deploying an entire Orion installation or excessively taxing the resources of your 
main Orion server. The following procedure installs the Orion Additional Website. 

To install an Orion Additional Web Server: 

1. If you downloaded the Orion Additional Website executable from the 
SolarWinds website, navigate to your download location, and then launch 
the executable. 

2. If you received the Orion Additional Website executable on physical 
media, browse to the executable file, and then launch it. 

Note: The executable extracts to a folder containing an HTML readme, an 
Installer Guide, and Additional Web Server installers for all Orion products 
that support Additional Web Servers. 

3. Launch the installer for the Orion products on your primary server. 

Note: If you have multiple Orion products installed on your main Orion 
server, to ensure full functionality, install the Additional Web Server for each 
product. 
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4. On the Welcome window of the Compatibility Check, provide the folowing 
information: 

¶ The Hostname or IP Address of your main Orion server. 

¶ The User name and Password of a user with administrative 
privileges to the Orion Web Console on your main Orion server. 

5. Click Next. 

6. If you are prompted to install requirements, click Install, and then 
complete the installation, including a reboot, if required. 

Notes: 

¶ Downloading and installing Microsoft .NET Framework 3.5 SP1 may take 
more than 20 minutes, depending on your existing system configuration. 

¶ If a reboot is required, after restart, you may need to launch the installer 
again. If the installer launches automatically, click Install to resume 
installation, and then click Next on the Welcome window. 

7. Review the Welcome text, and then click Next. 

8. Acccept the terms of the license agreement, and then click Next. 

9. If you want to install the Orion Additional Web Server to a folder other 
than the indicated default, click Browse, and then provide a different 
destination folder on the Choose Destination Location window. 

10. Click Next on the Choose Destination Location window. 

11. Confirm the settings on the Start Copying Files window, and then click Next. 

12. Click Finish when the Orion Network Performance Monitor Setup Wizard 
completes. 

13. If you are evaluating Orion, click Continue Evaluation. 

14. If you are installing a production version of an Orion Additional Web 
Server, click Enter Licensing Information, and then complete the following 
procedure to license your Orion installation: 

a. If you have both an activation key and access to the internet, select 
the first option, I have internet access and an activation keyé, enter 
your Activation Key, and then click Next. 

Note: If you are using a proxy server to access the internet, check I 
access the internet through a proxy server, and then provide the 
Proxy address and Port. 

b. If you do not have access to the internet from your designated 
Orion server, select This server does not have internet accessé, 
click Next, and then complete the steps provided. 
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15. If the Configuration Wizard does not start automatically, click Start > All 
Programs > SolarWinds Orion > Configuration and Auto-Discovery > 
Configuration Wizard. 

16. Click Next on the Welcome tab of the Configuration Wizard. 

17. Select or type the SQL Server used by your primary Orion server. 

18. If you are using Windows NT Integrated Security, select Use Windows 
Authentication, and then click Next. 

19. If you are using a SQL Server login and password, complete the following 
steps: 

a. Select Use SQL Server Authentication. 

b. Provide your Login and Password. 

c. Click Next. 

20. Select or type the Database Name that is connected to your Orion server, 
and then click Next. 

21. If a dialog appears that says that multiple polling engines have been 
detected, click OK to continue database upgrade/verification. 

22. When the database structure validation completes, click Next. 

23. Specify a SQL account User Name and Password for the polling engine and 
web site to use to access the database, and then click Continue. 

Note: If you already have a SQL account, you can specify the credentials for 
that account. 

24. To set up the web console, click Next on the Create Website tab, and then 
complete the following procedure: 

a. Specify the IP Address of the local server on which you are installing the 
new web-only interface. 

b. Specify the TCP Port through which you want to access the web 
console. 

Note: If you specify any port other than 80, you must specify that port in 

the URL that is used to access the web console. For example, if you 

specify an IP address of 192.168.0.3  and port 8080 , your URL is 

http://192.168.0.3:8080 . 

c. Specify the volume and folder in which you want to install the web 
console files, and then click Continue. 

25. If you are asked to overwrite an existing website, click Yes. 

26. When the new web console has been created, click Continue. 
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27. Click Start > All Programs > SolarWinds Orion > Orion Web Console. 

28. Enter the local IP address in the Address bar. 

29. If you already have an Admin account and password, enter them in the 
respective fields, and then click Login. 

Note: You can log in without a password using Admin  as the Account ID. 

30. Confirm that the new additional web server displays the same view for the 
same account, as used both locally and on your primary Orion server. 

31. If you intend to install either Orion NetFlow Traffic Analyzer or Orion 
Application Performance Monitor on this Orion additional web server, 
complete the following steps to install the required additional web console 
components. 

a. Using your SolarWinds Customer ID and Password, log in to the 

Customer Portal at http://www.solarwinds.com/customerportal/ . 

b. Click Additional Components in the Customer Portal menu on the left. 

c. Click Download Orion NPM Components. 

32. If you intend to use Orion Application Performance Monitor with this 
Orion additional web server, complete the following steps. 

a. Click Application Performance Monitor Additional Web Consoleðv2 
in the Additional Components ï Orion v8 and v9 section, and then click 
Save. 

b. Browse to an appropriate location, and then click Save. 

c. When the download completes, click Open. 

d. Launch the executable, and then complete the configuration wizard. 

33. If you intend to use Orion NetFlow Traffic Analyzer with this Orion 
additional web server, complete the following steps. 

a. Click Application NetFlow Traffic Analyzer Additional Web 
Consoleðv3 in the Additional Components ï Orion v8 and v9 section, 
and then click Save. 

b. Browse to an appropriate location, and then click Save. 

c. When the download completes, click Open. 

d. Launch the executable, and then complete the configuration wizard. 

http://www.solarwinds.com/customerportal/
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Orion Failover and Disaster Recovery 

Depending on the version of Orion you currently have installed, SolarWinds 
provides either of two failover and disaster recovery solutions: Hot Standby 
Server and Orion Failover Engine. Hot Standby Server provides limited failover 
protection for Orion installations older than version 10.0. For Orion version 10.0 
and higher, SolarWinds offers the Orion Failover Engine, which can  protect your 
primary Orion installation and any installed modules. 

For more information about the Orion Failover Engine, see the SolarWinds Orion 
Failover Engine Administrator Guide and related documentation provided at 
http://www.solarwinds.com/support/failoverengine/FailoverEngineDoc.aspx. 

Using a Hot Standby Engine 

For versions prior to Orion NPM 10.0, the Orion Hot Standby Engine is available 
as an additional product to provide seamless backup service for Orion polling 
engines. 

Note: For installations of Orion NPM version 10.0, the Orion Failover Engine is 
recommended. To provide failover and disaster recovery protection for Orion 
NPM versions 10.1 and higher, the Orion Failover Engine is required. For more 
information about the Orion Failover Engine, see the SolarWinds Orion Failover 
Engine Administrator Guide and related documentation provided at 
http://www.solarwinds.com/support/failoverengine/FailoverEngineDoc.aspx. 

In the event of an Orion server failure, the designated hot standby system 
immediately assumes monitoring, data collection, and basic alerting 
responsibilities for that server. If the Orion server becomes operational again, the 
Hot Standby Engine returns monitoring control to the Orion server.  

Warning: Orion Hot Standby Engines do not currently provide all the same data 
to custom pollers and Universal Device Pollers that may have been collected 
previously from the failed Orion server. Likewise, Orion Hot Standby Engines are 
not currently capable of collecting data and computing network performance 
statistics for EnergyWise, VMware ESX, or wireless devices.  

The following graphic shows how an Orion Hot Standby Engine assumes the 
polling duties of any one failed Orion server. 

http://www.solarwinds.com/support/failoverengine/FailoverEngineDoc.aspx
http://www.solarwinds.com/support/failoverengine/FailoverEngineDoc.aspx
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Note: A single Hot Standby Engine can serve as failover protection for multiple 
Orion servers and polling engines simultaneously, but a single Hot Standby 
Engine can only assume the monitoring functions of a single failed Orion server 
at any given  time. 

Installing a Hot Standby Engine 

Orion Hot Standby Engine installation is nearly identical to the installation of a 
standard Orion server, as shown in the following procedure. 

Notes: 

¶ To ensure optimal performance, your Orion Hot Standby Engine should not 
be any older than the latest version of any of the Orion servers the Hot 
Standby Engine is supporting. 

¶ For the same version, hardware and software requirements for both the 
Orion server and Orion Hot Standby Server are equivalent. For more 
information, see ñOrion Requirementsò on page 9. 

To install a Hot Standby Engine: 

1. Install and configure an Orion server on your network. For more information 
about installing and configuraing Orion, see ñPreparing a SolarWinds Orion 
Installationò on page 9. 

2. Log on to the server you want to use as the Hot Standby server. 

Note: The Hot Standby Engine must be installed on a server other than the 
primary Orion NPM server. 

3. Download or copy the Hot Standby Engine installer to an appropriate location 
on the server you want to use as the Hot Standby Server. 
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4. If you downloaded the Hot Standby Engine from the SolarWinds 
website, navigate to the download executable file, and then launch it. 

5. If you received Hot Standby Engine on physical media, browse to the 
executable file, and then launch the executable. 

6. If you are prompted to install any required components such as 
Microsoft .NET Framework 3.5, click Install, and then complete installation 
of the required additional components. 

7. Review the Welcome text, and then click Next. 

8. Agree to the license agreement, and then click Next. 

9. Provide an installation destination folder on the Choose Destination Location 
window, and then click Next. 

10. Click Next on the Start Copying Files window. 

11. Click Enter Licensing Information. 

Note: You need your customer ID and password to successfully install the 
key.  For more information, see ñSoftware License Keyò on page 263. 

12. Click Continue when the license is successfully installed, and then click 
Finish on the Installation Complete window. 

13. Click Next on the Welcome window of the Configuration Wizard. 

14. Select or type the address of your SQL Server. 

15. If you are using Windows NT Integrated Security, select the available 
option, and then click Continue. 

16. If you are using a SQL Server UserID and password, select the available 
option, type a username and password, and then click Continue. 

17. Select Use an existing database. 

18. Provide the name of the Existing Database that your primary Orion NPM 
server is currently using, and then click Next. 

Note: The Hot Standby Engine is designed to take the place of a failed 
server, so both the Orion NPM polling engine and standby polling engines 
must point to the same database in order to maintain network monitoring. 

19. Select Use an existing account. 

20. Provide an Existing Account and Password for the polling engine and web 
site to use to access the database, and then click Next. 
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21. If you need to specify a particular IP Address for your Orion NPM 
installation, provide the IP address of the web server that you want to use 
for the web console. 

Note: SolarWinds recommends that you retain the default IP address setting 
of All Unassigned, unless your environment requires the designation of a 
specific IP address for your Orion Web Console. 

22. Specify both the port through which you want to access the web console and 
the volume and folder in which you want to install the web console files.  

Note: If you specify any port other than 80, you must include that port in the 

URL used to access the web console. For example, if you specify an IP 

address of 192.168.0.3  and port 8080 , the URL used to access the web 

console is http://192.168.0.3:8080 . 

23. Click Next. 

24. If you are prompted to create a new directory, click Yes. 

25. Check the services to install on the Hot Standby server, and then click Next. 

Note: Selecting all available services will ensure that all network monitoring 
functions are maintained if and when the server fails. 

26. Click Next to start configuration. 

27. When SolarWinds services have been installed, click Finish. 

28. If you are prompted to send a request to start the Hot Standby polling 
service, click Yes. 

Note: The configuration wizard stopped all polling engines when you 
configured the Hot Standby server. 

29. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Monitor Polling Engines. 

30. Confirm that both your primary Orion server and the Hot Standby server are 
listed as Responding in the Monitor Polling Engines window. 

Note: Click an Orion NPM server to view server information in the lower half 
of the Monitor Polling Engines window. 

Configuring a Hot Standby Engine 

The Hot Standby server that you have installed and assigned has the ability to 
both alert you when it assumes the Orion server role and continue to alert you as 
long as the original server is stopped. However, the transition from the stopped 
Orion server to the Hot Standby Engine is not necessarily immediate, as the 
delay between primary failure and hot standby assumption is variable. 
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The following steps configure the Hot Standby Engine alerts and delays. 

To configure a Hot Standby Engine: 

1. Click Start > All Programs > SolarWinds Orion > Advanced Features > 
Monitor Polling Engines. 

2. Click your Hot-Standby server from the list in the top pane of the Monitor 
Polling Engines window. 

Note: The lower pane provides current information about the selected server. 

3. Click Configure Hot-Standby. 

Note: The default view of the Hot-Standby tab in the Configure Hot-Standby 
Server window provides a list of the servers for which the currently selected 
server is a hot standby. 

4. Check the Orion server for which you are installing the Hot Standby Engine. 

5. If you want to enable an alert action for when the hot standby server is 
employed, click Fail-Over Notifications, and then click Add New Action. 

Note: For more information, see ñAdding Alert Actionsò on page 135. 

6. Click Fail-Over Timing, and then position the top slider to set the delay 
between the stopping of the Orion server and the starting of your Hot-
Standby server. 

7. If you set an alert action that you want to alert continuously, as long as 
the Hot-Standby server is enabled, check Continuously send Fail-Over 
notificationsé, and then position the bottom slider to set the delay between 
the stopping of the Orion server and the starting of your Hot-Standby server. 

8. Once you have completed configuring your Hot Standby Engine, click OK. 

Testing a Hot Standby Engine 

After you have installed, assigned, and configured your Hot Standby Engine, test 
that it works properly with the following steps. 

Warning: Testing a Hot Standby Engine requires you to power off an Orion 
server on your network. SolarWinds recommends you conduct any testing in off-
peak usage periods to minimize potential uptime interruption. 

To test a Hot Standby Engine: 

1. Confirm that the SQL database you are maintaining with Orion is not on the 
same physical server as your primary Orion server. 

2. On your Hot Standby Server, click Start > All Programs > SolarWinds 
Orion > Advanced Features > Monitor Polling Engines. 
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3. On your Hot Standby Server, Click Start > All Programs > SolarWinds 
Orion > Orion Web Console. 

4. Turn off your primary Orion server. 

5. Confirm that the Hot Standby server has assumed Orion server duties by 
reviewing results from the Monitor Polling Engines window and the Orion 
Web Console. The lower pane of the Monitor Polling Engines window 
provides a number of helpful entries for determining engine state, including: 
Server Type, Hot-Standby Foré, and Last Fail-Over. 
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Appendix A 

Software License Key 

During installation, you may be prompted to provide licensing information. The 
following procedure provides the steps required to activate your SolarWinds 
Orion license. 

To activate your SolarWinds Orion license: 

1. If you are completing a new installation or upgrade, click Enter 
Licensing Information after completing the Orion Network Performance 
Monitor Setup Wizard. 

2. If the computer on which you installed Orion NPM is connected to the 
Internet, complete the following procedure:  

a. Select I have internet access... 

b. Browse to http://support.solarwinds.com, and then log in using your 
CustomerID and password. 

c. Click License Management. 

d. Browse to Orion Network Performance Monitor, and then locate the 
Unregistered Licenses list. 

e. Copy your unregistered Orion NPM activation key to the clipboard, and 
then paste it into the Activation Key field on the Activate NPM window.  

3. If you are using a proxy server to access the Internet, check I access the 
internet through a proxy server, and then type the proxy address and port 
number.  

4. Click Next.  

5. If the computer on which you are installing Orion NPM is not connected 
to the Internet, complete the following procedure:  

a. Select This server does not have internet access. 

b. Click Next.  

c. On the Activate Product window to finalize your registration, click Copy 
Unique Machine ID. 

d. Paste the copied data into a new document in a text editor, and then 
save the text document. 

e. Transfer the document to a computer with internet access. For example, 
transfer the document to a shared location. 

http://support.solarwinds.com/
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f. Browse to http://support.solarwinds.com from the computer with internet 
access, and then log in using your CustomerID and password. 

g. Click License Management. 

h. Browse to Orion Network Performance Monitor, and then click Manually 
Register License. 

i. Provide the Unique Machine ID you transferred in Step 3, above, and 
then download your license key. 

j. Transfer the license key to a shared location, and then browse to the 
shared License Key File location from the Activate Product window. 

6. Provide your First Name, Last Name, Email address, and Phone Number 
to register your Orion product, and then click Next. 

7. Click Finish when your license is activated. 

8. Review and record the information provided on the License Status window, 
and then click Close. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://support.solarwinds.com/
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Appendix B 

Status Icons and Identifiers 

Orion products use a number of different icons as status indicators. In the case of 
alerts and events, further information is provided with the icon in the resource. 

Status Indicators 

The following table lists Orion icons with associated status indications, status 
types, and numerical status identifiers, proceeding from the worst. 

Notes: 

¶ Status levels of type Ignore are not displayed in any status rollup mode. 

¶ Some listed status indications only apply to specific Orion products. For 
these states and associated monitored objects, the  relevant Orion products 
are indicated in parentheses.  

Icon Status Indication Type ID 

 
Node or Interface (Orion NPM) is Down (Polling request 
timed-out) 

Error 2 

 Shutdown Error 4 

 Lower Layer Down Error 8 

 Unreachable Error 12 

 

 

Node is in a Warning state as a result of dropped packets 
or a down interface (Orion NPM) 

Warning 3 

 Critical Warning 14 

 Mixed Availability Warning 15 

 Misconfigured Warning 16 

 Could Not Poll Warning 17 

 Unconfirmed Warning 19 

 
Polling Engine Shutdown, Monitoring Stopped, System 
Error, or Fail Over 

Warning -- 

 

System Warning; Node, Interface (Orion NPM), or Volume 
Changed; Interface Reappeared (Orion NPM); Network 
Baseline Started/Completed 

Warning -- 

 Node or Interface (Orion NPM) is Up OK 1 

 Dormant OK 6 
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Icon Status Indication Type ID 

 Active OK 22 

 Inactive OK 24 

 Expired OK 25 

 Unknown Ignore 0 

 Node or Interface (Orion NPM) is Unmanaged Ignore 9 

 Interface is Unplugged but not Down (Orion NPM) Ignore 10 

 

Node is defined as External 
(Node is not monitored by Orion NPM, but an application 
on the node may be monitored by Orion APM.) 

Ignore 11 

 Monitoring Disabled Ignore 26 

 Disabled Ignore 27 

 Not Licensed Ignore 28 

 
Informational 
Volume Reappeared 

N/A -- 

 Monitoring Started, Service Started, or Fail Back N/A -- 

 
Node, Interface (Orion NPM), or Volume Removed 
Interface Shutdown (Orion NPM) 

N/A -- 

 
Node Added 
Interface or Volume Added (Orion NPM System Manager) 

N/A -- 

 Interface (Orion NPM) or Volume Added (Web Console) N/A -- 

 Node Rebooted N/A -- 

 Interface Enabled (Orion NPM) N/A -- 

 Interface Remapped (Orion NPM) N/A -- 

 Volume Remapped N/A -- 

 Interface (Orion NPM) or Volume Disappeared N/A -- 



SolarWinds Orion Core Ö Administrator Guide 
 

 
Status Icons and Identifiers Ö 267 

Status Rollup Mode 

In the Orion Web Console, the Status Rollup Mode designates how the 
availability status of a collection of nodes on the node tree or on a map is 
displayed in the web console. Three options are available for the case when 
there are nodes or applications with different status levels in the selected group: 

¶ Show Best Status is most useful for displaying groups that are defined as 
collections of redundant or backup devices. The following table indicates how 
the Show Best Status option operates: 

Note: Compare Group Status results under the Show Best Status option with 
results for the same groups of objects under the Show Worst Status option. 

Object States Group Status 

 (Up, Warning, Down)  (Up) 

 (Warning, Up)  (Up) 

 (Warning, Down, Unknown)  (Warning) 

 

¶ Show Worst Status ensures that the worst status in a group of objects is 
displayed for the whole group. The following table indicates how the Show 
Worst Status option operates: 

Object States Group Status 

 (Up, Warning, Down)  (Down) 

 (Warning, Up)  (Warning) 

 (Warning, Down, Unknown)  (Down) 

 

¶ Mixed Status shows Warning ensures that the status of a group displays 
the worst warning-type state in the group. If there are no warning-type states, 
but the group contains a mix of up and down states, then a Mixed Availability 

( ) warning status is displayed for the whole group. The following table 
indicates how the Mixed Status shows Warning option operates: 

Object States Group Status 

  (Critical) 

  (Critical) 

  (Mixed Availability) 
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Appendix C 

Orion Variables and Examples 

Orion product components, including the Advanced Alert Manager, both the 
Traps Viewer and the Syslog Viewer, and Network Atlas can employ Orion 
variables. These variables are dynamic and, in the case of alerts, parse when the 

alert is triggered or reset. For example, the variable ${ ResponseTime }  will parse 

with the current response time of the node that is triggering the alert. 

Note: In some cases, the database table name may be required for alert 

variables, as in ${ Nodes. CPULoad} . If a variable does not respond as intended, 

include the relevant table name for the desired variable. 

Variable Modifiers 

The variables in the following sections can be modified by appending any of the 
variable modifiers in the following table. 

Variable Modifier Description 

-Raw 
Displays the raw value for the statistic. For example, if Transmit 
Bandwidth is set to 10 Mbps, then the raw value would beñ10000000ò. 
The cooked value would be ñ10 Mbpsò. 

-Previous 
Displays the previous value for the statistic before the Alert was 
triggered 

-Cooked 
Displays the cooked value for the statistic. For example, if Transmit 
Bandwidth is set to 10 Mbps, then the raw value would be ñ10000000ò 
and cooked value would be ñ10 Mbpsò. 

-PreviousCooked 
Displays the previous cooked value for the statistic before the Alert 
was triggered 

Advanced Alert Engine Variables 

The following variables can be used in alert messages within Orion and Orion 
Modules. You must begin each variable with a dollar sign and enclose each 
variable identifier in braces as, for example, ${ObjectName} . 

General 

The following are valid, general advanced alert variables. 

General Variable Description 

${Acknowledged} Acknowledged status 

${AcknowledgedBy} Who the alert was acknowledged by 

${AcknowledgedTime} Time the alert was acknowledged 
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General Variable Description 

${AlertTriggerCount} Count of triggers 

${AlertTriggerTime} 
Date and time of the last event for this Alert. (Windows control 
panel defined ñShort Dateò and ñShort Timeò) 

${Application} SolarWinds application information 

${CR} Line Feed ï Carriage Return 

${Copyright} Copyright information 

${ObjectName} Description/Name of the object in the alert 

${Release} Release information 

${Version} Version of the SolarWinds software package 

Date/Time 

The following are valid date and time variables. 

Date/Time Variable Description 

${AMPM} AM/PM indicator 

${AbreviatedDOW} Current day of the week. Three character abbreviation. 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (Short Date format) 

${DateTime} 
Current date and time. (Windows control panel defined ñLong 
Dateò and ñLong Timeò format) 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Last2Hours} Last two hours 

${Last24Hours} Last 24 hours 

${Last7Days} Last seven days (Short Date format) 

${LastHour} Last hour 

${LocalDOW} Current day of the week. Localized language format. 

${LocalMonthName} Current month name in the local language. 

${LongDate} Current date. (Long Date format) 

${M} Current numeric month 

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MMMM} Full name of the current month 

${MediumDate} Current date. (Medium Date format) 

${Minute} Current minute. Two digit format, zero padded. 

${S} Current second. 
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Date/Time Variable Description 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (Short Time format) 

${Today} Today (Short Date format) 

${Year} Four digit year 

${Year2} Two digit year 

${Yesterday} Yesterday (Short Date format) 

Group Variables 

The following are valid group variables. 

Group Variable Description 

${GroupDetailsURL} URL of the Group Details view for a selected group 

${GroupFrequency} 
Interval on which group membership is evaluated 
and group snapshots are taken. 

${GroupID} Designated identifier for a defined group 

${GroupMemberDisplayName} 
Display name of group member type:  Node, 
Volume, Component, Application, etc. 

${GroupMemberDisplayNamePlural} 
Display name of multiple group members of a type: 
Nodes, Components, Applications, etc. 

${GroupMemberFullName} Full name of a group member, including location 

${GroupMemberName} Name of a group member 

${GroupMemberPercentAvailability} 
Percent availability of a group member when group 
member status is Up, Warning, or Critical and 0% if 
status is anything else. 

${GroupMemberSnapshotID} Unique identifier of group member snapshot. 

${GroupMemberStatusID} 
Identifier assigned to a group member indicating its 
status. For more information see ñStatus Variablesò 
on page 272. 

${GroupMemberStatusName} 
Name of group member status. For more 
information see ñStatus Variablesò on page 272. 

${GroupMemberUri} 
Uri used by SolarWinds Information Service (SWIS) 
to refer to the selected group member within the 
web console. 

${GroupName} Name of the group. 

${GroupOwner} Orion product appropriate to the group type 

${GroupPercentAvailability} 
100% when group status is Up, Warning, Critical 
and 0% if status is anything else. 

${GroupStatusCalculatorID} 

Name of roll-up logic calculator that evaluates status 

of group based on member statuses. (0 = Mixed, 1 

= Worst, 2 = Best) 

${GroupStatusCalculatorName} 

Name of roll-up logic calculator that evaluates status 

of group based on member statuses. (Mixed , 

Worst , Best ) 
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Group Variable Description 

${GroupStatusID} 
Identifier assigned to a group indicating its status. 
For more information see ñStatus Variablesò on 
page 272. 

${GroupStatusName} 
Name of group status. For more information see 
ñStatus Variablesò on page 272. 

${GroupStatusRootCause} A list of all group members that are not Up 

${NodeID} NULL every time - just for legacy support. 

SQL Query 

Any value you can collect from the database can be generated, formatted, or 
calculated using a SQL query as a variable. To use a SQL query as a variable in 

Orion, use ${SQL:{query}}  as shown in the following example that returns the 

results of the SQL query Select Count(*) From Nodes : 

${SQL:Select Count(*) From Nodes}  

Status Variables 

When using the ${Status}  variable with a monitored object, status values are 

returned, as appropriate. The following table provides a description for each 
status value. 

Status Value Description 

0 Unknown 

1 Up 

2 Down 

3 Warning 

4 Shutdown 

5 Testing 

6 Dormant 

7 Not Present 

8 Lower Layer Down 

9 Unmanaged 

10 Unplugged 

11 External 

12 Unreachable 

14 Critical 

15 Mixed Availability 

16 Misconfigured 

17 Could Not Poll 

19 Unconfirmed 
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Status Value Description 

22 Active 

24 Inactive 

25 Expired 

26 Monitoring Disabled 

27 Disabled 

28 Not Licensed 

Node Variables 

The following are valid node variables. 

Node Variable Description 

${AgentPort} Node SNMP port number 

${Allow64BitCounters} Node allows 64-bit counters (1), or not (0) 

${AvgResponseTime} 
Average node response time , in msec, to 
ICMP requests 

${BlockUntil} 
Day, date, and time until which node polling is 
blocked 

${BufferBgMissThisHour} 
Device-dependent count of big buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.30 

${BufferBgMissToday} 
Device-dependent count of big buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.30 

${BufferHgMissThisHour} 
Device-dependent count of huge buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.62 

${BufferHgMissToday} 
Device-dependent count of huge buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.62 

${BufferLgMissThisHour} 
Device-dependent count of large buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.38 

${BufferLgMissToday} 
Device-dependent count of large buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.38 

${BufferMdMissThisHour} 
Device-dependent count of medium buffer 
misses on node in current hour, queried with 
MIB 1.3.6.1.4.9.2.1.22 

${BufferMdMissToday} 
Device-dependent count of medium buffer 
misses on node in current day, queried with 
MIB 1.3.6.1.4.9.2.1.22 

${BufferNoMemThisHour} 
Count of buffer errors due to low memory on 
node in current hour 

${BufferNoMemToday} 
Count of buffer errors due to low memory on 
node in current day 
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Node Variable Description 

${BufferSmMissThisHour} 
Device-dependent count of small buffer misses 
on node in current hour, queried with MIB 
1.3.6.1.4.9.2.1.14 

${BufferSmMissToday} 
Device-dependent count of small buffer misses 
on node in current day, queried with MIB 
1.3.6.1.4.9.2.1.14 

${Caption} User friendly node name 

${Community} Node community string 

${Contact} 
Contact information for person or group 
responsible for node 

${CPULoad} Node CPU utilization rate at last poll 

${CustomPollerLastStatisticsPoll} Day, date, and time of last poll attempt on node 

${CustomPollerLastStatisticsPollSuccess} 
Day, date, and time that node was last 
successfully polled 

${Description} Node hardware and software 

${DNS} Fully qualified node name 

${DynamicIP} 
If node supports dynamic IP address 
assignment via BOOTP or DHCP (1); static IP 
address return (0) 

${EngineID} 
Internal unique identifier of the polling engine 
to which node is assigned 

${GroupStatus} 
Filename of status icon for node and, in Orion 
NPM, its interfaces 

${IOSImage} Family name of Cisco IOS on node  

${IOSVersion} Cisco IOS version on node 

${IP_Address} Node IP address 

${LastBoot} Day, date and time of last node boot 

${LastSync} 
Time and date of last node database and 
memory synchronization 

${Location} Physical location of node 

${MachineType} 
Node manufacturer or distributor and family or 
version information 

${MaxResponseTime} 
Maximum node response time , in msec, to 
ICMP requests 

${MemoryUsed} Total node memory used over polling interval 

${MinResponseTime} 
Minimum node response time , in msec, to 
ICMP requests 

${NextPoll} 
Day, date and time of next scheduled node 
polling 

${NextRediscovery} Time of next node rediscovery 

${NodeID } Internal unique identifier of node 

${ObjectSubType} States if node supports SNMP or is ICMP-only 

${PercentLoss} 
ICMP packet loss percentage when node last 
polled 
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Node Variable Description 

${PercentMemoryUsed} 
Percentage of total node memory used over 
polling interval 

${PollInterval} Node polling interval, in seconds 

${RediscoveryInterval} Node rediscovery interval, in minutes 

${ResponseTime} 
Node response time, in milliseconds, to last 
ICMP request 

${RWCommunity} 
Node read/write community string; acts as 
security code for read/write SNMP access 

${RWSNMPV3AuthKey} 
SNMPv3 read/write credential authentication 
key 

${RWSNMPV3AuthKeyIsPwd} 
States if the SNMPv3 read/write credential 
authentication key is the password 

${RWSNMPV3AuthMethod} 
SNMPv3 read/write credential authentication 
method 

${RWSNMPV3Context} 
SNMPv3 read/write security context 
information 

${RWSNMPV3PrivKey} SNMPv3 read/write credential key 

${RWSNMPV3PrivKeyIsPwd} 
States if the SNMPv3 read/write credential 
privacy key is the password 

${RWSNMPV3PrivMethod} 
SNMPv3 read/write credential privacy 
encryption method 

${RWSNMPV3Username} 
User friendly name for SNMPv3 read/write 
credential 

${Severity} 

A network health score determined additively 
by scoring the status of monitored objects. For 
example, in Orion NPM 1 point is provided for 
an interface in a warning state, 1000 points for 
a down interface, and 1 million points for a 
down node. 

${SNMPV2Only} 
States if node only supports SNMPv1 or 
SNMPv2 

${SNMPV3AuthKey} SNMPv3 authentication key 

${SNMPV3AuthKeyIsPwd} 
States if node SNMPv3 authentication key is 
password 

${SNMPV3AuthMethod} SNMPv3 authentication type 

${SNMPV3Context} 
Group or domain of user with SNMPv3 access 
to node 

${SNMPV3PrivKey} SNMPv3 credential key 

${SNMPV3PrivKeyIsPwd} 
States if node SNMPv3 credential key is the 
password 

${SNMPV3PrivMethod} SNMPv3 credential key type 

${SNMPV3Username} User friendly name for SNMPv3 credential 

${SNMPVersion} States the version of SNMP used by the node 

${StatCollection} Statistics collection frequency, in minutes 
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Node Variable Description 

${Status} 
Numerical node status. For more information, 
see ñNode Status Variablesò on page 272. 

${StatusDescription} User friendly node status 

${StatusLED} Filename of node status icon 

${SysName} String reply to SNMP SYS_NAME OID request 

${SysObjectID} 
Vendor ID of the network management 
subsystem in OID form. Clearly determines the 
type of node. 

${SystemUpTime} 
Time, in hundredths of a second, since network 
monitoring started 

${TotalMemory} Total node memory available 

${UnManaged} States if node is currently unmanaged 

${UnManageFrom} 
Day, date, and time when node is set to 
ñUnmanagedò 

${UnManageUntil} 
Day, date, and time when node is scheduled to 
be managed 

${Vendor} Node manufacturer or distributor 

${VendorIcon} Filename of node vendor logo 

Volume Variables 

The following are valid volume variables. 

Volume Variable Description 

${Caption} User friendly volume name 

${FullName} 
User friendly volume name including captions of 
parent node and, in Orion NPM, interface  

${LastSync} 
Time and date volume last synchronized in database 
and memory models 

${NextPoll} Day, date and time of next scheduled volume polling 

${NextRediscovery} Scheduled time of next volume rediscovery 

${NodeID} Internal unique identifier of parent node 

${PollInterval} Volume status polling interval, in seconds 

${RediscoveryInterval} Volume rediscovery interval, in minutes 

${StatCollection} Statistics collection frequency, in minutes 

${Status} 
Numerical volume status: (0=òUnknownò, 1=òUpò, 
2=òShutdownò, 3=òTestingò) 

${StatusLED} Filename of volume status icon 

${VolumeAllocationFailuresThisHour} 
Number of volume allocation errors for this volume 
in last hour 

${VolumeAllocationFailuresToday} 
Number of volume allocation errors for this volume 
in current day 

${VolumeDescription} User friendly volume description 
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Volume Variable Description 

${VolumeID} Internal unique identifier of volume 

${VolumeIndex} Unique index of this volume within the parent node 

${VolumePercentUsed} Percentage of volume currently in use 

${VolumeResponding} 
(Y) = volume is currently responding to SNMP 
queries 

${VolumeSize} Size of volume, in bytes 

${VolumeSpaceAvailable} Total space available on volume, in bytes 

${VolumeSpaceUsed} Total space used on volume, in bytes 

${VolumeType} 
Volume type, as reported by hrStorageType OID 
(Removable Disk/Fixed Disk/Compact Disc/Virtual 
Memory/RAM/etc) 

${VolumeTypeIcon} Filename of icon for volume type 

Example Messages Using Variables 

The following examples illustrate some of the uses of variables. 

¶ Previous reboot was at ${LastBoot - Previous}.  

¶ Alert: ${NodeName} has exceptionally high response time. 

Average Response Time is ${AvgResponseTime} and is varying fr om 

${MinResponseTime} to ${MaxResponseTime}.  

¶ Current packet loss for ${NodeName} is ${%Loss}. Average 

Response time is ${AvgResponseTime} and is varying from 

${MinResponseTime} to ${MaxResponseTime}.  

¶ Alert: The SNMP Community string used to query ${NodeNam e} has 

been changed from ${Community - Previous} to ${Community}.  

¶ Orion  use s the new Community String to  query ${NodeName}.  

Syslog Alert Variables 

The following variables can be used in Syslog alert messages within Orion Core 
applications. You must begin each variable with a dollar sign and enclose each 

variable identifier in curly braces as, for example, ${ObjectName} . 

Syslog Date/Time Variables 

Syslog Date/Time 
Variable 

Description 

${AbreviatedDOW} Current day of the week. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 
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Syslog Date/Time 
Variable 

Description 

${Date} Current date. (Short Date format) 

${DateTime} 
Current date and time. (Windows control panel defined ñShort 
Dateò and ñShort Timeò format) 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Hour} Current hour. 24-hour format 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (Long Date format) 

${LocalMonthName} Current month name in the local language. 

${LongTime} Current Time. (Long Time format) 

${M} Current numeric month 

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MediumDate} Current date. (Medium Date format) 

${Minute} Current minute. Two digit format, zero padded. 

${Month} Full name of the current month 

${N} Current month and day 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (Short Time format) 

${Year2} Two digit year 

${Year} Four digit year 

Other Syslog Variables 

Syslog Variable Description 

${Application} SolarWinds application information 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${IP_Address} IP address of device triggering alert 

${Message} Status of device triggering alert 

${MessageType} Assigned alert name 

${Release} Release information 

${Severity} 
A network health score providing 1 point for an 
interface in a warning state, 1000 points for a down 
interface, and 1 million points for a down node. 

${Version} Version of the SolarWinds software package 
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Trap Alert Variables 

The following variables can be used in trap alert messages within Orion products.  

General Trap Variables 

Trap Variable Description 

${Application} SolarWinds application information 

${Community} Node community string 

${Copyright} Copyright information 

${DNS} Fully qualified node name 

${Hostname} Host name of the device triggering the trap 

${IP} IP address of device triggering alert 

${IP_Address} IP address of device triggering alert 

${Message} 
Message sent with triggered trap and displayed in Trap Details field 
of Trap Viewer 

${MessageType} Name or type of trap triggered 

${Raw} 
Raw numerical values for properties sent in the corresponding 
incoming trap 

${RawValue} 
Raw numerical values for properties sent in the corresponding 
incoming trap. The same as ${Raw} 

Trap Date/Time Variables 

Trap Date/Time 
Variable 

Description 

${AbbreviatedDOW} Current day of the week. Three character abbreviation. 

${AbbreviatedMonth} Current month of the year. Three character abbreviation. 

${AMPM} AM or PM corresponding to current time (before or after noon) 

${D} Current day of the month 

${DD} Current day of the month (two digit number, zero padded) 

${Date} Current date. (MM/DD/YYYY format) 

${DateTime} Current date and time. (MM/DD/YYYY HH:MM format) 

${Day} Current day of the month 

${DayOfWeek} Current day of the week. 

${DayOfYear} Numeric day of the year 

${H} Current hour 

${HH} Current hour. Two digit format, zero padded. 

${Hour} Current hour. 24-hour format 

${LocalDOW} Current day of the week. Localized language format. 

${LongDate} Current date. (DAY NAME, MONTH DAY, YEAR format) 

${LongTime} Current Time. (HH:MM:SS AM/PM format) 

${M} Current numeric month  
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Trap Date/Time 
Variable 

Description 

${MM} Current month. Two digit number, zero padded. 

${MMM} Current month. Three character abbreviation. 

${MMMM} Full name of the current month 

${MediumDate} Current date. (DD-MMM-YY format) 

${MediumTime} Current time. (HH:MM AM/PM format) 

${Minute} Current minute. Two digit format, zero padded. 

${MonthName} Full name of the current month 

${S} Current second. 

${Second} Current second. Two digit format, zero padded. 

${Time} Current Time. (HH:MM format) 

${Year} Four digit year 

${Year2} Two digit year 
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Appendix D 

Configuring Automatic Login 

The Orion Web Console allows you to log in using any of the following methods: 

¶ Windows Active Directory Authentication, available in all Orion products 
released after Orion NPM version 10.1.  

¶ Windows Pass-through Security. If you choose to employ Windows Pass-
through Security, Orion users can be authenticated through Windows 
Security, with no need to log in using a separate Orion Account or User 
Name and Password. For more information, see ñUsing Windows 
Pass-through Securityò on page 281. 

¶ DirectLink. If a DirectLink account is activated, any URL referring directly to 
an Orion Web Console page will bypass the Orion Web Console login page 
by logging the user into the DirectLink account. For more information, see 
ñUsing the DirectLink Accountò on page 284. 

¶ URL Pass-through. For more information, see ñPassing Login Information 
Using URL Parametersò on page 284. 

Orion prioritizes user login in the following manner: 

1. Windows Active Directory Authentication is enabled. To enable Windows 
Active Directory Authentication, check the Windows Authentication option 
when configuring the Orion Web Console in the Configuration Wizard. 

2. The Account or User ID and Password passed on the URL. 

3. The Account or User ID and Password entered on the login.aspx page. 

4. The Windows User if IIS NT Security is enabled, logging the user in using NT 
Security. 

5. The Windows Domain to which the User belongs, for example, 

Development \ Everyone . 

6. The presence of a DirectLink Account. 

Using Windows Pass-through Security 

On all Orion products released before Orion NPM version 10.1, you may take 
advantage of the Windows Pass-through Security functionality when IIS NT 
Security is enabled. Orion users can be authenticated through Windows Security, 
with no need to log in using a separate Orion account or User Id and Password. 
Pass-through Security can be configured to employ either Domain or Local 
computer security. Both may also be used at the same time. The Orion Core 
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Account or User ID and Passwords must then be set up to match the Account or 
User ID and Passwords that are used for the Domain and/or Local computer 
security. Use the following procedure to enable IIS NT Security for logging in to 
the Orion Web Console with Windows Pass-through Security. 

Notes: 

¶ With the release of Orion NPM 10.1, Orion Web Console users may be 
authenticated using Active Directory. 

¶ When authenticating users with Windows Security, ensure your Orion server 
uses the NetBIOS domain name, instead of the fully qualified domain name. 

To enable IIS NT security for Windows Pass-through Security: 

1. If you are using NT Domain Authentication Format for pass-through 
accounts, create these pass-through accounts in the Orion Web Console 
Account Manager using Domain\UserID as the User Name, as follows: 

¶ Washington \ Edward  

¶ StLouis \ Bill  

Note: For more information about creating accounts using the Orion Web 
Console Account Manager, see ñCreating New Accountsò on page 97. 

2. If you are using Local Computer Authentication Format for 
pass-through accounts, create these accounts in the Orion Web Console 
Account Manager using Computer\UserID as the User Name, as follows: 

¶ SolarWinds S2\ Edward  

¶ Server3 \ JonesR  

Note: For more information about creating accounts using the Orion Web 
Console Account Manager, see ñCreating New Accountsò on page 97. 

3. Click Start > Control Panel > Administrative Tools > Internet Information 
Services (IIS) Manager. 

4. If you are using Windows Server 2003, complete the following steps: 

a. Expand Internet Information Services > Local Computer > Web Sites 
in the left pane. 

b. Select SolarWinds NetPerfMon. 

c. Click Action > Properties. 

d. Click the Directory Security tab. 

e. Click Edit within the Authentication and access control area. 
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f. Clear Enable anonymous access. 

g. Check Integrated Windows authentication in the Authenticated access 
group. 

h. Click OK to close the Authentication Methods window. 

i. Click Apply, if available, and then click OK to close the SolarWinds 
NetPerfMon Properties window. 

j. Collapse Internet Information Services > Local Computer > Web 
Sites. 

k. Collapse Internet Information Services > Local Computer in the left 
pane. 

l. Click Action > All Tasks > Restart IIS. 

m. Confirm that Restart Internet Services on Local Computer is selected, 
and then click OK. 

n. Close the IIS Manager. 

5. If you are using Windows Server 2008, complete the following steps: 

a. Click Start > Administrative Tools > Server Manager. 

b. Expand Roles. 

c. Click Web Server (IIS). 

d. In the Role Services area, confirm that Web Server > Security > 
Windows Authentication is installed. 

e. If Windows Authentication is not installed, click Add Role Services, 
check Web Server > Security > Windows Authentication, click Next, 
and then complete the service installation. 

f. Click Start > Administrative Tools > Internet Information Services 
(IIS) Manager. 

g. Select your Orion server in the left pane. 

h. Click Authentication in the IIS group of the main pane. 

i. Right-click Anonymous Authentication, and then click Disable. 

j. Right-click Windows Authentication, and then click Enable. 

k. Click your Orion server, and then click Restart in the Actions pane. 

6. Close the IIS Manager. 

7. Log in to the Orion Web Console using the Windows account  credentials 
you have already established. 
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Passing Login Information Using URL Parameters 

The user ID and password can be passed as parameters within the URL. This 
allows you to create a favorite or bookmark within a browser, or on your desktop. 
Create a favorite with a link in the following form to pass the login information: 

http:// DOMAIN/Orion/Login.aspx?AccountID= USER&Password= PASSWORD 

Provide the hostname or IP address of your Orion server as the DOMAIN. Provide 

your Orion User ID as the USER, and then provide your Orion user account 

password as the  PASSWORD. 

Warning: HTTP requests are not encrypted, so User IDs and Passwords sent in 
HTTP requests are not secure. For more information about enabling HTTPS on 
your Orion server, consult www.microsoft.com. 

Using the DirectLink Account 

Enabling a DirectLink account allows you to make direct hyperlinks to specific 
web console views available to individuals who do not already have Orion Web 
Console user accounts. Any URL referring directly to an Orion web page  
bypasses the login screen, logging the user into the DirectLink account. The 
DirectLink account is created like any other account, and it can include custom 
views and account limitations. For more information web console accounts, see 
ñCreating New Accountsò on page 97. 

To enable a DirectLink account for the Orion Web Console: 

1. Log in to the Orion Web Console as an administrator. 

2. Click Settings in the top right of the web console, and then click Manage 
Accounts in the Accounts grouping. 

3. Click Add. 

4. Type DirectLink  as the new User Name. 

5. Type a Password, confirm it, and then click Submit. 

6. Edit DirectLink account options, as necessary, for your installation of Orion 
Network Performance Monitor. For more information about editing account 
options, see ñEditing User Accountsò on page 98.  

7. Create a custom view to be used as the home page of the DirectLink 
account. For more information, see ñCreating New Viewsò on page 38. 

8. Specify the new DirectLink view as a default view in Account Manger. For 
more information, see ñEditing User Accountsò on page 98. 

9. If you would like to limit the DirectLink account to specific devices or 
device types, see ñSetting Account Limitationsò on page 100. 
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Appendix E 

95
th

 Percentile Calculations 

Calculation of the 95
th
 percentile, a well-known statistical standard used to 

discard maximum spikes, is based on 5 minute data samples. The calculation 
gathers these values every 5 minutes for however long you select, throws away 
the top 5%, yielding the 95

th
 percentile value at the beginning of the list.  

Consider the following example of how the 95
th
 percentile is calculated for a 10 

hour work day from 8am to 6pm (600 minutes):  

1. Over the 10 hours, the following 120 values were collected for inbound traffic 
(Mb/s): 

0.149 0.623 0.281 0.136 0.024 0.042 0.097 0.185 0.198 0.243 0.274 0.390 
0.971 0.633 0.238 0.142 0.119 0.176 0.131 0.127 0.169 0.223 0.291 0.236 
0.124 0.072 0.197 0.105 0.138 0.233 0.374 0.290 0.871 0.433 0.248 0.242 
0.169 0.116 0.121 0.427 0.249 0.223 0.231 0.336 0.014 0.442 0.197 0.125 
0.108 0.244 0.264 0.190 0.471 0.033 0.228 0.942 0.219 0.076 0.331 0.227 
0.849 0.323 0.221 0.196 0.223 0.642 0.197 0.385 0.098 0.263 0.174 0.690 
0.571 0.233 0.208 0.242 0.139 0.186 0.331 0.124 0.249 0.643 0.481 0.936 
0.124 0.742 0.497 0.085 0.398 0.643 0.074 0.590 0.771 0.833 0.438 0.242 
0.092 0.376 0.231 0.627 0.249 0.663 0.181 0.636 0.224 0.342 0.697 0.285 
0.108 0.211 0.074 0.490 0.271 0.133 0.338 0.242 0.519 0.376 0.331 0.227  

2. When reordered from high to low: 

0.971 0.942 0.936 0.871 0.849 0.833 0.771 0.742 0.697 0.690 0.663 0.643 
0.643 0.642 0.636 0.633 0.627 0.623 0.590 0.571 0.519 0.497 0.490 0.481 
0.471 0.442 0.438 0.433 0.427 0.398 0.390 0.385 0.376 0.376 0.374 0.342 
0.338 0.336 0.331 0.331 0.331 0.323 0.291 0.290 0.285 0.281 0.274 0.271 
0.264 0.263 0.249 0.249 0.249 0.248 0.244 0.243 0.242 0.242 0.242 0.242 
0.238 0.236 0.233 0.233 0.231 0.231 0.228 0.227 0.227 0.224 0.223 0.223 
0.223 0.221 0.219 0.211 0.208 0.198 0.197 0.197 0.197 0.196 0.190 0.186 
0.185 0.181 0.176 0.174 0.169 0.169 0.149 0.142 0.139 0.138 0.136 0.133 
0.131 0.127 0.125 0.124 0.124 0.124 0.121 0.119 0.116 0.108 0.108 0.105 
0.098 0.097 0.092 0.085 0.076 0.074 0.074 0.072 0.042 0.033 0.024 0.014  

3. Drop the first 6, as these equal the top 5% of the values: 

0.771 0.742 0.697 0.690 0.663 0.643 0.643 0.642 0.636 0.633 0.627 0.623 
0.590 0.571 0.519 0.497 0.490 0.481 0.471 0.442 0.438 0.433 0.427 0.398 
0.390 0.385 0.376 0.376 0.374 0.342 0.338 0.336 0.331 0.331 0.331 0.323 
0.291 0.290 0.285 0.281 0.274 0.271 0.264 0.263 0.249 0.249 0.249 0.248 
0.244 0.243 0.242 0.242 0.242 0.242 0.238 0.236 0.233 0.233 0.231 0.231 
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0.228 0.227 0.227 0.224 0.223 0.223 0.223 0.221 0.219 0.211 0.208 0.198 
0.197 0.197 0.197 0.196 0.190 0.186 0.185 0.181 0.176 0.174 0.169 0.169 
0.149 0.142 0.139 0.138 0.136 0.133 0.131 0.127 0.125 0.124 0.124 0.124 
0.121 0.119 0.116 0.108 0.108 0.105 0.098 0.097 0.092 0.085 0.076 0.074 
0.074 0.072 0.042 0.033 0.024 0.014  

4. The 95
th
 percentile is 0.771. 
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Appendix F 

Regular Expression Pattern Matching 

When editing comparison criteria, the following regular expressions can be used 
for pattern matching. Examples a re provided at the end of this section. 

Characters 

Character Description Example 

Any character 
except 
[,\,^,$,.,|,?,*,+,(,), 

All characters except the listed special 
characters match a single instance of 
themselves. 

a matches a 

\ (backslash) 
followed by any of 
[,\,^,$,.,|,?,*,+,(,), 

A backslash escapes special characters to 
suppress their special meaning. 

\+ matches + 

\xFF where FF are 
2 hexadecimal 
digits  

Matches the character with the specified 
ASCII/ANSI value, which depends on the 
code page used. Can be used in character 
classes. 

\xA9 matches © 
when using the 
Latin-1 code page. 

\n, \r and \t 
Match an LF character, CR character and a 
tab character respectively. Can be used in 
character classes. 

\r\n matches a 
DOS/Windows 
CRLF line break. 

 

Character Classes or Character Sets [abc] 

Character Classes or Sets Description Example 

[ (opening square bracket) 

Starts a character class. A 
character class matches a single 
character out of all of the 
possibilities offered by the 
character class. Inside a character 
class, different rules apply. The 
rules in this section are only valid 
inside character classes. The 
rules outside this section are not 
valid in character classes, except 
\n, \r, \t and \xFF 

  

Any character except ^,-,],\ 
add that character to the 
possible matches for the 
character class. 

All characters except the listed 
special characters. 

[abc] matches a, b 
or c 

\ (backslash) followed by 
any of ^,-,],\ 

A backslash escapes special 
characters to suppress their 
special meaning. 

[\^\]] matches ^ or ] 

- (hyphen) except 
immediately after the 
opening [ 

Specifies a range of characters. 
(Specifies a hyphen if placed 
immediately after the opening [) 

[a-zA-Z0-9] 
matches any letter 
or digit 
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Character Classes or Sets Description Example 

^ (caret) immediately after 
the opening [ 

Negates the character class, 
causing it to match a single 
character not listed in the 
character class. (Specifies a caret 
if placed anywhere except after 
the opening [) 

[^a-d] matches x 
(any character 
except a, b, c or d) 

\d, \w and \s 

Shorthand character classes 
matching digits 0-9, word 
characters (letters and digits) and 
whitespace respectively. Can be 
used inside and outside character 
classes 

[\d\s] matches a 
character that is a 
digit or whitespace 

 

Anchors 

Anchors Description Example 

^ (caret) 

Matches at the start of the string to which 
the regular expression pattern is applied. 
Matches a position rather than a character. 
Most regular expression flavors have an 
option to make the caret match after line 
breaks (i.e. at the start of a line in a file) as 
well. 

^. matches a in 
abc\ndef. Also 
matches d in 
"multi-line" mode. 

$ (dollar) 

Matches at the end of the string to which the 
regular expression pattern is applied. 
Matches a position rather than a character. 
Most regular expression flavors have an 
option to make the dollar match before line 
breaks (i.e. at the end of a line in a file) as 
well. Also matches before the very last line 
break if the string ends with a line break. 

.$ matches f in 
abc\ndef. Also 
matches c in 
"multi-line" mode. 

\A 

Matches at the start of the string to which 
the regular expression pattern is applied to. 
Matches a position rather than a character. 
Never matches after line breaks. 

\A. matches a in 
abc 

\Z 

Matches at the end of the string to which the 
regular expression pattern is applied. 
Matches a position rather than a character. 
Never matches before line breaks, except 
for the very last line break if the string ends 
with a line break. 

.\Z matches f in 
abc\ndef 

\z 

Matches at the end of the string to which the 
regular expression pattern is applied. 
Matches a position rather than a character. 
Never matches before line breaks. 

.\z matches f in 
abc\ndef 
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Quantifiers 

Quantifiers Description Example 

? (question mark) 
Makes the preceding item optional. The 
optional item is included in the match, if 
possible. 

abc? matches ab 
or abc 

?? 

Makes the preceding item optional. The 
optional item is excluded in the match, if 
possible. This construct is often excluded 
from documentation due to its limited use. 

abc?? matches ab 
or abc 

* (star) 

Repeats the previous item zero or more 
times. As many items as possible will be 
matched before trying permutations with 
fewer matches of the preceding item, up to 
the point where the preceding item is not 
matched at all. 

.* matches "def" 
"ghi" in abc "def" 
"ghi" jkl 

*? (lazy star) 

Repeats the previous item zero or more 
times. The engine first attempts to skip the 
previous item before trying permutations 
with ever increasing matches of the 
preceding item. 

.*? matches "def" 
in abc "def" "ghi" jkl 

#NAME? 

Repeats the previous item once or more. As 
many items as possible will be matched 
before trying permutations with fewer 
matches of the preceding item, up to the 
point where the preceding item is matched 
only once. 

.+ matches "def" 
"ghi" in abc "def" 
"ghi" jkl 

+? (lazy plus) 

Repeats the previous item once or more. 
The engine first matches the previous item 
only once, before trying permutations with 
ever increasing matches of the preceding 
item. 

.+? matches "def" 
in abc "def" "ghi" jkl 

{n} where n is an 
integer >= 1 

Repeats the previous item exactly n times. a{3} matches aaa 

{n,m} where n >= 1 
and m >= n 

Repeats the previous item between n and 
m times. Will try to repeat m times before 
reducing the repetition to n times. 

a{2,4} matches aa, 
aaa or aaaa 

{n,m}? where n >= 
1 and m >= n 

Repeats the previous item between n and 
m times. Will try to repeat n times before 
increasing the repetition to m times. 

a{2,4}? matches 
aaaa, aaa or aa 

{n,} where n >= 1 

Repeats the previous item at least n times. 
Will try to match as many items as possible 
before trying permutations with fewer 
matches of the preceding item, up to the 
point where the preceding item is matched 
only m times. 

a{2,} matches 
aaaaa in aaaaa 

{n,}? where n >= 1 

Repeats the previous item between n and 
m times. The engine first matches the 
previous item n times before trying 
permutations with ever increasing matches 
of the preceding item. 

a{2,}? matches aa 
in aaaaa 
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Dot 

Dot Character Description Example 

. (dot) 
Matches any single character except line 
break characters \r and \n. 

. matches x or most 
any other character 

 

Word Boundaries 

Word Boundary Description Example 

\b 

Matches at the position between a word 
character (anything matched by \w) and a 
non-word character (anything matched by 
[^\w] or \W) as well as at the start and/or end 
of the string if the first and/or last characters 
in the string are word characters. 

.\b matches c in 
abc 

\B 

Matches at the position between two word 
characters (i.e the position between \w\w) as 
well as at the position between two non-word 
characters (i.e. \W\W). 

\B.\B matches b 
in abc 

 

Alternation 

Alternation 
Character 

Description Example 

|  
(vertical bar or 
ñpipeò) 

Causes the regular expression engine to 
match either the part on the left side or the 
part on the right side. Can be strung 
together into a series of options. 

abc|def|xyz 
matches abc, def 
or xyz 

|  
(vertical bar or 
ñpipeò) 

The vertical bar has the lowest precedence 
of all operators. Use grouping to alternate 
only part of the regular expression. 

abc(def|xyz) 
matches abcdef 
or abcxyz 

 

Regular Expression Pattern Matching Examples 

The following examples illustrate uses of regular expression pattern matching. 

snmp- server community public  

Finds any line that includes the text snmp- server community public . There 

can be text before and/or after the string on the same line. 

service tcp - keepalives - in.* \ n(.* \ n)*.*service tcp - keepalives - out  

Finds the first line service t cp - keepalives - in  and then looks for service 

tcp - keepalives - out  on any line after that. The regular expression string 

.* \ n(.* \ n)*.*  is used to search any number of lines between strings. 
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access - list 105 deny.*tcp any any eq 139 log  

Finds the line with acces s- list 105 deny , followed by any number of 

characters of any type, followed by tcp any any eq 139 log  on the same 

line. The regular expression string .*  finds any character and any number of 

characters on the same line. This expression can be used to find spaces, 
tabs, numbers, letters, or special characters. 

ntp clock - period \ d*  

Finds any line that includes ntp clock - perio d, followed by any number. 

The regular expression string \ d*  will find any number at any length, such as 

3, 48, or 2394887 . 

user \ x2a  

Finds any line that includes user * . The regular expression string \ x , 

followed by a hexadecimal value, specifies an individual character. In this 

example, \ x2a  represents the asterisk character, which has a hexadecimal 

value of 2a. 
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Appendix G 

Troubleshooting 

If you have problems with an Orion product, the causes are usually related to an 
incorrect configuration or corrupted files. The following suggestions can often 
clear up these problems. 

Back Up Your Data 

As a first step in any troubleshooting procedure, you should back up your Orion 
database. For more information, see ñCreating Database Backupsò on page 218. 

Verify Program Operation 

Orion runs many components at the same time to deliver a view of your network 
status. Confirm that the following components are running on your Orion server: 

¶ Services: 

o Message Queuing 

o Net.Tcp Port Sharing Service 

o SNMP Trap Service 

o SolarWinds Alerting Engine service 

o SolarWinds Collector Data Processor, Management Agent, and 
Polling Controller services 

o SolarWinds Information Service 

o SolarWinds Job Engine and Job Engine v2 

o SolarWinds Job Scheduler 

o SolarWinds Network Performance Monitor Service. All Orion 
products use this service. It is not exclusive to Orion NPM.  

o SolarWinds Orion Product services 

o SolarWinds Orion Information Service 

o SolarWinds Orion Module Engine 

o SolarWinds Syslog and Trap Services 

¶ SQL Server 

¶ Internet Information Service (IIS) 
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Stop and Restart 

Many problems disappear when programs are restarted. Stopping and restarting 
Internet Information Service (IIS) may eliminate web page problems. Problems 
with polling or data gathering may be eliminated by stopping and restarting the 
SolarWinds Network Performance Monitor Service using the available shutdown 
tool that you can locate as follows: 

Click Start > All Programs > SolarWinds Orion > Advanced Features > Orion 
Service Manager. 

For a complete refresh of the system, reboot the computer. 

Run the Configuration Wizard 

Running the Configuration Wizard, which refreshes files on the web server and 
performs checks on the structure of your database, may solve many problems. 

Note: Before you run the Configuration Wizard, you should close all open 
applications and stop the SolarWinds Network Performance Monitor Service in 
the Windows Services Control Panel. It will be restarted by the Wizard at the end 
of its process. 

Using Full Variable Names 

If you are having difficulty acquiring expected values from a selected variable, 

using the ${VariableName }format, it may be helpful to include the database table 

name within the variable name, as in ${Nodes.IP_Address }. 

Working with Temporary Directories 

The following sections provide procedures for moving Windows and SQL Server 
temporary directories to optimize Orion server performance and resources. 

Moving the SQL Server Temporary Directory 

The SQL Server temporary directory, tempdb , where temporary database objects 

generated during table creation and sorting are stored, is typically created in the 

same location on your Orion database server as the master , model , and msdb 

databases. Moving the tempdb  database to a physical drive separate from your 

Orion database can significantly improve overall system performance. 

For more information about moving the SQL Server 2005 temporary directory, 

tempdb , for see ñMoving System Databases ï Example A: Moving the tempdb 

Databaseò. 

http://msdn.microsoft.com/en-us/library/ms345408(SQL.90).aspx
http://msdn.microsoft.com/en-us/library/ms345408(SQL.90).aspx
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For more information about moving the SQL Server 2008 temporary directory, 

tempdb , for see ñMoving System Databases ï Example A: Moving the tempdb 

Databaseò. 

Redefining Windows System Temporary Directories 

Following established Windows standards, the Orion installer may use Windows 
User and System TEMP and TMP variable directories as temporary scratch 
spaces for file expansion and execution. If you do not have the required scratch 
space available in the default User or System TEMP and TMP directories, use 
the following procedure to redefine your default locations. 

Note: Regardless of where you actually install Orion, some common files may be 
installed where the operating system of your Orion server are located. 

To redefine default system temporary directories: 

1. Log on to your Orion server as a user with administrative rights. 

2. Right-click My Computer, and then click Properties. 

3. Click Advanced, and then click Environment Variables. 

4. Select the variable name representing the directory you want to redefine, 
click Edit, and then provide a new path as the Variable value for the 
selected temporary directory variable. 

Slow Performance on Windows Server 2008 

If Orion is installed on Windows Server 2008 or Windows Vista and there are any 
devices on your network, between your Orion server and your database server, 
that do not support RFC 1323, ñTCP Extensions for High Performanceò, the TCP 
window size auto-tuning feature of Windows Server 2008 and Windows Vista 
may prevent your Orion server from successfully connecting with your Orion 
database. This TCP auto-tuning feature is intended as a network-sensitive 
restriction, applied by the receiverðyour Orion serverðon the amount of data it 
is allowed or able to receive. If any devices along the network path between your 
Orion server and your Orion database do not support the TCP window scaling 
detailed in RFC 1323, the allowed size of the TCP window in packets sent to 
your Orion server may not match the TCP window size reported by packets sent 
from your Orion server. This mismatch may lead to failed connections between 
your Orion server and your Orion database. The following procedure disables 
this TCP auto-tuning feature, resetting the TCP receive window to 64kB. 

To disable tcp auto-tuning: 

1. Click Start > All Programs > Accessories. 

2. Right-click Command Prompt, and then click Run as administrator. 

http://msdn.microsoft.com/en-us/library/ms345408.aspx
http://msdn.microsoft.com/en-us/library/ms345408.aspx
http://www.ietf.org/rfc/rfc1323.txt
http://www.ietf.org/rfc/rfc1323.txt
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3. If you are prompted by User Account Control, click Continue to open the 
elevated command prompt. 

Note: In some cases, having User Account Control (UAC) enabled on 
Windows Server 2008 and Windows Vista (evaluation-only) can lead to 
installation errors. For more information about disabling UAC, see the article, 
ñDisabling User Account Control (UAC)ò in the SolarWinds Knowledge Base. 

4. At the prompt, enter the following: 

netsh interface tcp set global autotuninglevel=disabled  

5. Close the command prompt window, and then restart your Orion server. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://knowledgebase.solarwinds.com/kb/questions/2287/
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